Kirjoittaja Aihe: Päivitys meni looppiin  (Luettu 2208 kertaa)

Pendeli

  • Käyttäjä
  • Viestejä: 840
    • Profiili
Päivitys meni looppiin
« : 01.08.23 - klo:14.14 »
Päivitys menee jonkinlaiseen looppiin ja toistaa itseään

Graafisella päivityksellä tulee seuraavaa myös kun uudelleenkäynnistyksen jälkeen kun klikkaa päivitysten tarkistusta.
Autoremove-komento poisti ison määrän jotain. Mutta päivitys tarjoaa samaa satsia aina uudelleen päivitettäväksi: (kuva 1 ja 2)




Päätteellä päivityskomento näyttää seuraavaa

Koodia: [Valitse]
$ sudo apt update && sudo apt upgrade
[sudo] password for k1:
Hit:1 http://fi.archive.ubuntu.com/ubuntu jammy InRelease
Hit:2 http://fi.archive.ubuntu.com/ubuntu jammy-updates InRelease
Hit:3 http://fi.archive.ubuntu.com/ubuntu jammy-backports InRelease           
Hit:4 https://updates.signal.org/desktop/apt xenial InRelease                 
Hit:5 https://ppa.launchpadcontent.net/tatokis/alarm-clock-applet/ubuntu jammy InRelease
Hit:6 http://security.ubuntu.com/ubuntu jammy-security InRelease
Reading package lists... Done                         
Building dependency tree... Done
Reading state information... Done
25 packages can be upgraded. Run 'apt list --upgradable' to see them.
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
Get more security updates through Ubuntu Pro with 'esm-apps' enabled:
  vlc-plugin-qt libvlc5 vlc-data libvlccore9 vlc vlc-bin vlc-l10n
  libpostproc55 vlc-plugin-samba libavcodec58 vlc-plugin-notify libavutil56
  libswscale5 vlc-plugin-access-extra vlc-plugin-skins2
  vlc-plugin-video-splitter libswresample3 vlc-plugin-video-output
  libavformat58 libvlc-bin vlc-plugin-base vlc-plugin-visualization
Learn more about Ubuntu Pro at https://ubuntu.com/pro
#
# An OpenSSL vulnerability has recently been fixed with USN-6188-1 & 6119-1:
# CVE-2023-2650: possible DoS translating ASN.1 object identifiers.
# Ensure you have updated the package to its latest version.
#
The following packages have been kept back:
  gjs libgjs0g libnvidia-cfg1-535 libnvidia-common-535 libnvidia-compute-535
  libnvidia-compute-535:i386 libnvidia-decode-535 libnvidia-decode-535:i386
  libnvidia-encode-535 libnvidia-encode-535:i386 libnvidia-extra-535
  libnvidia-fbc1-535 libnvidia-fbc1-535:i386 libnvidia-gl-535
  libnvidia-gl-535:i386 linux-modules-nvidia-535-5.19.0-50-generic
  linux-modules-nvidia-535-generic-hwe-22.04
  linux-objects-nvidia-535-5.19.0-50-generic
  linux-signatures-nvidia-5.19.0-50-generic nvidia-compute-utils-535
  nvidia-driver-535 nvidia-kernel-common-535 nvidia-kernel-source-535
  nvidia-utils-535 xserver-xorg-video-nvidia-535
0 to upgrade, 0 to newly install, 0 to remove and 25 not to upgrade.


Kaikki tuntuu muutoin toimivan normaalisti mutta  miten tuon päivityksen saa normaaliksi?

Pendeli

  • Käyttäjä
  • Viestejä: 840
    • Profiili
Vs: Päivitys meni looppiin
« Vastaus #1 : 01.08.23 - klo:14.30 »
Lisäyksenä vielä nvidia info:
Koodia: [Valitse]
$ nvidia-settings

ERROR: NVIDIA driver is not loaded


(nvidia-settings:6312): GLib-GObject-CRITICAL **: 13:16:06.389: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

** (nvidia-settings:6312): CRITICAL **: 13:16:06.395: ctk_powermode_new: assertion '(ctrl_target != NULL) && (ctrl_target->h != NULL)' failed

ERROR: nvidia-settings could not find the registry key file or the X server is
       not accessible. This file should have been installed along with this
       driver at
       /usr/share/nvidia/nvidia-application-profiles-key-documentation. The
       application profiles will continue to work, but values cannot be
       prepopulated or validated, and will not be listed in the help text.
       Please see the README for possible values and descriptions.

** Message: 13:16:06.520: PRIME: No offloading required. Abort
** Message: 13:16:06.520: PRIME: is it supported? no

Eesaurus

  • Käyttäjä
  • Viestejä: 3420
    • Profiili
Vs: Päivitys meni looppiin
« Vastaus #2 : 01.08.23 - klo:14.53 »
Ehkä voisi ainakin asentaa Nvidia-ajurin uudelleen, ei näytä olevan käynnissä.
Koodia: [Valitse]
sudo ubuntu-drivers autoinstall
Sitten yrittää järjestelmän päivittämistä uudestaan. Ubuntu jättää nykyään joitain paketteja päivityksessä odottamaan (näkyy kuvassasi), se on normaalia. Asentuvat sitten ajallaan, ei tarvitse tehdä mitään.

Itse olisin varovainen autoremoven kanssa. Vaikuttaa siltä, että se on poistanut kerran-pari yhdestä lähipiirin Nvidia-koneesta jotain liikaa, jonka jälkeen ajuri ei käynnistynyt ja resoluutiot oli aivan pielessä. Ajurin uudelleenasennus korjasi tilanteen.

Pendeli

  • Käyttäjä
  • Viestejä: 840
    • Profiili
Vs: Päivitys meni looppiin
« Vastaus #3 : 01.08.23 - klo:20.46 »
Jotain hämminkiä edelleen. Eli graafisen päivityksen asetuksissa on varmaankin joku ongelma jossain. Graafinen päivitys ilmoittaa turvapäivityksiä olevan tarjolla   n. 1500 Megaa. Sitten jauhaa vanhoja Linuximageja ja moduleita moneen kertaan ja pitkän aikaa. Kun se tulee valmiiksi niin aukeaa uudelleen kuva poistettavista vanhoista tiedostoista. Kun sekin on valmista niin aukeaa uudestaan ilmoitus että samat 1500  Megaa tietoturvapäivityksiä on tarjolla.

Ubuntu drivers ilmoittaa että kaikki on ajantasalla. Nvidia-Settings näyttää edelleen että driver not loaded. Näyttö toimii silti normaalisti.

Terminaalin päivitystuloksessa on useita Nvidia-palikoita odottamassa myöhempää päivitystä mutta tuskin niistäkään toistatuhatta Megaa kertyy. Vai ovatko ne juuri samoja mitä graafisessa kuvassakin näkyy. Pitäisikö vaan rauhassa odotella että loputkin 25 palikkaa päivityy. Vähän outoa toimintaa.

Voin laittaa tänne myös päivityshistorian tietoa jos siitä joku osaa jotain sanoa. Se on aika pitkä litania.

nm

  • Käyttäjä
  • Viestejä: 16282
    • Profiili
Vs: Päivitys meni looppiin
« Vastaus #4 : 01.08.23 - klo:21.36 »
Kokeile poistaa väliaikaisesti Nvidian suljetun ajurin paketit:

Koodia: [Valitse]
sudo apt purge nvidia*
Päivitä sitten uudelleen:

Koodia: [Valitse]
sudo apt update
Koodia: [Valitse]
sudo apt full-upgrade
Varmista vielä ettei graafinen päivitysohjelma löydä enää lisää päivitettävää.
Lopuksi voit asentaa Nvidian ajurin uudelleen Lisäajurien kautta tai ubuntu-drivers-komennolla.

juyli

  • Käyttäjä / moderaattori
  • Viestejä: 1200
    • Profiili
Vs: Päivitys meni looppiin
« Vastaus #5 : 01.08.23 - klo:23.53 »
Päivitys menee jonkinlaiseen looppiin ja toistaa itseään ...
Koodia: [Valitse]
Hit:4 https://updates.signal.org/desktop/apt xenial InRelease Tuo Xenial-repo on edesmenneelle Ubuntu-versiolle 16.xx ?
Käytössäsi lienee useita eri Ubuntun kernel-versioita, joita ei välttämättä ole (aktiivisesti) käytössä.
Muistaakseni Ubuntu jo ainakin oletuksena säilyttää kaksi kernel-versiota, joten versiot 5.15.xx ja 5.17.xx poistettaisiin, jos näin on määritelty.
Jos tarpeettomat kernel-versiot poistetaan, voi myös olla mahdollista, että tarpeettomat nvidia-versiot poistuvat.
Omissa jakeluissani, joissa on Nvidia-ohjain, dkms:llä käännetään nvidia-ajuri kernel-päivityksen yhteydessä.
                 
Koodia: [Valitse]
Hit:5 https://ppa.launchpadcontent.net/tatokis/alarm-clock-applet/ubuntu jammy InRelease PPA-repot toki ovat luotettavia, mutta ne eivät ole jakelun virallisia repoja, joka pitää ymmärtää...
Käytössäni on repo, joka asentaa mm. Mozilla-firefox:in snap-paketin ohelle.

Pendeli

  • Käyttäjä
  • Viestejä: 840
    • Profiili
Vs: Päivitys meni looppiin
« Vastaus #6 : 02.08.23 - klo:19.54 »
Asensin Nvidian ajurin uusiksi. Nvidia-settings ilmoittaa edelleen saman:  ERROR: NVIDIA driver is not loaded.

ERROR: nvidia-settings could not find the registry key file or the X server is
       not accessible.
       
           
X-org istunto päällä.
Päivitys ilmoittaa vain yhden paketin pidettäväksi päivittämättä.


The following packages have been kept back:
  gjs libgjs0g libnvidia-common-535 ufw
 
  Palomuuri ei ole päällä jos tuo siihen viittaa.
 
  Graafinen päivitys siistiytyi normaaliksi.
 
  Nvidia-settings kuvake on erilainen kuin aikaisemmin.
 
  Näytön toiminnassa en huomaa mitään poikkeavaa.
 
  Onko jotain mitä pitäisi vielä korjata?

Pendeli

  • Käyttäjä
  • Viestejä: 840
    • Profiili
Vs: Päivitys meni looppiin
« Vastaus #7 : 02.08.23 - klo:20.25 »
Päivitys menee jonkinlaiseen looppiin ja toistaa itseään ...
Koodia: [Valitse]
Hit:4 https://updates.signal.org/desktop/apt xenial InRelease Tuo Xenial-repo on edesmenneelle Ubuntu-versiolle 16.xx ?
Käytössäsi lienee useita eri Ubuntun kernel-versioita, joita ei välttämättä ole (aktiivisesti) käytössä.
Muistaakseni Ubuntu jo ainakin oletuksena säilyttää kaksi kernel-versiota, joten versiot 5.15.xx ja 5.17.xx poistettaisiin, jos näin on määritelty.
Jos tarpeettomat kernel-versiot poistetaan, voi myös olla mahdollista, että tarpeettomat nvidia-versiot poistuvat.
Omissa jakeluissani, joissa on Nvidia-ohjain, dkms:llä käännetään nvidia-ajuri kernel-päivityksen yhteydessä.
                 
Koodia: [Valitse]
Hit:5 https://ppa.launchpadcontent.net/tatokis/alarm-clock-applet/ubuntu jammy InRelease PPA-repot toki ovat luotettavia, mutta ne eivät ole jakelun virallisia repoja, joka pitää ymmärtää...
Käytössäni on repo, joka asentaa mm. Mozilla-firefox:in snap-paketin ohelle.


Tein puhtaan Ubuntu 22.04 asennuksen koneelle, joten siinä ei pitäisi vanhoja versioita asennuksen yhteydessä ymmärtääkseni tulla. Signalista en muista mistä sen asensin. Ubuntun pakettivaraston Signal toisessa koneessa aiheutti jotain harmia joten en enää Ubuntun pakettivarastoon uskonut.

Kuinka muut mahdolliset kernelit saa tuon lisäksi näkyviin?
$ cat /proc/version_signature Ubuntu 6.2.0-1009.9~22.04.1-lowlatency 6.2.13

nm

  • Käyttäjä
  • Viestejä: 16282
    • Profiili
Vs: Päivitys meni looppiin
« Vastaus #8 : 02.08.23 - klo:22.36 »
Asensin Nvidian ajurin uusiksi. Nvidia-settings ilmoittaa edelleen saman:  ERROR: NVIDIA driver is not loaded.

Mikä näytönohjain koneessa on? Lshw tai lspci näyttää mallin:

Koodia: [Valitse]
lshw -c display
Tein puhtaan Ubuntu 22.04 asennuksen koneelle, joten siinä ei pitäisi vanhoja versioita asennuksen yhteydessä ymmärtääkseni tulla. Signalista en muista mistä sen asensin. Ubuntun pakettivaraston Signal toisessa koneessa aiheutti jotain harmia joten en enää Ubuntun pakettivarastoon uskonut.

Nähtävästi Signal tarjoaa pakettinsa saman repositorion kautta kaikille Ubuntun versioille 16.04:stä lähtien, jolloin ”xenial”-niminen lähde on käytössä myös uusimmissa jakeluversioissa.


Kuinka muut mahdolliset kernelit saa tuon lisäksi näkyviin?
$ cat /proc/version_signature Ubuntu 6.2.0-1009.9~22.04.1-lowlatency 6.2.13

Listaa asennetut linux-image-paketit:

Koodia: [Valitse]
dpkg -l | grep linux-image

Pendeli

  • Käyttäjä
  • Viestejä: 840
    • Profiili
Vs: Päivitys meni looppiin
« Vastaus #9 : 02.08.23 - klo:22.59 »


Mikä näytönohjain koneessa on? Lshw tai lspci näyttää mallin:

Koodia: [Valitse]
lshw -c display
Koodia: [Valitse]
~$ lshw -c display
WARNING: you should run this program as super-user.
  *-display UNCLAIMED       
       description: VGA compatible controller
       product: GM107GLM [Quadro M1000M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: vga_controller cap_list
       configuration: latency=0
       resources: memory:dc000000-dcffffff memory:b0000000-bfffffff memory:c0000000-c1ffffff ioport:e000(size=128) memory:dd000000-dd07ffff
  *-display
       description: VGA compatible controller
       product: HD Graphics 530
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       logical name: /dev/fb0
       version: 06
       width: 64 bits
       clock: 33MHz
       capabilities: vga_controller bus_master cap_list rom fb
       configuration: depth=32 driver=i915 latency=0 resolution=1920,1080
       resources: irq:132 memory:db000000-dbffffff memory:70000000-7fffffff ioport:f000(size=64) memory:c0000-dffff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

juyli

  • Käyttäjä / moderaattori
  • Viestejä: 1200
    • Profiili
Vs: Päivitys meni looppiin
« Vastaus #10 : 02.08.23 - klo:23.03 »
Kuinka muut mahdolliset kernelit saa tuon lisäksi näkyviin?
$ cat /proc/version_signature Ubuntu 6.2.0-1009.9~22.04.1-lowlatency 6.2.13
Koodia: [Valitse]
uname -a myös selvittää käytössäolevan kernel-version.
Koodia: [Valitse]
ls /boot kertoisi, mitä kernel-versioita on tarjolla käyttöön (grub-valikoissakin).

Enpä ole vuosiin asentanut Linux-jakeluja, koska päivitän jakeluversiot versiosta toiseen.
Mutta hämmästelen yhä, miksi repoihin ujuttautuisi vuosikausia vanhoja repoja uudelleenasennuksessa.
Käytössä ei näytä olevan repoja 14.xx tai 18.xx?
Tuo tuskin on kuitenkaan perimmäinen syy ongelmiisi.

PS. Jo kesäkuun lopulla olet kysellyt näytönohjaimesi toimivuudesta. https://forum.ubuntu-fi.org/index.php?topic=58192.msg443560#new
Ja jo viestiketjussa on selkeä vastaus, että näytönohjain on mitä todennäköisimmin tuettu Ubuntu-jakeluissa.
Minua tosin mietityttää käyttämäsi kernel-versiot, ja niiden tuki mm. suljetuille näytönohjainversioille.
« Viimeksi muokattu: 03.08.23 - klo:00.33 kirjoittanut juyli »

nm

  • Käyttäjä
  • Viestejä: 16282
    • Profiili
Vs: Päivitys meni looppiin
« Vastaus #11 : 03.08.23 - klo:00.32 »


Mikä näytönohjain koneessa on? Lshw tai lspci näyttää mallin:

Koodia: [Valitse]
lshw -c display
Koodia: [Valitse]
~$ lshw -c display
WARNING: you should run this program as super-user.
  *-display UNCLAIMED       
       description: VGA compatible controller
       product: GM107GLM [Quadro M1000M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: vga_controller cap_list
       configuration: latency=0
       resources: memory:dc000000-dcffffff memory:b0000000-bfffffff memory:c0000000-c1ffffff ioport:e000(size=128) memory:dd000000-dd07ffff
  *-display
       description: VGA compatible controller
       product: HD Graphics 530
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       logical name: /dev/fb0
       version: 06
       width: 64 bits
       clock: 33MHz
       capabilities: vga_controller bus_master cap_list rom fb
       configuration: depth=32 driver=i915 latency=0 resolution=1920,1080
       resources: irq:132 memory:db000000-dbffffff memory:70000000-7fffffff ioport:f000(size=64) memory:c0000-dffff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

Okei, ehkä Nvidia on kytketty pois käytöstä Primen avulla. Mitä kertoo:

Koodia: [Valitse]
sudo prime-select query
Nyt käytössä on prosessorin integroitu näytönohjain, jolla pärjää kyllä ihan hyvin, jos et tarvitse erillisen näytönohjaimen tehoa tai ominaisuuksia.

Mutta hämmästelen yhä, miksi repoihin ujuttautuisi vuosikausia vanhoja repoja uudelleenasennuksessa.

Esitin yllä jo todennäköisen selityksen:

Nähtävästi Signal tarjoaa pakettinsa saman repositorion kautta kaikille Ubuntun versioille 16.04:stä lähtien, jolloin ”xenial”-niminen lähde on käytössä myös uusimmissa jakeluversioissa.

Signal asentuu samasta xenial-repositoriosta kaikkiin muihinkin Debian-pohjaisiin jakeluihin: https://signal.org/download/linux/
« Viimeksi muokattu: 03.08.23 - klo:00.49 kirjoittanut nm »

Pendeli

  • Käyttäjä
  • Viestejä: 840
    • Profiili
Vs: Päivitys meni looppiin
« Vastaus #12 : 03.08.23 - klo:11.53 »




Okei, ehkä Nvidia on kytketty pois käytöstä Primen avulla. Mitä kertoo:

Koodia: [Valitse]
sudo prime-select query



$ sudo prime-select query

on-demand

nm

  • Käyttäjä
  • Viestejä: 16282
    • Profiili
Vs: Päivitys meni looppiin
« Vastaus #13 : 03.08.23 - klo:12.24 »
$ sudo prime-select query

on-demand

OK, tuo on kunnossa.

Ongelma johtunee käyttämästäsi lowlatency-kernelistä. Ubuntuun paketoitu Nvidian suljettu ajuri ei sisällä sille valmiiksi käännettyjä moduuleja, ja paikallisesti käännetyt ajurit vaativat Secure Boot -ympäristössä allekirjoituksen ja toimivan MOK:n (Machine Owner Key). Siinä voi helposti törmätä ongelmiin, jos MOK:n asettaminen ei jostain syystä ole onnistunut.

Kannattaa kokeilla kytkeä Secure Boot pois päältä UEFI-asetuksissa. Toimiiko Nvidian ajuri sen jälkeen?

Toinen vaihtoehto olisi vaihtaa lowlatency-kernelin tilalle tavallinen geneerinen kerneli. Onnistunee asentamalla paketti linux-image-generic-hwe-22.04 ja poistamalla lowlatency-kernelin paketit.

Pendeli

  • Käyttäjä
  • Viestejä: 840
    • Profiili
Vs: Päivitys meni looppiin
« Vastaus #14 : 03.08.23 - klo:13.47 »
Secure Boot oli pois päältä  jo entuudestaan.
Kuinka tuo kernelin vaihto tapahtuu käytännössä?

Pendeli

  • Käyttäjä
  • Viestejä: 840
    • Profiili
Vs: Päivitys meni looppiin
« Vastaus #15 : 03.08.23 - klo:15.16 »
Ehkä ei ole tarvis selostaa koko kernelinvaihdon revohkaa juurta jaksain. Riittänee kun löytäisin hyvän ja luotettavan sivuston minkä yksinkertaisilla ohjeilla ja vähimmällä vaivalla pääsen eteenpäin. Kaikenlaisia ohjesivuja näköjään on tarjolla.

Toisaalta en tiedä onko tarpeenkaan tehdä mitään kernelin vaihtoja kun kone kuitenkin kaikesta huolimatta näyttäisi toimivan hyvin tällaisenäänkin. Eri asia, jos on odotettavissa vaikeuksia myöhemmin. Niin on näköjään käynyt joillekin Nvidian yhteydessä kun kernel on päivittynyt.

Pendeli

  • Käyttäjä
  • Viestejä: 840
    • Profiili
Vs: Päivitys meni looppiin
« Vastaus #16 : 06.08.23 - klo:16.05 »
Graafinen päivitys tuotti tällä kertaa kuvan mukaisen ilmoituksen. Terminaalipäivitys sujui hyvin eikä koneen toiminnassa tunnu toistaiseksi olevan häiriöitä.

En tiedä  liittyykö ilmoitus aikaisempiin ongelmiin nvidian ja lowlatency-kernelin kanssa. Lowlatency kernel on
peräisin tältä samalta sivustolta ladattavissa olevalta asennusmedialta jonka olen heinäkuussa ladannut ja asentanut. Onko mahdollista että kyseisessä asennusmediassa on jotain bugeja? (Versio Ubuntu 22.04.3 LTS)

Sydän kylmänä saa aina seurata mitä tapahtuu kun käyttää graafista päivitystä.
« Viimeksi muokattu: 06.08.23 - klo:16.15 kirjoittanut Pendeli »

nm

  • Käyttäjä
  • Viestejä: 16282
    • Profiili
Vs: Päivitys meni looppiin
« Vastaus #17 : 06.08.23 - klo:16.26 »
Virhe paketoinnissa. Netistä löytyy viimeisen vuorokauden sisältä raportteja samasta ongelmasta. Todennäköisesti tuo korjataan muutaman päivän sisällä.

Luultavasti saat saman virheen myös komentorivillä, jos teet täyden päivityksen apt full-upgradella.