Kirjoittaja Aihe: [Ratkaistu] intel-microcode/jammy-security,now 3.20220510.  (Luettu 907 kertaa)

Eeriikki

  • Käyttäjä
  • Viestejä: 815
    • Profiili
Nyt meni taas sormi suuhun. Mitä tehdä ?

erkki@ensioot-hp6570b:~$ sudo apt list --upgradable
Listataan... Valmis
intel-microcode/jammy-updates 3.20220809.0ubuntu0.22.04.1 amd64 [päivitettävissä versiosta: 3.20220510.0ubuntu0.22.04.1]
N: 2 muuta versiota olemassa. Käytä kytkintä '-a' nähdäksesi ne.
erkki@ensioot-hp6570b:~$ sudo apt list --upgradable -a
Listataan... Valmis
intel-microcode/jammy-updates 3.20220809.0ubuntu0.22.04.1 amd64 [päivitettävissä versiosta: 3.20220510.0ubuntu0.22.04.1]
intel-microcode/jammy-security,now 3.20220510.0ubuntu0.22.04.1 amd64 [asennettu,päivitettävissä versioon: 3.20220809.0ubuntu0.22.04.1]
intel-microcode/jammy 3.20210608.2ubuntu1 amd64

« Viimeksi muokattu: 12.09.22 - klo:23.07 kirjoittanut Eeriikki »

juyli

  • Käyttäjä / moderaattori
  • Viestejä: 1200
    • Profiili
Nyt meni taas sormi suuhun. Mitä tehdä ?
Miksi? Tarjolla on uusi versio ohjelmasta jakelussa Ubuntu 22.04.1: intel-microcode/jammy-security,now 3.20220510.0ubuntu0.22.04.1 amd64 [asennettu,päivitettävissä versioon:
intel-microcode/jammy-security,now 3.20220510.0ubuntu0.22.04.1 amd64 [asennettu,päivitettävissä versioon: 3.20220809.0ubuntu0.22.04.1]
Siis toukokuun (202205) versio olisi päivitettävissä elokuussa (202208) julkaistuun versioon.
« Viimeksi muokattu: 12.09.22 - klo:22.36 kirjoittanut juyli »

Eeriikki

  • Käyttäjä
  • Viestejä: 815
    • Profiili
Mites noi 22 päivittämätöntä saa asennettua ?

Alin rivi: " 0 päivitetty, 0 uutta asennusta, 0 poistettavaa ja 22 päivittämätöntä."

erkki@ensioot-hp6570b:~$ sudo apt-get upgrade
[sudo] erkki-käyttäjän salasana:
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu... Valmis
Luetaan tilatiedot... Valmis                 
Käsitellään päivitystä... Valmis
Nämä paketit on jätetty odottamaan:
  intel-microcode libkf5newstuff-data libkf5newstuff5 libkf5newstuffcore5
  libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5 libqt5opengl5
  libqt5printsupport5 libqt5sql5 libqt5sql5-sqlite libqt5test5 libqt5widgets5
  libqt5xml5 python3-distupgrade qml-module-org-kde-newstuff
  qt5-gtk-platformtheme ubuntu-release-upgrader-core
  ubuntu-release-upgrader-gtk zlib1g zlib1g-dev
0 päivitetty, 0 uutta asennusta, 0 poistettavaa ja 22 päivittämätöntä.

raimo

  • Käyttäjä
  • Viestejä: 4168
  • openSUSE Tumbleweed
    • Profiili
Kuten päivitysvelho sanoo
Lainaus
Nämä paketit on jätetty odottamaan:

Suomeksi paketit odottaa kunnes kaikki päivitykset on valmiit,
sitä on nyt ilmentynny aika useasti.
Mitään ei siis kannata/voi tehdä, paketit päivittyy kun riippuvuudet täyttyy.
Tietä käyden tien on vanki. Vapaa on vain umpihanki.
Aaro Hellaakoski

Eeriikki

  • Käyttäjä
  • Viestejä: 815
    • Profiili
Kiitos !
Ihmettelin taas mitä teen väärin.

juyli

  • Käyttäjä / moderaattori
  • Viestejä: 1200
    • Profiili
Mites noi 22 päivittämätöntä saa asennettua ?
Alin rivi: " 0 päivitetty, 0 uutta asennusta, 0 poistettavaa ja 22 päivittämätöntä."
0 päivitetty, 0 uutta asennusta, 0 poistettavaa ja 22 päivittämätöntä.
Sain vielä yhden :386-paketin lisukkeeksi.           
Käsitellään päivitystä... Valmis
Nämä paketit on jätetty odottamaan:
  gnome-control-center gnome-control-center-data gnome-control-center-faces intel-microcode libqt5concurrent5 libqt5core5a libqt5dbus5
  libqt5gui5 libqt5network5 libqt5opengl5 libqt5printsupport5 libqt5sql5 libqt5sql5-sqlite libqt5test5 libqt5widgets5 libqt5xml5
  python3-distupgrade qt5-gtk-platformtheme ubuntu-release-upgrader-core ubuntu-release-upgrader-gtk zlib1g zlib1g:i386 zlib1g-dev
0 päivitetty, 0 uutta asennusta, 0 poistettavaa ja 23 päivittämätöntä.

Kun järjestelmä toimii, päivitykset asentuvat, kunhan tarvittavat riippuvuudetkin ovat tarjolla asennettaviksi. ("Nämä paketit on jätetty odottamaan:")

nm

  • Käyttäjä
  • Viestejä: 16245
    • Profiili
Noista ainakin intel-microcode on ns. phased update, eli sitä testataan jonkin aikaa vaiheittain osassa Ubuntu-asennuksia ennen täysimittaista julkaisua kaikille käyttäjille.

https://people.canonical.com/~ubuntu-archive/phased-updates.html

Vaiheittaiset päivitykset ovat olleet aiemminkin käytössä Ubuntun graafisessa päivitysohjelmassa, mutta 21.04:stä lähtien myös apt noudattaa niitä oletuksena

Ehkä myös odottamaan jääneet KDE- ja Qt-päivitykset ovat vaiheittaisia. Paketit vain taitavat sijaita muualla kuin main-repositoriossa, eivätkä siksi näy ensimmäisen linkin listauksessa. Voi myös olla, että ne asentuvat apt full-upgrade -komennolla.


Full-upgraden jälkeen odottamaan jääneet paketit päivittyvät sitten ajallaan, eikä yleensä ole syytä kiirehtiä pakottamaan niitä asentumaan.
« Viimeksi muokattu: 12.09.22 - klo:23.20 kirjoittanut nm »