Kirjoittaja Aihe: Ubuntu serveri ja Syncthing käynnistys? [Ratkaistu]  (Luettu 1510 kertaa)

qwertyy

  • Käyttäjä
  • Viestejä: 5437
    • Profiili
Moi, osaako joku vinkata, että miksi esim. tämän ohjeen seuraamisen jälkeen Syncthing ei käynnisty taustalle? Komentojen jälkeen se toimii, mutta serverin käynnistämisen jälkeen ei (Palvelu inactive (dead)).
https://computingforgeeks.com/how-to-install-and-use-syncthing-on-ubuntu-18-04/

Yritin myös tehdä pilkulleen YT:n Linux.tv:n ohjeen mukaan, mutta sillä taas törmään sellaiseen, että palvelu pysähtyy aina exit2 koodiin.
https://www.youtube.com/watch?v=J1bCWv14zYg&t=1068s

Eihän Proxmoxin pitäisi vaikuttaa yhtään mitenkään asentamiseen?

Jotain tuossa systemd:ssä täytyy tapahtua mitä en tajua. Olen yrittänyt tehdä tuota siis tavalliselle käyttäjälle, joka on tehty Ubuntu serverin asennuksessa.

*lisäys*
Siis sudo systemctl start syncthing@KÄYTTÄJÄNIMENI komennon jälkeen alkaa toimia heti.
« Viimeksi muokattu: 30.03.21 - klo:22.06 kirjoittanut qwertyy »

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 11307
    • Profiili
    • Tomin kotisivut
Vs: Ubuntu serveri ja Syncthing käynnistys?
« Vastaus #1 : 30.03.21 - klo:21.57 »
Moi, osaako joku vinkata, että miksi esim. tämän ohjeen seuraamisen jälkeen Syncthing ei käynnisty taustalle? Komentojen jälkeen se toimii, mutta serverin käynnistämisen jälkeen ei (Palvelu inactive (dead)).

---

Siis sudo systemctl start syncthing@KÄYTTÄJÄNIMENI komennon jälkeen alkaa toimia heti.

Laita se automaattisesti käynnistymään komennolla:
Koodia: [Valitse]
sudo systemctl enable syncthing@KÄYTTÄJÄNIMENI
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

qwertyy

  • Käyttäjä
  • Viestejä: 5437
    • Profiili
Vs: Ubuntu serveri ja Syncthing käynnistys?
« Vastaus #2 : 30.03.21 - klo:22.05 »
Ahhh. Kiitos Tomin  :)

Olen yrittänyt kaksi päivää saada tuota toimiin ja totta tosiaan. Tuo komento puuttui tästä viimeisimmästä kokeilusta. Tuossa Linux.tv:n ohjeessa se olikin mainittuna, mutta se ei muuten toiminut jostain syystä minulla, ei sitten millään. Ironisesti myös juuri tuossa oli välilehtiä auki ja noin 10s päähän pysäytettynä YT video kohdasta, jossa tuo taas oli mainittu  ::)