Kirjoittaja Aihe: Pakettien päivitys  (Luettu 862 kertaa)

winku61

  • Käyttäjä
  • Viestejä: 5
    • Profiili
Pakettien päivitys
« : 05.11.20 - klo:18.56 »
Hei,
Olen pävittänyt  Ubuntun edellisestä LTS versiosta tähän uusinpaan ja joka kerta kun haen päivitykset niin saan seuraavan virheilmoituksen.
W: Target Packages (partner/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:34 and /etc/apt/sources.list.d/xenial-partner.list:2.
Kuinka saan korjattua asian , jotta näitä virheilmoituksia ei tulisi. Olen hiukan tumpelo tän Linuxin kanssa  :-\
Kiitos jo etukäteen  :)

epiphone

  • Käyttäjä
  • Viestejä: 703
    • Profiili
Vs: Pakettien päivitys
« Vastaus #1 : 05.11.20 - klo:19.30 »
Koodia: [Valitse]
cat /etc/apt/sources.list
Mitä tuo komento tulostaa?
Kahvi on väkevin juomani

jekku

  • Käyttäjä
  • Viestejä: 2517
    • Profiili
Vs: Pakettien päivitys
« Vastaus #2 : 05.11.20 - klo:19.31 »
Poistamalla toisen mainituista riveistä.
Mutta odottele jos joku osaisi kertoa kumman poisto om ssvistyneempi ratkaisu.

winku61

  • Käyttäjä
  • Viestejä: 5
    • Profiili
Vs: Pakettien päivitys
« Vastaus #3 : 05.11.20 - klo:20.09 »
Hei,
Tuloste on seuraavanlainen.

deb http://fi.archive.ubuntu.com/ubuntu/ focal-security main restricted
deb http://fi.archive.ubuntu.com/ubuntu/ focal-security universe
deb http://fi.archive.ubuntu.com/ubuntu/ focal-security multiverse

winku61

  • Käyttäjä
  • Viestejä: 5
    • Profiili
Vs: Pakettien päivitys
« Vastaus #4 : 05.11.20 - klo:20.19 »
Hei,
Tuloste on seuraavanlainen.

deb http://fi.archive.ubuntu.com/ubuntu/ focal-security main restricted
deb http://fi.archive.ubuntu.com/ubuntu/ focal-security universe
deb http://fi.archive.ubuntu.com/ubuntu/ focal-security multiverse

Siis seuraavanlainen

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://fi.archive.ubuntu.com/ubuntu/ focal main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://fi.archive.ubuntu.com/ubuntu/ focal-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
deb http://fi.archive.ubuntu.com/ubuntu/ focal universe
deb http://fi.archive.ubuntu.com/ubuntu/ focal-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fi.archive.ubuntu.com/ubuntu/ focal multiverse
deb http://fi.archive.ubuntu.com/ubuntu/ focal-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.

## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu/ focal partner

deb http://fi.archive.ubuntu.com/ubuntu/ focal-security main restricted
deb http://fi.archive.ubuntu.com/ubuntu/ focal-security universe
deb http://fi.archive.ubuntu.com/ubuntu/ focal-security multiverse

epiphone

  • Käyttäjä
  • Viestejä: 703
    • Profiili
Vs: Pakettien päivitys
« Vastaus #5 : 05.11.20 - klo:20.52 »
Eipä kai tuossa ainakaan minun mielestä mitään suurempaa vikaa ole.

Mitäs tiedostoja löytyy kansiosta

Koodia: [Valitse]
/etc/apt/sources.list.d
Sen voi katsoa aivan tavallisella graafisella tiedostoselaimella.

Tai komentamalla päätteessä

Koodia: [Valitse]
cd /etc/apt/sources.list.d
ja sitten, kun olet siellä kansiossa

Koodia: [Valitse]
ls
« Viimeksi muokattu: 05.11.20 - klo:21.09 kirjoittanut epiphone »
Kahvi on väkevin juomani

nm

  • Käyttäjä
  • Viestejä: 14027
    • Profiili
Vs: Pakettien päivitys
« Vastaus #6 : 06.11.20 - klo:01.18 »
Hei,
Olen pävittänyt  Ubuntun edellisestä LTS versiosta tähän uusinpaan ja joka kerta kun haen päivitykset niin saan seuraavan virheilmoituksen.
W: Target Packages (partner/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:34 and /etc/apt/sources.list.d/xenial-partner.list:2

Voit poistaa tarpeettoman tiedoston /etc/apt/sources.list.d/xenial-partner.list, koska partner-repositorio on jo määritelty tiedostossa /etc/apt/sources.list

Poistaminen onnistuu komennolla:
Koodia: [Valitse]
sudo rm /etc/apt/sources.list.d/xenial-partner.list

winku61

  • Käyttäjä
  • Viestejä: 5
    • Profiili
Vs: Pakettien päivitys
« Vastaus #7 : 06.11.20 - klo:07.02 »
Eipä kai tuossa ainakaan minun mielestä mitään suurempaa vikaa ole.

Mitäs tiedostoja löytyy kansiosta

Koodia: [Valitse]
/etc/apt/sources.list.d
Sen voi katsoa aivan tavallisella graafisella tiedostoselaimella.

Tai komentamalla päätteessä

Koodia: [Valitse]
cd /etc/apt/sources.list.d
ja sitten, kun olet siellä kansiossa

Koodia: [Valitse]
ls

seuraavanlainen

fingerprint-ubuntu-fingerprint-gui-bionic.list
fingerprint-ubuntu-fingerprint-gui-bionic.list.distUpgrade
google-chrome.list
google-chrome.list.distUpgrade
google-chrome.list.save
kubuntu-ppa-ubuntu-backports-xenial.list
kubuntu-ppa-ubuntu-backports-xenial.list.distUpgrade
kubuntu-ppa-ubuntu-backports-xenial.list.save
skype-stable.list
skype-stable.list.distUpgrade
skype-stable.list.save
xenial-dell-dali-astro-kbl.list
xenial-dell-dali-astro-kbl.list.distUpgrade
xenial-dell-dali-astro-kbl.list.save
xenial-dell.list
xenial-dell.list.distUpgrade
xenial-dell.list.save
xenial-partner.list.distUpgrade
xenial-partner.list.save

epiphone

  • Käyttäjä
  • Viestejä: 703
    • Profiili
Vs: Pakettien päivitys
« Vastaus #8 : 06.11.20 - klo:09.40 »
Minun mielestä kaikki nuo tiedostot, joissa mainitaan xenial tai bionic voi poistaa. Jos sinulla on uusin Ubuntu 20.04 LTS Focal Fossa.

Tapahtuu komennolla rm, kuten nm tuossa edellä kirjoitti.

Koodia: [Valitse]
sudo rm xenial-partner.list.save
Koodia: [Valitse]
sudo rm xenial-partner.list.distUpgrade
Ja niin edelleen.
Kahvi on väkevin juomani

raimo

  • Käyttäjä
  • Viestejä: 3578
    • Profiili
Vs: Pakettien päivitys
« Vastaus #9 : 06.11.20 - klo:11.34 »
Minun mielestä kaikki nuo tiedostot, joissa mainitaan xenial tai bionic voi poistaa. Jos sinulla on uusin Ubuntu 20.04 LTS Focal Fossa.

Tapahtuu komennolla rm, kuten nm tuossa edellä kirjoitti.

Koodia: [Valitse]
sudo rm xenial-partner.list.save
Koodia: [Valitse]
sudo rm xenial-partner.list.distUpgrade
Ja niin edelleen.

Kerralla koko sakki nevadaan.
Koodia: [Valitse]
sudo rm *xenial*
So long and thanks for all the fish!

winku61

  • Käyttäjä
  • Viestejä: 5
    • Profiili
Vs: Pakettien päivitys
« Vastaus #10 : 06.11.20 - klo:18.53 »
Hei,

Kiitoksia kaikille avusta, eiköhän tämä ollut tässä  ;)