Kirjoittaja Aihe: Digikam ei lue tietokantaa, koska merkistöasetukseni on UTF-8  (Luettu 486 kertaa)

Pontus12

  • Käyttäjä
  • Viestejä: 1459
    • Profiili
Digikam ei lue tietokantaa, koska merkistöasetukseni on UTF-8. Aiempi asetus on ollut viestin mukaan system. Kun yritin käynnistää ohjelman siitä huolimatta, se ei toiminut kunnolla, vaan jähmettyi.

nm

  • Käyttäjä
  • Viestejä: 13470
    • Profiili
Olet nähtävästi käyttänyt samaa tietokantaa Digikamin Windows-versiolla. Tietokannan ristiinkäyttö erilaisissa käyttöjärjestelmissä ei välttämättä ole järkevää, kun dataa on tallennettu tuolla tavalla järjestelmän merkistöstä riippuen. Veikkaan, ettei Digikam osaa muuntaa tietokannan merkistöä, vaan seurauksena on sekaannusta kuviin lisätyissä tageissa ja muissa tiedoissa.

Jähmettyminen saattaa kyllä johtua muustakin kuin merkistöongelmasta...

Pontus12

  • Käyttäjä
  • Viestejä: 1459
    • Profiili
Hieman epäilin itsekin, että saman tietokannan käyttäminen ei ole viisasta, mutta käytin siitä huolimatta. En ole myöskään kokeillut nyt Windowsissa Digikamia. Ehkä minun kannattaa tästedes antaa sen kirjoittaa tiedot valokuviin, vaikka se hidastaakin ohjelma. Olen sählinyt tuon tietokannan kanssa jo niin monta kertaa. En myöskään tiedä, teinkö virheen, kun jätin Shotwellin ja siirryin Digikamiin. Jälkimmäinen on edityneempi, mutta Shotwellissa minulla ei ollut ainakaan muistaakseni ongelmia.

JussiK

  • Käyttäjä
  • Viestejä: 102
    • Profiili
On Digikamissa muutakin mätää, päivitin koneen 20.04:ään ja Digikam kaatuu käynnistäessä, herjaa ettei löydä tietokantaa.