Kirjoittaja Aihe: ubuntu 20.04 ongelmia  (Luettu 2565 kertaa)

redu

  • Käyttäjä
  • Viestejä: 475
    • Profiili
ubuntu 20.04 ongelmia
« : 25.04.20 - klo:16.19 »
1.
Tuleeko suomiserveristä väkisin suomeksi käännettyjä sanoja? Esimerkiksi Thunderbird, Gparted, Synaptic package manager? Suomenkieltä on sekavasti mukana. Noitten sovellusten uudelleenasennus brittiserveristä ei poista suomisanoja. Lienevät jossakin piilossa? Pitääkö minun asentaa uusiksi koko 20.04, ja hakea sovellustäydennykset brittiserveristä?
2.
Qjackctl ei toimi. Klassinen D-bus ongelma, joka ei poistu klassisilla tempuilla. Qjackctl on essentiaalinen musanteossa.
3.
Asensin Ubun dualbootiksi Win10:n rinnalle. Boottausta Grub:iin ei saa defaultiksi. Kone boottaa aina väkisin Windoosaan. F9-tempulla pääsen valitsemaan Grub-bootin, mutta en saa grub-boottia defaultiksi.

Kone on uusi HP Envy x360. Biosissa on periaatteessa mahdollisuus vakita Linux-boot, mutta valintya ei toimi. Biossin update ei auttanut.

Osaako joku neuvoa?
Ubuntua 98%, Winkua 2%

redu

  • Käyttäjä
  • Viestejä: 475
    • Profiili
Vs: ubuntu 20.04 ongelmia
« Vastaus #1 : 25.04.20 - klo:18.41 »
Lisätietoa kohtaan 2:
Kun kytken koneeseen ulkoisen usb-DAC:in, ja valitsen Qjackctl-asetuksissa DAC:in, niin qjackctl starttaa oikein. Qjackctl ei siis kelpiuuta koneen sisäistä äänikorttia, mutta toimii ulkoisella.

EDIT:
Kohdan 1 ongelma katosi, kun asensin Ubun uusiksi. Nyt kaikki tekstit ovat enkkua.
« Viimeksi muokattu: 25.04.20 - klo:21.30 kirjoittanut redu »
Ubuntua 98%, Winkua 2%

jarmala

  • Käyttäjä
  • Viestejä: 454
    • Profiili
Vs: ubuntu 20.04 ongelmia
« Vastaus #2 : 25.04.20 - klo:18.48 »

3.
Asensin Ubun dualbootiksi Win10:n rinnalle. Boottausta Grub:iin ei saa defaultiksi. Kone boottaa aina väkisin Windoosaan. F9-tempulla pääsen valitsemaan Grub-bootin, mutta en saa grub-boottia defaultiksi.

Eihän sinulla vaan ole windowsissa joku fast boot päällä? Silloin se aina buuttaa windowsiin eikä käy grubin kautta.
Ubuntu 18.04 LTS, Gnome Flashback Metacity, Xeon E3-1245 V2, 8 GB

redu

  • Käyttäjä
  • Viestejä: 475
    • Profiili
Vs: ubuntu 20.04 ongelmia
« Vastaus #3 : 25.04.20 - klo:21.28 »

3.
Asensin Ubun dualbootiksi Win10:n rinnalle. Boottausta Grub:iin ei saa defaultiksi. Kone boottaa aina väkisin Windoosaan. F9-tempulla pääsen valitsemaan Grub-bootin, mutta en saa grub-boottia defaultiksi.

Eihän sinulla vaan ole windowsissa joku fast boot päällä? Silloin se aina buuttaa windowsiin eikä käy grubin kautta.

Hyvä ajatus! Biossissa vaan kun ei ole fastboot-asetusta. Windowssissa saattaa jossakin olla, mutten löydä sitä?



« Viimeksi muokattu: 25.04.20 - klo:21.34 kirjoittanut redu »
Ubuntua 98%, Winkua 2%

jarmala

  • Käyttäjä
  • Viestejä: 454
    • Profiili
Vs: ubuntu 20.04 ongelmia
« Vastaus #4 : 25.04.20 - klo:23.25 »
Hyvä ajatus! Biossissa vaan kun ei ole fastboot-asetusta. Windowssissa saattaa jossakin olla, mutten löydä sitä?

Se ei ole Bios:in asetus vaan windowsin. Komennat windowsin sulkemaan itsensä _ihan oikeasti_ eikä mihinkään fast boot tai itse asiassa nukku- eli hibernate -tilaan. Silloin pääset grubiin ja sen käynnistämään oletuskäyttöjärjestelmään linuxiin... En enää 20-vuotisen linux-urani jälkeen ymmärrä windowsista yhtikäs mitään, joten en osaa neuvoa, miten windows käskytetään oikeasti sulkeutumaan kunnolla. Ehkä joku muu täällä osaa. Anyone?
Ubuntu 18.04 LTS, Gnome Flashback Metacity, Xeon E3-1245 V2, 8 GB

AimoE

  • Käyttäjä
  • Viestejä: 1735
    • Profiili
Vs: ubuntu 20.04 ongelmia
« Vastaus #5 : 26.04.20 - klo:07.01 »
Netistä löytyy ohjeita kun hakee vaikka sanoilla "disable Windows fast startup". Ongelma on keksiä oikeat suomenkieliset hakusanat, koska ohjeet eivät ihan sellaisenaan toimi suomenkielisessä windowsissa. Asetus kumminkin löytyy osoitteesta Ohjauspaneeli\Laitteisto ja äänet\Virranhallinta-asetukset\Järjestelmäasetukset, ja siellä ruksiboksi "Ota käyttöön nopea käynnistys (suositus)". Jos et löydä ohjauspaneeliin suoraan, avaa Asetukset / Järjestelmä / Virta ja Lepotila ja sieltä "Virran lisäasetukset" -linkki.

redu

  • Käyttäjä
  • Viestejä: 475
    • Profiili
Vs: ubuntu 20.04 ongelmia
« Vastaus #6 : 26.04.20 - klo:14.09 »
Kiitos neuvosta!
Kaikki sujui, kunnes jouduin huomaamaan, että shutdown setting-laatikoissa on vain "Sleep" ja "Lock", vaan ei "Hibernatea" eikä "Turn on fast startup":ia, vaikka googletettu ohje näin väittääkin? Liekö Win10 tässä koneessa erilainen? Tai onko fast startup-valinta nyt jossakin muualla?

EDIT:
Olin poistanut koneesta hibernaten, kun en muuten saanut kutistettua Windows-partitiota alle puolen kovalevyn kokoiseksi (hibernaten tallennuspaikka on defaultisti kovalevyn (ssd:n) keskellä, kiitos Microsoft!).
Nyt fast startup on poistettu.
Mutta kone ei silti boottaa Grub:ista muuten kuin F9-tempulla.
Pitäisikö minun nyt asentaa koko Ubu 20.04 uusiksi fast startupin poiston jälkeen?

EDIT2:
Kuten kirjoitin aiemmin, Biossissa on paikka, jossa voi valita Windows-bootin tai Grub-bootin. Mutta tämä paikka ei toimi = ei tallenna valinnanmuutosta.
« Viimeksi muokattu: 26.04.20 - klo:14.54 kirjoittanut redu »
Ubuntua 98%, Winkua 2%

redu

  • Käyttäjä
  • Viestejä: 475
    • Profiili
Vs: ubuntu 20.04 ongelmia
« Vastaus #7 : 26.04.20 - klo:17.41 »
Nyt grub boot manager toimii, kuin vanhaan hyvään aikaan!
Asensuín EasyUEFI-softan

https://www.easyuefi.com/faq/en-US/Disable-Enable-UEFI-Boot-Entries.html

ja disabloin (punainen täplä) koko Windows boot manager-entryn = Uhkarohkea temppu.

Pääsen nyt Grubin listasta myös Windoosaan silloin harvoin kun tarvetta on.


Nyt on ubuntu 20.04-ongelmana enää se, että Jack (Qjackctl) ei toimi, vaikka siinä on oikeat input/output asetukset. En ymmärrä yhtään, mistä kiikastaa?


Huomio: Ubuntu 20.04 tuntuu paljon epästabiilimmalta kuin Win10. Aika-ajoin joku sovellus tai koko käyttis tilttaa. Updateja odotellaan.
« Viimeksi muokattu: 26.04.20 - klo:17.43 kirjoittanut redu »
Ubuntua 98%, Winkua 2%

tikola

  • Käyttäjä
  • Viestejä: 152
    • Profiili
Vs: ubuntu 20.04 ongelmia
« Vastaus #8 : 27.04.20 - klo:12.46 »
Liittynee vähän samaan, eli minun pöytäkone meni päivityksessä mustaksi eikä sanonut mitään, ennen kuin poistin BIOSista kaikenlaista UEFI/AHCI jne. modernimmalta kuulostavia ominaisuuksia ja korvasin ne IDE tms. tiloilla. Siis jotain tämmöistä seurasin:

https://askubuntu.com/questions/1230512/why-ubuntu-20-04-does-not-boot-properly

Eli haiskahtaisi hieman, että 20.04 on vaikeuksissa erilaisten uudehkojen emolevyominaisuuksien kanssa ja innokkaan päivittäjän kannattaa nyt kuukausi pari odotella ihan rauhassa.

redu

  • Käyttäjä
  • Viestejä: 475
    • Profiili
Vs: ubuntu 20.04 ongelmia
« Vastaus #9 : 11.05.20 - klo:16.29 »
Huomasin tänään yllättäen että
Jack:ia hylkivässä koneessa ei alsamikserissä ole ollenklaan PCM-kanavaa? Kahdessa muussa koneessa, joissa Jack toimii on alsamikserissä PCM-palkki.

Mutta en silti saa ongelmakonetta toimimaan, kun en ymmärrä, mistä PCM-kanavan puute johtuu?
Ubuntua 98%, Winkua 2%

kjunix

  • Käyttäjä
  • Viestejä: 28
    • Profiili
Vs: ubuntu 20.04 ongelmia
« Vastaus #10 : 11.05.20 - klo:18.45 »
Ei tuolla ohjelmien kielellä ole serverin kanssa mitään tekemistä vaan sen kanssa minkä olet asettanut käyttiksen kieleksi.

redu

  • Käyttäjä
  • Viestejä: 475
    • Profiili
Vs: ubuntu 20.04 ongelmia
« Vastaus #11 : 12.05.20 - klo:15.19 »
Ei tuolla ohjelmien kielellä ole serverin kanssa mitään tekemistä vaan sen kanssa minkä olet asettanut käyttiksen kieleksi.

Noin se taitaa olla? Sekoitin koko ubuntun kielijutut, ja ne selkiytyivät vasta kun asensin koko ubun uusiksi.
Ubuntua 98%, Winkua 2%