Kirjoittaja Aihe: Apache sekaisin LE:n poistoyrityksen jälkeen  (Luettu 302 kertaa)

teele

  • Käyttäjä
  • Viestejä: 528
    • Profiili
Apache sekaisin LE:n poistoyrityksen jälkeen
« : 08.03.20 - klo:14.40 »

Olisiko vielä mahdollista pelastaa Apache, kun Let's encryptin poistoyritysten jälkeen virhetilanne  on

Koodia: [Valitse]
apachectl start
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
(13)Permission denied: AH00072: make_sock: could not bind to address [::]:80
(13)Permission denied: AH00072: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
AH00015: Unable to open logs
Action 'start' failed.

Mitä pitäisi server nameksi asettaa, jos se olisi ratkaisu asiaan. Palvelin on pilvessä virtuaalikoneessa eikä sillä taida olla nimeäkään, osoite on, ainakin toivottavasti vielä, jolleivät asist oel vieläkin pahemmin sotkussa.



nm

  • Käyttäjä
  • Viestejä: 13371
    • Profiili
Vs: Apache sekaisin LE:n poistoyrityksen jälkeen
« Vastaus #1 : 08.03.20 - klo:16.36 »
Käynnistä palvelu komennolla:

Koodia: [Valitse]
sudo service apache2 start

teele

  • Käyttäjä
  • Viestejä: 528
    • Profiili
Vs: Apache sekaisin LE:n poistoyrityksen jälkeen
« Vastaus #2 : 08.03.20 - klo:19.20 »


Komennpolla sai apachen käyntiin, mutta nyt tulee selaimessa ilmoitus ,

Koodia: [Valitse]
Secure Connection Failed

An error occurred during a connection to evvk.dy.fi. SSL received a record that exceeded the maximum permissible length.

Error code: SSL_ERROR_RX_RECORD_TOO_LONG

    The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
    Please contact the website owners to inform them of this problem.

.conf-tiedosto on tällainen

Koodia: [Valitse]
<VirtualHost *:80>
ServerAdmin webmaster@localhost
ServerName evvk.dy.fi
DocumentRoot "/var/www/html/pehmolinkattu_evvk-tila"
           <Directory />
             Options FollowSymLinks
             AllowOverride None
            </Directory>
ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

Eli siitä on yritetty tehdä ihan tavllinen ilman mitään viittauksia salailuun, ei rewrite ruleja tms., mutta jossain salailua kuitenkin vaaditaan LE:n jäljiltä.

Mistä sitä pitäisi etsiä ja miten sen saisi pois päältä.

Muok.
Virhe oli ainakin tehdyssä selainkentän pyynnössä, se täydentyi automaattisesti https-muotoon. Kun osoitekenttään kirjoitetaan http:// sivun eteen, näyttäisi toimivan. Tämä siis sen jälkeen, kun sain apachen käyntiin tämän keskustelusäikeen neuvojn avulla. Testailen vielä, näyttää hyvältä  :)
« Viimeksi muokattu: 08.03.20 - klo:19.33 kirjoittanut teele »