Kirjoittaja Aihe: Slideshow lakkasi toimimasta [ratkaistu]  (Luettu 1558 kertaa)

Seppo Jyrkinen

  • Käyttäjä
  • Viestejä: 157
    • Profiili
Slideshow lakkasi toimimasta [ratkaistu]
« : 16.12.19 - klo:07.43 »
Viime kesänä omilla sivuillani oli toimiva slideshow, jonka poistin tarpeettomana. Nyt laitoin sen kopion verkkoon, mutta ei toimi enää, ei Firefoxilla eikä Chromella eikä kännyssä. Tuore kopio on osoitteessa https://www.jyrkinen.fi/slide/index.html

Alkuperäinen koodi on Dynamic Drivessä http://www.dynamicdrive.com/dynamicindex14/fullpageslideshow/index.htm ja se toimii. Vaan kun kopioin tiedot omaan tiedostooni, niin ei toimi. Sitten tallensin kyseisen DD sivun omalle koneelleni mitään muuttamatta, ja se lakkasi toimimasta.

Minulta loppuu järki.
« Viimeksi muokattu: 16.12.19 - klo:15.20 kirjoittanut Seppo Jyrkinen »

nm

  • Käyttäjä
  • Viestejä: 13371
    • Profiili
Vs: Slideshow lakkasi toimimasta
« Vastaus #1 : 16.12.19 - klo:12.33 »
Avaa selaimeen kehittäjätyökalut (Ctrl+Shift+I) ja katso, mitä virheitä javascript-konsolissa näkyy. Chrome herjaa tällaista:

Koodia: [Valitse]
index.html:1 Mixed Content: The page at 'https://www.jyrkinen.fi/slide/index.html' was loaded over HTTPS, but requested an insecure script 'http://ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js'. This request has been blocked; the content must be served over HTTPS.

smooth_slider.css:1 Failed to load resource: the server responded with a status of 404 (Not Found)

jquery-slider.js:601 Uncaught ReferenceError: jQuery is not defined
    at jquery-slider.js:601

index.html:24 Uncaught ReferenceError: $ is not defined
    at index.html:24

smooth_slider.css:1 Failed to load resource: the server responded with a status of 404 (Not Found)

installHook.js:1 Uncaught TypeError: Cannot convert undefined or null to object
    at Function.keys (<anonymous>)
    at Module.12 (installHook.js:1)
    at n (installHook.js:1)
    at installHook.js:1

Eli korvaa jqueryn osoitteessa http -> https ja kopioi smooth_slider.css paikalleen. Tarkista sitten uudelleen, ettei virheitä enää tule.

Seppo Jyrkinen

  • Käyttäjä
  • Viestejä: 157
    • Profiili
Vs: Slideshow lakkasi toimimasta
« Vastaus #2 : 16.12.19 - klo:13.27 »
DD:n omilla sivuilla tuo toimii oikein. Mahtaako olla niin, että DD:n omilla sivuilla on oikea scripti, mutta se materiaali, jota tuo sivusto kehottaa kopioimaan, on puutteellista?

raimo

  • Käyttäjä
  • Viestejä: 3482
    • Profiili
Vs: Slideshow lakkasi toimimasta
« Vastaus #3 : 16.12.19 - klo:13.34 »
Hyvinhän tuo näyttää toimivan. Chromella kokeilin.
So long and thanks for all the fish!

Seppo Jyrkinen

  • Käyttäjä
  • Viestejä: 157
    • Profiili
Vs: Slideshow lakkasi toimimasta
« Vastaus #4 : 16.12.19 - klo:13.40 »
Slideshow toimii hyvin DD:n omilla sivuilla, mutta lakkaa toimimasta kun sen kopioi jollekin toiselle sivustolle.

raimo

  • Käyttäjä
  • Viestejä: 3482
    • Profiili
Vs: Slideshow lakkasi toimimasta
« Vastaus #5 : 16.12.19 - klo:13.42 »
Slideshow toimii hyvin DD:n omilla sivuilla, mutta lakkaa toimimasta kun sen kopioi jollekin toiselle sivustolle.

Tuolla https://www.jyrkinen.fi/slide/index.html toimii ihan OK, ehkä sinun pitää tyhjentää selaimen välimuisti tai painaa Ctrl+F5 sivulla.
So long and thanks for all the fish!

nm

  • Käyttäjä
  • Viestejä: 13371
    • Profiili
Vs: Slideshow lakkasi toimimasta
« Vastaus #6 : 16.12.19 - klo:14.57 »
http://www.dynamicdrive.com on HTTP-domain, joten siksi siellä toimii viittaus skriptiin http://ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js

https://www.jyrkinen.fi on HTTPS-domain, jolloin on käytettävä HTTPS-osoitetta https://ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js

Joku selain saattaa hyväksyä myös tuon HTTP-osoitteen HTTPS-sivulla, mutta ainakin Chrome ja Firefox blokkaavat skriptin.

Seppo Jyrkinen

  • Käyttäjä
  • Viestejä: 157
    • Profiili
Vs: Slideshow lakkasi toimimasta
« Vastaus #7 : 16.12.19 - klo:15.14 »
Toimii sittenkin, kiitoksia jälleen kovasti!
« Viimeksi muokattu: 16.12.19 - klo:15.20 kirjoittanut Seppo Jyrkinen »

nm

  • Käyttäjä
  • Viestejä: 13371
    • Profiili
Vs: Slideshow lakkasi toimimasta
« Vastaus #8 : 16.12.19 - klo:15.51 »
Toimii sittenkin, kiitoksia jälleen kovasti!

Jees, nyt toimii paremmin. smooth_slider.css tosin puuttuu vielä.

Seppo Jyrkinen

  • Käyttäjä
  • Viestejä: 157
    • Profiili
Vs: Slideshow lakkasi toimimasta [ratkaistu]
« Vastaus #9 : 16.12.19 - klo:19.53 »
Joo, tuo smooth oli minulla jemmassa... ;D

Kun homma alkoi toimia, niin tätä oli itse asiassa ihan hauska tehdä. Ideoita pursui yhtenään. Toki valmiitakin on, mutta itse muokatussa aina jotain ainutlaatuista. Kannattaa kokeilla!

Lopullinen: https://www.jyrkinen.fi/joulutervehdys/

raimo

  • Käyttäjä
  • Viestejä: 3482
    • Profiili
So long and thanks for all the fish!