Kirjoittaja Aihe: Kdenlive 19.** ja Kdenlive 18.**:sta luodut projektit [RATKAISTU]  (Luettu 1644 kertaa)

julio

  • Käyttäjä
  • Viestejä: 94
    • Profiili
Moi!

Alustuksena ongelmaan seuraavaa. Olen käyttänyt Kdenliveä joitakin vuosia, ja ajoittaisista bugailuista huolimatta sen parissa työskentely on kuitenkin pääasiassa onnistunut. Nyt videota editodessani Kdenlive 18.**:ssa ilmeni kummallisia bugeja, jotka teki sen lähes käyttökelvottomaksi. Esim kaikki aikajanan asetukset ei tallennu, kun ohjelman sulkee ja avaa myöhemmin uudestaan. Usein avatessa aikajanalle myös ilmestyy jotain random klippejä, joita on aikaisemmin sieltä poistanut. Usein teki myös sitä, että kun klippiä aikajanalla leikkasi tai pidensi, hävisi leike aikajanalta kokonaan. Aikajanalle ilmestyi myös joitakin "haamuklippejä", jotka ei siis aikajanalla näkynyt, mutta täytti tilan kuitenkin.

Noh, ajattelin tämän kanssa tovin painiskeltuani päivittää versioon 19.**, jota ainakin ohjelman sivuilla kehuttiin vakaammaksi. Tämän kanssa ilmeni vaan sitä, että ohjelma ei löydä järjestelmäkovon lisäksi muita kovalevyjä ollenkaan. Minulla projektit ja tiedostot on erillisellä kovalevyllä. Lisäksi 19.** ei tunnista Kdenlive 18.** luotuja projekteja. Onko joku kokenut vastaavaa?

Mainittakoon, että edellisen kerran työskentelin Kdenliven 18.** kanssa kesäkuussa, eikä silloin merkittäviä ongelmia ilmennyt.
« Viimeksi muokattu: 09.11.19 - klo:16.19 kirjoittanut julio »
Ubuntu 18.04
Intel Core i5-6600K 3.5GHz
16Gb DDR3
GeForce GTX970

mpiso

  • Käyttäjä
  • Viestejä: 422
    • Profiili
Vs: Kdenlive 19.** ja Kdenlive 18.**:sta luodut projektit
« Vastaus #1 : 09.11.19 - klo:15.30 »
Allekirjoituksen mukaan sinulla on Ubuntu 18.04. Lataussivun (ppa) mukaan Kdenlive 19.04 ei toimi siinä oikein. Siellä lukee:

”19.04 is the result of our 3 year long code refactoring, making it much more understandable, maintainable and extensible. It is already globally more stable than 16.x-18.x releases, but there are still some features missing and less tested areas. Unfortunately, the QML parts are not reliable with Qt versions below 5.11, so bionic is out of scope (18.04 LTS, basis for several derivatives).”

https://launchpad.net/~kdenlive/+archive/ubuntu/kdenlive-stable

julio

  • Käyttäjä
  • Viestejä: 94
    • Profiili
Vs: Kdenlive 19.** ja Kdenlive 18.**:sta luodut projektit
« Vastaus #2 : 09.11.19 - klo:16.18 »
Ok, kiitokset. Täytynee siis siirtyä takaisin aikaisempaan.
Ubuntu 18.04
Intel Core i5-6600K 3.5GHz
16Gb DDR3
GeForce GTX970

Postimies

  • Käyttäjä
  • Viestejä: 2379
    • Profiili
Qt kirjastoista 5.12.5  on jo vakaa ja uusin on 5.13.5 itsellä kokeilussa.  Kehittyy kovaa vauhtia.
P'äivittämistä uudempaan voi miettiä, jos ei tarvetta pysyä nykyisessä.

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 10989
    • Profiili
    • Tomin kotisivut
Qt kirjastoista 5.12.5  on jo vakaa ja uusin on 5.13.5 itsellä kokeilussa.  Kehittyy kovaa vauhtia.
P'äivittämistä uudempaan voi miettiä, jos ei tarvetta pysyä nykyisessä.

Ubuntussa ja muutenkin useimmissa jakeluissa ei ole järkevää lähteä itse päivittämään Qt-kirjastoa muuhun kuin jakelun tarjoamaan versioon. Sillä voi saada koneensa solmuun. Uudemman Qt:n saa sitten, kun päivättää uudempaan jakeluversioon.

Nykyään on onneksi mahdollista käyttää uudempia paketinhallintoja kuten Flatpakiä tai Snapia, jossa ohjelman käyttämien kirjastojen versiot eivät enää riipu jakelun tarjoamasta versiosta. Tämä on mahdollista, koska Flatpak asentaa ohjelman tarvitseman ajonaikaisen ympäristön, jonka sisällä ohjelma suoritetaan. Kdenlivekin näyttää olevan saatavilla Flathubista, joten Flatpak-versiota voisi kokeilla: https://flathub.org/apps/details/org.kde.kdenlive (tällä hetkellä versio 19.08.3).
« Viimeksi muokattu: 21.11.19 - klo:20.35 kirjoittanut Tomin »
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

Postimies

  • Käyttäjä
  • Viestejä: 2379
    • Profiili

Ubuntussa ja muutenkin useimmissa jakeluissa ei ole järkevää lähteä itse päivittämään Qt-kirjastoa muuhun kuin jakelun tarjoamaan versioon. Sillä voi saada koneensa solmuun. Uudemman Qt:n saa sitten, kun päivättää uudempaan jakeluversioon.

Voihan sitä kokeeksi asentaa vaikka KUbuntu 19.10 jollekin levynkulmalle tai käyttää asennusmediaa jos päivitys ei innosta.
Ainakin Kubuntu-ppa Backports löytyy jos ei vielä ole oletuksena. Itse en tuota käytä joten en osaa sanoa miten toimii.
« Viimeksi muokattu: 25.11.19 - klo:19.18 kirjoittanut Postimies »