Kirjoittaja Aihe: Rikkinäiset paketit estää päivittämisen (ratkaistu)  (Luettu 515 kertaa)

saisse

  • Käyttäjä
  • Viestejä: 4
    • Profiili
Terve! Olen osaamaton Ubuntun käyttäjä. Nyt päivitykset on mennyt täysin jumiin, enkä löytänyt täysin sopivia ohjeita vastaavista tapauksista haulla.

Ohjelmistopäivitykset-sovellus antaa virheilmoituksen:
"E:Virhe, pkgProblemResolver::Resolve tuotti katkoja, syynä voi olla pysytetyt paketit."

Paketeissa on riippuvuusvirheitä monodelop-ohjelman osalta, enkä saa poistettua kysestä sovellusta.

Komento "sudo apt --fix-broken install" tuotaa ilmoituksen:

Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
Korjataan riippuvuuksia... ei onnistunut.
Näillä paketeilla on tyydyttämättömiä riippuvuuksia:
 mono-devel : Riippuvuudet: ca-certificates-mono (= 6.0.0.319-0xamarin2+ubuntu1804b1) mutta 5.18.1.28-0xamarin5+ubuntu1804b1 on asennettu
E: Virhe, pkgProblemResolver::Resolve tuotti katkoja, syynä voi olla pysytetyt paketit.
E: Riippuvuuksien korjaus ei onnistu

Mistä pitäisi lähteä liikkeelle?
« Viimeksi muokattu: 21.08.19 - klo:20.48 kirjoittanut saisse »

nm

  • Käyttäjä
  • Viestejä: 12946
    • Profiili
Vs: Rikkinäiset paketit estää päivittämisen
« Vastaus #1 : 21.08.19 - klo:10.51 »
Ilmeisesti jokin paketin virhe estää ca-certificates-mono:n päivityksen. Kokeile poistaa ongelmalliset paketit dpkg:llä ja asenna ne sitten uudelleen:

Koodia: [Valitse]
sudo dpkg --remove ca-certificates-mono mono-devel
Koodia: [Valitse]
sudo apt install ca-certificates-mono mono-devel

saisse

  • Käyttäjä
  • Viestejä: 4
    • Profiili
Vs: Rikkinäiset paketit estää päivittämisen
« Vastaus #2 : 21.08.19 - klo:11.18 »
Vähän saman tapaista virheilmoitusta antaa kuin koko sovellusta poistettaessa:

sudo dpkg --remove ca-certificates-mono mono-devel
[sudo] salasana henkilölle x
dpkg: dependency problems prevent removal of mono-devel:
 fsharp riippuu paketista mono-devel (>= 4.0.0~); kuitenkin:
  Paketti mono-devel poistetaan.
 mono-roslyn riippuu paketista mono-devel; kuitenkin:
  Paketti mono-devel poistetaan.

dpkg: error processing package mono-devel (--remove):
 riippuvuusongelma - ei poistettu
dpkg: dependency problems prevent removal of ca-certificates-mono:
 mono-devel riippuu paketista ca-certificates-mono (= 6.0.0.319-0xamarin2+ubuntu1804b1); kuitenkin:
  Paketti ca-certificates-mono poistetaan.

dpkg: error processing package ca-certificates-mono (--remove):
 riippuvuusongelma - ei poistettu
Käsittelyssä tapahtui liian monta virhettä:
 mono-devel
 ca-certificates-mono

nm

  • Käyttäjä
  • Viestejä: 12946
    • Profiili
Vs: Rikkinäiset paketit estää päivittämisen
« Vastaus #3 : 21.08.19 - klo:11.42 »
Okei, riippuvuudet estävät suoran poiston, mutta voit seurata ketjua dpkg:n ilmoitusten mukaan. Eli poista myös fsharp ja mono-roslyn:

Koodia: [Valitse]
sudo dpkg --remove fsharp mono-roslyn ca-certificates-mono mono-devel
Luultavasti ketjussa on vielä muutakin, ja dpkg herjaa edelleen riippuvuuksista. Lisää nekin paketit komentoon.

saisse

  • Käyttäjä
  • Viestejä: 4
    • Profiili
Vs: Rikkinäiset paketit estää päivittämisen
« Vastaus #4 : 21.08.19 - klo:12.14 »
Tuo ketju ei tainnut jatkua pidemmälle jos oikein ymmärsin. Kuitenkaan tuo komento ei suostu toimimaan:

sudo dpkg --remove fsharp mono-roslyn ca-certificates-mono mono-devel
dpkg: dependency problems prevent removal of fsharp:
 monodevelop riippuu paketista fsharp.

dpkg: error processing package fsharp (--remove):
 riippuvuusongelma - ei poistettu
dpkg: dependency problems prevent removal of mono-devel:
 fsharp riippuu paketista mono-devel (>= 4.0.0~); kuitenkin:
  Paketti mono-devel poistetaan.

dpkg: error processing package mono-devel (--remove):
 riippuvuusongelma - ei poistettu
dpkg: dependency problems prevent removal of mono-roslyn:
 mono-devel riippuu paketista mono-roslyn (= 6.0.0.319-0xamarin2+ubuntu1804b1); kuitenkin:
  Paketti mono-roslyn poistetaan.

dpkg: error processing package mono-roslyn (--remove):
 riippuvuusongelma - ei poistettu
dpkg: dependency problems prevent removal of ca-certificates-mono:
 mono-devel riippuu paketista ca-certificates-mono (= 6.0.0.319-0xamarin2+ubuntu1804b1); kuitenkin:
  Paketti ca-certificates-mono poistetaan.

dpkg: error processing package ca-certificates-mono (--remove):
 riippuvuusongelma - ei poistettu
Käsittelyssä tapahtui liian monta virhettä:
 fsharp
 mono-devel
 mono-roslyn
 ca-certificates-mono

nm

  • Käyttäjä
  • Viestejä: 12946
    • Profiili
Vs: Rikkinäiset paketit estää päivittämisen
« Vastaus #5 : 21.08.19 - klo:13.04 »
Tuo ketju ei tainnut jatkua pidemmälle jos oikein ymmärsin. Kuitenkaan tuo komento ei suostu toimimaan:

sudo dpkg --remove fsharp mono-roslyn ca-certificates-mono mono-devel
dpkg: dependency problems prevent removal of fsharp:
 monodevelop riippuu paketista fsharp.

Jatkui se vielä monodevelop-pakettiin, kuten dpkg tuossa ilmoittaa. Eli lisää se poistettavien joukkoon:

Koodia: [Valitse]
sudo dpkg --remove monodevelop fsharp mono-roslyn ca-certificates-mono mono-devel

saisse

  • Käyttäjä
  • Viestejä: 4
    • Profiili
Vs: Rikkinäiset paketit estää päivittämisen [ratkaistu]
« Vastaus #6 : 21.08.19 - klo:13.32 »
Katos joo! Tuohon kun vielä lisäsi yhden paketin (monodoc-manual) ketjuun, niin suostui lähtemään!

Kiitos paljon avusta!

Vielä ei suostunut "sudo apt --fix-broken install" toimimaan riippuvuusogelmien vuoksi (vielä näitä monopaketteja), mutta jos nyt lähtisi tästä aukenemaan. Palaan asiaan kun olen ehtinyt poistella lisää paketteja.

Edit: Piti sittenkin vain käyttää autoremove-käskyä tässä välissä, jolloin nuo kaikki monot sitten lopulta hävisivät ja pakettiriippuvuudet ehjenivät.

Nyt kaikki taas tuntuu toimivan. Kiitokset vielä!

« Viimeksi muokattu: 21.08.19 - klo:20.47 kirjoittanut saisse »