Kirjoittaja Aihe: Lentokonetila ilmestyi päivityksessä eikä poistu ja wifi ei kytkeydy  (Luettu 740 kertaa)

Samanta

  • Käyttäjä
  • Viestejä: 18
    • Profiili
Hei,

Näin aiemmista keskusteluista, että tätä teemaa on sivuttuakin jo aiemmin. Mulla on kyseessä tässä HP EliteBook 6930p + Ubuntu 18.04LTS kone, jossa online päivityksen jälkeen ilmaantui uusi tilanne, jossa ''Lentokonetila on päällä'' ja Wifi ei mene päälle eikä Lentokonetilla  mene pois päältä.   

12.5.2016 nimimerkkien Savi ja nm välisessä keskustelussa  https://forum.ubuntu-fi.org/index.php?topic=50649.msg387943#msg387943 käsiteltiin HP EliteBook 820 kannettavan PC:n osalta saman tyyppistä tilannetta, jossa nimimerkki nm neuvoi, että .''....Joissain Elitebook 820 -malleissa on ilmeisesti BCM43228, jolloin ongelma johtuu puuttuvasta firmwaresta. Siinä tapauksessa riittää, että asennat paketin firmware-b43-installer:  sudo apt install firmware-b43-installer ....''  ja todettiin, että ....''Jep, eli Broadcomin wl-ajuri on nyt asennettuna ja estää b43:n käytön. Periaatteessa wifin pitäisi toimia myös tuolla wl-ajurilla, mutta ehkä päivityksessä meni jotain pieleen sen osalta.
Kokeile poistaa ajuri:
Koodia: [Valitse]
sudo apt-get purge bcmwl-kernel-source
Käynnistä sitten järjestelmä uudelleen. Jos ei lähde toimimaan, näytä grepin ja lshw:n listaukset uudelleen. ''' ja näillä ohjeilla

Tässä mun tapauksessa sama komento lshw -c network antaa tulokseksi, että:

 *-network                 
       description: Ethernet interface
       product: 82567LM Gigabit Network Connection
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: enp0s25
       version: 03
       serial: 00:24:81:d1:44:ec
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k duplex=full firmware=1.8-3 ip=192.168.8.103 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:31 memory:d8800000-d881ffff memory:d8824000-d8824fff ioport:70e0(size=32)
  *-network DISABLED
       description: Wireless interface
       product: Ultimate N WiFi Link 5300
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wls1
       version: 00
       serial: 00:21:6a:38:a0:0e
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=4.15.0-43-generic firmware=8.83.5.1 build 33692 latency=0 link=no multicast=yes wireless=IEEE 802.11
       resources: irq:30 memory:d8600000-d8601fff
...

eli tämän koneen wifi on DISABLED ja syy lienee Intellin Ultimate N WiFi Link 5300, joka ei nyt toimi. 

Koska tässä mulla on kyseessä eri laite, uskalla (osaamattomuuttani) käyttää em keskustelussa 12.5.2016 nm:n antamia jatko-ohjeita ongelman ratkaisuun: eli .... '' Tuli mieleen, että aiempi  Broadcomin wl-ajurin asennus on saattanut kytkeä kernelin b43-ajurin pois käytöstä. Mitä nämä komennot kertovat:

Koodia: [Valitse]
grep -R b43 /etc/modprobe.d/
Koodia: [Valitse]
dpkg -l |grep bcmwl

ja se ongelmatilanne päättyi onnelliseen ratkaisuun
.......

Miten saisin tämän koneen Intellin wifin toimimaan ja, uskoakseni, sen kautta myös Lentokonetilan pois päältä ?

Toivottavasti tämän ongelmatilanteen ratkaisusta on hyötyä muillekin !!






 
« Viimeksi muokattu: 27.12.18 - klo:16.49 kirjoittanut Samanta »

nm

  • Käyttäjä
  • Viestejä: 12902
    • Profiili
Joo, tuon Intelin piirin tapauksessa kyse on jostain muusta ongelmasta kuin firmwaresta tai väärästä ajurista. Todennäköisin syy on koneen wifi-kytkin (erillinen painike tai näppäimistöyhdistelmä Fn+jokufunktionäppäin). Jos näppäimistössä ei ole selkeää merkintää, sijainti kerrotaan koneen käyttöohjeessa. Kokeile kytkintä ja katso, vaihtuuko ledin väri tai muuttuuko tila Ubuntussa.

Jos tämä ei auta, bios-asetusten resetointi biosin omalla valinnalla on seuraava mahdollinen ratkaisu.

Samanta

  • Käyttäjä
  • Viestejä: 18
    • Profiili
nm,

Kiitos paljon fn +  painike - ohjeesta !

Nyt se kone toimii taas oikein !

« Viimeksi muokattu: 27.12.18 - klo:18.31 kirjoittanut Samanta »

HannuK

  • Käyttäjä
  • Viestejä: 141
    • Profiili
Nyt vähän asian vierestä.
On ollut hienoa seurata tämän vuoden aikana tätä keskustelupalstaa, siinä on esitetty paljon erilaisia ongelmia ja on näitä vapaaehtoisia sankareita jotka neuvovat ja auttavat vapaaehtoisesti. Hienoa hommaa ja kiitokset kaikille avustajille varmaankin meidän kaikkien neuvoa pyytäneiden puolesta ja samalla minäkin kiitän ja toivotan hyvää ja  menestyksellistä uutta vuotta 2019  kaikille palstalla vieraileville!