Kirjoittaja Aihe: [Ratkaistu] Ispconfig ja Mapserver  (Luettu 1603 kertaa)

JJK

  • Käyttäjä
  • Viestejä: 309
  • Lubuntu 16.04
    • Profiili
[Ratkaistu] Ispconfig ja Mapserver
« : 29.09.18 - klo:09.59 »
Yritän saada mapserveriä toimimaan Ispconfigin kans Ubuntu server 16.04:ssa.
Mapserver asennettu mutta sitä ei vain löydy /cgi-bin kansiosta

Lainaus
Not Found
The requested URL /cgi-bin/mapserv was not found on this server.

Teen linkin
sudo ln -s /usr/bin/mapserv /var/www/clients/client1/web4/cgi-bin/mapserv

Niin saan virheen
Lainaus
Internal Server Error

Logien tietoja
suexec.log
Koodia: [Valitse]
**** uid: (5006/web4) gid: (5005/client1) cmd: mapserv
**** cannot stat program: (mapserv)

other_vhost_access.log
Koodia: [Valitse]
**** "GET /cgi-bin/mapserv HTTP/1.1" 404 1173 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:62.0) Gecko/20100101 Firefox/62.0"
****.vhost:sta löytyy tämä pätkä. Ja vielä kahteen kertaan?
Koodia: [Valitse]
<Directory /var/www/clients/client1/web4/cgi-bin>
Require all granted
</Directory>
ScriptAlias  /cgi-bin/ /var/www/clients/client1/web4/cgi-bin/
<FilesMatch "\.(cgi|pl)$">
SetHandler cgi-script
</FilesMatch>
# suexec enabled
<IfModule mod_suexec.c>
SuexecUserGroup web4 client1
</IfModule>

Ispconfigin sivuston asetuksista on aktivoitu CGI ja SuEXEC

Onkohan tässä kyse jostain oikeus jutuista?
« Viimeksi muokattu: 04.10.18 - klo:19.01 kirjoittanut JJK »

nm

  • Käyttäjä
  • Viestejä: 12705
    • Profiili
Vs: Ispconfig ja Mapserver
« Vastaus #1 : 29.09.18 - klo:12.25 »
Yritän saada mapserveriä toimimaan Ispconfigin kans Ubuntu server 16.04:ssa.
Mapserver asennettu mutta sitä ei vain löydy /cgi-bin kansiosta

Lainaus
Not Found
The requested URL /cgi-bin/mapserv was not found on this server.

Teen linkin
sudo ln -s /usr/bin/mapserv /var/www/clients/client1/web4/cgi-bin/mapserv

Apache ei seuraa symbolisia linkkejä ellei sitä erikseen sallita konfiguraatiossa.


****.vhost:sta löytyy tämä pätkä. Ja vielä kahteen kertaan?
Koodia: [Valitse]
<Directory /var/www/clients/client1/web4/cgi-bin>
Require all granted
</Directory>

Lisää tuonne hakemiston määritykseen rivi "Options FollowSymLinks":

Koodia: [Valitse]
<Directory /var/www/clients/client1/web4/cgi-bin>
    Options FollowSymLinks
    Require all granted
</Directory>

JJK

  • Käyttäjä
  • Viestejä: 309
  • Lubuntu 16.04
    • Profiili
Vs: Ispconfig ja Mapserver
« Vastaus #2 : 29.09.18 - klo:22.56 »

Lisää tuonne hakemiston määritykseen rivi "Options FollowSymLinks":

Koodia: [Valitse]
<Directory /var/www/clients/client1/web4/cgi-bin>
    Options FollowSymLinks
    Require all granted
</Directory>

Ei auta?
Perus Ubuntuun Mapserver on mennyt aina ilman kikkailuja. Jotenkin Ispconfig sotkee tuon homman.
« Viimeksi muokattu: 29.09.18 - klo:22.59 kirjoittanut JJK »

JJK

  • Käyttäjä
  • Viestejä: 309
  • Lubuntu 16.04
    • Profiili
Vs: Ispconfig ja Mapserver
« Vastaus #3 : 30.09.18 - klo:14.15 »
Jos teen cgi-bin kansioon perus scriptin niin se toimii
Lainaus
#!/usr/bin/perl

print "Content-type: text/html\n\n";
print "<html><body>Hello, world.</body></html>";

nm

  • Käyttäjä
  • Viestejä: 12705
    • Profiili
Vs: Ispconfig ja Mapserver
« Vastaus #4 : 30.09.18 - klo:15.17 »
Jos teen cgi-bin kansioon perus scriptin niin se toimii

Käynnistit varmaankin Apachen uudelleen konfiguraatiomuutoksen jälkeen? Mainitsit myös, että samat asetukset löytyvät konfiguraatiosta kahteen kertaan. Poistithan toisen setin, ettei ole päällekkäisiä säätöjä?

Kokeile kopioida mapserv sinne hakemistoon linkittämisen sijaan, niin selviää, johtuuko vika symbolisesta linkistä vai jostain muusta.

JJK

  • Käyttäjä
  • Viestejä: 309
  • Lubuntu 16.04
    • Profiili
Vs: Ispconfig ja Mapserver
« Vastaus #5 : 30.09.18 - klo:18.40 »
Käynnistin Apachen uudelleen.

En poistanut tuplia. Tein vain muutokset molempiin.
Pitääpä poistaa.

Poistin linkin ja kopion itse kohteen sekä annoin oikeudet
Koodia: [Valitse]
sudo rm /var/www/clients/client1/web4/cgi-bin/mapserv
sudo cp /usr/bin/mapserv /var/www/clients/client1/web4/cgi-bin/mapserv
sudo chown web4:client1 /var/www/clients/client1/web4/cgi-bin/mapserv

Näin sen sai toimii.
Pitääpä vielä testailla, kun kerkee...

JJK

  • Käyttäjä
  • Viestejä: 309
  • Lubuntu 16.04
    • Profiili
Vs: Ispconfig ja Mapserver
« Vastaus #6 : 30.09.18 - klo:23.00 »
Tupla rivit ****.vhost:sissa eka setti on salaamattomalle(<VirtualHost *.*.*.*:80>) toinen salatulle (<VirtualHost *.*.*.*:443>)
Eli alkuperäinen vika ei ole sekään.

cgi-bin kansion listaus:ls -l
Lainaus
-rwxr-xr-x 1 web4 client1 10240 syys  30 18:29 mapserv
lrwxrwxrwx 1 root root       16 syys  30 23:17 mapserv2 -> /usr/bin/mapserv
-rwxr-xr-x 1 web4 client1   103 syys  30 14:06 test

mapserv2 on tehty linkkinä testausta varten
« Viimeksi muokattu: 30.09.18 - klo:23.38 kirjoittanut JJK »

nm

  • Käyttäjä
  • Viestejä: 12705
    • Profiili
Vs: Ispconfig ja Mapserver
« Vastaus #7 : 01.10.18 - klo:22.22 »
Jos konfiguraatio vaatii toimiakseen nuo web4:client1 -oikeudet, niitä ei ole /usr/bin/mapserv-binäärillä.