Kirjoittaja Aihe: Dual boot ei toimi enää - error: no such device setting partition type to 0x7  (Luettu 2275 kertaa)

JA5U

  • Käyttäjä
  • Viestejä: 427
    • Profiili
Moi

Nyt ei pääse enää Windows 7, kun tulee em. herja.

Koodia: [Valitse]
sudo blkid
/dev/loop0: TYPE="squashfs"
/dev/loop1: TYPE="squashfs"
/dev/loop2: TYPE="squashfs"
/dev/loop3: TYPE="squashfs"
/dev/loop4: TYPE="squashfs"
/dev/sda1: UUID="92A61C18A61BFC03" TYPE="ntfs" PARTUUID="001ce262-01"
/dev/sdb1: UUID="01D1083F5FDFCF40" TYPE="ntfs" PARTUUID="0f17ce2e-01"
/dev/sdb2: UUID="7EF68BFAF68BB0C7" TYPE="ntfs" PARTUUID="0f17ce2e-02"
/dev/sdb3: UUID="83b021b0-f434-4466-a109-1790ed1fe725" TYPE="ext4" PARTUUID="0f17ce2e-03"
/dev/sdb4: UUID="e49f7cab-3c72-40a9-8542-f8941e7ec1ca" TYPE="swap" PARTUUID="0f17ce2e-04"


Koodia: [Valitse]
cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdc3 during installation
UUID=83b021b0-f434-4466-a109-1790ed1fe725 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sdc4 during installation
UUID=e49f7cab-3c72-40a9-8542-f8941e7ec1ca none            swap    sw              0       0

Koodia: [Valitse]
sudo fdisk -l
Disk /dev/loop0: 87 MiB, 91160576 bytes, 178048 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop1: 81,6 MiB, 85516288 bytes, 167024 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop2: 79,6 MiB, 83488768 bytes, 163064 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop3: 86,9 MiB, 91099136 bytes, 177928 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop4: 86,6 MiB, 90812416 bytes, 177368 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/sda: 119,2 GiB, 128035676160 bytes, 250069680 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x001ce262

Device     Boot Start       End   Sectors   Size Id Type
/dev/sda1  *     2048 250068991 250066944 119,2G  7 HPFS/NTFS/exFAT


Disk /dev/sdb: 465,8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x0f17ce2e

Device     Boot     Start       End   Sectors  Size Id Type
/dev/sdb1  *        16072 388044179 388028108  185G  7 HPFS/NTFS/exFAT
/dev/sdb2       388044800 388964351    919552  449M 27 Hidden NTFS WinRE
/dev/sdb3       388965780 585117695 196151916 93,5G 83 Linux
/dev/sdb4       913252352 913283071     30720   15M 82 Linux swap / Solaris


nm

  • Käyttäjä
  • Viestejä: 12817
    • Profiili
Auttaako update-grub?

Koodia: [Valitse]
sudo update-grub

JA5U

  • Käyttäjä
  • Viestejä: 427
    • Profiili
Auttaako update-grub?

Koodia: [Valitse]
sudo update-grub

Eipä auttanut - sama tilanne .

nm

  • Käyttäjä
  • Viestejä: 12817
    • Profiili
Joudut varmaankin korjaamaan Windowsin omilla työkaluilla: https://askubuntu.com/a/872995

JA5U

  • Käyttäjä
  • Viestejä: 427
    • Profiili
Joudut varmaankin korjaamaan Windowsin omilla työkaluilla: https://askubuntu.com/a/872995
No just. Eikä ole CD/DVD-asemaa. USB:lle ei onnistunut.

Osaako joku kertoa, että mikä noissa USB-medioissa menee pieleen, kun niitä formatoi esim. eri tiedostojärjestelmiin?
EaseUS Partition softalla pitäisi pystyä luomaan WinPE levy, mutta ei onnistu tekemään sitä USB:lle ja kaatuu vain.
Tosin, sain sen kerran tekemään, mutta bootissa ei syntynyt vilkkuvaa | enempää elämää.

OT: Ylläpito taitaa siirtää tämän toisaalle

nm

  • Käyttäjä
  • Viestejä: 12817
    • Profiili
Osaako joku kertoa, että mikä noissa USB-medioissa menee pieleen, kun niitä formatoi esim. eri tiedostojärjestelmiin?
EaseUS Partition softalla pitäisi pystyä luomaan WinPE levy, mutta ei onnistu tekemään sitä USB:lle ja kaatuu vain.
Tosin, sain sen kerran tekemään, mutta bootissa ei syntynyt vilkkuvaa | enempää elämää.

Ei kokemusta kyseisestä ohjelmasta, mutta onnistuisiko manuaalisesti Windowsin omilla työkaluilla?
https://www.techradar.com/news/software/operating-systems/how-to-create-a-windows-rescue-usb-stick-984726

JA5U

  • Käyttäjä
  • Viestejä: 427
    • Profiili
Osaako joku kertoa, että mikä noissa USB-medioissa menee pieleen, kun niitä formatoi esim. eri tiedostojärjestelmiin?
EaseUS Partition softalla pitäisi pystyä luomaan WinPE levy, mutta ei onnistu tekemään sitä USB:lle ja kaatuu vain.
Tosin, sain sen kerran tekemään, mutta bootissa ei syntynyt vilkkuvaa | enempää elämää.

Ei kokemusta kyseisestä ohjelmasta, mutta onnistuisiko manuaalisesti Windowsin omilla työkaluilla?
https://www.techradar.com/news/software/operating-systems/how-to-create-a-windows-rescue-usb-stick-984726

Ei meinannut onnistua sitten millään. Ensin yritin linuxissa luoda boot asemaa, mutta turhaan.
Milloin puuttui mikäkin libpng12.so.0 kirjasto eikä esim. unetbootinia saanut aluksi toimimaan ja vaikka saikin, niin USB:ltä ei bootannut.

Sitten windowsissa ja ms omilla softilla eikä edelleenkään onnistunut.

Lopulta löysin ohjeen, jossa USB-aseman homma hoidetaan komentokehotteessa diskpart ja xcopy komennoilla.
En kyllä ymmärrä, että miten nämä omat projektit kulkee aina vaikeimman ja mutkien kautta.

nm

  • Käyttäjä
  • Viestejä: 12817
    • Profiili
Lopulta löysin ohjeen, jossa USB-aseman homma hoidetaan komentokehotteessa diskpart ja xcopy komennoilla.

Niinhän tuossa yllä mainitussa Techradarin ohjeessa neuvottiin. :)
xcopyn sijaan voi kyllä käyttää myös tiedostoselainta.

JA5U

  • Käyttäjä
  • Viestejä: 427
    • Profiili
Lopulta löysin ohjeen, jossa USB-aseman homma hoidetaan komentokehotteessa diskpart ja xcopy komennoilla.

Niinhän tuossa yllä mainitussa Techradarin ohjeessa neuvottiin. :)
xcopyn sijaan voi kyllä käyttää myös tiedostoselainta.
En tuosta TR sivusta omalla lukiräihiöllä löytänyt sitä, mutta löysin step by step ohjeen.
Oli TR sivuilla toki mainittu ainakin diskpart, mutta harvinaisen vaikeaselkoinen, imho.

Nyt on enää tuo vanha oire jäljellä eli joskus Linuxin uudelleenkäynnistyksen yhteydessä kone jää miettimään pariksi minuutiksi ennen kuin boot ikkuna tulee näkyviin.
Jotenkin vaikuttaa, että se etsii jotain laitetta tai jokin laite estää konetta käynnistymästä...