Kirjoittaja Aihe: asus usb-ac51 wlan adapterin ajuri ongelma  (Luettu 1219 kertaa)

oculardisc

  • Käyttäjä
  • Viestejä: 3
    • Profiili
asus usb-ac51 wlan adapterin ajuri ongelma
« : 06.08.18 - klo:08.20 »
hei olen uusi linux käyttäjä ja ostin juuri wlan adapterin joka tulee usb paikkaan, tikun mukana tuli linuxille .tar muodoinen asennus paketti mutten saanut asennusta tehtyä kun oli vain vaikea lukuiset ohjeet mukana, yritin purkaa paketin ja suorittaa make komennon, mutta tuli seuraava virhe ilmoitus:
Koodia: [Valitse]
cc1: some warnings being treated as errors
scripts/Makefile.build:332: recipe for target '/home/kayttaja/Lataukset/mt7610u_wifi_sta_v3001_dpo_20130725/os/linux/../../sta/sta_cfg.o' failed
make[2]: *** [/home/kayttaja/Lataukset/mt7610u_wifi_sta_v3001_dpo_20130725/os/linux/../../sta/sta_cfg.o] Error 1
Makefile:1552: recipe for target '_module_/home/kayttaja/Lataukset/mt7610u_wifi_sta_v3001_dpo_20130725/os/linux' failed
make[1]: *** [_module_/home/kayttaja/Lataukset/mt7610u_wifi_sta_v3001_dpo_20130725/os/linux] Error 2
make[1]: Poistutaan hakemistosta ”/usr/src/linux-headers-4.15.0-29-generic”
Makefile:393: recipe for target 'LINUX' failed
make: *** [LINUX] Error 2
mukana tulleet ohjeet oli seuraavanlaiset:
Lainaus
MT7610U Linux Driver quick start      

====================
Check tools: 

====================
*Before install driver, please check already install compile tool and  kernel source code

1>Install compile tool
    $yum install gcc-c++

2>check kernel source code exists /usr/src/kernels/ "kernel name"

    Download your kernel source code
    *http://www.kernel.org/pub/linux/kernel/       
   or
    $yum install kernel-devel



====================
Build Instructions: 

====================
1> $tar -xvf mt7610u_wifi_sta_vxxxx_dpo_xxxxxxxx.tar.bz2
     go to "mt7610u_wifi_sta_vxxxx_dpo_xxxxxxxx" directory.
   


2> In Makefile
   
     set the "MODE = STA" in Makefile and chose the TARGET to Linux by set "TARGET = LINUX"
   
     define the linux kernel source include file path LINUX_SRC
   
     modify to meet your need.


3> In os/linux/config.mk
   
     define the GCC and LD of the target machine
   
     define the compiler flags CFLAGS
   
     modify to meet your need.
     ** Build for being controlled by NetworkManager or wpa_supplicant wext functions
      
         Please set 'HAS_WPA_SUPPLICANT=y' and 'HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y'.
            
         => $wpa_supplicant -Dwext -ira0 -c wpa_supplicant.conf -d
     ** Build for being controlled by WpaSupplicant with Ralink Driver
      
         Please set 'HAS_WPA_SUPPLICANT=y' and 'HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=n'.
      
         => $wpa_supplicant -Dralink -ira0 -c wpa_supplicant.conf -d

4> $make         
   
     # compile driver source code, need administrator.
   
     # To fix "error: too few arguments to function ¡¥iwe_stream_add_event"
   
        => $patch -i os/linux/sta_ioctl.c.patch os/linux/sta_ioctl.c

5> $make install
     #install driver
     #copy RT2870STA.dat to /etc/Wireless/RT2870STA/RT2870STA.dat

6>$vi /etc/rc.d/rc.local
     #input "ifconfig ra0 up"

     ** Ubuntu 13.04 don't have this file.
    $reboot

7> unload driver   
   
     $ifconfig ra0 down

     $make uninstall
     $reboot


Note: If you want to change os/linux/config.mk setting, please remove driver and  reinstall.

nm

  • Käyttäjä
  • Viestejä: 12467
    • Profiili
Vs: asus usb-ac51 wlan adapterin ajuri ongelma
« Vastaus #1 : 06.08.18 - klo:13.27 »
hei olen uusi linux käyttäjä ja ostin juuri wlan adapterin joka tulee usb paikkaan, tikun mukana tuli linuxille .tar muodoinen asennus paketti mutten saanut asennusta tehtyä kun oli vain vaikea lukuiset ohjeet mukana, yritin purkaa paketin ja suorittaa make komennon, mutta tuli seuraava virhe ilmoitus:
Koodia: [Valitse]
cc1: some warnings being treated as errors
scripts/Makefile.build:332: recipe for target '/home/kayttaja/Lataukset/mt7610u_wifi_sta_v3001_dpo_20130725/os/linux/../../sta/sta_cfg.o' failed
make[2]: *** [/home/kayttaja/Lataukset/mt7610u_wifi_sta_v3001_dpo_20130725/os/linux/../../sta/sta_cfg.o] Error 1
Makefile:1552: recipe for target '_module_/home/kayttaja/Lataukset/mt7610u_wifi_sta_v3001_dpo_20130725/os/linux' failed
make[1]: *** [_module_/home/kayttaja/Lataukset/mt7610u_wifi_sta_v3001_dpo_20130725/os/linux] Error 2
make[1]: Poistutaan hakemistosta ”/usr/src/linux-headers-4.15.0-29-generic”
Makefile:393: recipe for target 'LINUX' failed
make: *** [LINUX] Error 2

Kuten yleensä, mukana tuleva Linux-ajuri on vanhentunut, nykyisten jakeluiden kanssa käyttökelvoton versio.

MT7610U:sta on keskusteltu mm. näissä aiheissa:
https://forum.ubuntu-fi.org/index.php?topic=53052.0
https://forum.ubuntu-fi.org/index.php?topic=53483

maksim

  • Käyttäjä
  • Viestejä: 131
    • Profiili
Vs: asus usb-ac51 wlan adapterin ajuri ongelma
« Vastaus #2 : 06.08.18 - klo:13.29 »
Tuo dongeli/piiri on aika haasteellista saada toimimaan Linuxissa. Minä en ole vielä saanut onnistumaan.
Vilkaise linkkiä, siellä on sama piiri.
https://forum.ubuntu-fi.org/index.php?PHPSESSID=3c64752d88234db05333ce175329603e&topic=53483.0
Mediatekin sivuilta löytyy linux-ajuri, ZIP-paketissa, mutta se on omppu-formaatista (.dmg) ja on muunnettava .img-formattiin, jotta sitä voisi käyttää.
Tuon olen tehnytkin, mutta jokin mättää vielä.
Täytyy jatkaa tutkailemista, kunhan ehdin.



nm

  • Käyttäjä
  • Viestejä: 12467
    • Profiili
Vs: asus usb-ac51 wlan adapterin ajuri ongelma
« Vastaus #3 : 06.08.18 - klo:13.43 »
Tuo dongeli/piiri on aika haasteellista saada toimimaan Linuxissa. Minä en ole vielä saanut onnistumaan.
Vilkaise linkkiä, siellä on sama piiri.
https://forum.ubuntu-fi.org/index.php?PHPSESSID=3c64752d88234db05333ce175329603e&topic=53483.0
Mediatekin sivuilta löytyy linux-ajuri, ZIP-paketissa, mutta se on omppu-formaatista (.dmg) ja on muunnettava .img-formattiin, jotta sitä voisi käyttää.
Tuon olen tehnytkin, mutta jokin mättää vielä.
Täytyy jatkaa tutkailemista, kunhan ehdin.

Ei kannata edes yrittää Mediatekin sivulta saatavalla ajurilla. Sekin vaatii muutoksia nykyisiä kerneleitä varten. Linkatuissa Github-repoissa yhteisö on tehnyt tarvittavat muutokset valmiiksi.

Kokeilkaa ensin tätä Viishin versiota, joka toimii kernelin version 4.15 kanssa, ja repositorion etusivulla on suhteellisen selkeät ohjeet kääntämiseen ja asentamiseen: https://github.com/Viish/mt7610u-linksys-ae6000-wifi-fixes

oculardisc

  • Käyttäjä
  • Viestejä: 3
    • Profiili
Vs: asus usb-ac51 wlan adapterin ajuri ongelma
« Vastaus #4 : 06.08.18 - klo:17.30 »
Tuo dongeli/piiri on aika haasteellista saada toimimaan Linuxissa. Minä en ole vielä saanut onnistumaan.
Vilkaise linkkiä, siellä on sama piiri.
https://forum.ubuntu-fi.org/index.php?PHPSESSID=3c64752d88234db05333ce175329603e&topic=53483.0
Mediatekin sivuilta löytyy linux-ajuri, ZIP-paketissa, mutta se on omppu-formaatista (.dmg) ja on muunnettava .img-formattiin, jotta sitä voisi käyttää.
Tuon olen tehnytkin, mutta jokin mättää vielä.
Täytyy jatkaa tutkailemista, kunhan ehdin.

Ei kannata edes yrittää Mediatekin sivulta saatavalla ajurilla. Sekin vaatii muutoksia nykyisiä kerneleitä varten. Linkatuissa Github-repoissa yhteisö on tehnyt tarvittavat muutokset valmiiksi.

Kokeilkaa ensin tätä Viishin versiota, joka toimii kernelin version 4.15 kanssa, ja repositorion etusivulla on suhteellisen selkeät ohjeet kääntämiseen ja asentamiseen: https://github.com/Viish/mt7610u-linksys-ae6000-wifi-fixes
tuo toimi ainakin minulla. kiitos neuvoista. :)

kamara

  • Käyttäjä
  • Viestejä: 1914
    • Profiili
Vs: asus usb-ac51 wlan adapterin ajuri ongelma
« Vastaus #5 : 06.08.18 - klo:19.41 »
tuo toimi ainakin minulla. kiitos neuvoista. :)

[OffTopic]
Täytyy hattua nostaa, kun aloittaa Linuxin käyttämisen onnistuneesti kernel-modulien kääntämisellä.  ;)
[/OffTopic]

nm

  • Käyttäjä
  • Viestejä: 12467
    • Profiili
Vs: asus usb-ac51 wlan adapterin ajuri ongelma
« Vastaus #6 : 06.08.18 - klo:21.59 »
tuo toimi ainakin minulla. kiitos neuvoista. :)

[OffTopic]
Täytyy hattua nostaa, kun aloittaa Linuxin käyttämisen onnistuneesti kernel-modulien kääntämisellä.  ;)
[/OffTopic]

Jeps. Lieneekö oculardiscillä koodaustaustaa?

oculardisc

  • Käyttäjä
  • Viestejä: 3
    • Profiili
Vs: asus usb-ac51 wlan adapterin ajuri ongelma
« Vastaus #7 : 08.08.18 - klo:15.55 »
tuo toimi ainakin minulla. kiitos neuvoista. :)

[OffTopic]
Täytyy hattua nostaa, kun aloittaa Linuxin käyttämisen onnistuneesti kernel-modulien kääntämisellä.  ;)
[/OffTopic]


Jeps. Lieneekö oculardiscillä koodaustaustaa?
Olen itseoppinut ohjelmoija, eli vain hiukan kokemusta koodaamisesta. :)