Kirjoittaja Aihe: Uusimman paketin asennus  (Luettu 1105 kertaa)

Pendeli

  • Käyttäjä
  • Viestejä: 450
    • Profiili
Uusimman paketin asennus
« : 05.08.18 - klo:17.26 »
Yritän asentaa suoraan  tuoreimman ohjelman Ubuntu 16.04:ään.
Pakettivarastossa löytyy  vain vanhentuneita versioita verrattuna ohjelmien kotisivuun.
Testasin vanhalla koneella päivittää olemassaolevaa pakettia ohjeen mukaan:
sudo apt-get install --only-upgrade <packagename>
Se tietysti asensi pakettivarastossa olevan vanhan version, vaikka uudempaakin olisi tarjolla.

Tavalliset update ja upgrade komennot eivät päivitä pakettivaraston paketteja. (Tai sitten minulla on joku asetus pielessä)

Jos asennan vanhan version, niin ei sekään yleensä päivity uudemmaksi. Onko ainoa keino ladata uusin versio suoraan ohjelmantekijän kotisivulta?

Mikä on paras tapa menetellä kun kyse on pelkästään pakettivarastosta löytyvistä ohjelmistoista?
« Viimeksi muokattu: 05.08.18 - klo:17.31 kirjoittanut Pendeli »

jekku

  • Käyttäjä
  • Viestejä: 1765
    • Profiili
Vs: Uusimman paketin asennus
« Vastaus #1 : 05.08.18 - klo:17.45 »
....
Mikä on paras tapa menetellä kun kyse on pelkästään pakettivarastosta löytyvistä ohjelmistoista?

Perussääntö lienee että pysy siinä jota pakettivarasto tarjoaa.

Jos uusi versio tarjoaa jonkin sellaisen ominaisuuden tai toiminnon jota ilman et pärjää, niin harkitse erillisen koneen hankkimista - tai virtuaalikonetta.

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 10430
    • Profiili
    • Tomin kotisivut
Vs: Uusimman paketin asennus
« Vastaus #2 : 05.08.18 - klo:17.57 »
Yritän asentaa suoraan  tuoreimman ohjelman Ubuntu 16.04:ään.
Pakettivarastossa löytyy  vain vanhentuneita versioita verrattuna ohjelmien kotisivuun.
Testasin vanhalla koneella päivittää olemassaolevaa pakettia ohjeen mukaan:
sudo apt-get install --only-upgrade <packagename>
Se tietysti asensi pakettivarastossa olevan vanhan version, vaikka uudempaakin olisi tarjolla.

Tavalliset update ja upgrade komennot eivät päivitä pakettivaraston paketteja. (Tai sitten minulla on joku asetus pielessä)

Noilla saat sen version, joka Ubuntun pakettivarastoihin on paketoitu. Sieltä ei voi asentaa uudempia versioita, koska niitä ei löydy. Ubuntun politiikka on pitää ohjelmien pääversiot samoina lukuunottamatta joitakin tiettyjä komponentteja kuten nettiselainta.

Jos asennan vanhan version, niin ei sekään yleensä päivity uudemmaksi. Onko ainoa keino ladata uusin versio suoraan ohjelmantekijän kotisivulta?

Ihan järkevä ratkaisu on hakea kotisivuilta .tar-paketti (yleensä .tar.gz tai vastaava) ja käyttää siinä olevaa versiota. Jossain tapauksissa saatavilla on AppImage-tiedosto, joka on oikein hyvä vaihtoehto. Se on siis ohjelma paketoituna yhdeksi suoritettavaksi tiedostoksi ja siihen on sisällytetty tärkeimmät riippuvuudet, jolloin se toimii jakelusta riippumatta.

Mikä on paras tapa menetellä kun kyse on pelkästään pakettivarastosta löytyvistä ohjelmistoista?

Toki on mahdollista lisätä yksittäiselle ohjelmalle PPA, jossa on uudempi versio, jos sellainen löytyy. Silloin kannattaa vähän katsoa, mitä muuta sieltä varastosta mahdollisesti asennetaan riippuvuutena. Tämä onnistuu hyvin esimerkiksi LibreOfficelle.

Tulevaisuudessa (ja joissain tapauksissa jo nyt) tämä uudempien versioiden asentaminen onnistuu helposti Flatpakin tai Snapin avulla, jotka ovat uudenlaisia paketinhallintaohjelmia. Ne osaavat hallita riippuvuuksia monipuolisemmin, sopivat paremmin pakettien asennukseen useista eri lähteistä ja mahdollistavat saman paketin käytön eri jakeluissa. Riippuu ihan ohjelmasta onko sille Flatpakiä tai Snappiä olemassa. Jos sellainen löytyy, niin suosittelen sen käyttöä.
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

Pendeli

  • Käyttäjä
  • Viestejä: 450
    • Profiili
Vs: Uusimman paketin asennus
« Vastaus #3 : 08.08.18 - klo:18.56 »
Sivun https://askubuntu.com/questions/770298/how-can-a-current-version-of-linphone-be-installed
ohjeiden mukaan yritin asentaa Linphonen uusinta versiota 4.

Koodia: [Valitse]
sudo add-apt-repository ppa:alexlarsson/flatpak
sudo apt update
sudo apt install flatpak
flatpak --user install --from https://linphone.org/flatpak/linphone.flatpakref
flatpak run com.belledonnecommunications.linphone --verbose

Flatpak asentui koneelle.
Linphonekin asentui mutta vanha toimimaton pakettivaraston versio 3.61 sieltä tuli vain. Ja se vaati erikseen komennon. Oletin, että se olisi asentunut tuon alkuperäisen komentolitanian mukana.

Jotain taisi mennä pieleen päätellen asennusvaiheen useita kyselyistä.
Varsinkin tuo verbose ihmetyttää. Pitääkö sekin sisällyttää komentoon?

Lisäksi terminaalissa jäi joku Alsan säätö kesken siinä vaiheessa kun käynnistin Linphonen. Uskaltaako sen sulkea vai mitä sille pitäisi tehdä?


Koodia: [Valitse]
:~$ sudo add-apt-repository ppa:alexlarsson/flatpak
[sudo] password for ben:
  Linux application sandboxing and distribution framework (formerly xdg-app)
 More info: https://launchpad.net/~alexlarsson/+archive/ubuntu/flatpak
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keyring `/tmp/tmp0cfmnygz/secring.gpg' created
gpg: keyring `/tmp/tmp0cfmnygz/pubring.gpg' created
gpg: requesting key FA577F07 from hkp server keyserver.ubuntu.com
gpg: /tmp/tmp0cfmnygz/trustdb.gpg: trustdb created
gpg: key FA577F07: public key "Launchpad PPA for Alexander Larsson" imported
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)
OK
~$ sudo apt update
Get:1 http://ppa.launchpad.net/alexlarsson/flatpak/ubuntu xenial InRelease [24.3 kB]
Hit:2 http://archive.canonical.com/ubuntu xenial InRelease                     
Hit:3 http://archive.ubuntu.com/ubuntu xenial InRelease                       
Hit:4 http://deb.opera.com/opera-stable stable InRelease                       
Hit:5 http://archive.canonical.com xenial InRelease                           
Get:6 http://archive.ubuntu.com/ubuntu xenial-updates InRelease [109 kB]
Get:7 http://archive.ubuntu.com/ubuntu xenial-security InRelease [107 kB]
Get:8 http://archive.ubuntu.com/ubuntu xenial-backports InRelease [107 kB]
Get:9 http://ppa.launchpad.net/alexlarsson/flatpak/ubuntu xenial/main amd64 Packages [4,300 B]
Get:10 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages [825 kB]
Get:11 http://ppa.launchpad.net/alexlarsson/flatpak/ubuntu xenial/main i386 Packages [4,308 B]
Get:12 http://archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages [751 kB]
Get:13 http://ppa.launchpad.net/alexlarsson/flatpak/ubuntu xenial/main Translation-en [3,188 B]
Get:14 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 DEP-11 Metadata [318 kB]
Get:15 http://archive.ubuntu.com/ubuntu xenial-updates/main DEP-11 64x64 Icons [227 kB]
Get:16 http://archive.ubuntu.com/ubuntu xenial-updates/multiverse amd64 DEP-11 Metadata [5,964 B]
Get:17 http://archive.ubuntu.com/ubuntu xenial-updates/multiverse DEP-11 64x64 Icons [14.3 kB]
Get:18 http://archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages [679 kB]
Get:19 http://archive.ubuntu.com/ubuntu xenial-updates/universe i386 Packages [619 kB]
Get:20 http://archive.ubuntu.com/ubuntu xenial-updates/universe amd64 DEP-11 Metadata [247 kB]
Get:21 http://archive.ubuntu.com/ubuntu xenial-updates/universe DEP-11 64x64 Icons [333 kB]
Get:22 http://archive.ubuntu.com/ubuntu xenial-security/main amd64 DEP-11 Metadata [67.7 kB]
Get:23 http://archive.ubuntu.com/ubuntu xenial-security/main DEP-11 64x64 Icons [68.0 kB]
Get:24 http://archive.ubuntu.com/ubuntu xenial-security/universe amd64 DEP-11 Metadata [107 kB]
Get:25 http://archive.ubuntu.com/ubuntu xenial-security/universe DEP-11 64x64 Icons [142 kB]
Get:26 http://archive.ubuntu.com/ubuntu xenial-backports/main amd64 DEP-11 Metadata [3,328 B]
Get:27 http://archive.ubuntu.com/ubuntu xenial-backports/universe amd64 DEP-11 Metadata [5,096 B]
Hit:28 https://repo.skype.com/deb stable InRelease
Fetched 4,770 kB in 2s (2,202 kB/s)                           
AppStream cache update completed, but some metadata was ignored due to errors.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
9 packages can be upgraded. Run 'apt list --upgradable' to see them.
W: Target Packages (partner/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:32 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target Packages (partner/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list:32 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target Packages (partner/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:32 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target Translations (partner/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list:32 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target Translations (partner/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:32 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target Translations (partner/i18n/Translation-fi) is configured multiple times in /etc/apt/sources.list:32 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target DEP-11 (partner/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list:32 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target DEP-11-icons (partner/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list:32 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target Packages (partner/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:32 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target Packages (partner/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list:32 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target Packages (partner/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:32 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target Translations (partner/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list:32 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target Translations (partner/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:32 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target Translations (partner/i18n/Translation-fi) is configured multiple times in /etc/apt/sources.list:32 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target DEP-11 (partner/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list:32 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target DEP-11-icons (partner/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list:32 and /etc/apt/sources.list.d/xenial-partner.list:4
~$ sudo apt install flatpak
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  libostree-1-1 xdg-desktop-portal xdg-desktop-portal-gtk
The following NEW packages will be installed:
  flatpak libostree-1-1 xdg-desktop-portal xdg-desktop-portal-gtk
0 upgraded, 4 newly installed, 0 to remove and 9 not upgraded.
Need to get 1,252 kB of archives.
After this operation, 5,705 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ppa.launchpad.net/alexlarsson/flatpak/ubuntu xenial/main amd64 libostree-1-1 amd64 2018.6-flatpak2~xenial [266 kB]
Get:2 http://ppa.launchpad.net/alexlarsson/flatpak/ubuntu xenial/main amd64 flatpak amd64 0.99.3-flatpak1~xenial [704 kB]
Get:3 http://ppa.launchpad.net/alexlarsson/flatpak/ubuntu xenial/main amd64 xdg-desktop-portal amd64 0.11-flatpak1~xenial [160 kB]
Get:4 http://ppa.launchpad.net/alexlarsson/flatpak/ubuntu xenial/main amd64 xdg-desktop-portal-gtk amd64 0.11-flatpak1~xenial [122 kB]
Fetched 1,252 kB in 2s (574 kB/s)               
Selecting previously unselected package libostree-1-1:amd64.
(Reading database ... 531393 files and directories currently installed.)
Preparing to unpack .../libostree-1-1_2018.6-flatpak2~xenial_amd64.deb ...
Unpacking libostree-1-1:amd64 (2018.6-flatpak2~xenial) ...
Selecting previously unselected package flatpak.
Preparing to unpack .../flatpak_0.99.3-flatpak1~xenial_amd64.deb ...
Unpacking flatpak (0.99.3-flatpak1~xenial) ...
Selecting previously unselected package xdg-desktop-portal.
Preparing to unpack .../xdg-desktop-portal_0.11-flatpak1~xenial_amd64.deb ...
Unpacking xdg-desktop-portal (0.11-flatpak1~xenial) ...
Selecting previously unselected package xdg-desktop-portal-gtk.
Preparing to unpack .../xdg-desktop-portal-gtk_0.11-flatpak1~xenial_amd64.deb ...
Unpacking xdg-desktop-portal-gtk (0.11-flatpak1~xenial) ...
Processing triggers for libc-bin (2.23-0ubuntu10) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for dbus (1.10.6-1ubuntu3.3) ...
Processing triggers for doc-base (0.10.7) ...
Processing 1 added doc-base file...
Registering documents with scrollkeeper...
Processing triggers for desktop-file-utils (0.22-1ubuntu5.2) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20180209-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Setting up libostree-1-1:amd64 (2018.6-flatpak2~xenial) ...
Setting up flatpak (0.99.3-flatpak1~xenial) ...
Setting up xdg-desktop-portal (0.11-flatpak1~xenial) ...
Setting up xdg-desktop-portal-gtk (0.11-flatpak1~xenial) ...
Processing triggers for libc-bin (2.23-0ubuntu10) ...
Processing triggers for dbus (1.10.6-1ubuntu3.3) ...
~$ flatpak --user install --from https://linphone.org/flatpak/linphone.flatpakref
The application com.belledonnecommunications.linphone depends on runtimes from:
  https://sdk.gnome.org/repo/
Configure this as new remote 'gnome' [y/n]: y
The application com.belledonnecommunications.linphone depends on runtimes from:
  https://sdk.gnome.org/repo/
Configure this as new remote 'gnome' [y/n]: y

Required runtime for com.belledonnecommunications.linphone/x86_64/4.1.1 (runtime/org.freedesktop.Platform/x86_64/1.6) found in remote gnome
Do you want to install it? [y/n]: Do you want to install it? [y/n]: y
Installing in user:
org.freedesktop.Platform/x86_64/1.6                gnome                                        ea1a12e21086
org.freedesktop.Platform.GL.default/x86_64/1.6     gnome                                        fefd42de91fd
org.freedesktop.Platform.VAAPI.Intel/x86_64/1.6    gnome                                        f5b764620d7b
org.freedesktop.Platform.ffmpeg/x86_64/1.6         gnome                                        e01955d7feef
org.freedesktop.Platform.Locale/x86_64/1.6         gnome                                        5bc67811966f
com.belledonnecommunications.linphone/x86_64/4.1.1 com.belledonnecommunications.linphone-origin bae79f29ce39
  permissions: ipc, network, pulseaudio, x11, devices
  file access: xdg-desktop, xdg-documents, xdg-download, xdg-music, xdg-pictures, xdg-videos
  dbus ownership: org.linphone.SingleApplication
Is this ok [y/n]: y
Installing for user: org.freedesktop.Platform/x86_64/1.6 from gnome
[####################] 8 delta parts, 65 loose fetched; 180856 KiB transferred i
Now at ea1a12e21086.
Installing for user: org.freedesktop.Platform.GL.default/x86_64/1.6 from gnome
[####################] 1 delta parts, 7 loose fetched; 47832 KiB transferred in
Now at fefd42de91fd.
Installing for user: org.freedesktop.Platform.VAAPI.Intel/x86_64/1.6 from gnome
[####################] 1 delta parts, 2 loose fetched; 2621 KiB transferred in 5
Now at f5b764620d7b.
Installing for user: org.freedesktop.Platform.ffmpeg/x86_64/1.6 from gnome
[####################] 1 delta parts, 2 loose fetched; 2650 KiB transferred in 5
Now at e01955d7feef.
Installing for user: org.freedesktop.Platform.Locale/x86_64/1.6 from gnome
[####################] 4 metadata, 1 content objects fetched; 13 KiB transferred
Now at 5bc67811966f.
Installing for user: com.belledonnecommunications.linphone/x86_64/4.1.1 from com.belledonnecommunications.linphone-origin
[####################] 353 metadata, 2718 content objects fetched; 117296 KiB tr
Now at bae79f29ce39.
:~$ linphone
The program 'linphone' is currently not installed. You can install it by typing:
sudo apt install linphone
~$ sudo apt install linphone
[sudo] password for ben:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  libexosip2-11 liblinphone5 libmediastreamer-base3 libortp9 libosip2-11
  libspandsp2 linphone-common linphone-nogtk
The following NEW packages will be installed:
  libexosip2-11 liblinphone5 libmediastreamer-base3 libortp9 libosip2-11
  libspandsp2 linphone linphone-common linphone-nogtk
0 upgraded, 9 newly installed, 0 to remove and 9 not upgraded.
Need to get 6,617 kB of archives.
After this operation, 10.9 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://archive.ubuntu.com/ubuntu xenial-updates/universe amd64 libosip2-11 amd64 4.1.0-2+deb8u1build0.16.04.1 [69.1 kB]
Get:2 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libexosip2-11 amd64 4.1.0-2 [99.9 kB]
Get:3 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libortp9 amd64 3.6.1-2.5 [53.8 kB]
Get:4 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libspandsp2 amd64 0.0.6-2.1 [273 kB]
Get:5 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libmediastreamer-base3 amd64 3.6.1-2.5 [178 kB]
Get:6 http://archive.ubuntu.com/ubuntu xenial/universe amd64 liblinphone5 amd64 3.6.1-2.5 [134 kB]
Get:7 http://archive.ubuntu.com/ubuntu xenial/universe amd64 linphone-common all 3.6.1-2.5 [5,687 kB]
Get:8 http://archive.ubuntu.com/ubuntu xenial/universe amd64 linphone-nogtk amd64 3.6.1-2.5 [37.6 kB]
Get:9 http://archive.ubuntu.com/ubuntu xenial/universe amd64 linphone amd64 3.6.1-2.5 [83.4 kB]
Fetched 6,617 kB in 1s (4,074 kB/s)
Selecting previously unselected package libosip2-11:amd64.
(Reading database ... 531552 files and directories currently installed.)
Preparing to unpack .../libosip2-11_4.1.0-2+deb8u1build0.16.04.1_amd64.deb ...
Unpacking libosip2-11:amd64 (4.1.0-2+deb8u1build0.16.04.1) ...
Selecting previously unselected package libexosip2-11.
Preparing to unpack .../libexosip2-11_4.1.0-2_amd64.deb ...
Unpacking libexosip2-11 (4.1.0-2) ...
Selecting previously unselected package libortp9:amd64.
Preparing to unpack .../libortp9_3.6.1-2.5_amd64.deb ...
Unpacking libortp9:amd64 (3.6.1-2.5) ...
Selecting previously unselected package libspandsp2:amd64.
Preparing to unpack .../libspandsp2_0.0.6-2.1_amd64.deb ...
Unpacking libspandsp2:amd64 (0.0.6-2.1) ...
Selecting previously unselected package libmediastreamer-base3:amd64.
Preparing to unpack .../libmediastreamer-base3_3.6.1-2.5_amd64.deb ...
Unpacking libmediastreamer-base3:amd64 (3.6.1-2.5) ...
Selecting previously unselected package liblinphone5:amd64.
Preparing to unpack .../liblinphone5_3.6.1-2.5_amd64.deb ...
Unpacking liblinphone5:amd64 (3.6.1-2.5) ...
Selecting previously unselected package linphone-common.
Preparing to unpack .../linphone-common_3.6.1-2.5_all.deb ...
Unpacking linphone-common (3.6.1-2.5) ...
Selecting previously unselected package linphone-nogtk.
Preparing to unpack .../linphone-nogtk_3.6.1-2.5_amd64.deb ...
Unpacking linphone-nogtk (3.6.1-2.5) ...
Selecting previously unselected package linphone.
Preparing to unpack .../linphone_3.6.1-2.5_amd64.deb ...
Unpacking linphone (3.6.1-2.5) ...
Processing triggers for libc-bin (2.23-0ubuntu10) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5.2) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20180209-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Setting up libosip2-11:amd64 (4.1.0-2+deb8u1build0.16.04.1) ...
Setting up libexosip2-11 (4.1.0-2) ...
Setting up libortp9:amd64 (3.6.1-2.5) ...
Setting up libspandsp2:amd64 (0.0.6-2.1) ...
Setting up libmediastreamer-base3:amd64 (3.6.1-2.5) ...
Setting up liblinphone5:amd64 (3.6.1-2.5) ...
Setting up linphone-common (3.6.1-2.5) ...
Setting up linphone-nogtk (3.6.1-2.5) ...
Setting up linphone (3.6.1-2.5) ...
Processing triggers for libc-bin (2.23-0ubuntu10) ...
~$ linphone
ALSA lib conf.c:4738:(snd_config_expand) Unknown parameters 0
ALSA lib control.c:954:(snd_ctl_open_noupdate) Invalid CTL default:0
ALSA lib conf.c:4738:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2266:(snd_pcm_open_noupdate) Unknown PCM default:0
ALSA lib conf.c:4738:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2266:(snd_pcm_open_noupdate) Unknown PCM default:0
ALSA lib conf.c:4738:(snd_config_expand) Unknown parameters 1
ALSA lib control.c:954:(snd_ctl_open_noupdate) Invalid CTL default:1
ALSA lib conf.c:4738:(snd_config_expand) Unknown parameters 1
ALSA lib pcm.c:2266:(snd_pcm_open_noupdate) Unknown PCM default:1
ALSA lib conf.c:4738:(snd_config_expand) Unknown parameters 1
ALSA lib pcm.c:2266:(snd_pcm_open_noupdate) Unknown PCM default:1

** (linphone:6373): WARNING **: Domain : sip:sip.linphone.org
** Message: Received wakeup command with arg
** Message: Received wakeup command with arg
« Viimeksi muokattu: 12.08.18 - klo:13.53 kirjoittanut Pendeli »

rs

  • Käyttäjä
  • Viestejä: 93
    • Profiili
Vs: Uusimman paketin asennus
« Vastaus #4 : 08.08.18 - klo:22.14 »
Lainaus
Koodia: [Valitse]
ben@OptiPlex3020:~$ linphone
The program 'linphone' is currently not installed. You can install it by typing:
sudo apt install linphone
ben@OptiPlex3020:~$ sudo apt install linphone
tuossa asennat linphonen ubuntun pakettivarastoista, jossa ohjelman versio on 3.61

sen sijaan pitäis käsittääkseni ajaa tuo ohjelma ohjeissakin olleella komennolla (ei siis pelkästään komentamalla "linphone"):
Koodia: [Valitse]
flatpak run com.belledonnecommunications.linphone --verbose

Pendeli

  • Käyttäjä
  • Viestejä: 450
    • Profiili
Vs: Uusimman paketin asennus
« Vastaus #5 : 08.08.18 - klo:23.06 »
Jossain se nelosversio - vai mikä tuo branch 4.1.1 lie - on valmiina mutta piilossa.Synapticissa ei näy mitään viitettä mistään 4-versiosta.
Vai onko se jossain sandboxissa?




   
Koodia: [Valitse]
$ sudo flatpak --user install --from https://linphone.org/flatpak/linphone.flatpakref
[sudo] password for ben:
error: App com.belledonnecommunications.linphone, branch 4.1.1 is already installed

rs

  • Käyttäjä
  • Viestejä: 93
    • Profiili
Vs: Uusimman paketin asennus
« Vastaus #6 : 08.08.18 - klo:23.13 »
se on kyllä asennettu, mutta se pitää käynnistää komentamalla päätteessä:
Koodia: [Valitse]
flatpak run com.belledonnecommunications.linphone --verbose

nm

  • Käyttäjä
  • Viestejä: 12467
    • Profiili
Vs: Uusimman paketin asennus
« Vastaus #7 : 08.08.18 - klo:23.58 »
Jossain se nelosversio - vai mikä tuo branch 4.1.1 lie - on valmiina mutta piilossa.Synapticissa ei näy mitään viitettä mistään 4-versiosta.

Flatpakilla asennetut sovellukset eivät näy Apt- tai dpkg-paketteina, joten Synaptic ei niitä näe. Sama koskee Snapia. Periaatteessa Flatpakilla asennetun ohjelman pitäisi ilmestyä myös järjestelmän sovellusvalikkoon -- ainakin uudelleenkirjautumisen jälkeen, jos ei heti. Riippuu toki myös siitä, miten sovellus on paketoitu.

Vai onko se jossain sandboxissa?

Kyllä, tavallaan.
« Viimeksi muokattu: 09.08.18 - klo:00.05 kirjoittanut nm »

Pendeli

  • Käyttäjä
  • Viestejä: 450
    • Profiili
Vs: Uusimman paketin asennus
« Vastaus #8 : 09.08.18 - klo:13.36 »
Sain sen käynnistymään RS:n mainitsemalla komennolla ja käynnistysikoni ilmestyi myös sovellusvalikkoon.

Uudemman kerran komennolla käynnistys antaa seuraavaa:

Koodia: [Valitse]
~$ flatpak run com.belledonnecommunications.linphone --verbose
Gtk-Message: Failed to load module "unity-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"
Qt: Session management error: None of the authentication protocols specified are supported
[13:18:37:713][0x280dbc0][Info]/run/build/linphone-qt/src/app/App.cpp:106: "Use locale: en_US"
[13:18:37:716][0x280dbc0][Info]/run/build/linphone-qt/src/app/App.cpp:110: "Destroying app..."
Valikosta käynnistämällä aukeaa, mutta ei ota vastaan asetuksia.
En tiedä, onko asennuksessa jotain mennyt vikaan vai onko kyseinen versio vielä raakile.

Olisko ehdotuksia?

jarmala

  • Käyttäjä
  • Viestejä: 311
    • Profiili
Vs: Uusimman paketin asennus
« Vastaus #9 : 09.08.18 - klo:19.54 »
Pakettivarastossa löytyy  vain vanhentuneita versioita verrattuna ohjelmien kotisivuun.

Esittäisin yhdeksi mahdollisuudeksi siirtyä käyttämään jotain rolling release -periaatteella toimivaa jakelua.

https://en.wikipedia.org/wiki/Rolling_distribution

Niissä ainakin luulisi, että ohjelmien uudet versiot tulisivat nopeasti käyttöön.

epiphone

  • Käyttäjä
  • Viestejä: 331
    • Profiili
Vs: Uusimman paketin asennus
« Vastaus #10 : 09.08.18 - klo:20.39 »
Pakettivarastossa löytyy  vain vanhentuneita versioita verrattuna ohjelmien kotisivuun.

Esittäisin yhdeksi mahdollisuudeksi siirtyä käyttämään jotain rolling release -periaatteella toimivaa jakelua.

https://en.wikipedia.org/wiki/Rolling_distribution

Niissä ainakin luulisi, että ohjelmien uudet versiot tulisivat nopeasti käyttöön.


Opensuse tumbleweed esimerkiksi.


Edit: OpenSusella on kotimaankielellä keskustelupalstakin:  http://opensuse.fi/keskustelu/index.php
« Viimeksi muokattu: 09.08.18 - klo:23.33 kirjoittanut epiphone »
Kahvi on väkevin juomani

jekku

  • Käyttäjä
  • Viestejä: 1765
    • Profiili
Vs: Uusimman paketin asennus
« Vastaus #11 : 10.08.18 - klo:06.50 »
...
Valikosta käynnistämällä aukeaa, mutta ei ota vastaan asetuksia.
En tiedä, onko asennuksessa jotain mennyt vikaan vai onko kyseinen versio vielä raakile.
....

Ihan uteliaisuuttani: mitä uutta ominaisuutta ja/tai korjausta odotat tuolta uudemmalta paketilta?

nm

  • Käyttäjä
  • Viestejä: 12467
    • Profiili
Vs: Uusimman paketin asennus
« Vastaus #12 : 10.08.18 - klo:11.38 »
Pakettivarastossa löytyy  vain vanhentuneita versioita verrattuna ohjelmien kotisivuun.

Esittäisin yhdeksi mahdollisuudeksi siirtyä käyttämään jotain rolling release -periaatteella toimivaa jakelua.

https://en.wikipedia.org/wiki/Rolling_distribution

Niissä ainakin luulisi, että ohjelmien uudet versiot tulisivat nopeasti käyttöön.


Opensuse tumbleweed esimerkiksi.


Edit: OpenSusella on kotimaankielellä keskustelupalstakin:  http://opensuse.fi/keskustelu/index.php

Keskustelupalstan nimimerkin tiger61 kommentti Tumbleweedistä: http://opensuse.fi/keskustelu/index.php?topic=5710.msg35550#msg35550

Lainaus
Kuten tuolla toisessa kyssärissä aiemmin mainitsin, niin kymmenen vuoden aikana (10 - 42.1) ei mitään tällaisia ongelmia ole ollut Susen kanssa. Pieniä säätöhommia aina silloin tällöin, mutta aina pääsysteemi toiminut kuin junanvessa - mutta 42.3 ja Tumbleweed - paljon on tullut lausuttua tuota nykypäivän nuorison välimerkkiä viimeaikoina.

 ;)

Pendeli

  • Käyttäjä
  • Viestejä: 450
    • Profiili
Vs: Uusimman paketin asennus
« Vastaus #13 : 10.08.18 - klo:11.54 »
...
Valikosta käynnistämällä aukeaa, mutta ei ota vastaan asetuksia.
En tiedä, onko asennuksessa jotain mennyt vikaan vai onko kyseinen versio vielä raakile.
....

Ihan uteliaisuuttani: mitä uutta ominaisuutta ja/tai korjausta odotat tuolta uudemmalta paketilta?

En muuta parannusta kaipaa kuin toimivan version.
Ubuntun pakettivaraston versiokin 3.61  kelpaisi hyvin, jos sen saisi toimimaan. Siinä on yleisesti valitettu vika. (Port 3560 already in use)

Vaimolla se toimii Windowsissa hyvin, joten tarvitsisin saman softan itsellenikin. Tai sitten on ruvettava haeskelemaan jotain, mikä toimii
Windows 8:ssa ja Ubuntu16.04:ssä yhteen ja keskenään.

Olisi vähän liioittelua ruveta sen takia opettelemaan Opensusea  ;D
« Viimeksi muokattu: 10.08.18 - klo:12.02 kirjoittanut Pendeli »

jekku

  • Käyttäjä
  • Viestejä: 1765
    • Profiili
Vs: Uusimman paketin asennus
« Vastaus #14 : 10.08.18 - klo:11.57 »
...
Valikosta käynnistämällä aukeaa, mutta ei ota vastaan asetuksia.
En tiedä, onko asennuksessa jotain mennyt vikaan vai onko kyseinen versio vielä raakile.
....

Ihan uteliaisuuttani: mitä uutta ominaisuutta ja/tai korjausta odotat tuolta uudemmalta paketilta?

En muuta parannusta kaipaa kuin toimivan version.
Ubuntun pakettivaraston versiokin 3.61  kelpaisi hyvin, jos sen saisi toimimaan. Siinä on yleisesti valitettu vika. (Port 3560 already in use)

Vaimolla se toimii Windowsissa hyvin, joten tarvitsisin saman softan itsellenikin. Tai sitten on ruvettava haeskelemaan jotain, mikä toimii
Windows 8:ssa ja Ubuntu16.04:ssä yhteen ja keskenään.

Oikein hyvä syy jatkaa kokeiluja - menestystä!

nm

  • Käyttäjä
  • Viestejä: 12467
    • Profiili
Vs: Uusimman paketin asennus
« Vastaus #15 : 10.08.18 - klo:16.40 »
Kokeilinpa itsekin Linphonen Flatpakia Ubuntu 18.04:ssä.

Sain sen käynnistymään RS:n mainitsemalla komennolla ja käynnistysikoni ilmestyi myös sovellusvalikkoon.

Uudemman kerran komennolla käynnistys antaa seuraavaa:

Koodia: [Valitse]
~$ flatpak run com.belledonnecommunications.linphone --verbose
Gtk-Message: Failed to load module "unity-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"
Qt: Session management error: None of the authentication protocols specified are supported
[13:18:37:713][0x280dbc0][Info]/run/build/linphone-qt/src/app/App.cpp:106: "Use locale: en_US"
[13:18:37:716][0x280dbc0][Info]/run/build/linphone-qt/src/app/App.cpp:110: "Destroying app..."

Tuossa tilanteessa ohjelma on jo käynnissä, mutta ikkuna on mahdollisesti suljettu, jolloin komennon pitäisi tuoda ikkuna esiin ja lopettaa komennon suoritus tuohon "Destroying app" -ilmoitukseen. Linphone kuitenkin jatkaa toimintaansa. Oletettavasti suljetussa tilassa ohjelman pitäisi näkyä yläpaneelin ilmoitusalueen kuvakkeena, mutta ehkä se ei ole yhteensopiva nykyisen GNOME Shellin kanssa, tai ongelma on Flatpak-paketoinnissa.

Ohjelman voi sammuttaa kokonaan oikean yläkulman valikon (hamburger menu) Quit-valinnalla tai painamalla Ctrl+Q
Toimii siis pitkälti samalla tavalla kuin muutkin vastaavat sovellukset.


Valikosta käynnistämällä aukeaa, mutta ei ota vastaan asetuksia.
En tiedä, onko asennuksessa jotain mennyt vikaan vai onko kyseinen versio vielä raakile.

Mitä asetusta se ei ota vastaan? Minulla tuntuu toimivan kaikki mitä kokeilin.


Ubuntun pakettivaraston versiokin 3.61  kelpaisi hyvin, jos sen saisi toimimaan. Siinä on yleisesti valitettu vika. (Port 3560 already in use)

Lienee ohjelman asetuksista tai verkkoympäristöstä johtuva ongelma. Itse pystyn soittamaan ainakin lähiverkossa Ubuntu 14.04:n  Linphone 3.6.1:llä tuohon Flatpakilla asennettuun Linphone 4.1.1:een. En muuttanut oletusasetuksia lainkaan.
« Viimeksi muokattu: 10.08.18 - klo:17.05 kirjoittanut nm »

Pendeli

  • Käyttäjä
  • Viestejä: 450
    • Profiili
Vs: Uusimman paketin asennus
« Vastaus #16 : 11.08.18 - klo:16.52 »


Lienee ohjelman asetuksista tai verkkoympäristöstä johtuva ongelma. Itse pystyn soittamaan ainakin lähiverkossa Ubuntu 14.04:n  Linphone 3.6.1:llä tuohon Flatpakilla asennettuun Linphone 4.1.1:een. En muuttanut oletusasetuksia lainkaan.

Teitkö tuon kahdella eri koneella, kummallakin oma identiteetti?
Itse en pysty luomaan toista identiteettiä samalle koneelle. Ohjelma kai ottaa kompuutterin nimen ja estää siten toisen identiteetin luomisen samalle koneelle? Ilmoittaa aina, että tili on jo olemassa jos yrittää toisella nimellä rekisteröintiä.

Minulla oli joitakin reitittimeen liittyviä vanhoja palomuurisääntöjä olemassa, mutta niiden poisto ei auttanut asiaa.

Aikaa vievää touhua tämä räpeltäminen...

nm

  • Käyttäjä
  • Viestejä: 12467
    • Profiili
Vs: Uusimman paketin asennus
« Vastaus #17 : 11.08.18 - klo:17.15 »
Lienee ohjelman asetuksista tai verkkoympäristöstä johtuva ongelma. Itse pystyn soittamaan ainakin lähiverkossa Ubuntu 14.04:n  Linphone 3.6.1:llä tuohon Flatpakilla asennettuun Linphone 4.1.1:een. En muuttanut oletusasetuksia lainkaan.

Teitkö tuon kahdella eri koneella, kummallakin oma identiteetti?
Itse en pysty luomaan toista identiteettiä samalle koneelle. Ohjelma kai ottaa kompuutterin nimen ja estää siten toisen identiteetin luomisen samalle koneelle? Ilmoittaa aina, että tili on jo olemassa jos yrittää toisella nimellä rekisteröintiä.

Käytin eri versioita eri koneilla, enkä rekisteröinyt identiteettejä/tilejä mihinkään. Voin testata sitäkin ensi viikolla.

Oletko kokeillut uuden tilin luontia siten että kirjaudut Ubuntuun eri käyttäjätunnuksella, jos on tarvetta saada useampi tili toimimaan samalla koneella?

Pendeli

  • Käyttäjä
  • Viestejä: 450
    • Profiili
Vs: Uusimman paketin asennus
« Vastaus #18 : 12.08.18 - klo:13.15 »


Käytin eri versioita eri koneilla, enkä rekisteröinyt identiteettejä/tilejä mihinkään. Voin testata sitäkin ensi viikolla.

Oletko kokeillut uuden tilin luontia siten että kirjaudut Ubuntuun eri käyttäjätunnuksella, jos on tarvetta saada useampi tili toimimaan samalla koneella?

En tajua miten saat sen toimimaan, pitäähän siihen jonkinlaiset lähettäjän ja vastaanottajan tunnukset luoda.
Kyllä minun ainakin piti vahvistaa tili sähköpostin kautta päästäkseni edes alkuun. Puhelinnumerollakin se onnistuu, mutta en halunnut jaella sitä minnekään.

Sain uuden identiteetin toimimaan 4.1.1:llä ja soimaan vastaanottajalla
mutta vielä ilman puheyhteyttä.
Vaatinee vielä toisen osapuolen koneen säätämistä.

nm

  • Käyttäjä
  • Viestejä: 12467
    • Profiili
Vs: Uusimman paketin asennus
« Vastaus #19 : 12.08.18 - klo:13.35 »
En tajua miten saat sen toimimaan, pitäähän siihen jonkinlaiset lähettäjän ja vastaanottajan tunnukset luoda.

Tunnuksena on oletuksena Ubuntun käyttäjätunnus ja koneen IP, mutta nimen voi vaihtaa asetuksissa. Tiliä ei tarvitse rekisteröidä linphone.orgiin tai mihinkään, jos ohjelmaa käyttää lähiverkossa tai suorilla IP-osoitteilla. Ohjelma avaa wizard-ikkunan tilin rekisteröintiin käynnistyessään, mutta sen voi sulkea.
« Viimeksi muokattu: 12.08.18 - klo:13.37 kirjoittanut nm »