Kirjoittaja Aihe: Muistitikku-ongelma Xubuntussa [Ratkaistu]  (Luettu 690 kertaa)

makel58

  • Käyttäjä
  • Viestejä: 760
    • Profiili
Muistitikku-ongelma Xubuntussa [Ratkaistu]
« : 07.06.18 - klo:15.39 »
Olen asentanut uusimman Xubuntu LTS-version toiselle koneelle ja yritän saada työpöydällä olevia kuvakansioita muistitikulle, että ne voisin siirtää toiseen koneeseen, mutta ei onnistu. Tätä aihetta on käsitelty aikaisemminkin. Muistitikussa on ollut Xubuntu LTS-asennusmedia, mutta taas kaikki sen kansiot lukkiutuivat. Sain täältä aikaisemmin ohjeet, jossa käytin tälläisiä komentoja päätteessä. Tältä samalta tikulta sain kuitenkin asennettua Xubuntun toiselle koneelle.

Koodia: [Valitse]
sudo dd if=/dev/zero of=/dev/sdg bs=512 count=1

Koodia: [Valitse]
sync
Nuo onnistui hyvin, joten loin msdos-osiotaulun ja alustin vielä muotoon ntfs.

Mutta kun taas yritän siirtää työpöydältä kuvakansiota muistitikulle, niin herjaa "Virhe kopioitaessa kohteeseen "61DE687E33B3256B". Mikähän meni taas vikaan?

Muistitikku on tämän näköinen GPardetilla näytettäessä. Kuvakaappaus alla.





« Viimeksi muokattu: 07.06.18 - klo:19.32 kirjoittanut makel58 »

makel58

  • Käyttäjä
  • Viestejä: 760
    • Profiili
Vs: Muistitikku-ongelma Xubuntussa
« Vastaus #1 : 07.06.18 - klo:15.45 »
Pitää lisätä tuohon  "Virhe kopioitaessa kohteeseen "61DE687E33B3256B". Kohde vain lukutilassa.

nm

  • Käyttäjä
  • Viestejä: 11943
    • Profiili
Vs: Muistitikku-ongelma Xubuntussa
« Vastaus #2 : 07.06.18 - klo:16.02 »
Kannattaa kokeilla alustaa uudelleen. Mieluiten Windowsissa, kun on kyse NTFS:stä.

makel58

  • Käyttäjä
  • Viestejä: 760
    • Profiili
Vs: Muistitikku-ongelma Xubuntussa
« Vastaus #3 : 07.06.18 - klo:16.12 »
Kannattaa kokeilla alustaa uudelleen. Mieluiten Windowsissa, kun on kyse NTFS:stä.

Minulla ei enää ole Windowsia, kun siihen toiseen koneeseen asensin Xubuntun. Siinä oli aikaisemmin Windows 10. Jääkö ainoaksi vaihtoehdoksi ostaa uusi muistitikku?

Lisäys: Tein aikaisemmin nm-ohjeen mukaan myös sen "nollaus-session" tikulle. Olisiko se ratkaisu?
« Viimeksi muokattu: 07.06.18 - klo:16.16 kirjoittanut makel58 »

nm

  • Käyttäjä
  • Viestejä: 11943
    • Profiili
Vs: Muistitikku-ongelma Xubuntussa
« Vastaus #4 : 07.06.18 - klo:16.50 »
Kannattaa kokeilla alustaa uudelleen. Mieluiten Windowsissa, kun on kyse NTFS:stä.

Minulla ei enää ole Windowsia, kun siihen toiseen koneeseen asensin Xubuntun. Siinä oli aikaisemmin Windows 10. Jääkö ainoaksi vaihtoehdoksi ostaa uusi muistitikku?

Jos uudelleenalustaminen GPartedilla tai Levyt-ohjelmalla ei auta, kannattaa kokeilla jotain muuta tiedostojärjestelmää NTFS:n sijaan. Valitettavasti irrotettavan median käyttöoikeuksien hallinta on jokseenkin hankalaa Linuxissa (ja yleensäkin Unix-pohjaisissa käyttöjärjestelmissä), joten natiivit tiedostojärjestelmät eivät välttämättä helpota asioita. FAT32 on yksi vaihtoehto, jos ei ole tarvetta siirtää yli 4 Gt:n kokoisia tiedostoja.


Lisäys: Tein aikaisemmin nm-ohjeen mukaan myös sen "nollaus-session" tikulle. Olisiko se ratkaisu?

Tällä kertaa ongelma vaikuttaa pikemminkin tiedostojärjestelmän kuin osioinnin vialta. Sinänsä toki hieman outoa, jos NTFS on aiemmin toiminut samalla tavalla luotuna.


Tiedostojen siirtelyyn voisi harkita myös levyjakoa lähiverkossa, mutta en tiedä kuinka helppoa sellaisen konfigurointi on Xubuntussa.

makel58

  • Käyttäjä
  • Viestejä: 760
    • Profiili
Vs: Muistitikku-ongelma Xubuntussa
« Vastaus #5 : 07.06.18 - klo:19.15 »
Jos uudelleenalustaminen GPartedilla tai Levyt-ohjelmalla ei auta, kannattaa kokeilla jotain muuta tiedostojärjestelmää NTFS:n sijaan. Valitettavasti irrotettavan median käyttöoikeuksien hallinta on jokseenkin hankalaa Linuxissa (ja yleensäkin Unix-pohjaisissa käyttöjärjestelmissä), joten natiivit tiedostojärjestelmät eivät välttämättä helpota asioita. FAT32 on yksi vaihtoehto, jos ei ole tarvetta siirtää yli 4 Gt:n kokoisia tiedostoja.

Muistitikun uudeleenalustaminen onnistui viimeksi hyvin, kun tätä asiaa täällä pohdittiin. Mutta kun latasin Ubuntu Suomen sivulta asennusmedian muistitikulle ja kun sen laitoin koneeseen, niin heti kansiot lukkiutuivat. Ei siis sillä kertaa ollut vielä tarkoitus asentaa Xubuntua toiselle koneelle. Ongelma alkoi tällä "vanhalla" koneella.

makel58

  • Käyttäjä
  • Viestejä: 760
    • Profiili
Vs: Muistitikku-ongelma Xubuntussa
« Vastaus #6 : 07.06.18 - klo:19.28 »
Nyt tapahtui ihme: kävin välillä asioilla ja sammutin tietokoneen siksi aikaa. Kun käynnistin koneen uudelleen myöhemmin ja laitoin taas muistitikun koneeseen, onnistui kuvakansioiden siirto täysin ongelmitta. Ja kaikki oikeudet näyttää olevan kunnossa.

makel58

  • Käyttäjä
  • Viestejä: 760
    • Profiili
Vs: Muistitikku-ongelma Xubuntussa [Ratkaistu]
« Vastaus #7 : 07.06.18 - klo:22.07 »
Pitää vielä vähän jatkaa. Uusi Xubuntu-kone on nyt käytössä. Kaikki kuvakansiot siirtyi työpöydälle, mutta pieni ongelma tuli. Kun kaikki talleenteet olin siirtänyt koneeseen muistitikulta, yritin irroittaa tikkua järjestelmästä, niin se ei onnistunut. Herjasi jotain, että joku prosessi on vielä kesken. Siinä oli vielä, että "irroita silti". Irroitin tikun kun aikaa meni, mutta kuvakansioitten kuvat ei näy nyt ihan normaalisti. Niitä kyllä pystyy katsomaan kun avaan kuvakansion, mutta kuvien vasemmalla on mustalla pohjalla punainen ympyränmuotoinen, kuin kieltoliikennemerkki. Normaalisti siinä pitäisi olla kaikista kuvista piennoiskuvat. Kansiossa on 12 kuvaa. Kuvakaappaus alla.

makel58

  • Käyttäjä
  • Viestejä: 760
    • Profiili
Vs: Muistitikku-ongelma Xubuntussa [Ratkaistu]
« Vastaus #8 : 07.06.18 - klo:23.20 »
Kopioin uudestaan toiselta koneelta kuvakansiot muistikulle ja siirsin ne nykyiselle koneelle. Kansiot siirtyivät taas työpöydälle, mutta sama tulos. Ei siirtynyt ihan täydellisinä. Ja nyt pystyin irroittamaan muistitikun oikein järjestelmästä. Vastustaa näköjään loppuun asti.

nm

  • Käyttäjä
  • Viestejä: 11943
    • Profiili
Vs: Muistitikku-ongelma Xubuntussa [Ratkaistu]
« Vastaus #9 : 07.06.18 - klo:23.53 »
Irroitin tikun kun aikaa meni, mutta kuvakansioitten kuvat ei näy nyt ihan normaalisti. Niitä kyllä pystyy katsomaan kun avaan kuvakansion, mutta kuvien vasemmalla on mustalla pohjalla punainen ympyränmuotoinen, kuin kieltoliikennemerkki. Normaalisti siinä pitäisi olla kaikista kuvista piennoiskuvat. Kansiossa on 12 kuvaa. Kuvakaappaus alla.

Eli näkyvätkö kuvat kuitenkin oikein ja virheettä kun avaat ne, ja ongelmana on vain puuttuva kuvake? Vaikuttaa vialta thumbnail-kuvien luonnissa jossain XFCE:n tiedostoselaimen suunnalla. Onhan levyllä edelleen tilaa vapaana?

makel58

  • Käyttäjä
  • Viestejä: 760
    • Profiili
Vs: Muistitikku-ongelma Xubuntussa [Ratkaistu]
« Vastaus #10 : 08.06.18 - klo:01.16 »
Eli näkyvätkö kuvat kuitenkin oikein ja virheettä kun avaat ne, ja ongelmana on vain puuttuva kuvake? Vaikuttaa vialta thumbnail-kuvien luonnissa jossain XFCE:n tiedostoselaimen suunnalla. Onhan levyllä edelleen tilaa vapaana?

Kuvat näkyvät oikein. Lisäksi kun kuvia katsoo, niin niiden taustat ovat punaiset, kun kuvia katsoo kokoruutukuvina. Toisessa Xubuntu-koneessa mustina, tai ainakin tummina. Lisäksi kuvakansiossa kuvat ei näy ns. pikkukuvina, vaan mustalla taustalla olevana JPG-tiedostoina. Tässä kuvakaappaus kahdesta PNG-kuvista. JPG-kuvatiedostot ovat sananlaisia.

Lisäys: Levyllä on tilaa vapaana 7,2 Gt.

Lisäys: Tarkoitan kuvan punaisella taustalla sitä, että kun olen ottanut kameralla kuvan jonka koko on sellainen, että tietokoneella kuva näkyy niin, että kuvan ylä- ja alaosassa on kapea punainen tyhjä tila. Kuva ei peitä koko ruutua. Normaalisti nuo alueet ovat tummia.
« Viimeksi muokattu: 08.06.18 - klo:23.18 kirjoittanut makel58 »

makel58

  • Käyttäjä
  • Viestejä: 760
    • Profiili
Vs: Muistitikku-ongelma Xubuntussa [Ratkaistu]
« Vastaus #11 : 08.06.18 - klo:01.59 »
Kokeilin toista muistitikkua ja siinäkin kuvat näkyivät kansiossa pieninä mustina JPG-tiedostoina. Normaalisti ne pitäisi näkyä pieninä kuva-tiedostoina. Siitä siis jo näkee, mikä kuva missäkin on. 

nm

  • Käyttäjä
  • Viestejä: 11943
    • Profiili
Vs: Muistitikku-ongelma Xubuntussa [Ratkaistu]
« Vastaus #12 : 08.06.18 - klo:11.08 »
Lisäksi kuvakansiossa kuvat ei näy ns. pikkukuvina, vaan mustalla taustalla olevana JPG-tiedostoina. Tässä kuvakaappaus kahdesta PNG-kuvista. JPG-kuvatiedostot ovat sananlaisia.

Jokin työpöytäympäristön asetus on sellaisessa asennossa, että esikatselukuvia ei luoda tai näytetä.


Lisäys: Tarkoitan kuvan punaisella taustalla sitä, että kun olen ottanut kameralla kuvan jonka koko on sellailnen, että tietokoneella kuva näkyy niin, että kuvan ylä- ja alaosassa on kapea punainen tyhjä tila. Kuva ei peitä koko ruutua. Normaalisti nuo alueet ovat tummia.

Kuulostaa katseluohjelman asetukselta/bugilta/ominaisuudelta.
« Viimeksi muokattu: 08.06.18 - klo:11.10 kirjoittanut nm »

makel58

  • Käyttäjä
  • Viestejä: 760
    • Profiili
Vs: Muistitikku-ongelma Xubuntussa [Ratkaistu]
« Vastaus #13 : 08.06.18 - klo:23.43 »
Kuulostaa katseluohjelman asetukselta/bugilta/ominaisuudelta.

Sain säädettyä asetuksista, että ei-kokoruutukuvan tyhjät tilat ovat mustat. Kokoruutukuvan tausta on musta, jos kuva ei peitä koko kuvaruutua.

Avasin kuvan ja vasemmalla yläosassa Muokkaa/Asetukset, Näyttö-välilehti, ruksi kohtaan Korvaa taustaväri. Oikealla puolella väriruudusta pääsee väriä muuttamaan. Nyt ainakin vähän parempi. Nuo vasemmalla olevat "liikennemerkki"-kuvakkeet jäi tuollaiseksi, kun niitä ei saa muutettua.