Kirjoittaja Aihe: Ubuntu 17.10 syndaemon ei toimi oikein koneessani (RATKAISTU)  (Luettu 1683 kertaa)

Pontus12

  • Käyttäjä
  • Viestejä: 993
    • Profiili
Komento
#
  syndaemon -i 3.0 -K -R
#

Ei toimi oikein. Touchpadin  kursori liikkuu edelleen. Jos siihen liittää vielä #-t #, jonka pitäisi poistaa vain näpäytys (tapping) ja rullaus, niin tulos on silti sama. Onko komennon parametreissä jotain väärin tai olenko ymmärtänyt ne
väärin?

Haluaisin myös tietää, miten sysdaemonin saa käynnistymään automaattisesti päälle Ubuntussa?
« Viimeksi muokattu: 13.03.18 - klo:10.55 kirjoittanut Pontus12 »

nm

  • Käyttäjä
  • Viestejä: 12634
    • Profiili
Vs: Ubuntu 17.10 syndaemon ei toimi oikein koneessani
« Vastaus #1 : 12.03.18 - klo:21.02 »
Ubuntu 17.10:ssä (ja tulevassa 18.04:ssä) käytetään libinputia synapticsin sijaan.
« Viimeksi muokattu: 12.03.18 - klo:21.04 kirjoittanut nm »

Pontus12

  • Käyttäjä
  • Viestejä: 993
    • Profiili
Vs: Ubuntu 17.10 syndaemon ei toimi oikein koneessani
« Vastaus #2 : 12.03.18 - klo:21.21 »
Miten libinputia voisi tässä tapauksessa käyttää? Minä kosketan ilmeisesti, vaikka kuinka yritän varoa, koskestuslevyä kirjoittaessani ja yritän siksi löytää ratkaisun ongelmaani. Voin tietenkin poistaa kosketuslevyn kokonaan ja käyttää vain hiirtä, mutta varsinkin matkoilla se ei ole käytännöllistä. Akku kuluu nopeammin ja konetta joutuu usein pitämään sylissä.

Jos toggle touchpad on ja off toimisi, sekin kelpaisi.

nm

  • Käyttäjä
  • Viestejä: 12634
    • Profiili
Vs: Ubuntu 17.10 syndaemon ei toimi oikein koneessani
« Vastaus #3 : 13.03.18 - klo:01.25 »
Kosketuslevyn hallinta onnistunee GNOME:ssa helpoiten TouchpadIndicator-laajennuksella: https://user501254.github.io/TouchpadIndicator/

Pontus12

  • Käyttäjä
  • Viestejä: 993
    • Profiili
Vs: Ubuntu 17.10 syndaemon ei toimi oikein koneessani
« Vastaus #4 : 13.03.18 - klo:10.54 »
Kiitos jälleen opastuksesta. Kyllä tämä käy, vaikka se syndaemon oli mielestäni vielä parempi. Otan touchpadistä napautukset pois, jos en käytä hiirtä. Silloin ei kursorin pitäisi enää hypellä kirjoittaessa.

nm

  • Käyttäjä
  • Viestejä: 12634
    • Profiili
Vs: Ubuntu 17.10 syndaemon ei toimi oikein koneessani
« Vastaus #5 : 13.03.18 - klo:11.56 »
Otan touchpadistä napautukset pois, jos en käytä hiirtä. Silloin ei kursorin pitäisi enää hypellä kirjoittaessa.

GNOME:ssa pitäisi kyllä olla vakiona käytössä kosketuslevyn esto kirjoitettaessa (disable touchpad while typing) ja kämmenen tunnistus (palm detection) niin, että kättä voi pitää kosketuslevyllä osoittimen liikkumatta. Jos nämä eivät toimi, vika voi johtua siitä, että olet päivittänyt Ubuntun 17.10:een jostain aiemmasta versiosta, tai järjestelmään on muusta syystä asentunut synaptics-ajuri: https://bugs.launchpad.net/ubuntu/+source/mutter/+bug/1733032

Kokeile poistaa paketti xserver-xorg-input-synaptics:

Koodia: [Valitse]
sudo apt-get purge xserver-xorg-input-synaptics

Jos koneessa on kosketusnäyttö, sekin voi osaltaan sotkea näitä asetuksia.
« Viimeksi muokattu: 13.03.18 - klo:11.59 kirjoittanut nm »

Pontus12

  • Käyttäjä
  • Viestejä: 993
    • Profiili
Lähettämästä linkistä kävi ilmi, että kysymyksessä on jonkinlainen bugi. Ja vaikka ajoin komennon, jonka laitoit, niin se auttoi vain osittain. Touchpad kytkeytyi kyllä sen jälkeen pois, kun hiiri liitettiin koneeseen. Viivettä ei kuitenkaan voinut määritellä eikä napautusta voinut kytkeä pois ja päälle muuten kuin menemällä asetuksiin. Ilmeisesti ongelma korjautuu viimeistään seuraavassa versiossa keskustelusta päätellen.

Mutta lähettämäsi ohje auttoi hiiren suhteen ja minä kytkin napautuksen pois, joten voin kirjoittaa läppärilläkin ilman hiirtä. Kiitos.

nm

  • Käyttäjä
  • Viestejä: 12634
    • Profiili
Viivettä ei kuitenkaan voinut määritellä eikä napautusta voinut kytkeä pois ja päälle muuten kuin menemällä asetuksiin. Ilmeisesti ongelma korjautuu viimeistään seuraavassa versiossa keskustelusta päätellen.

En pidättäisi hengitystä tämän suhteen. GNOME 3:ssa asetukset on yleensä pidetty mahdollisimman yksinkertaisina ja geneerisinä. Apuohjelmilla, kuten tässä tapauksessa TouchpadIndicatorilla, voi sitten mukauttaa toimintaa haluamallaan tavalla.

Pontus12

  • Käyttäjä
  • Viestejä: 993
    • Profiili
En löytänyt indicatorista asetusta, jolla olisi voinut hallita viivettä kkirjoittaessa. Poistan vain napautuksen käytöstä, kun pitää kirjoittaa pitempi teksti. Jos viiveen voi tehdä, olisin kiinnostunut.