Kirjoittaja Aihe: (GNU) softien kääntäminen  (Luettu 1069 kertaa)

jarmala

  • Käyttäjä
  • Viestejä: 316
    • Profiili
(GNU) softien kääntäminen
« : 11.02.18 - klo:14.51 »
Oli tarkoitus kokeilla PSPP:tä, jota kai ei saa muuten kuin sorsina. Hyvä. Mutta configure valittaa seuraavaa:

Koodia: [Valitse]
configure: WARNING: The following optional prerequisites are not installed.
You may wish to install them to obtain additional functionality:
libxml2
libreadline (which may itself require libncurses or libtermcap)
configure: error: The following required prerequisites are not installed.
You must install them before PSPP can be built:
cairo 1.5 or later and pango 1.22 or later (or use --without-cairo)
gthread 2.0 (or use --without-gui)
gtk+ 3.0 version 3.14.5 or later (or use --without-gui)
gtksourceview 3.0 version 3.4.2 or later (or use --without-gui)
glib 2.0 version 2.32 or later (or use --without-gui)
glib-genmarshal (or use --without-gui)
zlib
zlib
libgslcblas
gsl version 1.13 or later


Miten ihmeessä nuo kaikki oikein asennetaan? Osaa niistä ei löydy, kuten vaikka cairo ja pango... Miten tämän tekisi helpoiten?

nm

  • Käyttäjä
  • Viestejä: 12591
    • Profiili
Vs: (GNU) softien kääntäminen
« Vastaus #1 : 11.02.18 - klo:15.08 »
Oli tarkoitus kokeilla PSPP:tä, jota kai ei saa muuten kuin sorsina.

On saatavilla Ubuntun universe-lähteestä: https://packages.ubuntu.com/search?searchon=names&keywords=pspp

Koodia: [Valitse]
sudo apt-get install pspp

Jos tarvitset version 1.0.1 Ubuntu 16.04:ään tai 17.10:een, sellaisen saa tästä PPA:sta: https://launchpad.net/~adamzammit/+archive/ubuntu/pspp

Koodia: [Valitse]
sudo add-apt-repository ppa:adamzammit/pspp
sudo apt-get update
Koodia: [Valitse]
sudo apt-get install pspp

Binääripaketoinnit eri jakeluihin ja käyttöjärjestelmiin on listattu ohjelman kotisivullakin: https://www.gnu.org/software/pspp/get.html


Koodia: [Valitse]
configure: WARNING: The following optional prerequisites are not installed.
You may wish to install them to obtain additional functionality:
libxml2
libreadline (which may itself require libncurses or libtermcap)
configure: error: The following required prerequisites are not installed.
You must install them before PSPP can be built:
cairo 1.5 or later and pango 1.22 or later (or use --without-cairo)
gthread 2.0 (or use --without-gui)
gtk+ 3.0 version 3.14.5 or later (or use --without-gui)
gtksourceview 3.0 version 3.4.2 or later (or use --without-gui)
glib 2.0 version 2.32 or later (or use --without-gui)
glib-genmarshal (or use --without-gui)
zlib
zlib
libgslcblas
gsl version 1.13 or later


Miten ihmeessä nuo kaikki oikein asennetaan? Osaa niistä ei löydy, kuten vaikka cairo ja pango... Miten tämän tekisi helpoiten?

Selvitetään yksitellen, mikä jakelun paketti tarjoaa tarvittavan riippuvuuden. Esimerkiksi Cairon ja Pangon headerit ovat Ubuntussa paketeissa libcairo2-dev ja libpango1.0-dev. Riittää, että asentaa dev-paketit. Ne vetävät mukanaan varsinaiset kirjastot, jos niitä ei vielä ole järjestelmään asennettu.

Mutta 99 prosentissa tunnetuista sovelluksista joku on jo tehnyt tämän puolestasi ja paketoinut ohjelman saataville joko Ubuntun virallisissa lähteissä tai jostain PPA:sta. Riittää googlata hakusanoilla "sovelluksennimi ppa".
« Viimeksi muokattu: 11.02.18 - klo:15.15 kirjoittanut nm »