Kirjoittaja Aihe: Skannaus verkon yli??  (Luettu 614 kertaa)

MarkoN

  • Käyttäjä
  • Viestejä: 533
    • Profiili
Skannaus verkon yli??
« : 12.08.17 - klo:08.55 »
Moro.

Ostin uuden wifi monitoimitulostimen joka toimii tulostuksen osalta moitteitta verkon yli kaikilla laitteilla joita minulla on.

Miten saisin skannauksen toimimaan myös verkon yli?

Tulostin on HP Laserjet Pro MFP M26nw


Hplip on 3.16.3
Ubuntu 16.04.1 LTS
Asus P8P67, i5-2500K 3,3GHz(->4,6GHz),
8Gt 1600MHz DDR3, Gigabyte GeForce GTX970 G1 Gaming

Ubuntu 16.04.1 LTS
ACER Aspire M3-581T, i3-2367M 1,4GHz, 4Gt 1333MHz

Ubuntu 14.04.5 LTS
Asus P5K, Q6600 3,0GHz, 8Gt 800MHz,
Gigabyte GTX780oc

MarkoN

  • Käyttäjä
  • Viestejä: 533
    • Profiili
Vs: Skannaus verkon yli??
« Vastaus #1 : 13.08.17 - klo:13.46 »
No nyt ei muijan läppäristä saakkaan tulosteita.

Tulostin näkyy verkon yli hienosti ja asennus onnituu moitteitta. testitulostetta tai muuta tulostaessa ei tulostus mene läpi.

HPLIP on asennettu.
Ubuntu 16.04.1 LTS
Asus P8P67, i5-2500K 3,3GHz(->4,6GHz),
8Gt 1600MHz DDR3, Gigabyte GeForce GTX970 G1 Gaming

Ubuntu 16.04.1 LTS
ACER Aspire M3-581T, i3-2367M 1,4GHz, 4Gt 1333MHz

Ubuntu 14.04.5 LTS
Asus P5K, Q6600 3,0GHz, 8Gt 800MHz,
Gigabyte GTX780oc

MarkoN

  • Käyttäjä
  • Viestejä: 533
    • Profiili
Vs: Skannaus verkon yli??
« Vastaus #2 : 13.08.17 - klo:14.01 »
hplip asennuksessa ilmeisesti on jotain pielessä. graafinen tila ei ole toiminnassa ja päätteestä ajamalla ei löydä verkkotulostinta.

asensin hplipin uudeleen mutta mikään ei muuttunut.
Ubuntu 16.04.1 LTS
Asus P8P67, i5-2500K 3,3GHz(->4,6GHz),
8Gt 1600MHz DDR3, Gigabyte GeForce GTX970 G1 Gaming

Ubuntu 16.04.1 LTS
ACER Aspire M3-581T, i3-2367M 1,4GHz, 4Gt 1333MHz

Ubuntu 14.04.5 LTS
Asus P5K, Q6600 3,0GHz, 8Gt 800MHz,
Gigabyte GTX780oc

nm

  • Käyttäjä
  • Viestejä: 10794
    • Profiili
Vs: Skannaus verkon yli??
« Vastaus #3 : 13.08.17 - klo:14.05 »
Tulostin on HP Laserjet Pro MFP M26nw

Hplip on 3.16.3

HP Laserjet Pro MFP M26nw on tuettu vasta HPLIPin versiosta 3.17.5 lähtien: http://hplipopensource.com/hplip-web/models/laserjet/hp_laserjet_pro_mfp_m26nw.html

Poista Ubuntun hplip-paketti ja lataa ja asenna uusin versio täältä: http://hplipopensource.com/hplip-web/index.html


Jos skannaus ei lähde toimimaan uudella ajurilla, kokeile asentaa tarvittava liitännäinen manuaalisesti: https://bugs.launchpad.net/hplip/+bug/1646653/comments/10

MarkoN

  • Käyttäjä
  • Viestejä: 533
    • Profiili
Vs: Skannaus verkon yli??
« Vastaus #4 : 13.08.17 - klo:15.33 »
omaan koneeseen uusin hplip asentui ongelmitta mutta tähän läppäriin ei sitten millään.

Koodia: [Valitse]
DEPENDENCY AND CONFLICT RESOLUTION
----------------------------------
Running 'sudo apt-get install --assume-yes libcupsimage2-dev'
Please wait, this may take several minutes...
error: Command failed. Re-try #1...
Running 'sudo apt-get install --assume-yes libcupsimage2-dev'
Please wait, this may take several minutes...
error: Command failed. Re-try #2...
Running 'sudo apt-get install --assume-yes libcupsimage2-dev'
Please wait, this may take several minutes...
error: Command failed. Re-try #3...
Running 'sudo apt-get install --assume-yes libcupsimage2-dev'
Please wait, this may take several minutes...
error: Package install command failed with error code 100
Would you like to retry installing the missing package(s) (y=yes*, n=no, q=quit) ? y
Running 'sudo apt-get install --assume-yes libcupsimage2-dev'
Please wait, this may take several minutes...
error: Package install command failed with error code 100
Would you like to retry installing the missing package(s) (y=yes*, n=no, q=quit) ? n
warning: Some HPLIP functionality might not function due to missing package(s).
Running 'sudo apt-get install --assume-yes openssl'
Please wait, this may take several minutes...
Running 'sudo apt-get install --assume-yes libsnmp-dev'
Please wait, this may take several minutes...
error: Command failed. Re-try #1...
Running 'sudo apt-get install --assume-yes libsnmp-dev'
Please wait, this may take several minutes...
error: Command failed. Re-try #2...
Running 'sudo apt-get install --assume-yes libsnmp-dev'
Please wait, this may take several minutes...
error: Command failed. Re-try #3...
Running 'sudo apt-get install --assume-yes libsnmp-dev'
Please wait, this may take several minutes...
error: Package install command failed with error code 100
Would you like to retry installing the missing package(s) (y=yes*, n=no, q=quit) ? y
Running 'sudo apt-get install --assume-yes libsnmp-dev'
Please wait, this may take several minutes...
error: Package install command failed with error code 100
Would you like to retry installing the missing package(s) (y=yes*, n=no, q=quit) ? n
warning: Some HPLIP functionality might not function due to missing package(s).
Running 'sudo apt-get install --assume-yes snmp-mibs-downloader'
Please wait, this may take several minutes...
Running 'sudo apt-get install --assume-yes libdbus-1-dev'
Please wait, this may take several minutes...
error: Command failed. Re-try #1...
Running 'sudo apt-get install --assume-yes libdbus-1-dev'
Please wait, this may take several minutes...
error: Command failed. Re-try #2...
Running 'sudo apt-get install --assume-yes libdbus-1-dev'
Please wait, this may take several minutes...
error: Command failed. Re-try #3...
Running 'sudo apt-get install --assume-yes libdbus-1-dev'
Please wait, this may take several minutes...
error: Package install command failed with error code 100
Would you like to retry installing the missing package(s) (y=yes*, n=no, q=quit) ? n
warning: Some HPLIP functionality might not function due to missing package(s).
error: A required dependency 'cups-image (CUPS image - CUPS image development files)' is still missing.
error: A required dependency 'libcrypto (libcrypto - OpenSSL cryptographic library)' is still missing.
error: A required dependency 'libnetsnmp-devel (libnetsnmp-devel - SNMP networking library development files)' is still missing.
error: A required dependency 'dbus (DBus - Message bus system)' is still missing.


RUNNING POST-PACKAGE COMMANDS
-----------------------------
OK


RE-CHECKING DEPENDENCIES
------------------------
error: A required dependency 'cups-image (CUPS image - CUPS image development files)' is still missing.
error: A required dependency 'libcrypto (libcrypto - OpenSSL cryptographic library)' is still missing.
error: A required dependency 'libnetsnmp-devel (libnetsnmp-devel - SNMP networking library development files)' is still missing.
error: A required dependency 'dbus (DBus - Message bus system)' is still missing.
error: Installation cannot continue without these dependencies.
error: Please manually install this dependency and re-run this installer.

joitakin paketteja jää asentamatta eikä niitä löydy verkosta...
Ubuntu 16.04.1 LTS
Asus P8P67, i5-2500K 3,3GHz(->4,6GHz),
8Gt 1600MHz DDR3, Gigabyte GeForce GTX970 G1 Gaming

Ubuntu 16.04.1 LTS
ACER Aspire M3-581T, i3-2367M 1,4GHz, 4Gt 1333MHz

Ubuntu 14.04.5 LTS
Asus P5K, Q6600 3,0GHz, 8Gt 800MHz,
Gigabyte GTX780oc

nm

  • Käyttäjä
  • Viestejä: 10794
    • Profiili
Vs: Skannaus verkon yli??
« Vastaus #5 : 13.08.17 - klo:15.53 »
omaan koneeseen uusin hplip asentui ongelmitta mutta tähän läppäriin ei sitten millään.

Koodia: [Valitse]
DEPENDENCY AND CONFLICT RESOLUTION
----------------------------------
Running 'sudo apt-get install --assume-yes libcupsimage2-dev'
Please wait, this may take several minutes...
error: Command failed. Re-try #1...

Mitä nuo apt-get-komennot herjaavat päätteessä manuaalisesti ajettuna?

Koodia: [Valitse]
sudo apt-get install --assume-yes libcupsimage2-dev

MarkoN

  • Käyttäjä
  • Viestejä: 533
    • Profiili
Vs: Skannaus verkon yli??
« Vastaus #6 : 13.08.17 - klo:16.39 »
Mitä nuo apt-get-komennot herjaavat päätteessä manuaalisesti ajettuna?

Koodia: [Valitse]
sudo apt-get install --assume-yes libcupsimage2-dev

Tällaista herjaa...

Koodia: [Valitse]
Näillä paketeilla on tyydyttämättömiä riippuvuuksia:
 libcupsimage2-dev : Riippuvuudet: libcupsfilters-dev (>= 1.0~b1) mutta ei ole merkitty asennettavaksi
E: Pulmia ei voi korjata, rikkinäisiä paketteja on pysytetty.
Ubuntu 16.04.1 LTS
Asus P8P67, i5-2500K 3,3GHz(->4,6GHz),
8Gt 1600MHz DDR3, Gigabyte GeForce GTX970 G1 Gaming

Ubuntu 16.04.1 LTS
ACER Aspire M3-581T, i3-2367M 1,4GHz, 4Gt 1333MHz

Ubuntu 14.04.5 LTS
Asus P5K, Q6600 3,0GHz, 8Gt 800MHz,
Gigabyte GTX780oc

nm

  • Käyttäjä
  • Viestejä: 10794
    • Profiili
Vs: Skannaus verkon yli??
« Vastaus #7 : 13.08.17 - klo:17.09 »
Mitä nuo apt-get-komennot herjaavat päätteessä manuaalisesti ajettuna?

Koodia: [Valitse]
sudo apt-get install --assume-yes libcupsimage2-dev

Tällaista herjaa...

Koodia: [Valitse]
Näillä paketeilla on tyydyttämättömiä riippuvuuksia:
 libcupsimage2-dev : Riippuvuudet: libcupsfilters-dev (>= 1.0~b1) mutta ei ole merkitty asennettavaksi
E: Pulmia ei voi korjata, rikkinäisiä paketteja on pysytetty.

Mitä sanoo riippuvuusketjun seuraavan paketin asennus:

Koodia: [Valitse]
sudo apt-get install libcupsfilters-dev

MarkoN

  • Käyttäjä
  • Viestejä: 533
    • Profiili
Vs: Skannaus verkon yli??
« Vastaus #8 : 13.08.17 - klo:17.11 »
Mitä sanoo riippuvuusketjun seuraavan paketin asennus:

Koodia: [Valitse]
sudo apt-get install libcupsfilters-dev
Koodia: [Valitse]
Joitakin paketteja ei voitu asentaa. On ehkä vaadittu mahdottomia tai,
jos käytetään epävakaata jakelua, joitain vaadittuja paketteja ei ole
vielä luotu tai siirretty Incoming-kansiosta.
Seuraavista tiedoista voi olla hyötyä selvitettäessä tilannetta:

Näillä paketeilla on tyydyttämättömiä riippuvuuksia:
 libcupsfilters-dev : Riippuvuudet: libcupsfilters1 (= 1.8.3-2ubuntu3) mutta 1.8.3-2ubuntu3.1 on merkitty asennettavaksi
E: Pulmia ei voi korjata, rikkinäisiä paketteja on pysytetty.
Ubuntu 16.04.1 LTS
Asus P8P67, i5-2500K 3,3GHz(->4,6GHz),
8Gt 1600MHz DDR3, Gigabyte GeForce GTX970 G1 Gaming

Ubuntu 16.04.1 LTS
ACER Aspire M3-581T, i3-2367M 1,4GHz, 4Gt 1333MHz

Ubuntu 14.04.5 LTS
Asus P5K, Q6600 3,0GHz, 8Gt 800MHz,
Gigabyte GTX780oc

nm

  • Käyttäjä
  • Viestejä: 10794
    • Profiili
Vs: Skannaus verkon yli??
« Vastaus #9 : 13.08.17 - klo:17.21 »
Hmm. Aja apt-get update ja yritä uudelleen:

Koodia: [Valitse]
sudo apt-get update
Koodia: [Valitse]
sudo apt-get install libcupsfilters-dev
Jos ei edelleenkään onnistu, kopioi apt-get updaten listaus tänne.

MarkoN

  • Käyttäjä
  • Viestejä: 533
    • Profiili
Vs: Skannaus verkon yli??
« Vastaus #10 : 13.08.17 - klo:17.23 »
Koodia: [Valitse]
sudo apt-get update
Löytyi:1 http://fi.archive.ubuntu.com/ubuntu xenial InRelease
Siv:2 http://dl.google.com/linux/chrome/deb stable InRelease                                                                                                     
Nouda:3 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]                                                                   
Löytyi:4 http://archive.canonical.com/ubuntu xenial InRelease                                                                                                     
Löytyi:5 http://ppa.launchpad.net/mc3man/mpv-tests/ubuntu xenial InRelease                                                                                       
Löytyi:6 http://dl.google.com/linux/chrome/deb stable Release                                                                                   
Löytyi:7 http://repository.spotify.com stable InRelease                                                                   
Nouda:8 https://repo.skype.com/deb stable InRelease [4 487 B]
Siv:10 https://mega.nz/linux/MEGAsync/xUbuntu_16.04 ./ InRelease 
Siv:8 https://repo.skype.com/deb stable InRelease
Nouda:11 https://mega.nz/linux/MEGAsync/xUbuntu_16.04 ./ Release [988 B]
Noudettiin 108 kt ajassa 1s (87,4 kt/s)
Luetaan pakettiluetteloita... Valmis
W: GPG-virhe: https://repo.skype.com/deb stable InRelease: Seuraavia allekirjoituksia ei voinut varmentaa koska julkista avainta ei ole saatavilla: NO_PUBKEY 1F3045A5DF7587C3
W: The repository 'https://repo.skype.com/deb stable InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
Ubuntu 16.04.1 LTS
Asus P8P67, i5-2500K 3,3GHz(->4,6GHz),
8Gt 1600MHz DDR3, Gigabyte GeForce GTX970 G1 Gaming

Ubuntu 16.04.1 LTS
ACER Aspire M3-581T, i3-2367M 1,4GHz, 4Gt 1333MHz

Ubuntu 14.04.5 LTS
Asus P5K, Q6600 3,0GHz, 8Gt 800MHz,
Gigabyte GTX780oc

nm

  • Käyttäjä
  • Viestejä: 10794
    • Profiili
Vs: Skannaus verkon yli??
« Vastaus #11 : 13.08.17 - klo:17.28 »
Koodia: [Valitse]
sudo apt-get update
Löytyi:1 http://fi.archive.ubuntu.com/ubuntu xenial InRelease
Siv:2 http://dl.google.com/linux/chrome/deb stable InRelease                                                                                                     
Nouda:3 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]                                                                   
Löytyi:4 http://archive.canonical.com/ubuntu xenial InRelease                                                                                                     
Löytyi:5 http://ppa.launchpad.net/mc3man/mpv-tests/ubuntu xenial InRelease                                                                                       
Löytyi:6 http://dl.google.com/linux/chrome/deb stable Release                                                                                   
Löytyi:7 http://repository.spotify.com stable InRelease                                                                   
Nouda:8 https://repo.skype.com/deb stable InRelease [4 487 B]
Siv:10 https://mega.nz/linux/MEGAsync/xUbuntu_16.04 ./ InRelease 
Siv:8 https://repo.skype.com/deb stable InRelease
Nouda:11 https://mega.nz/linux/MEGAsync/xUbuntu_16.04 ./ Release [988 B]
Noudettiin 108 kt ajassa 1s (87,4 kt/s)
Luetaan pakettiluetteloita... Valmis

xenial-updates ja xenial-backports -ohjelmalähteet puuttuvat. Ota ne käyttöön Ohjelmistot ja päivitykset -asetusikkunan välilehdellä Päivitykset.

Kun kaikki oletusasennukseen kuuluvat lähteet ovat käytössä, ne näkyvät apt-get updaten listauksessa tähän tapaan:

Koodia: [Valitse]
Löytyi:1 http://fi.archive.ubuntu.com/ubuntu xenial InRelease
Löytyi:2 http://fi.archive.ubuntu.com/ubuntu xenial-updates InRelease
Löytyi:3 http://fi.archive.ubuntu.com/ubuntu xenial-backports InRelease
Löytyi:4 http://security.ubuntu.com/ubuntu xenial-security InRelease
« Viimeksi muokattu: 13.08.17 - klo:17.29 kirjoittanut nm »

MarkoN

  • Käyttäjä
  • Viestejä: 533
    • Profiili
Vs: Skannaus verkon yli??
« Vastaus #12 : 13.08.17 - klo:17.54 »
Jes kiitos, nyt toimii!!!

Myös skannaus alkoi toimimaan.
Ubuntu 16.04.1 LTS
Asus P8P67, i5-2500K 3,3GHz(->4,6GHz),
8Gt 1600MHz DDR3, Gigabyte GeForce GTX970 G1 Gaming

Ubuntu 16.04.1 LTS
ACER Aspire M3-581T, i3-2367M 1,4GHz, 4Gt 1333MHz

Ubuntu 14.04.5 LTS
Asus P5K, Q6600 3,0GHz, 8Gt 800MHz,
Gigabyte GTX780oc