Kirjoittaja Aihe: Ubuntu 17.04 Gnome hyytyy mennessään valmiustilaan(RATKAISTU)  (Luettu 1219 kertaa)

Pontus12

  • Käyttäjä
  • Viestejä: 782
    • Profiili
Ubuntu 17.04 Gnome hyytyy mennessään valmiustilaan. Aikaisemmin se ei tehnyt sitä. Kone ei lukkiudu joka kerta, mutta ärsyttävän usein. Vika saattaa johtua siitä, että yritin asentaa Ubuntuvarastosta touchpad off ohjelman, vaikka se oli Ubuntu 16.04 versio. Ohjelma ei ole toistaiseksi toiminut. Ehkä se pitäisi poistaa. Asensin sen "apt install" komennolla nettiohjeiden mukaan. Riittääköhän siinä vain "apt remove#. Kirjoittaminen on kuitenkin hankalaa, ellei kosketuslevyä saa silloin pois käytöstä.

Toinen ikävä piirre on, ettei lukitus mene pois päältä, vaikka olen sen määritellyt asetuksissa. Joudun joka kerta avatessani koneen tai sen palautuessa valmiustilasta kirjoittamaan salasanani.
« Viimeksi muokattu: 19.05.17 - klo:14.20 kirjoittanut Pontus12 »

nm

  • Käyttäjä
  • Viestejä: 11142
    • Profiili
Vs: Ubuntu 17.04 Gnome hyytyy mennessään valmiustilaan
« Vastaus #1 : 18.05.17 - klo:19.06 »
Ubuntu 17.04 Gnome hyytyy mennessään valmiustilaan. Aikaisemmin se ei tehnyt sitä. Kone ei lukkiudu joka kerta, mutta ärsyttävän usein. Vika saattaa johtua siitä, että yritin asentaa Ubuntuvarastosta touchpad off ohjelman, vaikka se oli Ubuntu 16.04 versio. Ohjelma ei ole toistaiseksi toiminut. Ehkä se pitäisi poistaa. Asensin sen "apt install" komennolla nettiohjeiden mukaan. Riittääköhän siinä vain "apt remove#. Kirjoittaminen on kuitenkin hankalaa, ellei kosketuslevyä saa silloin pois käytöstä.

En usko, että ongelma johtuu tuosta ohjelmasta, mutta voit poistaa sen sudo apt removella. Minkä ohjeen mukaan asensit sen?

Disable While Typing (dwt) -ominaisuuden pitäisi käsittääkseni olla vakiona päällä nykyisissä GNOME Shellin versioissa, mutta on mahdollista, että libinput ei tunnista koneen kosketuslevyä kosketuslevyksi vaan geneeriseksi hiireksi, jolloin kyseinen ominaisuus ei ole käytössä. Myös BIOSin asetukset voivat vaikuttaa tähän.


Valmiustilan hyytyminen johtuu todennäköisesti jostain ajurista. Perinteisesti syy on näytönohjaimen ajurin suunnalla, mutta joku konekohtainen ongelmakin on mahdollinen. Mikä läppäri on kyseessä?

Pontus12

  • Käyttäjä
  • Viestejä: 782
    • Profiili
Vs: Ubuntu 17.04 Gnome hyytyy mennessään valmiustilaan
« Vastaus #2 : 18.05.17 - klo:21.18 »
Läppärini on Lenovo Yoga 2 Pro, 500gb ssda kiintolevy. Poistan varmuuden vuoksi kosketuslevyohjelman. Se kyllä asentui aivan normaalisti, mutta se ei vaikuta millään tavalla touchpadiin. Asetuksissa ei kosketuslevyn kohdalla ole oikeastaan minkäänlaisia asetuksia, joilla voisi säätää sitä.  Luuletko että kosketuslevyohjelman voisi saada toimimaan? Ubuntu 16.04 kanssa se toimii oikein hyvin.

Hyytyminen valmiustilassa on harmillinen, mutta nyt sitä ei ole tapahtunut vähään aikaan. Voiko se laueta jostain käyttäjävirheestä?



jekku

  • Käyttäjä
  • Viestejä: 1516
    • Profiili
Vs: Ubuntu 17.04 Gnome hyytyy mennessään valmiustilaan
« Vastaus #3 : 18.05.17 - klo:21.48 »
Kuinkahan monenlaisia kosketuslevyjä mahtaa olla?

Minulla on HP:n kosketuslevyt asettuneet .bashrc:n rivillä (tosin niissa on Debian 8)
Koodia: [Valitse]
synclient TouchpadOff=1

Tuota ei muistaakseni voi asentaa suoraan vaan oli osa jotain muuta?

Lisää tarinaa aiheeseen liittyen:
https://help.ubuntu.com/community/SynapticsTouchpad

nm

  • Käyttäjä
  • Viestejä: 11142
    • Profiili
Vs: Ubuntu 17.04 Gnome hyytyy mennessään valmiustilaan
« Vastaus #4 : 18.05.17 - klo:23.47 »
Läppärini on Lenovo Yoga 2 Pro, 500gb ssda kiintolevy. Poistan varmuuden vuoksi kosketuslevyohjelman. Se kyllä asentui aivan normaalisti, mutta se ei vaikuta millään tavalla touchpadiin. Asetuksissa ei kosketuslevyn kohdalla ole oikeastaan minkäänlaisia asetuksia, joilla voisi säätää sitä.  Luuletko että kosketuslevyohjelman voisi saada toimimaan? Ubuntu 16.04 kanssa se toimii oikein hyvin.

Nykyiset GNOME Shellin versiot käyttävät Synapticsin sijaan uutta libinput-rajapintaa syötelaitteille, jolloin nuo vanhemmat ohjelmat eivät välttämättä toimi. Katsoitko koneen BIOS-asetuksista, onko siellä mitään valintoja kosketuslevylle? Epäilen, että se toimii nyt tavallisena hiirenä, jos pystyt täppäilemään tai liikuttamaan osoitinta samalla, kun kirjoitat näppäimistöllä?


Hyytyminen valmiustilassa on harmillinen, mutta nyt sitä ei ole tapahtunut vähään aikaan. Voiko se laueta jostain käyttäjävirheestä?

Ohjelmilla ja käyttäjän toimilla voi toki olla vaikutusta asiaan, mutta en sanoisi sitä käyttäjävirheeksi. Kyseessä on bugi jossain ajurissa kernelin sisällä tai X.org:ssa, ja totaalisessa hyytymisessä syyn selvittäminen voi olla hyvinkin vaikeaa.

Pontus12

  • Käyttäjä
  • Viestejä: 782
    • Profiili
Vs: Ubuntu 17.04 Gnome hyytyy mennessään valmiustilaan
« Vastaus #5 : 19.05.17 - klo:09.37 »
Biosin asetuksista eni löytänyt hiireen tai kosketuslevyyn viittaavia asioita. Ubuntu Gnomen asetuksissa ei saa edes kosketuslevyä pois käytöstä, mikä tosin olisikin aika hankalaa ellei sitä saisi palautettua näppäinkomennolla. Asensin pointing devices ohjelman App Gridillä, mutta se ei toiminut. Touhpadistä oli paljon asetuksia, mutta mikään ei toiminut. Nyt on jo ikävä Ubuntu 16.04 versiota.

arieep

  • Käyttäjä
  • Viestejä: 253
    • Profiili
Vs: Ubuntu 17.04 Gnome hyytyy mennessään valmiustilaan
« Vastaus #6 : 19.05.17 - klo:13.56 »
Asenna 16.04 LTS ja pidä se, ei asioista kannata tehdä liian vaikeita.

Pontus12

  • Käyttäjä
  • Viestejä: 782
    • Profiili
Vs: Ubuntu 17.04 Gnome hyytyy mennessään valmiustilaan
« Vastaus #7 : 19.05.17 - klo:14.19 »
Asensin sysdaemon ohjelma käynnistettäviin ohjelmiin. Löysin ubuntu forumilta seuraavan ohjeen:
#
First entirely undo the current setting: Remove the tick for Disable touchpad while typing in
Mouse & Touchpad settings.
Now search for and open Startup Applications from the Dash. Click Add.
Name: Syndaemon
Command: syndaemon -i 1.0 -K -R -t
Comment: Disable touchpad while typing, with a reasonable delay and only for
tapping and scrolling
The -i 1.0 parameter sets the idle time of the keyboard to 1s. -K option ignores the Modifier
keys. -R option uses the XRecord extension for detecting keyboard activity instead of polling
the keyboard state. -t option disables tapping and scrolling but not mouse movements.
Click Add and then Close.
Reboot your computer.
Note: this is a user preference, so repeat this in every user account.
#
Annoin mennä toistaiseksi yhdellä sekunnilla, mutta jos se ei riitä, niin aika on helppo muuttaa. Jos joku ei osaa englantia, niin "-1 1.0" on aikaparametri" ja sen voi muuttaa mieleisekseen. Tämä tuntuu kaikkein kätevimmältä vaihtoehdolta. Kiitos kaikille. Kone ei ole ainakaan toistaiseksi hyytynyt uudelleen.