Kirjoittaja Aihe: Lightworks for ubuntu ei asennu deb-paketista (RATKAISTU)  (Luettu 2760 kertaa)

Pontus12

  • Käyttäjä
  • Viestejä: 1893
    • Profiili
Lightworks 14 ei asennu sovellusohjelman kautta deb-paketista, Koetin asentaa komentoriviltä, koska klikattuani kielletty ajosuunta merkkiä oikealla näppäimellä yläpaneelissa neuvottiin niin.
#
sudo apt-get install lwks-14.0.0-amd64.deb
[sudo] salasana henkilölle jotaarkka:
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
E: Paketti linux-image-4.4.0-72-generic olisi asennettava uudelleen, mutta sen arkistoa ei löydy.
#
Mikähän neuvoksi?
« Viimeksi muokattu: 07.04.17 - klo:21.34 kirjoittanut Pontus12 »

kamara

  • Käyttäjä
  • Viestejä: 2598
    • Profiili
Vs: Lightworks for ubuntu ei asennu deb-paketista
« Vastaus #1 : 06.04.17 - klo:21.10 »
Kokeile...
Koodia: [Valitse]
sudo dpkg -i  lwks-14.0.0-amd64.deb

Edit - Mutta minä asentaisin sen graafisesti hiiren kakkosta klikkaamalla tiedoston päällä, jolloin kyseinen gui ehdottaa asentaa myös tarvittavat riippuvuudet.
« Viimeksi muokattu: 06.04.17 - klo:21.12 kirjoittanut kamara »

Jakke77

  • Käyttäjä
  • Viestejä: 3850
  • Oulu (Oinaansuo)
    • Profiili
Vs: Lightworks for ubuntu ei asennu deb-paketista
« Vastaus #2 : 07.04.17 - klo:10.02 »
kokeile

Koodia: [Valitse]
[ sudo dpkg -i <paketti>/code]
U_G_H

Aspire E5-575G V1.27 CPU: Intel i3-6100U (4) @ 2.300GHz GPU: Intel® HD Graphics 520 GPU: NVIDIA GeForce 940MX

Pontus12

  • Käyttäjä
  • Viestejä: 1893
    • Profiili
Vs: Lightworks for ubuntu ei asennu deb-paketista
« Vastaus #3 : 07.04.17 - klo:10.44 »
Sain tällaisen vastauksen annettuani komennon:
#
 sudo dpkg -i lwks-14.0.0-amd64.deb/code
[sudo] salasana henkilölle jotaarkka:
dpkg: error processing archive lwks-14.0.0-amd64.deb/code (--install):
 ei pääsyä arkistoon: Tiedostoa tai hakemistoa ei ole
Käsittelyssä tapahtui liian monta virhettä:
 lwks-14.0.0-amd64.deb/code
#
Hiiren oikealla näppäimellä klikkaaminen avaa vain pakettien käsittelyn.

Eesaurus

  • Käyttäjä
  • Viestejä: 3238
    • Profiili
Vs: Lightworks for ubuntu ei asennu deb-paketista
« Vastaus #4 : 07.04.17 - klo:11.18 »
Sain tällaisen vastauksen annettuani komennon:
#
 sudo dpkg -i lwks-14.0.0-amd64.deb/code
[sudo] salasana henkilölle jotaarkka:
dpkg: error processing archive lwks-14.0.0-amd64.deb/code (--install):
 ei pääsyä arkistoon: Tiedostoa tai hakemistoa ei ole
Käsittelyssä tapahtui liian monta virhettä:
 lwks-14.0.0-amd64.deb/code
#
Hiiren oikealla näppäimellä klikkaaminen avaa vain pakettien käsittelyn.

Siirrä se deb -paketti kotikansioon ja aja sitten komento:
Koodia: [Valitse]
sudo dpkg -i lwks-14.0.0-amd64.deb
MUOKS: Että hiiren oikealla tulisi asennusvaihtoehtoja, niin pitäisi olla Gdebi tms. asennettuna. Oletuksenahan Ubuntussa ei deb -pakettien asentamiseen ole graafisia vaihtoehtoja Sovellusvalikoimalle.
« Viimeksi muokattu: 07.04.17 - klo:11.24 kirjoittanut Eesaurus »

Pontus12

  • Käyttäjä
  • Viestejä: 1893
    • Profiili
Vs: Lightworks for ubuntu ei asennu deb-paketista
« Vastaus #5 : 07.04.17 - klo:13.28 »
Ajoin komennon ja se lähti käyntiin, mutta keskenkaiken ilmeni ongelma:
#
dpkg: dependency problems prevent configuration of lightworks:
 lightworks riippuu paketista nvidia-cg-toolkit; kuitenkin:
  Pakettia nvidia-cg-toolkit ei ole asennettu.
 lightworks riippuu paketista libportaudiocpp0; kuitenkin:
  Pakettia libportaudiocpp0 ei ole asennettu.

dpkg: error processing package lightworks (--install):
 riippuvuusongelmia - jätetään asetukset säätämättä
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for fontconfig (2.11.94-0ubuntu1.1) ...
Käsittelyssä tapahtui liian monta virhettä:
#
Sen verran ymmärrän, että jotain paketteja ilmeisesti puuttuu. Voiko asialle tehdä jotain, vai onko niin, että se ei tue tätä Ubuntu versio 16.04:ää? Jossain taisi olla, että se tarvitsisi 16.10 versiota tai uudempaa tai sitten asentaa jotain ylimääräistä.

raimo

  • Käyttäjä
  • Viestejä: 3656
    • Profiili
Vs: Lightworks for ubuntu ei asennu deb-paketista
« Vastaus #6 : 07.04.17 - klo:13.34 »
Ajoin komennon ja se lähti käyntiin, mutta keskenkaiken ilmeni ongelma:
#
dpkg: dependency problems prevent configuration of lightworks:
 lightworks riippuu paketista nvidia-cg-toolkit; kuitenkin:
  Pakettia nvidia-cg-toolkit ei ole asennettu.
 lightworks riippuu paketista libportaudiocpp0; kuitenkin:
  Pakettia libportaudiocpp0 ei ole asennettu.

dpkg: error processing package lightworks (--install):
 riippuvuusongelmia - jätetään asetukset säätämättä
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for fontconfig (2.11.94-0ubuntu1.1) ...
Käsittelyssä tapahtui liian monta virhettä:
#
Sen verran ymmärrän, että jotain paketteja ilmeisesti puuttuu. Voiko asialle tehdä jotain, vai onko niin, että se ei tue tätä Ubuntu versio 16.04:ää? Jossain taisi olla, että se tarvitsisi 16.10 versiota tai uudempaa tai sitten asentaa jotain ylimääräistä.

dpkg ei osaa asentaa asennuspaketin ulkopuolisia riippuvuuksia, korjaa tilanne tällä komennolla:
Koodia: [Valitse]
sudo apt-get -f installMikäli kaikki riippuvuudet löytyy, ne asentuu ja homma lähtee toimimaan.
So long and thanks for all the fish!

Pontus12

  • Käyttäjä
  • Viestejä: 1893
    • Profiili
Vs: Lightworks for ubuntu ei asennu deb-paketista
« Vastaus #7 : 07.04.17 - klo:13.59 »
Ajoin komennon, mutta ei onnistunut.
#
sudo apt-get -f install lwks-14.0.0-amd64.deb
[sudo] salasana henkilölle jotaarkka:
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
E: Paketti linux-image-4.4.0-72-generic olisi asennettava uudelleen, mutta sen arkistoa ei löydy.
#
Sama ilmoitus tulee yläpaneeliin asettuneesta "kielteinen ajosuunta" merkistä.

raimo

  • Käyttäjä
  • Viestejä: 3656
    • Profiili
Vs: Lightworks for ubuntu ei asennu deb-paketista
« Vastaus #8 : 07.04.17 - klo:14.08 »
Älä lisää komentoon mitään vaan aja komento sellaisena kuin se on esitetty, eli:
Koodia: [Valitse]
sudo apt-get -f install
Asennus aloitetaan asentamalla deb-paketti dpkg:llä, sen olet jo tehnyt.
 Tuo apt-get komento korjaa kesken jääneen asennuksen.
So long and thanks for all the fish!

Pontus12

  • Käyttäjä
  • Viestejä: 1893
    • Profiili
Vs: Lightworks for ubuntu ei asennu deb-paketista
« Vastaus #9 : 07.04.17 - klo:14.13 »
Ei onnistunut tuollakaan.

#
sudo apt-get -f install
[sudo] salasana henkilölle jotaarkka:
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
E: Paketti linux-image-4.4.0-72-generic olisi asennettava uudelleen, mutta sen arkistoa ei löydy.
#
Tätä se on herjannut koko ajan. Jälleen yläpaneeliin asettui "kielteinen ajosuunta" merkki.

nm

  • Käyttäjä
  • Viestejä: 14639
    • Profiili
Vs: Lightworks for ubuntu ei asennu deb-paketista
« Vastaus #10 : 07.04.17 - klo:15.44 »
E: Paketti linux-image-4.4.0-72-generic olisi asennettava uudelleen, mutta sen arkistoa ei löydy.
#
Tätä se on herjannut koko ajan. Jälleen yläpaneeliin asettui "kielteinen ajosuunta" merkki.

Tuo onkin vähän tavallista hankalampi juttu. Kokeile tällä komennolla:

Koodia: [Valitse]
sudo dpkg --remove --force-remove-reinstreq linux-image-4.4.0-72-generic
Sitten uusi asennusyritys:

Koodia: [Valitse]
sudo apt-get install linux-image-4.4.0-72-generic

Jos ei auta, joudut ehkä editoimaan tiedostoa /var/lib/dpkg/status: http://askubuntu.com/questions/122699/how-to-remove-package-in-bad-state-software-center-freezes-no-synaptic
« Viimeksi muokattu: 07.04.17 - klo:21.30 kirjoittanut nm »

Pontus12

  • Käyttäjä
  • Viestejä: 1893
    • Profiili
Vs: Lightworks for ubuntu ei asennu deb-paketista
« Vastaus #11 : 07.04.17 - klo:20.52 »
Komennot eivät auttaneet asentamaan. Yritin ohjeiden mukaan editoida komennolla sudo nano /var/lib/dpkg/status. Etsi toiminta ei tuottanut tulosta. Nuolinäppäimillä selaten ja tuntien kuluessa löysin kyllä linux-imageja, mutta en kyseistä. Kielletty ajosuunta kertoo nyt, että virheviesti oli: "Virhe BrokenCount>0". Se neuvoi avaamaan pakettien hallinnan hiiren oikealla näppäimellä tai käyttämään päätteessä apt-get komentoa. Pakettien hallinta ei löytänyt mitään, kun kirjoitin "Rikki". Ehkä yritän vielä kerran poistaa rikkinäiset paketit. Olisin vain kokeillut uutta Lightworksia, mutta ei maailma siihen kaadu, jos en saa sitä toimimaan.

nm

  • Käyttäjä
  • Viestejä: 14639
    • Profiili
Vs: Lightworks for ubuntu ei asennu deb-paketista
« Vastaus #12 : 07.04.17 - klo:21.02 »
Komennot eivät auttaneet asentamaan.

Kopioi esittämäni dpkg-komennon listaus tänne.

Yritin ohjeiden mukaan editoida komennolla sudo nano /var/lib/dpkg/status. Etsi toiminta ei tuottanut tulosta. Nuolinäppäimillä selaten ja tuntien kuluessa löysin kyllä linux-imageja, mutta en kyseistä. Kielletty ajosuunta kertoo nyt, että virheviesti oli: "Virhe BrokenCount>0". Se neuvoi avaamaan pakettien hallinnan hiiren oikealla näppäimellä tai käyttämään päätteessä apt-get komentoa. Pakettien hallinta ei löytänyt mitään, kun kirjoitin "Rikki". Ehkä yritän vielä kerran poistaa rikkinäiset paketit. Olisin vain kokeillut uutta Lightworksia, mutta ei maailma siihen kaadu, jos en saa sitä toimimaan.

linux-image-paketin virhe ei liity Lightworksiin, mutta vika kannattaisi korjata. Muuten pakettienhallintajärjestelmä ei välttämättä toimi oikein. Korjaus ei onnistu graafisilla työkaluilla, eikä tavallisesti käytetyillä komennoilla.

Etsi grepillä sieltä status-tiedostosta:

Koodia: [Valitse]
grep -A 10 linux-image-4.4.0-72 /var/lib/dpkg/status
Kopioi listaus tänne.
« Viimeksi muokattu: 07.04.17 - klo:21.05 kirjoittanut nm »

Pontus12

  • Käyttäjä
  • Viestejä: 1893
    • Profiili
Vs: Lightworks for ubuntu ei asennu deb-paketista
« Vastaus #13 : 07.04.17 - klo:21.21 »
Hei. Vastaus dpkg komentoon oli tämä:
#
sudo dpkg --remove --force-remove-reinstreq linux-image-4.4.0-72-generic
[sudo] salasana henkilölle jotaarkka:
dpkg: varoitus: ignoring request to remove linux-image-4.4.0-72-generic which isn't installed
#
Grep komentoon ei tullut mitään vastausta, vaan se palasi komennon jälkeen perustilaan. #grep -A 10 linux-image-4.4.0-72 /var/lib/dpkg/status#
 Kokeilin sudoakin, mutta mikään ei muuttunut.

nm

  • Käyttäjä
  • Viestejä: 14639
    • Profiili
Vs: Lightworks for ubuntu ei asennu deb-paketista
« Vastaus #14 : 07.04.17 - klo:21.25 »
dpkg: varoitus: ignoring request to remove linux-image-4.4.0-72-generic which isn't installed
#
Grep komentoon ei tullut mitään vastausta, vaan se palasi komennon jälkeen perustilaan. #grep -A 10 linux-image-4.4.0-72 /var/lib/dpkg/status#
 Kokeilin sudoakin, mutta mikään ei muuttunut.

Hmm. Vaikuttaa siltä, että komento korjasi vian ensimmäisellä kerralla. Mitä apt-get -f install sanoo nyt:

Koodia: [Valitse]
sudo apt-get -f install

Pontus12

  • Käyttäjä
  • Viestejä: 1893
    • Profiili
Vs: Lightworks for ubuntu ei asennu deb-paketista
« Vastaus #15 : 07.04.17 - klo:21.31 »
Nyt tuli aika pitkä listaus:
#
~$ sudo apt-get -f install
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
Korjataan riippuvuuksia... Valmis
The following additional packages will be installed:
  libcg libcggl libportaudiocpp0 nvidia-cg-dev nvidia-cg-toolkit
Ehdotetut paketit:
  nvidia-cg-doc
Seuraavat UUDET paketit asennetaan:
  libcg libcggl libportaudiocpp0 nvidia-cg-dev nvidia-cg-toolkit
0 päivitetty, 5 uutta asennusta, 0 poistettavaa ja 63 päivittämätöntä.
1 ei asennettu kokonaan tai poistettiin.
Noudettavaa arkistoa 4 137 kt.
Toiminnon jälkeen käytetään 32,4 M t lisää levytilaa.
Haluatko jatkaa? [K/e] K
Nouda:1 http://fi.archive.ubuntu.com/ubuntu xenial/multiverse amd64 libcg amd64 3.1.0013-2 [2 439 kB]
Nouda:2 http://fi.archive.ubuntu.com/ubuntu xenial/multiverse amd64 libcggl amd64 3.1.0013-2 [143 kB]
Nouda:3 http://fi.archive.ubuntu.com/ubuntu xenial/multiverse amd64 nvidia-cg-dev amd64 3.1.0013-2 [14,5 kB]
Nouda:4 http://fi.archive.ubuntu.com/ubuntu xenial/multiverse amd64 nvidia-cg-toolkit amd64 3.1.0013-2 [1 525 kB]
Nouda:5 http://fi.archive.ubuntu.com/ubuntu xenial/main amd64 libportaudiocpp0 amd64 19+svn20140130-1build1 [15,4 kB]
Noudettiin 4 137 kt ajassa 5s (776 kt/s)   
Selecting previously unselected package libcg:amd64.
(Luetaan tietokantaa... 317179 files and directories currently installed.)
Preparing to unpack .../libcg_3.1.0013-2_amd64.deb ...
Unpacking libcg:amd64 (3.1.0013-2) ...
Selecting previously unselected package libcggl:amd64.
Preparing to unpack .../libcggl_3.1.0013-2_amd64.deb ...
Unpacking libcggl:amd64 (3.1.0013-2) ...
Selecting previously unselected package nvidia-cg-dev:amd64.
Preparing to unpack .../nvidia-cg-dev_3.1.0013-2_amd64.deb ...
Unpacking nvidia-cg-dev:amd64 (3.1.0013-2) ...
Selecting previously unselected package nvidia-cg-toolkit.
Preparing to unpack .../nvidia-cg-toolkit_3.1.0013-2_amd64.deb ...
Unpacking nvidia-cg-toolkit (3.1.0013-2) ...
Selecting previously unselected package libportaudiocpp0:amd64.
Preparing to unpack .../libportaudiocpp0_19+svn20140130-1build1_amd64.deb ...
Unpacking libportaudiocpp0:amd64 (19+svn20140130-1build1) ...
Processing triggers for man-db (2.7.5-1) ...
Tehdään asetuksia: libcg:amd64 (3.1.0013-2) ...
Tehdään asetuksia: libcggl:amd64 (3.1.0013-2) ...
Tehdään asetuksia: nvidia-cg-dev:amd64 (3.1.0013-2) ...
Tehdään asetuksia: nvidia-cg-toolkit (3.1.0013-2) ...
Tehdään asetuksia: libportaudiocpp0:amd64 (19+svn20140130-1build1) ...
Tehdään asetuksia: lightworks (14.0.0.0) ...
Processing triggers for libc-bin (2.23-0ubuntu7) ...
#

Pontus12

  • Käyttäjä
  • Viestejä: 1893
    • Profiili
Vs: Lightworks for ubuntu ei asennu deb-paketista
« Vastaus #16 : 07.04.17 - klo:21.34 »
En tajunnut heti, mutta sitten avasin sovellusvalikoiman ja siellähän Lightworks oli ja avautui. Eikä päätteessä virheilmoituksia. Tuhannet kiitokset!

nm

  • Käyttäjä
  • Viestejä: 14639
    • Profiili
Vs: Lightworks for ubuntu ei asennu deb-paketista
« Vastaus #17 : 07.04.17 - klo:21.35 »
Jep. Nyt näyttää siltä miltä pitää. Lightworksin asennus meni läpi, kun apt-get -f install asensi puuttuvat riippuvuudet.