Kirjoittaja Aihe: ASUS RT-AC51U reititin pätkii nettiä Linux Mintissä. Ratkaistu-tavallaan  (Luettu 10368 kertaa)

Kaasumies

  • Käyttäjä
  • Viestejä: 353
    • Profiili
Eli katkasee netin ihan liian usein. Mintistä on uusin versio, en nyt muista mikä, enkä voi katsoa kun olen Wintoosassa. Reititintä asennettaessa ei tarvinnut tehdä mitään, vaan netti toimi heti. Olisiko siltikin pitänyt jotain tehdä? Netti on 10/10 ja reititin noin kolmen metrin päässä koneesta ikkunalaudalla TV:n takana. Reitittimessä on kaksi antennia.


https://www.google.fi/search?q=ASUS+RT-AC51U&source=lnms&tbm=isch&sa=X&ved=0ahUKEwicwcHizaXSAhULliwKHe1cCkAQ_AUICCgB&biw=1920&bih=901
« Viimeksi muokattu: 12.03.17 - klo:09.02 kirjoittanut Kaasumies »

Kaasumies

  • Käyttäjä
  • Viestejä: 353
    • Profiili
Vs: ASUS RT-AC51U reititin pätkii nettiä Linux Mintissä
« Vastaus #1 : 27.02.17 - klo:18.15 »
Sama ongelma myös uudessa Ubuntu Matessa, eli vika saattaa olla koneen alkuperäisessä verkkokortissa. Testaan vielä jonkun aikaa Wind 10:llä. Jos sillä toimii aina, niin verkkokortti on ehjä ja vika ehkä sen Linuxajureissa.

jekku

  • Käyttäjä
  • Viestejä: 2624
    • Profiili
Vs: ASUS RT-AC51U reititin pätkii nettiä Linux Mintissä
« Vastaus #2 : 28.02.17 - klo:12.57 »
Miten päädyit tulokseen että on tuo reititin joka pätkii?

Echramath

  • Käyttäjä
  • Viestejä: 242
    • Profiili
    • http://iki.fi/ech/
Vs: ASUS RT-AC51U reititin pätkii nettiä Linux Mintissä
« Vastaus #3 : 28.02.17 - klo:16.29 »
Katkon aikana voisit kurkistaa, mitä tarkalleen on tilanne, eli selvitä oma IP-osoitteesi ja vielä reitittimenkin. Eli ifconfig ja route -n.

Koodia: [Valitse]
echramath@trilobite:~$ ifconfig
....
enp5s1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.10.16  netmask 255.255.255.0  broadcast 192.168.10.255
...

Koodia: [Valitse]
echramath@trilobite:~$ route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.10.1    0.0.0.0         UG    100    0        0 enp5s1
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 enp5s1
192.168.10.0    0.0.0.0         255.255.255.0   U     100    0        0 enp5s1

Ensinmainittu voi antaa yhden jos toisenkin "interfacen" eli verkkoliittimen (useimmiten erilaisia ihan fyysisiä verkkokortteja) mutta todennäköisesti niistä vain yhdellä on se IP-osoite eli listauksessa tuo "inet", tässä tapauksessa siis 192.168.10.16. (Aina on olemassa myös koneeseen itseensä osoittava loopback eli lo jolla on aina osoite 127.0.0.1 mutta siitä ei olla nyt kiinnostuneita). Route taas antaa yleensä vain yhden gatewayn joka ei ole 0.0.0.0 eli tässä 192.168.10.1.

Tämän jälkeen voi kokeilla pingata ensin reititintä:

Koodia: [Valitse]
echramath@trilobite:~$ ping 192.168.10.1
PING 192.168.10.1 (192.168.10.1) 56(84) bytes of data.
64 bytes from 192.168.10.1: icmp_seq=1 ttl=64 time=0.418 ms
64 bytes from 192.168.10.1: icmp_seq=2 ttl=64 time=0.411 ms
64 bytes from 192.168.10.1: icmp_seq=3 ttl=64 time=0.386 ms

Ja sitten vastaavasti FUNETia:

Koodia: [Valitse]
echramath@trilobite:~$ ping ping.funet.fi

Ja sama IP-osoitteella eli:

Koodia: [Valitse]
ping 128.214.248.132

Tällä voi yrittää haarukoida, mihin välille vika sijoittuu – tai jos ping onnistuu ip-osoitteella muttei kohteen nimellä, vika on selvästi nimipalvelussa.

Toinen yleinen osoite mitä voi kokeilla on google-public-dns-a.google.com eli helposti muistettava 8.8.8.8.


Eipä siinä mitään, tuli vastaan emon integroitu verkkopiiri, jossa ei – Windows seiskassa vieläpä, vaikka luulisi että sen ajuriin olisi panostettu eniten – verkkoyhteyksistä tullut mitään, ainakaan oletusasetuksilla. En jaksanut tunkata enempää kun toimivakin PCI-kortti sattui makaamaan hyllyssä.


Kaasumies

  • Käyttäjä
  • Viestejä: 353
    • Profiili
Vs: ASUS RT-AC51U reititin pätkii nettiä Linux Mintissä
« Vastaus #4 : 03.03.17 - klo:06.14 »
Miten päädyit tulokseen että on tuo reititin joka pätkii?

Juu ei olekaan reititin joka pätkii, koska Wintoosan puolella toimii normaalisti. Katson noiden ohjeiden mukaan myöhemmin.

nm

  • Käyttäjä
  • Viestejä: 16306
    • Profiili
Vs: ASUS RT-AC51U reititin pätkii nettiä Linux Mintissä
« Vastaus #5 : 03.03.17 - klo:14.28 »
Sama ongelma myös uudessa Ubuntu Matessa, eli vika saattaa olla koneen alkuperäisessä verkkokortissa. Testaan vielä jonkun aikaa Wind 10:llä. Jos sillä toimii aina, niin verkkokortti on ehjä ja vika ehkä sen Linuxajureissa.

Mikä wlan-piiri koneessa on, ja mikä ajuri käytössä? Selviää lshw:lla:

Koodia: [Valitse]
lshw -c network

Kaasumies

  • Käyttäjä
  • Viestejä: 353
    • Profiili
Vs: ASUS RT-AC51U reititin pätkii nettiä Linux Mintissä
« Vastaus #6 : 03.03.17 - klo:20.41 »
Sama ongelma myös uudessa Ubuntu Matessa, eli vika saattaa olla koneen alkuperäisessä verkkokortissa. Testaan vielä jonkun aikaa Wind 10:llä. Jos sillä toimii aina, niin verkkokortti on ehjä ja vika ehkä sen Linuxajureissa.

Mikä wlan-piiri koneessa on, ja mikä ajuri käytössä? Selviää lshw:lla:

Koodia: [Valitse]
lshw -c network

Alla tulos tuosta.
harri@karva-varvas:~$ sudo lshw -c network
[sudo] salasana henkilölle harri:
  *-network               
       description: Wireless interface
       product: RT3090 Wireless 802.11n 1T/1R PCIe
       vendor: Ralink corp.
       physical id: 0
       bus info: pci@0000:05:00.0
       logical name: wlp5s0
       version: 00
       serial: 68:a3:c4:17:81:d7
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rt2800pci driverversion=4.8.0-39-generic firmware=0.34 ip=192.168.1.32 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:19 memory:fe500000-fe50ffff
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:06:00.0
       logical name: enp6s0
       version: 06
       serial: e0:69:95:70:2a:17
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl_nic/rtl8168e-2.fw latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:25 ioport:d000(size=256) memory:d0004000-d0004fff memory:d0000000-d0003fff
harri@karva-varvas:~$

Kaasumies

  • Käyttäjä
  • Viestejä: 353
    • Profiili
Ratkaisin ongelman ostamalla uuden sisäisen verkkokortin, jossa on 2 antennia. Vikaa ei siis korjattu, mutta ongelma poistui.  :)

Kaasumies

  • Käyttäjä
  • Viestejä: 353
    • Profiili
Ratkaisin ongelman ostamalla uuden sisäisen verkkokortin, jossa on 2 antennia. Vikaa ei siis korjattu, mutta ongelma poistui.  :)

Eipäs poistunutkaan. Sama juttu silläkin Linuxissa. Windowsissa toimii hyvin. Noloa. Ajurijuttu varmaan. Pitää siis laittaa vaan johto seinään.

spark

  • Käyttäjä
  • Viestejä: 1752
    • Profiili
Katkeaako se yhteys tukiasemaan vai ainoastaan nettikö lakkaa toimimasta?

Kaasumies

  • Käyttäjä
  • Viestejä: 353
    • Profiili
Koneella netti poikki. Ilmoittaa, ettei verkkoja käytössä ja se "antennikuvake" kellon vieressä on harmaa. Kyllä langaton muuten toimii, jos vaikka puhelimella katsoo.

Lepotila zZ

  • Käyttäjä
  • Viestejä: 347
    • Profiili
Minulla on pari wifi-tikkua, joilla on samanlaista oiretta. Niiden kohdalla on kyse kernelin mukana tulevasta bugisesta ajurista. Ilmeisesti tikut menevät virransäästötilaan, jos niiden kautta ei kulje bittejä jonkin ajanjakson aikana. Obgelma on siinä, että ne eivät osaa enää herätä lepotilastaan. Niille on onneksi olemassa korjattu ajuri. Jos sellaista ei olisi, voisi luultavasti yrittää tehdä jokin prosessi, joka säännöllisesti (esim. 30 sekunnin välein) pingaa joitakin osotteita ja sitä kautta pitää tikun valveilla.

Kyseessä on eri piirisarja ja eiköhän aivan eri ajurikin, mutta kerroin nyt vain yhdestä mahdollisesta syystä, miksi wifi voi uinahdella.

spark

  • Käyttäjä
  • Viestejä: 1752
    • Profiili
Virransäästö voisi olla syyllinen. Katkeaako se yhteys, kun langaton on käyttämättä jonkinaikaa?

Voithan tuota kokeilla laittaa terminaaliin jatkuvan pingin, jos sitten ei tuota enään tee, niin silloin vika voi hyvinkin olla virransässtössä.

Pane vaikka tuo jauhamaan taustalle.

ping 8.8.8.8

Kaasumies

  • Käyttäjä
  • Viestejä: 353
    • Profiili
Virransäästö voisi olla syyllinen. Katkeaako se yhteys, kun langaton on käyttämättä jonkinaikaa?

Voithan tuota kokeilla laittaa terminaaliin jatkuvan pingin, jos sitten ei tuota enään tee, niin silloin vika voi hyvinkin olla virransässtössä.

Pane vaikka tuo jauhamaan taustalle.

ping 8.8.8.8

Tyhmä kysymys, mutta miten...  :o

nm

  • Käyttäjä
  • Viestejä: 16306
    • Profiili
Virransäästö voisi olla syyllinen. Katkeaako se yhteys, kun langaton on käyttämättä jonkinaikaa?

Voithan tuota kokeilla laittaa terminaaliin jatkuvan pingin, jos sitten ei tuota enään tee, niin silloin vika voi hyvinkin olla virransässtössä.

Pane vaikka tuo jauhamaan taustalle.

ping 8.8.8.8

Tyhmä kysymys, mutta miten...  :o

Pääte auki ja sinne tuo komento.


Ratkaisin ongelman ostamalla uuden sisäisen verkkokortin, jossa on 2 antennia. Vikaa ei siis korjattu, mutta ongelma poistui.  :)

Mikä kortti se on?

Koodia: [Valitse]
lshw -c network

Hieman erikoinen sattuma kyllä, että samanlaista vikaa ilmenee eri piireillä. Oireet kuitenkin viittaavat ajuriongelmaan.

Kaasumies

  • Käyttäjä
  • Viestejä: 353
    • Profiili
Ja se pätkäsee nettiä myös kesken käytön...

Kaasumies

  • Käyttäjä
  • Viestejä: 353
    • Profiili
Tilanne muuttunut. Netti on yleensä poikki, kun tietokone palaa lepotilasta, mutta hetken päästä kone yhdistää nettiin, josta tulee myös ilmoitus ruudun oikeaan yläkulmaan. Kesken käytön ei ole pitkään aikaan netti katkennut. Liekö joku päivitys korjannut tilanteen? Hyvä kuitenkin.  :)

spark

  • Käyttäjä
  • Viestejä: 1752
    • Profiili
Teitkö sitä pingitestiä aikanaan, jos sekin johtui tuosta DNS bugista.

nm

  • Käyttäjä
  • Viestejä: 16306
    • Profiili
Tilanne muuttunut. Netti on yleensä poikki, kun tietokone palaa lepotilasta, mutta hetken päästä kone yhdistää nettiin, josta tulee myös ilmoitus ruudun oikeaan yläkulmaan. Kesken käytön ei ole pitkään aikaan netti katkennut. Liekö joku päivitys korjannut tilanteen? Hyvä kuitenkin.  :)

Jep, eli selvästi dnsmasq-ongelma kyseessä: https://forum.ubuntu-fi.org/index.php?topic=52020.0

Kaasumies

  • Käyttäjä
  • Viestejä: 353
    • Profiili
Koitin joo. Netti tuli todella hitaaksi ja pätki oikein kunnolla. Buuttaus palautti sitten tietenkin kaiken ennalleen.