Kirjoittaja Aihe: [RATKAISTU] Nvidia GeForce GTX460 kuva katoaa bootissa.  (Luettu 9089 kertaa)

MarkoN

  • Käyttäjä
  • Viestejä: 555
    • Profiili
Moro.
Mulla on jo aika kauan ollut satunnainen ongelma Nvidian näytönohjainten kanssa...

Ubuntuna ollut 14.04 LTS ja nykyinen 16.04 LTS versiot, nvidia ajuri 361.42, MSI GeForce GTX460.

Eli aika ajoin joudun poistamaan näytönohjaimen kokonaan sekä muistit ja käynnistämään konneen jotta kuva palautuisi. En tiedä mikä ongelman aiheuttaa koska ainakaan edellisellä kerralla ei tarvinnut ajureita asentaa uudelleen. aikaisemmin nimittäin epäilin että olisiko yrittänyt päivittää ajureita jolloin olisi ollut kahdet päälekkäin niin kuin aikaisemmin minulle on käynyt. Erikoista tässä on kuitenkin sekin että sama ongelma ilmenee vaikka minulla oli aikaisemmin tämä näytönohjain kiinni vanhassa koneessa (Asus P5K, Q6600 3,0GHz, 8Gt 800MHz) ja nykyinen on Asus P8P67, i5-2500K 3,3GHz, 8Gt 1600MHz DDR3 (Arctic Cooling Freezer i30), MSI GeForce 460GTX 1Gt

Tämä on sinäänsä harmiton mutta raivostuttava ongelma. Että jos tähän löytyisi ratkaisu miten tämä korjata olisin kiitollinen... Taas  8)


TÄMÄ ONGELMA JOHTUI VANHASTA BIOSISTA JOKA EI TUNNISTANUT NÄYTÖNOHJAINTA OIKEIN...
« Viimeksi muokattu: 26.05.16 - klo:10.59 kirjoittanut MarkoN »
Ubuntu 16.04.1 LTS
Asus P8P67, i5-2500K 3,3GHz(->4,6GHz),
8Gt 1600MHz DDR3, Gigabyte GeForce GTX970 G1 Gaming

Ubuntu 16.04.1 LTS
ACER Aspire M3-581T, i3-2367M 1,4GHz, 4Gt 1333MHz

Ubuntu 14.04.5 LTS
Asus P5K, Q6600 3,0GHz, 8Gt 800MHz,
Gigabyte GTX780oc

Postimies

  • Käyttäjä
  • Viestejä: 2589
    • Profiili
Vs: Nvidia GeForce GTX460 kuva katoaa bootissa.
« Vastaus #1 : 07.05.16 - klo:10.01 »
Ajureita voi olla useampia koska jokainen kerneli tarvitsee oman ajurin. Nvidian ajuri pitää kääntää jokaista kerneliä vasten. Paketinhallinta hoitaa... Itsellä käytössä vielä vanhempi ajuri. En ole viitsinyt päivittää kun nykyinen toimii hyvin. X lokeista voit katsoa mikä mättää. Aina voi tehdä xorg.conf tiedoston (/etc/X11 kansion alle) missä ladataan nvidian ajuri. Nouveau ajuri on myös asennettu asennuksessa ja sitä käytetään oletuksena.

Näytönohjain on melko tarkka. Jos kortti on huonosti paikallaan kone ei käynnisty ja kuvaa ei tule. Itsellä nvidia 750ti nyt käytössä ja se ei tarvitse lisävirtaa. Sillä pärjää jos ei pelaile.

MarkoN

  • Käyttäjä
  • Viestejä: 555
    • Profiili
Vs: Nvidia GeForce GTX460 kuva katoaa bootissa.
« Vastaus #2 : 07.05.16 - klo:10.38 »
En pysty käyttämään vanhempaa ajuria koska pelit vaativat uusimman. Kokeilin eilen eikä pelit käynnistyneet.

En usko myöskään että kortti olisi huonosti kiinni koska kone kyllä käynnistyy ja yleensä kuva katoaa päivityksen jälkeen. Voi olla että palaan takaisin 14.04 LTS:sään koska on alkanut tulemaan aika paljon virheilmoituksia heti koneen käynnistyttyä enkä ole huomannut oikeastaan mitään uutta ja ihmeellistä Tässä 16.04 versiossa. Ainoa mitä olen huomannut on että joudun säätämään kaikkien ohjelmien kanssa...
« Viimeksi muokattu: 07.05.16 - klo:10.42 kirjoittanut MarkoN »
Ubuntu 16.04.1 LTS
Asus P8P67, i5-2500K 3,3GHz(->4,6GHz),
8Gt 1600MHz DDR3, Gigabyte GeForce GTX970 G1 Gaming

Ubuntu 16.04.1 LTS
ACER Aspire M3-581T, i3-2367M 1,4GHz, 4Gt 1333MHz

Ubuntu 14.04.5 LTS
Asus P5K, Q6600 3,0GHz, 8Gt 800MHz,
Gigabyte GTX780oc

kx

  • Käyttäjä
  • Viestejä: 680
    • Profiili
Vs: Nvidia GeForce GTX460 kuva katoaa bootissa.
« Vastaus #3 : 07.05.16 - klo:10.41 »
Minulla on Nvidia ajuri 352.63 ja näytönohjain GT 730. Muistaakseni kokeilin joskus jotain uudempaakin ajuria, muttei se kyllä toiminut. Tuo sammutusnapin valikko "tietoja laitteesta" näyttää käytössä olevan näytönohjaimen. Siitä kannattaa tarkastaa.
HP Compaq 6300 sff intel i3-3220 core 2  3,3,Hz RAM 12 Gb+Kingston 240Gt SSD+ nVidia Gt730+Ubuntu 22.04 lts + W10Pro64-bit ja Samsung ML-2165 sekä CanoScan Lide300

MarkoN

  • Käyttäjä
  • Viestejä: 555
    • Profiili
Vs: Nvidia GeForce GTX460 kuva katoaa bootissa.
« Vastaus #4 : 07.05.16 - klo:10.49 »
Muistelinkin että että 340 ja 361 suureiden välissä oli joku versio... Kokeilin eilen nimittäin 340 ajuria jolla pelit ei toimineet...
Eilen kun googlasin niin en löytänyt Linuxille tuota versiota nvidian sivuilta ainoastaan 304, 340, 361...
Eikä tuota versiota ole lisäajureissakaan... Mut kokeilen sitä silti...
Ubuntu 16.04.1 LTS
Asus P8P67, i5-2500K 3,3GHz(->4,6GHz),
8Gt 1600MHz DDR3, Gigabyte GeForce GTX970 G1 Gaming

Ubuntu 16.04.1 LTS
ACER Aspire M3-581T, i3-2367M 1,4GHz, 4Gt 1333MHz

Ubuntu 14.04.5 LTS
Asus P5K, Q6600 3,0GHz, 8Gt 800MHz,
Gigabyte GTX780oc

Postimies

  • Käyttäjä
  • Viestejä: 2589
    • Profiili
Vs: Nvidia GeForce GTX460 kuva katoaa bootissa.
« Vastaus #5 : 07.05.16 - klo:10.56 »
nvidia-settings kertoo myös ajurin ja paljon muutakin. Pelit ovat minulle vieraita. 14.04 on itsellä
vielä käytössä ubuntu koneella. Tässä ajurina 355.11 (ei ubuntu). Mikä ajuri on paras tietylle X,
kerneli, peli yhdistelmälle on vaikea. Itsellä jotain ongelmaa tuo uuden kanssa. Päätin, että kerneliä,
X:ää ja nvidian ajuria ei päivitetä vähään aikaan kun kerran toimii. Leffojen katselu kivampaa kuin
koneen kanssa taistelu. Kerneli on 3.18 sarjaa.

MarkoN

  • Käyttäjä
  • Viestejä: 555
    • Profiili
Vs: Nvidia GeForce GTX460 kuva katoaa bootissa.
« Vastaus #6 : 08.05.16 - klo:09.32 »
Voisi kai alkaa tutkimaan tätä... Jos joku viitsisi neuvoa.

Eli tänään kone ei käynnistynyt kuvan kanssa... powerboottasin ja kuva tuli mutta samalla ilmoitus että kuvaa ei voitu tunnistaa ja että haluanko yrittää default ajureilla. En kuitenkaan saanut valittua mitään vaihtoehtoa harmaasta laatikossa jossa oli muitakin vaihtoehtoja koska näppäimistö eikä hiiri toimineet...
Tein uudestaan powerbootin ja kone käynnistyi normaalisti.

Ubuntu versio: 16.04 LTS
Kerneli: 4.4.0-22-generic,
Nvidia ajuri: 361.42,
Näytönohjain: GeForce GTX 460/PCIe/SSE2
Emo: Asus P8P67
Ubuntu 16.04.1 LTS
Asus P8P67, i5-2500K 3,3GHz(->4,6GHz),
8Gt 1600MHz DDR3, Gigabyte GeForce GTX970 G1 Gaming

Ubuntu 16.04.1 LTS
ACER Aspire M3-581T, i3-2367M 1,4GHz, 4Gt 1333MHz

Ubuntu 14.04.5 LTS
Asus P5K, Q6600 3,0GHz, 8Gt 800MHz,
Gigabyte GTX780oc

Postimies

  • Käyttäjä
  • Viestejä: 2589
    • Profiili
Vs: Nvidia GeForce GTX460 kuva katoaa bootissa.
« Vastaus #7 : 08.05.16 - klo:11.19 »
Voit yrittää käynnistää koneen nomodeset parametrilla. Itselläni ei ole nyt
ubuntua nvidia koneella. /var/log kansion alta löydät X:n lokit. Voit katsoa
niistä mikä mättää. kernelin 4 versiolla ja nvidian 360 ajurilla on varmasti
paljon tehty muutoksia. Yhä enemmän ajureita tuntuu siirtyvän kerneliin.
Ennen kerneli ei osannut hallita ei grafiikkatiloja ja näyttää grafiikkaa
käynnistyksessä.

MarkoN

  • Käyttäjä
  • Viestejä: 555
    • Profiili
Vs: Nvidia GeForce GTX460 kuva katoaa bootissa.
« Vastaus #8 : 08.05.16 - klo:11.26 »
Ilmeisesti ainakin tällä hetkellä on ongelma Kernelin grafiikkatilassa koska kone käynnistyy mutta kuva tulee vasta työpöydällä.

Löysin tällaisen ohjeen tuohon
http://askubuntu.com/questions/162075/my-computer-boots-to-a-black-screen-what-options-do-i-have-to-fix-it

Ilmeisesti joudun siis käynnistämään koneen tuolla live-cd:llä ja tekemään jotain muutoksia tai sitten yritän bootata niin kauan että kuva tulee ja pääsisin Grub menuun...
Ubuntu 16.04.1 LTS
Asus P8P67, i5-2500K 3,3GHz(->4,6GHz),
8Gt 1600MHz DDR3, Gigabyte GeForce GTX970 G1 Gaming

Ubuntu 16.04.1 LTS
ACER Aspire M3-581T, i3-2367M 1,4GHz, 4Gt 1333MHz

Ubuntu 14.04.5 LTS
Asus P5K, Q6600 3,0GHz, 8Gt 800MHz,
Gigabyte GTX780oc

Postimies

  • Käyttäjä
  • Viestejä: 2589
    • Profiili
Vs: Nvidia GeForce GTX460 kuva katoaa bootissa.
« Vastaus #9 : 08.05.16 - klo:14.16 »
Grubin valikkoa pystyy editoimaan. Painaa vain 'e' näppäintä niin pääsee editoriin.
Jos työpöytä käynnistyy niin sittenhän on kaikki hyvin.

nm

  • Käyttäjä
  • Viestejä: 15242
    • Profiili
Vs: Nvidia GeForce GTX460 kuva katoaa bootissa.
« Vastaus #10 : 10.05.16 - klo:03.09 »
Miten näyttö on kytketty näytönohjaimeen? HDMI:llä vai DVI:llä? Oletko kokeillut toista porttia tai kytkentää?

MarkoN

  • Käyttäjä
  • Viestejä: 555
    • Profiili
Vs: Nvidia GeForce GTX460 kuva katoaa bootissa.
« Vastaus #11 : 13.05.16 - klo:13.50 »
Ei ole merkitystä onko kytketty DVI vai HDMI kaapelilla sama toistuu parin viikon välein... joskus menee jopa pitempään ilman ongelmia.

En ole löytänyt mitään erroreja... Äsken huomasin ettei nvidia löytänyt resoluutiota kun yritin pelata Switcher2:sta. Boottasin koneen ei kuvaa taaskaan tullut. jouduin käyttämään näytönohjaimen ja muistit irti. käynnistämään koneen ilman niitä. Sammutus ja romujen takaisin asennuksen jälkeen kuva tuli takaisin ja nvidia tunnisti näytön ja resoluution normaalisti ja Switcher2 käynnistyy...
Ubuntu 16.04.1 LTS
Asus P8P67, i5-2500K 3,3GHz(->4,6GHz),
8Gt 1600MHz DDR3, Gigabyte GeForce GTX970 G1 Gaming

Ubuntu 16.04.1 LTS
ACER Aspire M3-581T, i3-2367M 1,4GHz, 4Gt 1333MHz

Ubuntu 14.04.5 LTS
Asus P5K, Q6600 3,0GHz, 8Gt 800MHz,
Gigabyte GTX780oc

MarkoN

  • Käyttäjä
  • Viestejä: 555
    • Profiili
Vs: Nvidia GeForce GTX460 kuva katoaa bootissa.
« Vastaus #12 : 13.05.16 - klo:14.26 »
No niin nyt on taas hukassa resoluutio eikä nvidia tunnista näyttöä. Nyt jos olis jollain neuvo ennenkuin Boottaan ja irroitan taas romut ja kaikkihan sen jälkeen toimii moitteetomasti...
Ubuntu 16.04.1 LTS
Asus P8P67, i5-2500K 3,3GHz(->4,6GHz),
8Gt 1600MHz DDR3, Gigabyte GeForce GTX970 G1 Gaming

Ubuntu 16.04.1 LTS
ACER Aspire M3-581T, i3-2367M 1,4GHz, 4Gt 1333MHz

Ubuntu 14.04.5 LTS
Asus P5K, Q6600 3,0GHz, 8Gt 800MHz,
Gigabyte GTX780oc

nm

  • Käyttäjä
  • Viestejä: 15242
    • Profiili
Vs: Nvidia GeForce GTX460 kuva katoaa bootissa.
« Vastaus #13 : 13.05.16 - klo:18.01 »
Taitaa olla rautavika näytönohjaimessa.

MarkoN

  • Käyttäjä
  • Viestejä: 555
    • Profiili
Vs: Nvidia GeForce GTX460 kuva katoaa bootissa.
« Vastaus #14 : 13.05.16 - klo:18.47 »
No jos ei ihan vielä maalailla piruja seinille... Kokeiltais asennella vaikka toiset Nvidia ajurit kuin nuo 361.42...

Ongelma oli aikaisemmin etten tiedä mistä lähteestä ladata vanhemmat 352.XX ajurit?? tai jotkin muut jotka toimisi steamissa.
Ubuntu 16.04.1 LTS
Asus P8P67, i5-2500K 3,3GHz(->4,6GHz),
8Gt 1600MHz DDR3, Gigabyte GeForce GTX970 G1 Gaming

Ubuntu 16.04.1 LTS
ACER Aspire M3-581T, i3-2367M 1,4GHz, 4Gt 1333MHz

Ubuntu 14.04.5 LTS
Asus P5K, Q6600 3,0GHz, 8Gt 800MHz,
Gigabyte GTX780oc

nm

  • Käyttäjä
  • Viestejä: 15242
    • Profiili
Vs: Nvidia GeForce GTX460 kuva katoaa bootissa.
« Vastaus #15 : 14.05.16 - klo:14.28 »
No jos ei ihan vielä maalailla piruja seinille... Kokeiltais asennella vaikka toiset Nvidia ajurit kuin nuo 361.42...

Ongelma oli aikaisemmin etten tiedä mistä lähteestä ladata vanhemmat 352.XX ajurit?? tai jotkin muut jotka toimisi steamissa.

16.04:ään sen saa Graphics Drivers -PPA:sta.

Koodia: [Valitse]
sudo apt-add-repository ppa:graphics-drivers/ppa
sudo apt-get update

Tuon jälkeen pitäisi näkyä lisäajureissa.

Jos sama vika on kuitenkin ilmennyt sekä 361-ajurilla että 14.04:ssä jollain vanhemmalla ajurilla (tai juuri 352:lla), on erittäin todennäköistä, että se esiintyy myös 16.04:ssä tällä 352-ajurilla.

Toimiiko GTX 285 nyt ongelmitta siinä vanhemmassa koneessa, jossa GTX 460 oireili?
« Viimeksi muokattu: 14.05.16 - klo:14.33 kirjoittanut nm »

MarkoN

  • Käyttäjä
  • Viestejä: 555
    • Profiili
Vs: Nvidia GeForce GTX460 kuva katoaa bootissa.
« Vastaus #16 : 14.05.16 - klo:14.56 »
Joo. Jotain taisi olla pielessä tuossa 16.04 asennuksessa tai jossakin. Asensin koko ubuntun uudelleen ja hain 340.96 ajurin... Tällä ainakin WarThunder ja Switcher2 toimii moitteetta mitä olen ehtinyt testata.
Nyt tuntuisi toimivan ihan oikein, tai siis ainakaan vielä ei ole tarvinnut boottailla eikä irroitella osia.
Ubuntu 16.04.1 LTS
Asus P8P67, i5-2500K 3,3GHz(->4,6GHz),
8Gt 1600MHz DDR3, Gigabyte GeForce GTX970 G1 Gaming

Ubuntu 16.04.1 LTS
ACER Aspire M3-581T, i3-2367M 1,4GHz, 4Gt 1333MHz

Ubuntu 14.04.5 LTS
Asus P5K, Q6600 3,0GHz, 8Gt 800MHz,
Gigabyte GTX780oc

MarkoN

  • Käyttäjä
  • Viestejä: 555
    • Profiili
Vs: Nvidia GeForce GTX460 kuva katoaa bootissa.
« Vastaus #17 : 18.05.16 - klo:19.03 »
No niin...
Kaikki pelasi hyvin kunnes erehdyin eilen illalla klikkaamaan koneen Valmiustilaan... No tuostapa ei kone tykännyt eikä kuvaa aamulla tullut sitten kirveelläkään. Rojut irti ja käynnistys ilman näytönohjainta ja muisteja.
Kuva palasi vähäksi aikaa. Seuraavassa bootissa ei taaskaan kuvaa. Sama siis toistui. Rojut irti ja käynnistys... Ubuntun uudelleen asennus. Onneksi en paljon asennellut mitään. Ainoastaan Google-Chrome, Thunderbird, Dropbox, Mega uploads, Steam+5peliä... Noi asentaa muutamassa minuutissa aina takaisin kun tätä saa säätää.

Mut nyt taas vörkkii niin pitkään kunnes klikkaan vahingossa valmiustilaan... Joskus aikaisemminkin olen tuon virheen tehnyt.

Mikähän siinä oikein on vidurallaan et tuo valmiustila homma ei oikein toimi.
Ubuntu 16.04.1 LTS
Asus P8P67, i5-2500K 3,3GHz(->4,6GHz),
8Gt 1600MHz DDR3, Gigabyte GeForce GTX970 G1 Gaming

Ubuntu 16.04.1 LTS
ACER Aspire M3-581T, i3-2367M 1,4GHz, 4Gt 1333MHz

Ubuntu 14.04.5 LTS
Asus P5K, Q6600 3,0GHz, 8Gt 800MHz,
Gigabyte GTX780oc

nm

  • Käyttäjä
  • Viestejä: 15242
    • Profiili
Vs: Nvidia GeForce GTX460 kuva katoaa bootissa.
« Vastaus #18 : 19.05.16 - klo:00.22 »
Kyllä tuo vahvasti vaikuttaa siltä, että näytönohjaimessa (tai sen vbiosissa) on jotain vikaa tai yhteensopivuusongelmaa ajurien kanssa.

Toimiiko GTX 285 nyt ongelmitta koneessa, jossa GTX 460 aiemmin temppuili?
« Viimeksi muokattu: 19.05.16 - klo:00.24 kirjoittanut nm »

MarkoN

  • Käyttäjä
  • Viestejä: 555
    • Profiili
Vs: Nvidia GeForce GTX460 kuva katoaa bootissa.
« Vastaus #19 : 19.05.16 - klo:05.36 »
Toimiiko GTX 285 nyt ongelmitta koneessa, jossa GTX 460 aiemmin temppuili?

Tuohon vähän hankala sanoa mitään... Kone vähäisellä käytöllä eikä sillä pelata enää mitään. Ja kone aina sammutetaan käytön jälkeen, eli ei käytetä valmiustilaa.

Mutta että kellään muulla ei tällaisia ongelmia esiinny kuin minulla??


Tuli näin työpäivän jälkeen mieleen että kyllä tuossa GTX 285 koneessa jotain ongelmaa aina oli enkä saanut sitä korjattua. Eli kone kun käynnistyi työpöydälle ei hiirtä näkynyt kuvaruudulla. sen aisti liikkuvan kyllä työpöydällä mut ei sillä pystynyt klikkaamaan mitään. Hetken odottelun jälkeen kuva räpsähti ja hiiri tuli näkyviin.

Toinen ongelma ilmeni sammutettaessa. Kone jumiutui mustaan ruutuun josta se ei omin avuin sammunut vaan piti painaa virtapainikkeesta pois päältä.
« Viimeksi muokattu: 19.05.16 - klo:18.43 kirjoittanut MarkoN »
Ubuntu 16.04.1 LTS
Asus P8P67, i5-2500K 3,3GHz(->4,6GHz),
8Gt 1600MHz DDR3, Gigabyte GeForce GTX970 G1 Gaming

Ubuntu 16.04.1 LTS
ACER Aspire M3-581T, i3-2367M 1,4GHz, 4Gt 1333MHz

Ubuntu 14.04.5 LTS
Asus P5K, Q6600 3,0GHz, 8Gt 800MHz,
Gigabyte GTX780oc