Kirjoittaja Aihe: Steam asennusongelma  (Luettu 18857 kertaa)

sepi666

  • Käyttäjä
  • Viestejä: 152
    • Profiili
Steam asennusongelma
« : 06.11.15 - klo:15.36 »
Mistäköhän alkais ratkomaan ongelmaa, koneessa uusi asennus 14.04 lts. ja steam ainut ensimmäinen sovellus

Koodia: [Valitse]
Steam needs to install these additional packages:
libgl1-mesa-dri:i386, libgl1-mesa-glx:i386, libc6:i386
[sudo] password for piia-pingviini:
...
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
Joitakin paketteja ei voitu asentaa. On ehkä vaadittu mahdottomia tai,
jos käytetään epävakaata jakelua, joitain vaadittuja paketteja ei ole
vielä luotu tai siirretty Incoming-kansiosta.
Seuraavista tiedoista voi olla hyötyä selvitettäessä tilannetta:

Näillä paketeilla on tyydyttämättömiä riippuvuuksia:
 libgl1-mesa-glx:i386 : Riippuvuudet: libglapi-mesa:i386 (= 10.1.3-0ubuntu0.5)
 unity-control-center : Riippuvuudet: libcheese-gtk23 (>= 3.4.0) mutta ei ole merkitty asennettavaksi
                        Riippuvuudet: libcheese7 (>= 3.0.1) mutta ei ole merkitty asennettavaksi
E: Virhe, pkgProblemResolver::Resolve tuotti katkoja, syynä voi olla pysytetyt paketit.
Press return to continue:


ja kun enter niin:
You are missing the following 32-bit libraries, and Steam may not run:
libc.so.6

mrl586

  • Käyttäjä
  • Viestejä: 4638
    • Profiili
Vs: Steam asennusongelma
« Vastaus #1 : 06.11.15 - klo:15.44 »
Koodia: [Valitse]
sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install libc6:i386

MarkoN

  • Käyttäjä
  • Viestejä: 562
    • Profiili
Vs: Steam asennusongelma
« Vastaus #2 : 11.12.15 - klo:12.50 »
Mulla sama ongelma. Ei poistunut noilla käskyillä...

Ilmoittaa edelleen.

Koodia: [Valitse]
Steam needs to install these additional packages:
libgl1-mesa-dri:i386, libgl1-mesa-glx:i386
[sudo] password for marko:
...
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
Joitakin paketteja ei voitu asentaa. On ehkä vaadittu mahdottomia tai,
jos käytetään epävakaata jakelua, joitain vaadittuja paketteja ei ole
vielä luotu tai siirretty Incoming-kansiosta.
Seuraavista tiedoista voi olla hyötyä selvitettäessä tilannetta:

Näillä paketeilla on tyydyttämättömiä riippuvuuksia:
 libgl1-mesa-glx:i386 : Riippuvuudet: libglapi-mesa:i386 (= 10.1.3-0ubuntu0.5)
 unity-control-center : Riippuvuudet: libcheese-gtk23 (>= 3.4.0) mutta ei ole merkitty asennettavaksi
                        Riippuvuudet: libcheese7 (>= 3.0.1) mutta ei ole merkitty asennettavaksi
E: Virhe, pkgProblemResolver::Resolve tuotti katkoja, syynä voi olla pysytetyt paketit.
Press return to continue:
Windows 10 PRO
Asus P8Z77-V, i7-3770K 3,5GHz(->4,2GHz),
16Gt 2400MHz DDR3, Asus GeForce GTX 1070
Acer Aspire One, ATOM N270 1,6GHz, 1,5Gt DDR2

Ubuntu 20.04.6 LTS
Asus P8P67, i5-2500K 3,3GHz(->4,6GHz),
8Gt 1600MHz DDR3, Gigabyte GeForce GTX970 G1 Gaming

nm

  • Käyttäjä
  • Viestejä: 16306
    • Profiili
Vs: Steam asennusongelma
« Vastaus #3 : 11.12.15 - klo:13.30 »
Tarvitsette oikeat versiot 32-bittisistä libgl1-mesa-dri ja libglapi-mesa -kirjastoista. Selvittäkää ensin, mikä versio Ubuntusta on käytössä: 14.04.2 vai 14.04.3.

Tarkista kernelin versio:

Koodia: [Valitse]
uname -r
Jos kerneli on 3.16-sarjaa, käytössä on Ubuntu 14.04.2. Jos taas kerneli on 3.19-sarjaa, käytössä on Ubuntu 14.04.3.


Vaadittujen kirjastojen asennus 14.04.2:een:

Koodia: [Valitse]
sudo apt-get install libgl1-mesa-glx-lts-utopic libgl1-mesa-glx-lts-utopic:i386 libglapi-mesa-lts-utopic:i386

Asennus 14.04.3:een:

Koodia: [Valitse]
sudo apt-get install libgl1-mesa-glx-lts-vivid libgl1-mesa-glx-lts-vivid:i386 libglapi-mesa-lts-vivid:i386

MarkoN

  • Käyttäjä
  • Viestejä: 562
    • Profiili
Vs: Steam asennusongelma
« Vastaus #4 : 11.12.15 - klo:13.32 »
Ubuntu 14.04.3 LTS
Kernel 3.19.0-25-generic


EDIT: kiitos paljon... nyt toimii!
« Viimeksi muokattu: 11.12.15 - klo:13.35 kirjoittanut MarkoN »
Windows 10 PRO
Asus P8Z77-V, i7-3770K 3,5GHz(->4,2GHz),
16Gt 2400MHz DDR3, Asus GeForce GTX 1070
Acer Aspire One, ATOM N270 1,6GHz, 1,5Gt DDR2

Ubuntu 20.04.6 LTS
Asus P8P67, i5-2500K 3,3GHz(->4,6GHz),
8Gt 1600MHz DDR3, Gigabyte GeForce GTX970 G1 Gaming

Jyrki L

  • Käyttäjä
  • Viestejä: 501
    • Profiili
Vs: Steam asennusongelma
« Vastaus #5 : 30.12.15 - klo:23.01 »
Törmäsin samaan ongelmaan ja kokeilin myös tuota ratkaisua.

korjauksen jälkeen ilmoittaa:

Nyt ilmoittaa:
Koodia: [Valitse]
jyrki@jyrki-G73Sw:~$ steam
Running Steam on ubuntu 14.04 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0_client)
libGL error: unable to load driver: nouveau_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: nouveau
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
« Viimeksi muokattu: 31.12.15 - klo:12.26 kirjoittanut Storck »

nm

  • Käyttäjä
  • Viestejä: 16306
    • Profiili
Vs: Steam asennusongelma
« Vastaus #6 : 31.12.15 - klo:02.39 »
Törmäsin samaan ongelmaan ja kokeilin myös tuota ratkaisua.

korjauksen jälkeen ilmoittaa:

Nyt ilmoittaa:
jyrki@jyrki-G73Sw:~$ steam
Running Steam on ubuntu 14.04 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0_client)
libGL error: unable to load driver: nouveau_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: nouveau
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

Olisikohan tästä apua: http://askubuntu.com/questions/635851/error-in-installing-steam-on-ubuntu-15-04/648953#648953

Eli kokeile käynnistää Steam komennolla:

Koodia: [Valitse]
LD_PRELOAD='/usr/$LIB/libstdc++.so.6' DISPLAY=:0 steam

deebee

  • Käyttäjä
  • Viestejä: 2
    • Profiili
Vs: Steam asennusongelma
« Vastaus #7 : 22.02.16 - klo:15.11 »
Terve kaikille,

Wintoosia on ollut 95, 98, 2000, xp, vista ja sittemin 7.
Tänään päädyin asentamaan elämäni ensimmäisen ubuntun, joka on tuo 14.04.4 64-bit.

Asennus meni hienosti, ei mitään ongelmia. Nyt kun koitan asentaa ohjelmia, niin alkaa näitä ongelmia tulemaan. Steam ei asennu ollenkaan.
Se sanoo:
Koodia: [Valitse]
" Steam needs to install these additional packages:
libgl1-mesa-dri:i386, libgl1-mesa-glx:i386, libc6:i386
[sudo] password for pekka:
...............................................................................................
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
Joitakin paketteja ei voitu asentaa. On ehkä vaadittu mahdottomia tai,
jos käytetään epävakaata jakelua, joitain vaadittuja paketteja ei ole
vielä luotu tai siirretty Incoming-kansiosta.
Seuraavista tiedoista voi olla hyötyä selvitettäessä tilannetta:

Näillä paketeilla on tyydyttämättömiä riippuvuuksia:
 libgl1-mesa-glx:i386 : Riippuvuudet: libglapi-mesa:i386 (= 10.1.3-0ubuntu0.6)
 unity-control-center : Riippuvuudet: libcheese-gtk23 (>= 3.4.0) mutta ei ole merkitty asennettavaksi
                        Riippuvuudet: libcheese7 (>= 3.0.1) mutta ei ole merkitty asennettavaksi
E: Virhe, pkgProblemResolver::Resolve tuotti katkoja, syynä voi olla pysytetyt paketit.
Press return to continue:
"

No minä otin googlen kauniiseen käteen ja löysin kohtalaisen nopeasti apuun erilaisia sudo-komentoja.
Enemmän aikaa meni löytää terminaali alt+f2 takaa.

Mutta edelleenkään steam ei käynnisty, näyttiksen ajurit pitäisi saada asennettua.
Jostain varmaan näkee järjestelmän tiedot jne. että on löytänyt muistit jne. oikein.

Jotenkin vain tämä foorumi tuntuu hitaalta tähän kaikkeen.


Meinasin just ehdoittaa teamspeakkiä, jos joku auttaa. Mutta eihän mulla ole sellaistakaan......


Kaikki päätteeseen laitettavat ja päätteestä kopiotavat jutut kannattaa laittaa "koodien" sisään, löytyy ylhäältä #-merkin takaa. Kaikkia foorumin hienouksia voi harjoitella mielin määrin Testaus-alueella
Laitoin tulosteet koodeihin puolestasi.  -Storck
« Viimeksi muokattu: 22.02.16 - klo:19.50 kirjoittanut Storck »

deebee

  • Käyttäjä
  • Viestejä: 2
    • Profiili
Vs: Steam asennusongelma
« Vastaus #8 : 22.02.16 - klo:15.17 »
Johan alkoi tapahtuun, kun löysi ctrl+alt+t näppäin yhdistelmän.

Mikä tuo alt+f2 avautuva on, missä koitin noita komentoja käyttää ? :)

nm

  • Käyttäjä
  • Viestejä: 16306
    • Profiili
Vs: Steam asennusongelma
« Vastaus #9 : 22.02.16 - klo:15.53 »
Asennus meni hienosti, ei mitään ongelmia. Nyt kun koitan asentaa ohjelmia, niin alkaa näitä ongelmia tulemaan. Steam ei asennu ollenkaan.
Se sanoo:
" Steam needs to install these additional packages:
   libgl1-mesa-dri:i386, libgl1-mesa-glx:i386, libc6:i386

Kyseistä ongelmaa on käsitelty aiemminkin tällä foorumilla: http://forum.ubuntu-fi.org/index.php?topic=49653.msg381813#msg381813

Ubuntu 14.04.4:n tapauksessa asennuskomento on:

Koodia: [Valitse]
sudo apt-get install libgl1-mesa-glx-lts-wily libgl1-mesa-glx-lts-wily:i386 libglapi-mesa-lts-wily:i386

Mikä tuo alt+f2 avautuva on, missä koitin noita komentoja käyttää ? :)

Se on pikakehote (graafisten) ohjelmien käynnistämiseen komennolla.

Postimies

  • Käyttäjä
  • Viestejä: 2629
    • Profiili
Vs: Steam asennusongelma
« Vastaus #10 : 25.02.16 - klo:21.42 »
Johan alkoi tapahtuun, kun löysi ctrl+alt+t näppäin yhdistelmän.

Mikä tuo alt+f2 avautuva on, missä koitin noita komentoja käyttää ? :)
Vastine Windows maailmassa on ikkuna- eli win-näppäin + r. Tuota haeskelin kun olin pitkästä aikaa Win koneella.
Tärkeimmät kannattaa Ubuntussakin opetella - moni näppäin määritelty valmiiksi.
Mikä näytönohjain käytössä? Ainakin Nvidialle kannattaa ajurit asentaa.

Storck

  • Käyttäjä
  • Viestejä: 90
    • Profiili
Vs: Steam asennusongelma
« Vastaus #11 : 25.02.16 - klo:22.02 »
Aiheet yhdistetty ja kaikkien otsikko muutettu koska jälkimmäinen ei kertonut yhtään mitään.
Kiitos ja anteeksi