Kirjoittaja Aihe: CMStorm led-taustavalaistun näppäimistön valot toimimaan Ubuntussa  (Luettu 20743 kertaa)

petritol

  • Käyttäjä
  • Viestejä: 50
    • Profiili
OPAS näppäimistön taustavalaisun kytkemiseksi Ubuntussa, toimii ainakin Cooler Masterin CmStorm-näppäimistöllä

Ledit saa päälle tai pois päätteessä (CTRL + ALT + T) kirjoittamalla:
Koodia: [Valitse]
xset led on tai
Koodia: [Valitse]
xset led off
Ne voit saada kuitenkin toimimaan myös näppikseltä seuraavasti, luomalla käynnistyvän tiedoston keyboard-led.sh:
Koodia: [Valitse]
cd /usr/local/bin
sudo -i gedit keyboard-led.sh

Leikkaa jaa liitä:
Koodia: [Valitse]
#!/bin/bash
FLAGS=$(xset -q | awk 'NR==2' | awk '{ print $10 }')

printf "$FLAGS""\n"
xset led on

FLAGS=$(xset -q | awk 'NR==2' | awk '{ print $10 }')

printf "$FLAGS""\n"

Tallenna ja poistu.
Tee keyboard-led.sh:sta käynnistyvä:
Koodia: [Valitse]
sudo chmod u+x /usr/local/bin/keyboard-led.sh
Testaa toiminta käskyllä:
Koodia: [Valitse]
sudo /usr/local/bin/keyboard-led.shKomennon perään saat pari koodia, tyyliin:
00000000
ffffe7fc   <-----Jos eroaa tästä, ota tämä ylös ja syötä se seuraavassa kohdassa if-lausekkeen perään ennen hakasulkuja.

Jotta valot myös sammuisi, avaa tiedosto uudelleen:
Koodia: [Valitse]

sudo -i gedit /usr/local/bin/keyboard-led.sh
Ja korvaa sisältö tällä (huomioi äskeinen koodi):
Koodia: [Valitse]
#!/bin/bash
FLAGS=$(xset -q | awk 'NR==2' | awk '{ print $10 }')
if [ "$FLAGS" = ffffe7fc ]; then
    xset led off
else
    xset led on
fi


Testaa toiminta käskyllä:
Koodia: [Valitse]
sudo /usr/local/bin/keyboard-led.sh
Tämän jälkeen avaa "Järjestelmäasetukset" -> "näppäimistö" -> "pikanäppäimet"
Valitse omat pikanäppäimet ja paina plussaa luodaksesi uuden.
Nimeksi voit antaa, mitä haluat, mutta komennoksi anna:
Koodia: [Valitse]
bash /usr/local/bin/keyboard-led.shPaina "toteuta".
Klikkaa rivin oikeaa reunaa ja tämän jälkeen paina haluttua pikanäppäintä, todennäköisesti SCR LK.

Voilà!


Ohje suomennettu ja täsmennetty täältä: http://blog.rumyhub.com/post/2015/01/31/ubuntu-fixing-cm-storm-devastator-keyboard-backlight-button.aspx




« Viimeksi muokattu: 05.10.15 - klo:20.30 kirjoittanut petritol »
Juudan Leijona karjuu ja ärisee!

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 10624
    • Profiili
    • Tomin kotisivut
Hyvä ohje, mutta muuttaisin pari kohtaa. Ymmärrän kyllä, että ne olivat noin alkuperäisessä lähteessä.

Suosittelen, että muutat nuo kaikki polut vähän fiksummiksi. Sopiva tallennuspaikka tuolle skriptille voisi olla vaikka /usr/local/bin. Siispä kun komennat
Koodia: [Valitse]
cd /komentaisitkin
Koodia: [Valitse]
cd /usr/local/binja vastaavasti (tässä korjattu sudo pois, koska sitä ei tarvita)
Koodia: [Valitse]
sudo /keyboard-led.sholisi
Koodia: [Valitse]
/usr/local/bin/keyboard-led.shNoiden kohtien lisäksi ainakin tuo viimeinen komento on muutettava. Toisaalta tässä ei tarvitsisi koko cd:tä hakemistosta toiseen siirtymiseen, kun tekstieditorille voi antaa tiedoston polkuineen eli:
Koodia: [Valitse]
sudo gedit /usr/local/bin/keyboard-led.shJa vastaava myös chmod-komennon kanssa. Lisäksi voisi kinastella siitä pitäisikö gedit:lle (graafinen ohjelma) sudo:n sijasta käyttää gksudo:a, mutta sillä ei onneksi taida enää nykyään olla väliä.

Lisäksi tuota skriptiä ei tarvitse ajaa root-oikeuksin eli jätä sudo pois, kun ajat sen.
« Viimeksi muokattu: 01.10.15 - klo:16.04 kirjoittanut Tomin »
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

petritol

  • Käyttäjä
  • Viestejä: 50
    • Profiili
Kiitos ja kiitos korjausehdotuksista, huomioin ne. Tuon sudon ainakin miulla jostain syystä tarvitsi. Huomasin myös puuttuvan kohdan, tuo koodi voi vaihdella, kun kävin kohta kohdalta vielä läpi.
Juudan Leijona karjuu ja ärisee!

nm

  • Käyttäjä
  • Viestejä: 12897
    • Profiili
Lisäksi voisi kinastella siitä pitäisikö gedit:lle (graafinen ohjelma) sudo:n sijasta käyttää gksudo:a, mutta sillä ei onneksi taida enää nykyään olla väliä.

On siinä edelleen samat vaarat, eli kun sudolla ajettava ohjelma kirjoittaa asetustiedostoja käyttäjän kotihakemistoon, tiedostojen omistajaksi asetetaan pääkäyttäjä. Tämä johtuu siitä, että sudoa käytettäessä ohjelma ajetaan pääkäyttäjänä, mutta kotihakemisto ($HOME) ja muut ympäristömuuttujat ovat edelleen alkuperäisen käyttäjän säädöissä. Tällöin asetustiedostojen omistajaksi tulee root, vaikka ne sijaitsevat käyttäjän kotihakemistossa. Seuraavalla käyttökerralla Gedit, muut ohjelmat tai pahimmassa tapauksessa koko työpöytäjärjestelmä ei enää pysty kirjoittamaan asetuksia talteen puuttuvien oikeuksien vuoksi. Muita mahdollisia haittavaikutuksia on ohjelmien kaatuilu ja erinäiset vaikeasti diagnosoitavat bugit työpöytäjärjestelmän toiminnassa.

Tässä kuvaus eräästä tällaisesta tapauksesta viime keväältä: http://ubuntuforums.org/showthread.php?t=2269093


Käyttäkää siis graafisia ohjelmia ajaessanne sudon parametria -i, joka vaihtaa ajoympäristöön pääkäyttäjän asetukset (HOME=/root jne) tai parametria -H, joka vaihtaa vain kotihakemiston. Eli tähän tapaan:

Koodia: [Valitse]
sudo -i gedit tiedosto.txt

Toinen yleisesti suositeltu vaihtoehto on pkexec, mutta se edellyttää ohjelmakohtaista lisäkonfigurointia: http://www.webupd8.org/2015/03/how-to-run-gedit-and-nautilus-as-root.html
« Viimeksi muokattu: 01.10.15 - klo:18.36 kirjoittanut nm »

petritol

  • Käyttäjä
  • Viestejä: 50
    • Profiili

Käyttäkää siis graafisia ohjelmia ajaessanne sudon parametria -i, joka vaihtaa ajoympäristöön pääkäyttäjän asetukset (HOME=/root jne) tai parametria -H, joka vaihtaa vain kotihakemiston. Eli tähän tapaan:



Lisätty -i.
Juudan Leijona karjuu ja ärisee!

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 10624
    • Profiili
    • Tomin kotisivut
Kiitos ja kiitos korjausehdotuksista, huomioin ne. Tuon sudon ainakin miulla jostain syystä tarvitsi. Huomasin myös puuttuvan kohdan, tuo koodi voi vaihdella, kun kävin kohta kohdalta vielä läpi.

No ainakaan viimeisessä kohdassa sitä ei mitenkään ajeta root-oikeuksin eli tuossa vaiheessa, kun se laitetaan pikanäppäimeksi se ei voi käyttää root-oikeuksia. En myöskään äkkiseltään keksi, miksi tuo voisi tarvita root-oikeuksia.
http://www.linux.fi/wiki/Root
http://www.linux.fi/wiki/Sudo
(Jälkimmäiseen voisi muuten päivittää huomautuksen tuon -i -vivun käytöstä ja yleensäkin siitä, miksi ei kannata käyttää sudoa graafisille ohjelmille)

Lisäksi voisi kinastella siitä pitäisikö gedit:lle (graafinen ohjelma) sudo:n sijasta käyttää gksudo:a, mutta sillä ei onneksi taida enää nykyään olla väliä.

On siinä edelleen samat vaarat, eli kun sudolla ajettava ohjelma kirjoittaa asetustiedostoja käyttäjän kotihakemistoon, tiedostojen omistajaksi asetetaan pääkäyttäjä.

Eli tilanne ei ole muuttunut mihinkään, mutta ihmiset ovat vain unohtaneet. Ihan aina en jaksa edes muistuttaa tuosta. Ehkä pitäisi itsekin ehdottaa aina tuota -i -vipua gksudon ja kumppaneiden sijasta.
« Viimeksi muokattu: 01.10.15 - klo:19.41 kirjoittanut Tomin »
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

petritol

  • Käyttäjä
  • Viestejä: 50
    • Profiili


No ainakaan viimeisessä kohdassa sitä ei mitenkään ajeta root-oikeuksin eli tuossa vaiheessa, kun se laitetaan pikanäppäimeksi se ei voi käyttää root-oikeuksia. En myöskään äkkiseltään keksi, miksi tuo voisi tarvita root-oikeuksia.


Tottahan tuo on. Jostain syystä ainakin itselläni jostain syystä antoi kuitenkin virheilmoituksen ilman tuota sudoa edessä, joten jätin sen oppaaseen. Löytyy myös tuosta eng-versiosta. Nyt opas on tallennettuna Wikin sivuille. Olihan tuossa vähän opettelemista, mutta kai se on noin ok...  http://wiki.ubuntu-fi.org/CmStorm_nappaimiston_taustaledit_toimimaan

Iso kiitos korjauksista!
Juudan Leijona karjuu ja ärisee!

petritol

  • Käyttäjä
  • Viestejä: 50
    • Profiili
Olen huomannut, että taustaledien käyttö hävittää numeronäppäimistön pelistä pois, vaikka NUMlock-valo palaisi. Samoin ledien sammutus ei läheskään joka kerta toimi. Mistähän voisi johtua?
Juudan Leijona karjuu ja ärisee!

nm

  • Käyttäjä
  • Viestejä: 12897
    • Profiili
Olen huomannut, että taustaledien käyttö hävittää numeronäppäimistön pelistä pois, vaikka NUMlock-valo palaisi. Samoin ledien sammutus ei läheskään joka kerta toimi. Mistähän voisi johtua?

Voit tarkistaa indikaattoriledien tilat komennolla:

Koodia: [Valitse]
xset q
Omassa koneessani saan tällaisen listan, kun ledit ovat pois päältä:
Koodia: [Valitse]
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000000
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    off    02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off

Jos kytken ledit päälle komennolla xset led on, kaikki muut ledit paitsi Caps Lock, Num Lock, Shift Lock ja Group2 kytkeytyvät päälle:

Koodia: [Valitse]
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  ffffe7fc
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    off    02: Scroll Lock: on
    03: Compose:     on     04: Kana:        on     05: Sleep:       on
    06: Suspend:     on     07: Mute:        on     08: Misc:        on
    09: Mail:        on     10: Charging:    on     11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  on

Tuossa siis vaihtaa tilaa aika moni ledi, ja ehkä näppäimistössäsi joku niistä vaikuttaa Num Lockiin. Ei välttämättä pitäisi vaikuttaa, mutta näppäimistössä voi olla tällainen ominaisuus.

Taustavalo on todennäköisesti kytköksissä vain yhteen xsetin ohjaamaan indikaattorilediin. Etsi oikea ledikytkin kokeilemalla, niin ei tarvitse läimiä kaikkia päälle ja pois. Silloin Num Lock saattaisi pysyä oikeassa asennossa.

Eli esimerkiksi indikaattoriledin "8: Misc" voi kytkeä erikseen päälle komennolla:

Koodia: [Valitse]
xset led named "Misc"
Ja sen saa pois päältä komennolla:

Koodia: [Valitse]
xset -led named "Misc"(Huomaa viiva led-parametrin edessä: se kytkee ledin pois päältä)

Kokeile samalla tavalla nuo kaikki läpi, kunnes löydät oikean kytkimen.
« Viimeksi muokattu: 09.10.15 - klo:18.51 kirjoittanut nm »

petritol

  • Käyttäjä
  • Viestejä: 50
    • Profiili
Kiitos vastauksesta. Kyllä tuolla molemmilla kerroilla on Num Lockin kohdalla on-asento. Huomasin, ettei numpadi toimi ollenkaan Ubuntussa, riippumatta siitä olenko valoja näppikseen kytkenyt. Windowsissa toimii ongelmitta.
Juudan Leijona karjuu ja ärisee!

nm

  • Käyttäjä
  • Viestejä: 12897
    • Profiili
Huomasin, ettei numpadi toimi ollenkaan Ubuntussa, riippumatta siitä olenko valoja näppikseen kytkenyt. Windowsissa toimii ongelmitta.

Auttaisiko tämä: http://unix.stackexchange.com/a/206606

Koodia: [Valitse]
setxkbmap -option keypad:pointerkeys

petritol

  • Käyttäjä
  • Viestejä: 50
    • Profiili
KIITOS taas erittäin paljon nm! Juuri tuo koodi ei toiminut, mutta linkkaamasi sivun seuraava SHIFT + NUMLK toimi!
Juudan Leijona karjuu ja ärisee!

petritol

  • Käyttäjä
  • Viestejä: 50
    • Profiili
Mut toimii näköjään vaan, kun valot on pois päältä. Jos valot laittaa näppikseen, ei numpadin käyttö onnistu.
Juudan Leijona karjuu ja ärisee!

nm

  • Käyttäjä
  • Viestejä: 12897
    • Profiili
Mut toimii näköjään vaan, kun valot on pois päältä. Jos valot laittaa näppikseen, ei numpadin käyttö onnistu.

Kannattaisi etsiä se yksi indikaattorivalitsin, joka ohjaa taustavaloja ja kytkeä valot päälle vain sen avulla. Scroll lock -indikaattori lienee yleisesti käytetty tähän, eli kokeile näin:

Koodia: [Valitse]
xset led 3
tai

Koodia: [Valitse]
xset led named "Scroll Lock"
ja pois päältä:

Koodia: [Valitse]
xset -led 3
« Viimeksi muokattu: 15.10.15 - klo:12.48 kirjoittanut nm »