Kirjoittaja Aihe: wi-fi -verkot ei näy [RATKAISTU]  (Luettu 4409 kertaa)

zarmo

  • Käyttäjä
  • Viestejä: 51
    • Profiili
wi-fi -verkot ei näy [RATKAISTU]
« : 12.09.15 - klo:15.11 »
Hei,
ostin uuden läppärin mallia Asus X554L ja asensin siihen Ubuntu 14.04:n. Ongelma on, että en saa wi-fiä näkymään. Vanhalla koneella (monta vuotta vanha Asus-läppäri) on sama käyttis ja wi-fi toimii hyvin. Uudessa koneessa ei näy tuota yläreunan nettikuvaketta painamalla edes tuota "ota wi-fi käyttöön" -kohtaa, että siihen saisi laittaa täpän.

Mikä avuksi?

edit: Windoussilla wi-fi toimii myös uudessa koneessa
« Viimeksi muokattu: 02.10.15 - klo:20.08 kirjoittanut zarmo »
Asus X554L (i5, 8G, ssd)
Ubuntu 16.04 LTS

mrl586

  • Käyttäjä
  • Viestejä: 4637
    • Profiili
Vs: wi-fi -verkot ei näy
« Vastaus #1 : 12.09.15 - klo:16.01 »
Millainen wlan-piiri koneessa on? Mitä komento lspci sanoo?

zarmo

  • Käyttäjä
  • Viestejä: 51
    • Profiili
Vs: wi-fi -verkot ei näy
« Vastaus #2 : 12.09.15 - klo:18.14 »
Koodia: [Valitse]
jarkko@jarkko-X555LAB:~$ lspci
00:00.0 Host bridge: Intel Corporation Broadwell-U Host Bridge -OPI (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)
00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09)
00:04.0 Signal processing controller: Intel Corporation Broadwell-U Camarillo Device (rev 09)
00:14.0 USB controller: Intel Corporation Wildcat Point-LP USB xHCI Controller (rev 03)
00:16.0 Communication controller: Intel Corporation Wildcat Point-LP MEI Controller #1 (rev 03)
00:1b.0 Audio device: Intel Corporation Wildcat Point-LP High Definition Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #1 (rev e3)
00:1c.2 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #3 (rev e3)
00:1c.3 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #4 (rev e3)
00:1f.0 ISA bridge: Intel Corporation Wildcat Point-LP LPC Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation Wildcat Point-LP SATA Controller [AHCI Mode] (rev 03)
00:1f.3 SMBus: Intel Corporation Wildcat Point-LP SMBus Controller (rev 03)
00:1f.6 Signal processing controller: Intel Corporation Wildcat Point-LP Thermal Management Controller (rev 03)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)
03:00.0 Network controller: MEDIATEK Corp. MT7630e 802.11bgn Wireless Network Adapter

Seuraavalla kerralla laita itse päätteen tulosteet ns. koodien sisään, löytyy ylhäältä #-merkin takaa -Storck
« Viimeksi muokattu: 12.09.15 - klo:18.27 kirjoittanut Storck »
Asus X554L (i5, 8G, ssd)
Ubuntu 16.04 LTS

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 11218
    • Profiili
    • Tomin kotisivut
Vs: wi-fi -verkot ei näy
« Vastaus #3 : 12.09.15 - klo:19.25 »
Koodia: [Valitse]
03:00.0 Network controller: MEDIATEK Corp. MT7630e 802.11bgn Wireless Network Adapter

Tuo onkin vähän harvinaisempi piiri eikä ilmeisesti yhtä hyvin tuettu kuin yleisempien valmistajien piirit. Noista ohjeista voisi kuitenkin olla apua: http://community.linuxmint.com/tutorial/view/1796
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

zarmo

  • Käyttäjä
  • Viestejä: 51
    • Profiili
Vs: wi-fi -verkot ei näy
« Vastaus #4 : 12.09.15 - klo:21.43 »
Koodia: [Valitse]
03:00.0 Network controller: MEDIATEK Corp. MT7630e 802.11bgn Wireless Network Adapter

Tuo onkin vähän harvinaisempi piiri eikä ilmeisesti yhtä hyvin tuettu kuin yleisempien valmistajien piirit. Noista ohjeista voisi kuitenkin olla apua: http://community.linuxmint.com/tutorial/view/1796

Tämä toimi. Kiitos!
Asus X554L (i5, 8G, ssd)
Ubuntu 16.04 LTS

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 11218
    • Profiili
    • Tomin kotisivut
Vs: wi-fi -verkot ei näy [RATKAISTU]
« Vastaus #5 : 12.09.15 - klo:22.27 »
Kannattaa sitten muistaa, että kun ydin päivittyy, niin tuo ajuri ei päivity mukana vaan se on asennettava uudestaan. Ajurista olisi varmaankin mahdollista tehdä esimerkiksi dkms:llä automaattisesti päivittyvä, mutta se vaatisi vähän lisätyötä.

Jos ajurin lähdekoodi on tallessa, niin tuo uudelleen asentaminen onnistuu vaikkapa näin:
Koodia: [Valitse]
cd ajurin/hakemisto
make clean
make
sudo make install

Ja tuohan ei toimi ainakaan vielä uudempien kuin 3.14 ytimien kanssa, joten jos päivität Ubuntun uudempaan tai asennat tuoreemman laitteistotuen, niin ajuria ei ehkä saa enää asennettua. Toivottavasti tilanne paranee.
« Viimeksi muokattu: 12.09.15 - klo:22.28 kirjoittanut Tomin »
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

zarmo

  • Käyttäjä
  • Viestejä: 51
    • Profiili
Vs: wi-fi -verkot ei näy [RATKAISTU]
« Vastaus #6 : 13.09.15 - klo:11.36 »
Kannattaa sitten muistaa, että kun ydin päivittyy, niin tuo ajuri ei päivity mukana vaan se on asennettava uudestaan. Ajurista olisi varmaankin mahdollista tehdä esimerkiksi dkms:llä automaattisesti päivittyvä, mutta se vaatisi vähän lisätyötä.

Jos ajurin lähdekoodi on tallessa, niin tuo uudelleen asentaminen onnistuu vaikkapa näin:
Koodia: [Valitse]
cd ajurin/hakemisto
make clean
make
sudo make install

Ja tuohan ei toimi ainakaan vielä uudempien kuin 3.14 ytimien kanssa, joten jos päivität Ubuntun uudempaan tai asennat tuoreemman laitteistotuen, niin ajuria ei ehkä saa enää asennettua. Toivottavasti tilanne paranee.

Joo, päivityksen jälkeen katosi taas wi-fit. Tuo kirjoittamasi uudelleenasennushomma ei auttanut, mutta tein uudestaan tuon aiemman ohjeen mukaisen asennuksen ja nyt taas toimii.
Asus X554L (i5, 8G, ssd)
Ubuntu 16.04 LTS

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 11218
    • Profiili
    • Tomin kotisivut
Vs: wi-fi -verkot ei näy [RATKAISTU]
« Vastaus #7 : 13.09.15 - klo:12.24 »
Kannattaa sitten muistaa, että kun ydin päivittyy, niin tuo ajuri ei päivity mukana vaan se on asennettava uudestaan. Ajurista olisi varmaankin mahdollista tehdä esimerkiksi dkms:llä automaattisesti päivittyvä, mutta se vaatisi vähän lisätyötä.

Jos ajurin lähdekoodi on tallessa, niin tuo uudelleen asentaminen onnistuu vaikkapa näin:
Koodia: [Valitse]
cd ajurin/hakemisto
make clean
make
sudo make install

Ja tuohan ei toimi ainakaan vielä uudempien kuin 3.14 ytimien kanssa, joten jos päivität Ubuntun uudempaan tai asennat tuoreemman laitteistotuen, niin ajuria ei ehkä saa enää asennettua. Toivottavasti tilanne paranee.

Joo, päivityksen jälkeen katosi taas wi-fit. Tuo kirjoittamasi uudelleenasennushomma ei auttanut, mutta tein uudestaan tuon aiemman ohjeen mukaisen asennuksen ja nyt taas toimii.

Tuosta puuttuu vielä se, että moduuli ladataan uudestaan. Uudelleenkäynnistys tai sitten pari komentoa lisää:
Koodia: [Valitse]
sudo modprobe mt7630e
sudo modprobe mt76xx
Tosin ymmärtääkseni vain ylempi tarvitaan, jos bluetooth ei kiinnosta.
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

zarmo

  • Käyttäjä
  • Viestejä: 51
    • Profiili
Vs: wi-fi -verkot ei näy [RATKAISTU]
« Vastaus #8 : 18.09.15 - klo:16.57 »

Ja tuohan ei toimi ainakaan vielä uudempien kuin 3.14 ytimien kanssa, joten jos päivität Ubuntun uudempaan tai asennat tuoreemman laitteistotuen, niin ajuria ei ehkä saa enää asennettua. Toivottavasti tilanne paranee.

Päivitysten jälkeen en enää saanut toimimaan, eli vaihtoehtonako on siis olla päivittämättä kerneliä?

edit:

Ja jos ratkaisu on olla päivittämättä kerneliä, niin miten saan päivitettyä muut asiat, mutta ei kerneliä?

Ja saanko jostain omin avuin seurattua, että milloin kenties toimii uudellakin kernelillä nuo yo. systeemit tai jotkut muut, ettei tarvitsisi täällä koko ajan kysellä?
« Viimeksi muokattu: 18.09.15 - klo:17.34 kirjoittanut zarmo »
Asus X554L (i5, 8G, ssd)
Ubuntu 16.04 LTS

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 11218
    • Profiili
    • Tomin kotisivut
Vs: wi-fi -verkot ei näy [uusi ongelma?]
« Vastaus #9 : 18.09.15 - klo:17.55 »
Mihin versioon päivitit? Tämän saa selville mm. käskyllä `uname -r`.

Paketteja voi merkitä pitoon komennolla `sudo apt-mark hold paketin_nimi`. Tällöin niitä ei päivitetä, mutta sitä en voi suositella ratkaisuksi. Enemminkin kannattaisi tutkia miksi tuo ei toimi enää. Ensimmäinen asia, mikä kannattaisi selvittää on ajossa olevan ytimen versio. Jos se on kunnossa, niin pitäisi tutkia kääntyvätkö moduulit ilman virheitä. Voi olla tarpeellista hakea uudempi versio lähdekoodista, jos sellainen on saatavilla. Jos moduuli on kääntynyt ja asentunut oikein, niin kannattaa katsoa,  onko moduulin latauksessa tullut jonkin virhe, minkä voi nähdä dmesg-komennolla.

En usko, että tuo ongelma johtuu ytimen päivittymisestä, koska Ubuntussa ytimet eivät päivity jakeluversion sisällä uuteen versioon muuten kuin korjausten ja paikkausten osalta. Poikkeuksena päivitetty laitetuki LTS-versioon.
« Viimeksi muokattu: 18.09.15 - klo:18.00 kirjoittanut Tomin »
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

zarmo

  • Käyttäjä
  • Viestejä: 51
    • Profiili
Vs: wi-fi -verkot ei näy [uusi ongelma?]
« Vastaus #10 : 18.09.15 - klo:18.08 »
Mihin versioon päivitit? Tämän saa selville mm. käskyllä `uname -r`.

Paketteja voi merkitä pitoon komennolla `sudo apt-mark hold paketin_nimi`. Tällöin niitä ei päivitetä, mutta sitä en voi suositella ratkaisuksi. Enemminkin kannattaisi tutkia miksi tuo ei toimi enää. Ensimmäinen asia, mikä kannattaisi selvittää on ajossa olevan ytimen versio. Jos se on kunnossa, niin pitäisi tutkia kääntyvätkö moduulit ilman virheitä. Voi olla tarpeellista hakea uudempi versio lähdekoodista, jos sellainen on saatavilla. Jos moduuli on kääntynyt ja asentunut oikein, niin kannattaa katsoa,  onko moduulin latauksessa tullut jonkin virhe, minkä voi nähdä dmesg-komennolla.

En usko, että tuo ongelma johtuu ytimen päivittymisestä, koska Ubuntussa ytimet eivät päivity jakeluversion sisällä uuteen versioon muuten kuin korjausten ja paikkausten osalta. Poikkeuksena päivitetty laitetuki LTS-versioon.

3.19.0-25-generic
Toistaiseksi toimii. Viimeksi, kun tässä tilanteessa latasin päivitykset, niin ei enää toiminut. Nyt en uskalla päivittää.
Asus X554L (i5, 8G, ssd)
Ubuntu 16.04 LTS

zarmo

  • Käyttäjä
  • Viestejä: 51
    • Profiili
Vs: wi-fi -verkot ei näy [uusi ongelma?]
« Vastaus #11 : 22.09.15 - klo:21.56 »
Muista syistä tehdyn uuden asennuksen ja päivitysten jälkeen lakkasi taas toimimasta eikä ajuria saa enää asennettua, vaan tulee:

Koodia: [Valitse]
jarkko@jarkko-X555LAB:~/Lataukset/MT7630E-release$ sudo ./install
make -C /lib/modules/`uname -r`/build M=/home/jarkko/Lataukset/MT7630E-release/rt2x00 modules
make[1]: Entering directory `/usr/src/linux-headers-3.19.0-28-generic'
make[2]: Warning: File `/home/jarkko/Lataukset/MT7630E-release/rt2x00/.rt2x00queue.o.cmd' has modification time 8.3e+03 s in the future
make[2]: warning:  Clock skew detected.  Your build may be incomplete.
  Building modules, stage 2.
make[2]: Warning: File `/home/jarkko/Lataukset/MT7630E-release/rt2x00/.mt7630e.mod.o.cmd' has modification time 8.3e+03 s in the future
  MODPOST 1 modules
make[2]: warning:  Clock skew detected.  Your build may be incomplete.
make[1]: Leaving directory `/usr/src/linux-headers-3.19.0-28-generic'
make -C /lib/modules/`uname -r`/build M=/home/jarkko/Lataukset/MT7630E-release/btloader modules
make[1]: Entering directory `/usr/src/linux-headers-3.19.0-28-generic'
make[2]: Warning: File `/home/jarkko/Lataukset/MT7630E-release/btloader/.mt76xx.o.cmd' has modification time 8.3e+03 s in the future
make[2]: warning:  Clock skew detected.  Your build may be incomplete.
  Building modules, stage 2.
make[2]: Warning: File `/home/jarkko/Lataukset/MT7630E-release/btloader/.mt76xx.mod.o.cmd' has modification time 8.3e+03 s in the future
  MODPOST 1 modules
make[2]: warning:  Clock skew detected.  Your build may be incomplete.
make[1]: Leaving directory `/usr/src/linux-headers-3.19.0-28-generic'
cp -v firmware/*/* /lib/firmware/
‘firmware/BT/mt76x0.bin’ -> ‘/lib/firmware/mt76x0.bin’
‘firmware/Wi-FI/MT7650E234.bin’ -> ‘/lib/firmware/MT7650E234.bin’
cp rt2x00/mt7630e.ko /lib/modules/`uname -r`/kernel/drivers/net/wireless/
cp btloader/mt76xx.ko /lib/modules/`uname -r`/kernel/drivers/net/wireless/
depmod
modprobe: ERROR: could not insert 'mt7630e': Exec format error
modprobe: ERROR: could not insert 'mt76xx': Exec format error

Ennen päivitystä tällä uudellakin asennuksella toimi tuo aiemmin mainittu systeemi.
Asus X554L (i5, 8G, ssd)
Ubuntu 16.04 LTS

matsukan

  • Käyttäjä
  • Viestejä: 2128
    • Profiili
Vs: wi-fi -verkot ei näy [uusi ongelma?]
« Vastaus #12 : 22.09.15 - klo:22.31 »
Auttaisikos

Koodia: [Valitse]
make clean

jne ?

Tai sitten ota uudestaan johonkin toiseen hakemistoon ja buildaa uudestaan

Pohjois-pohjanmaa
-- motto:  backupin tarve huomataan aina liian myöhään