Kirjoittaja Aihe: EI - Ratkaistu Huawey E3372 aka E398 Ja Ubuntu 15.04 -Ongelmaa  (Luettu 4111 kertaa)

samsunix

  • Käyttäjä
  • Viestejä: 198
    • Profiili
    • samuliweb
Onkohan kellään kokemuksia otsikon mukaisesta combosta?

Ongelmana on että, laite tunnistetaan mutta, yhteyttä muodostaessa tulee tenkka-poo. Ei onnistu.
Yrittää yhdistää mutta keskeyttää.

lsusb:
Lainaus
Bus 001 Device 005: ID 12d1:1506 Huawei Technologies Co., Ltd. E398 LTE/UMTS/GSM Modem/Networkcard

syslog:
Lainaus
Jun 23 00:00:20 Ol-reliable-eeh NetworkManager[607]: <info> Activation (cdc-wdm0) Stage 4 of 5 (IPv4 Configure Timeout) scheduled...
Jun 23 00:00:20 Ol-reliable-eeh NetworkManager[607]: <info> Activation (cdc-wdm0) Stage 4 of 5 (IPv4 Configure Timeout) started...
Jun 23 00:00:20 Ol-reliable-eeh NetworkManager[607]: <info> (cdc-wdm0): device state change: ip-config -> failed (reason 'ip-config-unavailable') [70 120 5]
Jun 23 00:00:20 Ol-reliable-eeh NetworkManager[607]: <warn> Activation (cdc-wdm0) failed for connection 'Play Online'
Jun 23 00:00:20 Ol-reliable-eeh kernel: [   98.114359] huawei_cdc_ncm 1-4:1.2 wwan0: kevent 12 may have been dropped
Jun 23 00:00:20 Ol-reliable-eeh NetworkManager[607]: <info> Activation (cdc-wdm0) Stage 4 of 5 (IPv4 Configure Timeout) complete.
Jun 23 00:00:20 Ol-reliable-eeh NetworkManager[607]: <info> (cdc-wdm0): device state change: failed -> disconnected (reason 'none') [120 30 0]
Jun 23 00:00:20 Ol-reliable-eeh NetworkManager[607]: <info> (cdc-wdm0): deactivating device (reason 'none')

Tälläsillä  se sitte starttas vaikka ei mitää järkeä:

/etc/usb_modeswitch.d/12d1\:1506
Lainaus
# Huawei E398

DisableSwitching=0

EnableLogging=1

DefaultVendor=  0x12d1
DefaultProduct= 0x1506

TargetVendor=  0x12d1
TargetProductList= 0x14fe

MessageContent="55534243123456780000000000000011062000000100000000000000000000"

CheckSuccess=5

Koodia: [Valitse]
sudo usb_modeswitch -c /etc/usb_modeswitch.d/12d1\:1506
Lainaus
Look for target devices ...
Error: entry in product ID list has wrong length: 0x14fe. Ignored
 No devices in target mode or class found
Look for default devices ...
   product ID matched
 Found devices in default mode (1)
Access device 007 on bus 001
Current configuration number is 1
Use interface number 0
Use endpoints 0x02 (out) and 0x82 (in)
Error: can't use storage command in MessageContent with interface 0;
       interface class is 255, expected 8. Abort

Pystyn lukeen tiedostoja laitteen muistista (cd-rom'ish) ja näkyy normaalisti samaan aikaan broadband -laitteena. Toimii ainakin toistaiseksi. Jotain tein oikein mutta, en tiedä vielä mitä.

syslogissa näkyy laite muuttaneen nimeään:
Lainaus
Jun 23 11:02:58 Ol-reliable-eeh NetworkManager[607]: <info> (ttyUSB1): modem state changed, 'connecting' --> 'connected' (reason: user-requested)
Jun 23 11:02:58 Ol-reliable-eeh NetworkManager[607]: <warn> (ttyUSB2): failed to look up interface index
Jun 23 11:02:58 Ol-reliable-eeh NetworkManager[607]: <info> Activation (ttyUSB1) Stage 2 of 5 (Device Configure) scheduled...
Jun 23 11:02:58 Ol-reliable-eeh NetworkManager[607]: <info> Activation (ttyUSB1) Stage 2 of 5 (Device Configure) starting...
Jun 23 11:02:58 Ol-reliable-eeh NetworkManager[607]: <info> (ttyUSB1): device state change: prepare -> config (reason 'none') [40 50 0]
Jun 23 11:02:58 Ol-reliable-eeh NetworkManager[607]: <info> Activation (ttyUSB1) Stage 2 of 5 (Device Configure) successful.
Jun 23 11:02:58 Ol-reliable-eeh NetworkManager[607]: <info> Activation (ttyUSB1) Stage 3 of 5 (IP Configure Start) scheduled.
Jun 23 11:02:58 Ol-reliable-eeh NetworkManager[607]: <info> Activation (ttyUSB1) Stage 2 of 5 (Device Configure) complete.
Jun 23 11:02:58 Ol-reliable-eeh NetworkManager[607]: <info> Activation (ttyUSB1) Stage 3 of 5 (IP Configure Start) started...
Jun 23 11:02:58 Ol-reliable-eeh NetworkManager[607]: <info> (ttyUSB1): device state change: config -> ip-config (reason 'none') [50 70 0]
Jun 23 11:02:58 Ol-reliable-eeh NetworkManager[607]: <warn> (ttyUSB1): interface ttyUSB2 not up for IP configuration
Jun 23 11:02:58 Ol-reliable-eeh NetworkManager[607]: <info> using modem-specified IP timeout: 20 seconds
Jun 23 11:02:58 Ol-reliable-eeh NetworkManager[607]: <info> starting PPP connection
Jun 23 11:02:58 Ol-reliable-eeh NetworkManager[607]: <info> pppd started with pid 10230
Jun 23 11:02:58 Ol-reliable-eeh NetworkManager[607]: <info> Activation (ttyUSB1) Stage 4 of 5 (IPv6 Configure Timeout) scheduled...
Jun 23 11:02:58 Ol-reliable-eeh NetworkManager[607]: <info> Activation (ttyUSB1) Stage 3 of 5 (IP Configure Start) complete.
Jun 23 11:02:58 Ol-reliable-eeh NetworkManager[607]: <info> Activation (ttyUSB1) Stage 4 of 5 (IPv6 Configure Timeout) started...
Jun 23 11:02:58 Ol-reliable-eeh NetworkManager[607]: <info> Activation (ttyUSB1) Stage 4 of 5 (IPv6 Configure Timeout) complete.

Pakkaa sekoittaa mukavasti se, että tikku toimii itsestään tarkalleen joka kolmannella kerralla kun sen tietokoneeseen kytkee (varmistin tämän uudella ubuntu asennuksella). Voi siis olettaa, että tikussa on vähintäänkin kolme eri moodia joihin se käynistyy.

Tavoitteena siis pakottaa huihaihin modeemi-moodi päälle käynnistyksen yhteydessä usb_modeswitchillä tai muulla keinoin.


- Samuli
« Viimeksi muokattu: 24.06.15 - klo:11.04 kirjoittanut samsunix »

spark

  • Käyttäjä
  • Viestejä: 1752
    • Profiili
Oletko varma ettei se ole ns. HiLink versio jolloin se tunnistuu kiinteänä verkkoyhteytenä?

boy007

  • Käyttäjä
  • Viestejä: 10
    • Profiili

moi,

E398 toimii 14.04 ihan suoraan laatikosta.

https://sites.google.com/site/jpsdatareviewstheboy007/4gcantennamobileinternet löytyy
vaikeampaan konfiguraatioon ohje vanhemille ja tulossa 14.04 uudempi ohje.

Työn allla E398 kanssa:
LTE
DNA

uusi kovo:
useampi WIFI toistin samassa rungossa jonka kautta nettiin E398 kautta

===

E398 toimii parhaiten wvdial/ppp kautta,
qmi ns. wwan:ina toimii mutta ei virheettä
viikkokausia.






boy007
the@boy007.dy.fi