Kirjoittaja Aihe: Libreoffice lisäosa LanguageTool 2.9 [RATKAISTU tavallaan]  (Luettu 1524 kertaa)

Jallu59

  • Käyttäjä
  • Viestejä: 3430
    • Profiili
Yritän saada Espanjan oikolukua Libreofficeen(4.2.7.2) Xubuntu14.04:ssä. LanguageTool 2.9-lisäosan   asennus kuitenkin tärähtää virheeseen:
Koodia: [Valitse]
(com.sun.star.uno.RuntimeException) { { Message = "[jni_uno bridge error] UNO calling Java method writeRegistryInfo: non-UNO exception occurred: java.lang.UnsupportedClassVersionError: org/languagetool/openoffice/Main : Unsupported major.minor version 51.0\X000ajava stack trace:\X000ajava.lang.UnsupportedClassVersionError: org/languagetool/openoffice/Main : Unsupported major.minor version 51.0\X000a\X0009at java.lang.ClassLoader.defineClass1(Native Method)\X000a\X0009at java.lang.ClassLoader.defineClass(ClassLoader.java:643)\X000a\X0009at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)\X000a\X0009at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)\X000a\X0009at java.net.URLClassLoader.access$000(URLClassLoader.java:73)\X000a\X0009at java.net.URLClassLoader$1.run(URLClassLoader.java:212)\X000a\X0009at java.security.AccessController.doPrivileged(Native Method)\X000a\X0009at java.net.URLClassLoader.findClass(URLClassLoader.java:205)\X000a\X0009at java.lang.ClassLoader.loadClass(ClassLoader.java:323)\X000a\Xn0009at java.lang.ClassLoader.loadClass(ClassLoader.java:316)\X000a\X0009at java.net.FactoryURLClassLoader.loadClass(URLClassLoader.java:615)\X000a\X0009at java.lang.ClassLoader.loadClass(ClassLoader.java:268)\X000a\X0009at com.sun.star.comp.loader.RegistrationClassFinder.find(RegistrationClassFinder.java:52)\X000a\X0009at com.sun.star.comp.loader.JavaLoader.writeRegistryInfo(JavaLoader.java:399)\X000a", Context = (com.sun.star.uno.XInterface) @0 } } Puuttuuko jotain avoimen Javan palikoita vai vaatiiko tuo toimiakseen Oraclen Javan ?

T:jallu59
« Viimeksi muokattu: 09.04.15 - klo:07.16 kirjoittanut Jallu59 »
Jari J. Lehtinen, Wanhempi (iki?)tietoteekkari & tietotekniikkakonsultti Turust, P4-HT / 3,0 GHz, Intel945 IGP 226MB & 4GBram & UbuntuStudio 14.04. Toshiba Satellie 50-C, i5 dual-core 2,3GHz, ubuntu-mate 16.04 LTS

Jakke77

  • Käyttäjä
  • Viestejä: 3795
  • Oulu (Oinaansuo)
    • Profiili
U_G_H

Aspire E5-575G V1.27 CPU: Intel i3-6100U (4) @ 2.300GHz GPU: Intel® HD Graphics 520 GPU: NVIDIA GeForce 940MX

Jallu59

  • Käyttäjä
  • Viestejä: 3430
    • Profiili
Vs: Libreoffice lisäosa LanguageTool 2.9
« Vastaus #2 : 08.04.15 - klo:19.04 »
Kyseistä lisäosaa, openoffice.org-java-common, ei löydy 14.04:n repoista. Täytynee koettaa Oraclen Javalla.

T:Jallu59
Jari J. Lehtinen, Wanhempi (iki?)tietoteekkari & tietotekniikkakonsultti Turust, P4-HT / 3,0 GHz, Intel945 IGP 226MB & 4GBram & UbuntuStudio 14.04. Toshiba Satellie 50-C, i5 dual-core 2,3GHz, ubuntu-mate 16.04 LTS

nm

  • Käyttäjä
  • Viestejä: 13756
    • Profiili
Vs: Libreoffice lisäosa LanguageTool 2.9
« Vastaus #3 : 08.04.15 - klo:20.32 »
Kyseistä lisäosaa, openoffice.org-java-common, ei löydy 14.04:n repoista.

LibreOfficen tapauksessa vastaava paketti on tietysti libreoffice-java-common.

Jallu59

  • Käyttäjä
  • Viestejä: 3430
    • Profiili
Vs: Libreoffice lisäosa LanguageTool 2.9
« Vastaus #4 : 09.04.15 - klo:07.15 »
LibreOfficen tapauksessa vastaava paketti on tietysti libreoffice-java-common.
Ohjeessa oli, että nimenomaan libreoffice-java-common korvataan openoffice.org-java-common .

No, Language Tool asentui Oraclen Javalla(8), mutta se riiteli voikon kanssa ja vaikka voikon poisti oikoluku oli suomenkielellä.

Ratkaisin asian luomalla espanjankielisen käyttäjän, jolle asensin Language tool:in. Sillä tavalla sain espanjankielen oikoluvun toimimaan, kun dokumentin kieleksi vaihtoi espanjan.

T:Jallu
Jari J. Lehtinen, Wanhempi (iki?)tietoteekkari & tietotekniikkakonsultti Turust, P4-HT / 3,0 GHz, Intel945 IGP 226MB & 4GBram & UbuntuStudio 14.04. Toshiba Satellie 50-C, i5 dual-core 2,3GHz, ubuntu-mate 16.04 LTS

nm

  • Käyttäjä
  • Viestejä: 13756
    • Profiili
Vs: Libreoffice lisäosa LanguageTool 2.9
« Vastaus #5 : 09.04.15 - klo:11.30 »
Ohjeessa oli, että nimenomaan libreoffice-java-common korvataan openoffice.org-java-common .

Missä ohjeessa on niin? Jakke77:n linkin takana oli vain viiden vuoden takaista keskustelua OpenOfficesta.

No, Language Tool asentui Oraclen Javalla(8), mutta se riiteli voikon kanssa ja vaikka voikon poisti oikoluku oli suomenkielellä.

Minulla LanguageTool asentuu ja toimii OpenJDK 7:llä (openjdk-7-jre), kunhan tuo libreoffice-java-common on asennettuna. Ilman kyseistä pakettia asennus antaa tuon "UNO calling Java method" -herjan.
« Viimeksi muokattu: 09.04.15 - klo:11.35 kirjoittanut nm »

Jallu59

  • Käyttäjä
  • Viestejä: 3430
    • Profiili
Vs: Libreoffice lisäosa LanguageTool 2.9 [RATKAISTU tavallaan]
« Vastaus #6 : 09.04.15 - klo:19.48 »
Kohdekoneessa(Xubuntu 14.04 64-bit) oli sekä openjdk-7-jre, että libreoffice-java-common ja siitä huolimatta tuli tuo Uno-herjarimpsu.
Jostain syystä se ei siinä koneessa(AmiloA7640) pelittänyt. Ehkä syynä oli se,että kyseessä oli 12.04:stä päivitetty 14.04 ja mukana oli jotain vanhaa tauhkaa.

Kiitos kuitenkin kokeilusta.

T:Jallu59
Jari J. Lehtinen, Wanhempi (iki?)tietoteekkari & tietotekniikkakonsultti Turust, P4-HT / 3,0 GHz, Intel945 IGP 226MB & 4GBram & UbuntuStudio 14.04. Toshiba Satellie 50-C, i5 dual-core 2,3GHz, ubuntu-mate 16.04 LTS