Kirjoittaja Aihe: kanta.fi palvelu ja Mozilla Firefox [RATKAISTU]  (Luettu 2925 kertaa)

Vostok

  • Käyttäjä
  • Viestejä: 93
    • Profiili
Moi !

Käytössä on Ubuntu 14.04 LTS:n mukana tullut Firefox-selain.  Joudun käyttämään Kanta.fi palvelua säännöllisesti ja nyt sinne tulevat tietoturvamuutokset hiukan mietityttävät. 

01.04.15 alkaen siellä vaaditaan että selain täyttää seuraavat ehdot: "Tarkista, että selaimesi tukee salausprotokollaa TLSv1.1 tai TLSv1.2 tai päivitä tarvittaessa selaimesi uudempaan versioon."

Yritin tuossa jo tutkailla selaimen asetuksista mistä tuo tieto TLSv1.1 tai TLSv1.2 käytössä olosta löytyy mutta en onnistunut tässä hankkeessa; voisiko joku vinkata mistä tuo tieto löytyy?
« Viimeksi muokattu: 09.04.15 - klo:20.00 kirjoittanut Vostok »
Ubuntu?.... joo, se on ehdottoman ХОРОШИЙ!

kamara

  • Käyttäjä
  • Viestejä: 2443
    • Profiili
Vs: kanta.fi palvelu ja Mozilla Firefox
« Vastaus #1 : 20.03.15 - klo:13.31 »
http://en.wikipedia.org/wiki/Transport_Layer_Security

Itselläni on riittävän tuore Firefox 14.04:ssä.

raimo

  • Käyttäjä
  • Viestejä: 3595
    • Profiili
Vs: kanta.fi palvelu ja Mozilla Firefox
« Vastaus #2 : 20.03.15 - klo:13.41 »
Tuolta löytyy infoa http://kb.mozillazine.org/Security.tls.version.*
Kaikki on nähdäkseni Kanta.fi osalta OK, mutta tarkista itse, näpsyttele Firefoxin osoiteriville:
Koodia: [Valitse]
about:configHyväksy varoitushuomautus (varovasti sitten) ja etsi haulla avain:
Koodia: [Valitse]
security.tls.version.maxJos 3 on arvona, on TLS 1.2 korkein käytössä oleva ja siis OK.
Ja sitten
Koodia: [Valitse]
security.tls.version.minarvo pitää olla 1 (TLS 1.0), kanta.fi osalta varmaan sitten toimii myös arvo 2, mutta ei liene tarvetta muuttaa?
So long and thanks for all the fish!

AimoE

  • Käyttäjä
  • Viestejä: 2003
    • Profiili
Vs: kanta.fi palvelu ja Mozilla Firefox
« Vastaus #3 : 20.03.15 - klo:13.46 »
Katso viestintäviraston ohjeet eri selaimille. Eli jos ei halua käpälöidä about:config-asetuksia, voi asentaa lisäosan jonka avulla vanhan turvattoman protokollaversion voi ottaa pois käytöstä. SSL on protokollan vanha nimi, uudempia versioita nimitetään nimellä TLS. Tämä hämää aika monia, ei ymmärretä että SSL pitää ottaa pois käytöstä kun on tottunut ajattelemaan että juuri SSL on se mitä tarvitaan salaukseen. Mutta se on siis TLS jota tarvitaan.

nm

  • Käyttäjä
  • Viestejä: 14173
    • Profiili
Vs: kanta.fi palvelu ja Mozilla Firefox
« Vastaus #4 : 20.03.15 - klo:14.46 »
Katso viestintäviraston ohjeet eri selaimille. Eli jos ei halua käpälöidä about:config-asetuksia, voi asentaa lisäosan jonka avulla vanhan turvattoman protokollaversion voi ottaa pois käytöstä. SSL on protokollan vanha nimi, uudempia versioita nimitetään nimellä TLS. Tämä hämää aika monia, ei ymmärretä että SSL pitää ottaa pois käytöstä kun on tottunut ajattelemaan että juuri SSL on se mitä tarvitaan salaukseen. Mutta se on siis TLS jota tarvitaan.

SSL 3.0 on oletuksena pois päältä Chromium/Chrome 40:ssä ja Firefox 34:ssä ja uudemmissa. Ubuntussa on jo riittävän uudet versiot näistä selaimista, eikä lisätoimenpiteitä tarvita. Toki kannattaa tarkistaa, että selain on päivitetty uusimpaan versioon. SSLv3-tuen olemassaolon voi tarkistaa vaikkapa tällä sivustolla: https://zmap.io/sslv3/sslv3test.html

Kanta.fi:n tapauksessa sivu itse vaatii TLS 1.1:n tai 1.2:n. Jos sivusto toimii, selain tukee tarvittavia protokollia.

« Viimeksi muokattu: 20.03.15 - klo:14.49 kirjoittanut nm »

Vostok

  • Käyttäjä
  • Viestejä: 93
    • Profiili
Vs: kanta.fi palvelu ja Mozilla Firefox [RATKAISTU]
« Vastaus #5 : 09.04.15 - klo:20.02 »
Kanta.fi pelitti ihan hyvin Ubuntun mukana tulleella Firefoksilla 01.04 jälkeen
Ubuntu?.... joo, se on ehdottoman ХОРОШИЙ!