Kirjoittaja Aihe: Ubuntu 14.04LTS ei asennu Pavilion 17-e157eo :ssa  (Luettu 13262 kertaa)

supuntupuomi

  • Käyttäjä
  • Viestejä: 7
    • Profiili
Ubuntu 14.04LTS ei asennu toimimaan HP Pavilion 17-e157eo :ssa.
Onko tietoa ongelman syistä tai peräti joku onnistunut asentamaan?

Storck

  • Vieras
Vs: Ubuntu 14.04LTS ei asennu Pavilion 17-e157eo :ssa
« Vastaus #1 : 12.08.14 - klo:22.13 »
Kun ei tiedä ongelmaa niin paha kertoa mitään.

Mitä tapahtuu ja mitä ei tapahtu?

Kerro enemmän niin helpompi auttaa..

supuntupuomi

  • Käyttäjä
  • Viestejä: 7
    • Profiili
Vs: Ubuntu 14.04LTS ei asennu Pavilion 17-e157eo :ssa
« Vastaus #2 : 16.08.14 - klo:10.52 »
Niin. Anteeksi ja kiitos.
Kiireeni on kovin hitaanpuoleinen, enkä joka päivä käy sivustolla.

Tosiaan kone on uusi, kaupasta haettu, esiasennettuna Windows 8.1.
This PC has both the integrated INTEL 4600 graphics chip and an  AMD Radeon 8670M 

Ubuntua olen käyttänyt päivittäin kotona vanhalla pöytäkoneella ja kahdella vanhalla läppärillä kuutisen vuotta, ja aina aiemmin asennukset ovat koneille sujuneet ongelmitta.
Windowseja en kaipaa rinnalle. Linuxia mieluummin käyttäisin, jos koneelle sen saisin.

Tämän HP Pavilion 17-e157eo:n kanssa tein seuraavaa:
Avasin myyntipakkauksen ja otin koneen käyttöön tehden normaalit Windowsin käyttöönottoon liittyvät aloitusrutiinit. Windows 8.1 näytti toimivan ongelmitta.
Sitten aloitin Ubuntu 14.04 LTS amd64 Finnish remix - asennus-DVD:llä, ajattelin - varovaisuussyistä - kokeilla asentaa Ubuntun  Windows 8.1:n rinnalle dual boot -virityksenä,  ja prosessi ei oikein muistaakseni edennyt
kovinkaan pitkälle, herjasi jollain sanamuodolla grub -ongelmaa.
Päättelin, ettei toistamalla parane.
Tein sitten 32 GB:n USB-tikulle Windows 8.1:n pautustiedostot.
Sitten - Ubuntu-päytäkoneella - tein UNetbootin -ohjelmaa apuna käyttäen USB-tikun (LIVEkö lienee?) Ubuntu 14.04 LTS 64AMD:n kokeilua ja asennusta varten.
Rohkeasti asentamaan, kun olin koneen ensin pannut ensisijaisesti käynnistymään USB:ltä.
Etenin asentamaan Ubuntua siten, että Windows poistettiin, ja Ubuntu otti koko tilan valtaansa.
Asennusprosessi näytti etenevän alusta loppuun ok.
Sitten piti käynnistää ensi kertaa koneelle asentunut(?) Ubuntu 14.04 LTS 64AMD Finnish remix.

Tässäpä alkoikin sitten tökkiminen.
Ubuntun käynnistyminen tökkii virhe/puuteilmoituksiin, joista kohta kirjoitan alempana.
Jotta ylipäätään konetta olisin mitenkään kyennyt järkevästi käyttämään, palautin onnistuneesti Windows 8.1:n.
Sitten olen yrittänyt tuolta USB-tikulta kokeilla käynnistää koneelle Ubuntua ilman asennusta, mutta käynnistysyritys törmää samoihin ongelma/virheilmoituksiin, joita kone antoi, kun olin Ubuntun koneelle (ilmeisesti) asentanut.  Tästä arvelen, että ongelma on varmaankin sama, yrittipä Ubuntua käynnistää koneelle asentuneena tai USB-tikulta.

USB-tikulta kun nyt yrittää, tapahtuu seuraavaa:
-aukeaa askeettinen "ikkuna" otsikolla "GNU GRUB 2.02~beta2-9"
  siinä valikkorivit: Try Ubuntu without installing
                                Install Ubuntu
                                OEM install (for manufacturers)
                                Check disk for defects       
-kun valitsen ensimmäisen vaihtoehdon "Try Ubuntu without installing", käynnistyy muutaman sekunnin kuluttua tuo Ubuntun violetti aloitusruutu, jossa keskellä on sana "UBUNTU" ja sen alla vaakarivissä viisi pistettä, joissa hitaasti vilkkuu vuoroin valkoinen vuoroin lohenpunainen luoden vaikutelmaa, että kone varmaan jotain duunaa
-muutamaa sekuntia myöhemmin  menee 1-2 sekunniksi ruutu mustaksi, ja sitten tulee keskelle ruutua ilmoitus, jossa ensinnäkin on vasemmassa yläkulmassa punainen vajaan 1 cm:n kokoinen ympyrä, jonka keskellä on huutomerkki ja tämän merkin oikealla puolella  (ihan kauniilla fonteilla, ei siis ASCII-kirjoituksella) teksti: "The system in running in low-graphics mode"    (uusi rivi) "Your screen, graphics card and input device settings could not be detected correctly. You will need to configure these yourself"
Ilmoitusikkunan alalaidasta klikkaan ainoaa vaihtoehtoa "OK" painamalla Enter.
-avautuu grafiikaltaan edellistä muistuttava valikkoruutu kysymyksellä: "What would you like to do?" ja siihen vaihtoehdot  täpättäviksi ovat seuraavat neljä.
   "Run in low-graphics mode for just one session"
   "Reconfigure graphics"
   "Troubleshoot the error"
   "Exit to console login"
- kun yritän valita näistä jonkin, nuolinppäimet eivät  ikkunassa toimi, ei sarkainnäppäinkään. Aiemmin muuten sain valinnat ongelmitta aktivoitua. Sokkona hiirtä liikutellen löytyy lopulta viite hiiritoiminnosta, kun vahingossa osun kohdalle, niin kukin näistä täppäruuduista vuorollaan hieman korostuu, mutta klikkaamalla tai enterillä ei tapahdu mitään. Tästä pääsee pakenemaan vain esc -näppäimellä ja
- sitten noin minuutin kuluttua aukeaa vanhan ajan komentokehotemaisema varsin tavanomaisena
"Welcome to Ubuntu 14.04 LTS (GNU Linux 3.13..0-24-generic x86_64)" jne,
alimmalla rivillä:
ubuntu@ubuntu:~$
Siihen kun kirjoitan dir [enter], ilmoittaa Desktop 
Kun kirjoitan help [enter], vastaapi GNU bash version jne, lopuksi  listaten bashin komennot.

Huomionarvoista ehkä on sekin, että aiemmin, kun jollain pläräämiskerralla onnistuin valitsemaan "troubleshooting" -vaihtoehdon, se pyöräytti lopulta johonkin umpikujaan, ja aina on ainoa pakenemistie ollut esc -näppäin, josta pääsen siis tähän viimeksi mainittuun komentokehotteeseen, josta saan kauniisti nämä bash -komennot listatuksi.
Osaamiseni Ubuntun osalta loppuu nyt tähän.

Ajattelin siis tässä vaiheessa kysyä, josko joku täällä foorumilla tietäisi tämän uuden läppärin ongelman syistä tai peräti olisi onnistunut Ubuntun kyseiseen koneeseen asentamaan.

Liekö ongelma mitenkään yhteydessä siihen, että aparaatissa on kaksi näytönohjainta...

qwertyy

  • Käyttäjä
  • Viestejä: 4774
    • Profiili
Vs: Ubuntu 14.04LTS ei asennu Pavilion 17-e157eo :ssa
« Vastaus #3 : 16.08.14 - klo:12.10 »
Liekö ongelma mitenkään yhteydessä siihen, että aparaatissa on kaksi näytönohjainta...
Olet luultavasti täysin oikeilla jäljillä. Biosista voi ilmeisesti pakottaa toisen näistä jatkuvasti päälle. Todennäköisesti tuo Amd aiheuttaa ongelmia ja vaatisi suljetut ajurit toimiakseen.

Tuolla on englanniksi hyvin pitkä ketju, koskien vahempaa Ubuntua ja toki hiukan vanhempaa näytönohjainmalliakin, mutta tuollaista tuplanäytönohjainmallia kuitenkin.
http://ubuntuforums.org/showthread.php?t=1930450&highlight=hybrid+graphics
Huom. tietystikään ohjeita tuon alusta ei missään nimessä kannata alkaa kokeilemaan 14.04:llä.

Itse aloittaisin kuitenkin kokeilemalla niin tuoreella kernel-ytimellä ja ajureilla kuin mahdollista. Eli jos nettiyhteys on siedettävä, niin lataisin vielä kehityksessä ja kesken olevan päivittäisimagen tulevasta Ubuntusta.
http://cdimage.ubuntu.com/daily-live/current/

Täysin mahdollista että kone boottaa tuolla mukisematta työpöydälle kokeilutilassa. Eli ilmeisesti Biosista Intelin pakottamalla kone voisi toimia ihan oikein. Tosin ilman tuota tehokkaampaa AMD:tä


Tuossa ensimmäisessä linkissä oli aika lupaava viesti kyllä Intelistä. mitä nyt pikaisesti sitä vilkuilin.
Lainaus
I'm using Ubuntu 14.04 on the HP 4530s with AMD Radeon HD 6490M/Intel HD Graphics 3000 Switchable graphics.
I have installed the first Intel driver from here.
Then I reboot so far there are no problems
Then I install the ati driver "amd-catalyst-14-4-rev2-linux-x86-x86-64-may6.zip" and reboot.
The system is opening low graphic mode. I also tried switch integrated Intel graphics card everything works fine. Any ideas what to do to fix this problem?

supuntupuomi

  • Käyttäjä
  • Viestejä: 7
    • Profiili
Vs: Ubuntu 14.04LTS ei asennu Pavilion 17-e157eo :ssa
« Vastaus #4 : 16.08.14 - klo:12.37 »
Kiitoksia vinkeistä. Täytyy käydä tutkimassa.
Nyt sokkoleikkiä hiiren kanssa leikittyäni riittävän pitkään pääsin klikkaamaan lokitiedostojen tarkasteluja auki. Näkyy olevan kohtalaisen paljon. Valokuvailen ne, ja palailen asiaan, joka tapauksessa.

Tulipa mieleen sellainenkin vaihtoehto, että avaan koneen sisuskalut ja, mikäli  mahdollista, poistan tuon Radeonin ihan fyysisesti. Muuttuisi kone simppelimmäksi.

Palailen asiaan.

qwertyy

  • Käyttäjä
  • Viestejä: 4774
    • Profiili
Vs: Ubuntu 14.04LTS ei asennu Pavilion 17-e157eo :ssa
« Vastaus #5 : 16.08.14 - klo:14.19 »
Tulipa mieleen sellainenkin vaihtoehto, että avaan koneen sisuskalut ja, mikäli  mahdollista, poistan tuon Radeonin ihan fyysisesti. Muuttuisi kone simppelimmäksi.
Suosittelen kokeilemaan ensin Bios-asetuksilla pakottamista. Olettaen tietysti että se on mahdollista kyseisessä koneessa. Itsellä ei ole kokemusta, mutta ilmeisesti kaikista vastaavista löytyy tuo vaihtoehto. Eli Intelin kanssa ongelmia ei kait ole. Tietystikään tehokkaampaa Radeonia ei voi silloin hyödyntää.

Tuo mekaaninen näytönohjaimen irroittaminen voi ollakin mahdollista. Tosin suosittelen kokeilemaan ihan viimeisenä vaihtoehtona, oikeastaan en silloinkaan. Hyvin todennäköisesti kone ei nimittäin lähde edes käyntiin Biosin POST-vaiheesta. Melko varmasti kone luulee, että on tapahtunut todella paha rautavika. Luultavasti tuon jälkeen törmäät lähes takuulla ongelmiin jos yrität käyttää Windowsia koneella. Lähes varmasti valmistaja on tehnyt ajurit niin, että Radeonia hyödynnetään vain joissain DirectX ominaisuuksissa ja todennäköisesti myös videotoiston dekoodauksessa. Olen lähes varma että jos kone vaikuttaisi toimivan työpöydällä, niin viimeistään kun ajurit yrittäisi vaihtaa näytönohjainta, kone hyvin todennäköisesti kaatuu täydellisesti.

Hiukan täsmennettynä, tuo kone taitaa sisältää UEFI-biosin, joka mahdollistaa ajuritasolla paremman raudan ohjaamisen vrt. perinteiseen ns. "legacy"-biosiin. Siksi oletan, että Biosin näytönohjainvalinta voisi olla hyvinkin ohitettuna Windowsin ajureilla. Jos näin on, niin tilanne on lähes varmasti katastrofi näytönohjaimen irroittamisen jälkeen. Ajurivalmistaja tuskin on olettanut, että käyttäjä irroittaa mekaanisesti näytönohjaimen.

Eli oikein tiivistettynä. Tuon Biosin Intel-pakottamisen pitäisi vastata täysin näytönohjaimen irroittamista. Ilman mitään riskitekijöitä.

Huom. tuo on ihan omaa spekulointia, mutta suosittelen kyllä etsimään ainakin tietoa koneen käyttäytymisestä näytönohjaimen irroitamisen jälkeen, ennen kuin alkaa itse testaileen.

supuntupuomi

  • Käyttäjä
  • Viestejä: 7
    • Profiili
Vs: Ubuntu 14.04LTS ei asennu Pavilion 17-e157eo :ssa
« Vastaus #6 : 16.08.14 - klo:23.54 »
Kiitos jälleen.
Ollos huoleton. Teen täällä näitä temppuja koneeni kanssa ihan totaalisesti omalla vastuullani, enkä saa primitiivireaktiota, vaikka vehkeelle tapahtuisi mitä tahansa.
En nyt vielä ajatellut ruuvimeisseliä kaivaa, koska jotenkin kuvittelisi, että lempeämpikin keino saattaisi löytyä. Toisaalta, jos sen Radeonin saa irti, saanee sen takaisin kiinnikin.
Tilannehan on myös sikäli suruton, että tuolla koneella ei ole (vielä) mitään menetettävää dataa. Yritän vasta sitä kesyttää.
Windows 8.1:n palauttaminenkin aiemmin jo kertaalleen onnistui USB-tikulta, vaikka olin sen poistanut Ubuntun asennuksen yhteydessä. Onnistunee jatkossakin.
 
Kiintoisaa oli tänään myös, että huolimatta siitä, että sisäinen DVD-asema on pantu buuttaamaan ennen OS boot Manageria, ei kone buuttaa DVD:ltä. USB-tikulta kyllä buuttaa, kuten edellä jo kerroinkin.
Windowsin tiedostonhallinnasta voi kyllä ajaa Ubuntun asennus-DVD:ltä asennnusohjelman, joka menee lähes loppuun asti, kunnes antaa virheilmoituksen; "Ubuntu-asennus    Tapahtui virhe: Permission denied.  Lisätietoja lokitiedostossa c:\users\omanimeni\appdata\local\temp\wubi-14.04-rev286.log".   No, WIndowsin tiedostonhallinnan kautta tuollaista lokitiedostoa ei löydy. Ubuntu ei siis noinkaan asennu, kuten oletinkin.

UEFI-BIOS koneessa on.
System Configuration -valikossa :
Language                                    <English>
Virtualization Technology              <Disabled>
Card Reader Power Saving            <Enabled>
Fan Always On                              <Enabled>
Action Keys Mode                          <Enabled>
USB3.0 Configuration in Pre-OS      <Auto>

  edelleen:
Boot Options    (Otsikkona tämä rivi)
POST Hotkey Delay (sec)                             <0>
CD-ROM Boot                                             <Enabled>
Internal Network Adapter Boot                    <Disabled>
Network Boot Protocol                                <IPv4+IPv6(UEFI)>
Legacy Support                                           <Disabled>
Secure Boot                                                <Disabled>
Platform Key                                                Enrolled       -tämä muuten ei ole muokattavissa
Pending Action                                             None           -tämäkään ei ole muokattavissa
Clear All Secure Boot Keys                                               - en aio tähän enteriä painaa...
Load HP Factory Default Keys                                           -tämäkään ei ole valittavissa

UEFI Boot Order
   tämän alla normaalit plörinät
Ja sitten alempana harmaalla inaktiivina:
Legacy Boot Order
   jonka alla myös normaalit plörinät buuttausjärjestyksistä
---
Eipä ainakaan tätä kautta  päässyt pakottamaan näytönohjainta.

-----------------------------------------------------------------------------------------------------------
No niin, seuraava yritys, mutta eipä ratkennut ongelma vieläkään.
Tein buuttaavan USB-tikun  linkistä http://cdimage.ubuntu.com/daily-live/current/ päiväyksellä 16.8.2014 ja lähtötiedostona utopic-desktop-amd64.iso, ja yritin kokeilla tikulta Ubuntua  ilman asennusta.
Siitä saadaan sentään jo virheilmoituksia.
Lataapi virheilmoitusten jälkeen Ubuntun työpöytään vasemman reunan käynnistyskuvakkeita, mutta niistä ei tapahdu muuta kuin  ensimmäisellä klikkauskerralla vai pyörähtää hiirikursorin "odota"-animaatio. Sen jälkeen Ubuntu on jumissa.

Yritän laittaa seuraaviin viesteihini valokuvista ottamani kuvakaappaukset virheilmoituksista.
Saattavat olla hyödyksi.



supuntupuomi

  • Käyttäjä
  • Viestejä: 7
    • Profiili
Vs: Ubuntu 14.04LTS ei asennu Pavilion 17-e157eo :ssa
« Vastaus #7 : 17.08.14 - klo:00.01 »
Tässä liitteenä kaappauskuvaa tekstistä, jota ruutuun suoltui, kun  utopic-desktop-amd64 -usb-tikulta (pvm 16.8.2014) yritin käynnistää Ubuntua.
Osa 1./2

supuntupuomi

  • Käyttäjä
  • Viestejä: 7
    • Profiili
Vs: Ubuntu 14.04LTS ei asennu Pavilion 17-e157eo :ssa
« Vastaus #8 : 17.08.14 - klo:00.03 »
Ja tässä tulee kuvakaappauskuvaa osa 2./2

Muuta en nyt tässä vaiheessa keksi.

qwertyy

  • Käyttäjä
  • Viestejä: 4774
    • Profiili
Vs: Ubuntu 14.04LTS ei asennu Pavilion 17-e157eo :ssa
« Vastaus #9 : 17.08.14 - klo:15.17 »
Vaikuttaa jo huomattaen paremmalta. Tuo kehitysversio on siitä ikävä, että se ei ole mitenkään vakaa. Oma kokeiluasennus ei perjantaina käynnistettäessä käynnistynyt graafiseen tilaan lainkaan. Jouduin päivittämään päätteestä uusimpiin paketteihin ja sen jälkeen pääsin taas työpöydälle. Näytti olevan paljon Waylandiin yms. grafiikkapuoleen olevan päivityksiä.

Aika pahasti vielä vaiheessa tuo 14.10
https://wiki.ubuntu.com/UtopicUnicorn/ReleaseSchedule

Vähän huono sauma sinänsä, että alpha1:stä on jo kehitysversion kannalta kauan ja ensimmäiseen betaan menee vielä pari viikkoa. Nuo levykuvat on aina toimineet kun olen itse testaillut kehitysversiota. Dailyt on vähän aina kyseenalaisia. Jos on mielenkiintoa, tuota alpha1:stä voisi tietysti kokeilla sattuisiko sillä käynnistymään työpöytä.
http://cdimage.ubuntu.com/ubuntu-gnome/releases/14.10/alpha-1/

Noissa kuvakaappauksissa en huomaa mitään ratkaisevaa. Lähinnä vain mutisee, että Windowsin tiedostojärjestelmät on suljettu väärin.
« Viimeksi muokattu: 17.08.14 - klo:15.19 kirjoittanut qwertyy »

supuntupuomi

  • Käyttäjä
  • Viestejä: 7
    • Profiili
Vs: Ubuntu 14.04LTS ei asennu Pavilion 17-e157eo :ssa
« Vastaus #10 : 17.08.14 - klo:20.29 »
Yleensähän softapuolen kehitys saa raudasta kiinni, kun annetaan hieman aikaa.
Koska kehitystä näyttää jälleen olevan luvassa, jätän tässä vaiheessa ruuvimeisselitemput ehdottomasti tekemättä ja jään odottamaan lokakuuta ja uutta jakeluversiota.
Mikäli ennen sitä löydän jotain lupaavaa tai muuten mielenkiintoista, kirjoittelen.
Aikani ei valitettavasti anna myöten ihan viikoittain ryhtyä testailemaan vaikka periaatteessa uteliaisuus on hyvällä tasolla.
14.10 -version ilmestyttyä  panen tulemaan infoa, miten asennusyritys on onnistunut.
Tässä vaiheessa kiitos neuvoista ja mielenkiinnosta.

Jos jollakulla sattuu olemaan sama rauta, kiinnostaisi kuulla kommentteja.

leal

  • Käyttäjä
  • Viestejä: 246
    • Profiili
Vs: Ubuntu 14.04LTS ei asennu Pavilion 17-e157eo :ssa
« Vastaus #11 : 18.08.14 - klo:17.40 »
Etenin asentamaan Ubuntua siten, että Windows poistettiin, ja Ubuntu otti koko tilan valtaansa.
Asennusprosessi näytti etenevän alusta loppuun ok.
Sitten piti käynnistää ensi kertaa koneelle asentunut(?) Ubuntu 14.04 LTS 64AMD Finnish remix.

Asennus onnistui graafisesti joten jollain konstilla pitäisi myös sen asennetun Ubuntun käynnistyä. Koita nomodeset-parametria asennettuun Ubuntuun ja/tai asennusmediaan mikä ei käynnisty.

http://askubuntu.com/questions/38780/how-do-i-set-nomodeset-after-ive-already-installed-ubuntu
https://help.ubuntu.com/community/BootOptions#Ubuntu_CD_Advanced_Welcome_Page_Options

USB-tikulta kun nyt yrittää, tapahtuu seuraavaa:
-aukeaa askeettinen "ikkuna" otsikolla "GNU GRUB 2.02~beta2-9"
  siinä valikkorivit: Try Ubuntu without installing
                                Install Ubuntu
                                OEM install (for manufacturers)
                                Check disk for defects

USB-tikulla (ehkä myös levylläkin) on kaksi käynnistyslatainta, toinen biossille ja toinen uefille. Tämä missä lukee grub, on uefille tarkoitettu. Uefi-koneessa pitäisi pystyä käyttämään molempia; varmaan bootti järjestys oli vaihtunut edellisestä niin käytti eri käynnistyslatainta kuin viimeksi. Outoa, että biossille tarkoitetulla graafinen puoli sitten käynnistyi mutta tällä ei, jos siis tulkitsin oikein eli käytit asennuksessa sitä biossille tarkoitettua.

"Welcome to Ubuntu 14.04 LTS (GNU Linux 3.13..0-24-generic x86_64)" jne,
alimmalla rivillä:
ubuntu@ubuntu:~$
Siihen kun kirjoitan dir [enter], ilmoittaa Desktop 
Kun kirjoitan help [enter], vastaapi GNU bash version jne, lopuksi  listaten bashin komennot.

Koita seuraavan kerran tässä startx-komentoa, joka yrittää käynnistää graafisen puolen. Voisi myös katsoa /var/log/-kansiosta kernelin ja x:n lokit esim. nano-tekstieditorilla jos löytyy vihjettä ongelmasta.