Kirjoittaja Aihe: Outo desimaaliongelma [RATKAISTU]  (Luettu 2102 kertaa)

New_user

  • Käyttäjä
  • Viestejä: 1243
    • Profiili
Outo desimaaliongelma [RATKAISTU]
« : 23.07.14 - klo:16.09 »
Työkoneellani (12.04) oleva Qgis-ohjelma lukee shape-tiedostojen attribuuttitaulut (.dbf-tiedostot) sisään niin, että desimaaliluvuista kaikki desimaalit häviävät.  Vika ei ole dbf-tiedostoissa, koska ne avautuvat muualla ihan oikein. Kotikoneellani on sama versio Qgis-ohjelmasta, viimeisin GDAL-versio, ja tässä kaikki pelaa oikein. Palikat siis samat, käyttis ja ohjelmaversiot, ja kuitenkin toisella koneella desimaaleja ei lueta, eli luvusta 123.456 tulee 123.000 (qgis näyttää erottimena aina pisteen). Locale-komento näyttää kummallakin koneella tismalleen samoin.

Enpä tiedä, mistä lähtisi purkamaan ongelmaa. Osaisiko joku vinkata?
« Viimeksi muokattu: 29.07.14 - klo:20.36 kirjoittanut New_user »

anttimr

  • Käyttäjä
  • Viestejä: 1625
    • Profiili
Vs: Outo desimaaliongelma
« Vastaus #1 : 23.07.14 - klo:19.02 »
QGIS:n asetuksissa voi vaihtaa localen joksikin toiseksi kuin järjestelmänlaajuinen locale on. Olisko eri koneissa eri asetukset? Enkkuversiossa Settings -> Options -> Locale -> Override system locale
t. juuri asentanut QGIS 2.4:n
Ubuntu 12.10 Quantal Quetzal

New_user

  • Käyttäjä
  • Viestejä: 1243
    • Profiili
Vs: Outo desimaaliongelma
« Vastaus #2 : 24.07.14 - klo:08.11 »
QGIS:n asetuksissa voi vaihtaa localen joksikin toiseksi kuin järjestelmänlaajuinen locale on. Olisko eri koneissa eri asetukset? Enkkuversiossa Settings -> Options -> Locale -> Override system locale
t. juuri asentanut QGIS 2.4:n

Tuota kokeilin eilen ihan ensimmäiseksi, ja ei auta mitään. Jossain häipyvät desimaalit. Muistaakseni myös ArcGridin desimaaliset ruutuarvot muuttuivat kokonaisiksi nekin. Hämärä juttu. Nyt etätöissä, ja loma tulee päälle, joten homman setviminen menee elokuun puolelle hyvinkin.

New_user

  • Käyttäjä
  • Viestejä: 1243
    • Profiili
Vs: Outo desimaaliongelma
« Vastaus #3 : 29.07.14 - klo:20.35 »
Helteen jatkuminen sai siirtämään loman alkua :) Desimaaliongelmaan ei sitten auttanut muu, kuin Qgis-ohjelman kitkeminen juurineen (apt-get --purge remove) ja uudelleen asennus. Jokin bitti oli mennyt matkan varrella poikittain. Nyt pelajaa. Suosittelen ohjelmaa paikkatiedon kanssa pelaaville. Löytyy ainakin Ubuntugis stable -reposta.