Kirjoittaja Aihe: [Ratkaistu]14.04 cgi-bin oikeudet  (Luettu 1357 kertaa)

JJK

  • Käyttäjä
  • Viestejä: 325
  • Ubuntu Mate 18.04
    • Profiili
[Ratkaistu]14.04 cgi-bin oikeudet
« : 17.05.14 - klo:13.29 »
En saa käytettyä Mapserveriä uuden 14.04 asenuksen jälkeen.
Koodia: [Valitse]
You don't have permission to access /cgi-bin/ on this server.Marserverin tiedosto on "/usr/lib/cgi-bin" kansiossa.

Jotain toimintoja on muutetu sitten 12.04 version.

Minulla on "DocumentRoot /home/www" joka piti uudessa vaihtaa myös apache2.conf tiedostoon.

Koodia: [Valitse]
<VirtualHost *:80>
        ServerAdmin webmaster@localhost

        DocumentRoot /home/www
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /home/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>
        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                #Allow from all
Require all granted
        </Directory>
......

Miten saan oikeuden cgi-bin kansioon?
« Viimeksi muokattu: 17.05.14 - klo:14.19 kirjoittanut JJK »

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 10894
    • Profiili
    • Tomin kotisivut
Vs: 14.04 cgi-bin oikeudet
« Vastaus #1 : 17.05.14 - klo:13.34 »
Koodia: [Valitse]
ls -l /usr/lib/cgi-bin?
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

JJK

  • Käyttäjä
  • Viestejä: 325
  • Ubuntu Mate 18.04
    • Profiili
Vs: 14.04 cgi-bin oikeudet
« Vastaus #2 : 17.05.14 - klo:13.41 »
Koodia: [Valitse]
yhteensä 8716
-rwxr-xr-x 1 root root    9580 maali  4 13:46 mapserv
lrwxrwxrwx 1 root root      29 touko 11 23:25 php -> /etc/alternatives/php-cgi-bin
-rwxr-xr-x 1 root root 8909932 huhti  9 20:26 php5

nm

  • Käyttäjä
  • Viestejä: 13362
    • Profiili
Vs: 14.04 cgi-bin oikeudet
« Vastaus #3 : 17.05.14 - klo:13.47 »
Tarkista myös itse hakemiston oikeudet. Onnistuu ls:n parametrilla -a:

Koodia: [Valitse]
ls -la /usr/lib/cgi-bin

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 10894
    • Profiili
    • Tomin kotisivut
Vs: 14.04 cgi-bin oikeudet
« Vastaus #4 : 17.05.14 - klo:13.48 »
Koodia: [Valitse]
yhteensä 8716
-rwxr-xr-x 1 root root    9580 maali  4 13:46 mapserv
lrwxrwxrwx 1 root root      29 touko 11 23:25 php -> /etc/alternatives/php-cgi-bin
-rwxr-xr-x 1 root root 8909932 huhti  9 20:26 php5

Ups. Tarkoitin:
Koodia: [Valitse]
ls -ld /usr/lib/cgi-bin
Luku ja suoritus oikeudet noilla tiedostoilla kuitenkin näyttäisi olevan eli ei pitäisi olla siitä kiinni.

Muoks: nm näköjään ehtikin korjailemaan komentoa. a-vipu hoitaa myös homman ja listaa myös tiedostojen oikeudet eli sen puoleen parempi.
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

JJK

  • Käyttäjä
  • Viestejä: 325
  • Ubuntu Mate 18.04
    • Profiili
Vs: 14.04 cgi-bin oikeudet
« Vastaus #5 : 17.05.14 - klo:13.51 »
Koodia: [Valitse]
ls -la /usr/lib/cgi-bin
yhteensä 8740
drwxr-xr-x   2 root root    4096 touko 11 23:25 .
drwxr-xr-x 153 root root   20480 touko 10 20:21 ..
-rwxr-xr-x   1 root root    9580 maali  4 13:46 mapserv
lrwxrwxrwx   1 root root      29 touko 11 23:25 php -> /etc/alternatives/php-cgi-bin
-rwxr-xr-x   1 root root 8909932 huhti  9 20:26 php5

Koodia: [Valitse]
ls -ld /usr/lib/cgi-bin
drwxr-xr-x 2 root root 4096 touko 11 23:25 /usr/lib/cgi-bin
« Viimeksi muokattu: 17.05.14 - klo:13.58 kirjoittanut JJK »

nm

  • Käyttäjä
  • Viestejä: 13362
    • Profiili
Vs: 14.04 cgi-bin oikeudet
« Vastaus #6 : 17.05.14 - klo:14.05 »
Ongelma saattaa johtua "Require all granted" -asetuksesta. Onko Apache varmasti päivittynyt versioon 2.4? Toimiiko vanhoilla asetuksilla:

Koodia: [Valitse]
       <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>


En saa käytettyä Mapserveriä uuden 14.04 asenuksen jälkeen.
Koodia: [Valitse]
You don't have permission to access /cgi-bin/ on this server.

cgi-bin-hakemiston sisällön listaukseen ei pidäkään olla oikeutta. Yritä avata suoraan kohde /cgi-bin/mapserv
« Viimeksi muokattu: 17.05.14 - klo:14.08 kirjoittanut nm »

JJK

  • Käyttäjä
  • Viestejä: 325
  • Ubuntu Mate 18.04
    • Profiili
Vs: 14.04 cgi-bin oikeudet
« Vastaus #7 : 17.05.14 - klo:14.13 »
Koodia: [Valitse]
ou don't have permission to access /cgi-bin/mapserv on this server.
Apache/2.4.7 (Ubuntu) Server at domain.org Port 80

Koneessa on puhdas 14.04 server asennus.

JJK

  • Käyttäjä
  • Viestejä: 325
  • Ubuntu Mate 18.04
    • Profiili
Vs: 14.04 cgi-bin oikeudet
« Vastaus #8 : 17.05.14 - klo:14.18 »

Tämä piti paikkansa. Nyt toimii.
Lainaus
Ongelma saattaa johtua "Require all granted" -asetuksesta.

Kiitos.