Kirjoittaja Aihe: Ubuntu serveri päivitys 13.10 - 14.04 fail [Ratkaistu]  (Luettu 1695 kertaa)

PaHa

  • Käyttäjä
  • Viestejä: 160
    • Profiili
Moi!

Päivittelin tuossa serveriä sunnuntaina ja kaikki meni hyvin kunnes tuli virheilmoitus:

ubuntu upgrade Error: GDBus.Error:org.freedesktop.DBus.Error.Spawn.PermissionsInvalid: The permission of the setuid helper is not correct

Ja asennus jymähti sitten siihen. Lopettaminen ei enää onnistunut vaan aina tultiin samaan tilaan.

Nyt serveriin ei pääse ssh:lla eikä webbipalvelin rullaa... Käynnistyksen jälkeen on musta ruutu ja ctrl-alt-f1:llä pääsee kuitenkin terminaaliin. Veikkaukseni on se että asennus on jäänyt jotenkin "kesken" ja jotain puuttuu... Googlaamalla en löytänyt mitään sellaista joka olisi auttanut asiaa meikäläisen osaamisella.

Jostain luin että 2d-desktop (jota tuo freedesktop ilmeisesti on) aiheuttaa ongelmia?

MItäs suosittelisitte jatkossa? Missään nimessä en haluaisi lähteä asentamaan puhtaalta pöydältä - niin paljon menisi oleellista uusiksi.

Voiko asennusta yrittää uudestaan? do-release upgrade kertoo että uusin versio on jo olemassa.

Pitäisikö source listasta poistaa ensin jotain? Ja/tai vaihtaa työpöytä toiseksi ennen uudelleen yritystä?

Heitelkää vinkkejä / kysymyksiä niin katson mitä palvelin vastaa. Meikäläisellä on sormi tällä hetkellä suussa...

apt-get install -f lähtee tekemään juttujansa mutta lopettaa erroriin: Cannot open pixbuf loader module....

ja lopuksi tuo sama error GDBus.......


Otsikkoa tarkennettu -Storck



« Viimeksi muokattu: 07.05.14 - klo:13.15 kirjoittanut PaHa »

nm

  • Käyttäjä
  • Viestejä: 12920
    • Profiili
Vs: Ubuntu päivitys 13.10 - 14.04 fail
« Vastaus #1 : 06.05.14 - klo:21.41 »
Mitä sanoo:

Koodia: [Valitse]
sudo apt-get update
sudo apt-get dist-upgrade

Entä jos yrität vielä asentaa työpöytäpaketit (jos ne ovat jääneet matkalle):

Koodia: [Valitse]
sudo apt-get install ubuntu-desktop
Luultavasti verkko ei kuitenkaan ole käynnissä. Tarkista komennoilla:

Koodia: [Valitse]
route -n
ifconfig

dhclientillä voisi saada jotain aikaan, jos eth0 näkyy ifconfigin listauksessa, mutta ping ei kulje:

Koodia: [Valitse]
sudo dhclient eth0


Voit yrittää käynnistää työpöytäympäristön uudelleen komennoilla

Koodia: [Valitse]
sudo stop lightdm
sudo start lightdm

X.org:n lokitiedostosta saattaisi selvitä jotain ongelmasta:

Koodia: [Valitse]
cat /var/log/Xorg.0.log

PaHa

  • Käyttäjä
  • Viestejä: 160
    • Profiili
Vs: Ubuntu päivitys 13.10 - 14.04 fail
« Vastaus #2 : 06.05.14 - klo:23.11 »
sudo apt-get update antaa lopussa virheen:

Koodia: [Valitse]
Ign http://fi.archive.ubuntu.com trusty-updates/universe Translation-en_US
Fetched 142 kB in 3s (43.9 kB/s)
Error: GDBus.Error:org.freedesktop.DBus.Error.Spawn.PermissionsInvalid: The permission of the setuid helper is not correct

sudo apt-get upgrade:

 sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libpam-smbpass : Depends: samba-common (= 2:3.6.18-1ubuntu3.2) but 2:4.1.6+dfsg-1ubuntu2 is installed
 libsmbclient : Depends: samba-libs (= 2:4.1.6+dfsg-1ubuntu2) but it is not installed
 python-samba : Depends: samba-libs (= 2:4.1.6+dfsg-1ubuntu2) but it is not installed
 samba : Depends: samba-libs (= 2:4.1.6+dfsg-1ubuntu2) but it is not installed
         Recommends: attr but it is not installed
         Recommends: samba-vfs-modules but it is not installed
 samba-common-bin : Depends: samba-libs (= 2:4.1.6+dfsg-1ubuntu2) but it is not installed
 samba-dsdb-modules : Depends: samba-libs (= 2:4.1.6+dfsg-1ubuntu2) but it is not installed
 smbclient : Depends: samba-libs (= 2:4.1.6+dfsg-1ubuntu2) but it is not installed
E: Unmet dependencies. Try using -f.

 sudo apt-get install ubuntu-desktop
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libpam-smbpass : Depends: samba-common (= 2:3.6.18-1ubuntu3.2) but 2:4.1.6+dfsg-1ubuntu2 is to be installed
 libsmbclient : Depends: samba-libs (= 2:4.1.6+dfsg-1ubuntu2) but it is not going to be installed
 python-samba : Depends: samba-libs (= 2:4.1.6+dfsg-1ubuntu2) but it is not going to be installed
 samba : Depends: samba-libs (= 2:4.1.6+dfsg-1ubuntu2) but it is not going to be installed
         Recommends: attr but it is not going to be installed
         Recommends: samba-vfs-modules but it is not going to be installed
 samba-common-bin : Depends: samba-libs (= 2:4.1.6+dfsg-1ubuntu2) but it is not going to be installed
 samba-dsdb-modules : Depends: samba-libs (= 2:4.1.6+dfsg-1ubuntu2) but it is not going to be installed
 smbclient : Depends: samba-libs (= 2:4.1.6+dfsg-1ubuntu2) but it is not going to be installed
 ubuntu-desktop : Depends: ubuntu-session but it is not going to be installed
                  Recommends: cheese but it is not going to be installed
                  Recommends: fonts-droid but it is not going to be installed
                  Recommends: python3-aptdaemon.pkcompat but it is not going to be installed
                  Recommends: totem but it is not going to be installed
                  Recommends: totem-mozilla but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Tämä herjaa tulee kokoajan kun ajaa apt-get install -f

https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/1282276

mutta kun ajan komennon niin:
Koodia: [Valitse]
gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
-bash: /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache: No such file or directory
Tällaisen löysin googlaamalla: http://askubuntu.com/questions/450109/when-attempting-upgrade-from-13-10-to-14-04-upgrade-halted-and-will-not-allow-2n

Ja tuosta ohje: Basically, you should rename /var/lib/samba/secrets.tdb to something like /var/lib/samba/secrets.tdb.old and then try the sudo apt-get install -f

Nyt näyttää asennus ainakin etenevän... katsotaan miten käy...

edit: Nyt on up & running mutta apt-get install -f jäi "jumiin" Found kernel /boot/memtest86+.bin kohtaan. Ctrl-c saa sen kyllä stopattua mutta herjaa sitten... kun ajaa apt-get updaten
Koodia: [Valitse]
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

Lisätty code-tagit. -- Timo
« Viimeksi muokattu: 07.05.14 - klo:14.00 kirjoittanut Timo Tamminen »

PaHa

  • Käyttäjä
  • Viestejä: 160
    • Profiili
Vs: Ubuntu serveri päivitys 13.10 - 14.04 fail
« Vastaus #3 : 07.05.14 - klo:10.53 »
Nyt alkaa olemaan sen verran tosiaan valoa tunnelin päässä että palvelin nousee pystyyn ja palvelut ylös.

Päivitettäviä paketteja olisi kuitenkin aika paljon ja niitä en pysty ajamaan koska ubuntu ilmoittaa että dpkg prosessi jäi viimeksi kesken.

dpkg --configure -a jää jumiin siis ao. mukaisesti:

Koodia: [Valitse]
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-3.11.0-20-generic
Found kernel: /boot/vmlinuz-3.11.0-19-generic
Found kernel: /boot/vmlinuz-3.11.0-17-generic
Found kernel: /boot/vmlinuz-3.11.0-15-generic
Found kernel: /boot/vmlinuz-3.5.0-23-generic
Found kernel: /boot/vmlinuz-3.2.0-30-generic
Found kernel: /boot/vmlinuz-2.6.38-8-generic
Found kernel: /boot/vmlinuz-2.6.35-22-generic
Found kernel: /boot/vmlinuz-2.6.32-22-generic
Found kernel: /boot/memtest86+.bin
^Cdpkg: error processing package mdadm (--configure):
 subprocess installed post-installation script was interrupted
Setting up python-simplejson (3.3.1-1ubuntu6) ...
Setting up libmimic0 (1.0.4-2.1ubuntu1) ...

Eli tuohon Found kernel: /boot/memtest86+.bin mutta se ei olekaan se kohta johon homma jumittaa vaan tuohon:

error processing package mdadm (--configure):

Mitenköhän tuon korjaisi? uname -r kertoo: 3.11.0-20-generic

Tämmöisen olen löytänyt googlaamalla http://askubuntu.com/questions/455975/14-04-dpkg-found-kernel-memtest86-bin-issue olen löytänyt...

Ja tämmöistä bugiraporttia..: https://bugs.launchpad.net/ubuntu/+source/mdadm/+bug/1285312

Nyt olen hieman sormi kuitenkin suussa että mitä pitäisi tehdä...

Valoa tunnelin päässä!! Grub upgrade näyttäisi auttavan...

https://help.ubuntu.com/community/Grub2/Upgrading
« Viimeksi muokattu: 07.05.14 - klo:11.38 kirjoittanut PaHa »

lompolo

  • Käyttäjä
  • Viestejä: 849
    • Profiili
Vs: Ubuntu serveri päivitys 13.10 - 14.04 fail
« Vastaus #4 : 07.05.14 - klo:11.35 »
Vanha grub1 ja mdadm..

https://bugs.launchpad.net/ubuntu/+source/mdadm/+bug/1285312

Onko raid käytössä?

PaHa

  • Käyttäjä
  • Viestejä: 160
    • Profiili
Vs: Ubuntu serveri päivitys 13.10 - 14.04 fail
« Vastaus #5 : 07.05.14 - klo:11.43 »
Kyllä kyllä ja kyllä... Ajoin update grub ja nyt näyttäisi paremmalta... Katsotaan miten dist-upgrade menee nyt loppuun.

Ainakaan apt-get update & upgrade enää herjannut...

PaHa

  • Käyttäjä
  • Viestejä: 160
    • Profiili
Vs: Ubuntu serveri päivitys 13.10 - 14.04 fail [Ratkaistu]
« Vastaus #6 : 07.05.14 - klo:13.17 »
Ongelma ratkesi kun päivitin Grubin tällä https://help.ubuntu.com/community/Grub2/Upgrading ohjeella.

Sen jälkeen dist-upgrade ja homma pelittää.

Kiitos vastauksista ja kommenteista!