Kirjoittaja Aihe: python3 ja uusin 14.04  (Luettu 9552 kertaa)

seniori

  • Käyttäjä
  • Viestejä: 83
    • Profiili
python3 ja uusin 14.04
« : 02.04.14 - klo:17.37 »
Latasin ja asensin ubuntu 14.04 beta-version vain nähdäkseni mitkä ohjelmien versiot on otettu mukaan.
Luulin ,että python3 piti tulla oletuksena tähän uusimpaan ubuntuun mutta se näyttääkin olevan 2.7.6.
Onkohan kovin vaikeaa asentaa python 3 tämän python276 tilalle tai rinnalle?
Ubuntu 13.10 koneella  kun käytin idle3:sta, niin  valittaa, että ei löydä moduulia sympy vaikka olisin sen juuri hakenut pakettivarastosta (ilmeisesti sain sieltä kakkosversion idleen ja pythoniin sopivan sympyn). Hain paketin synapticilla, saisiko sen jotenkin muutenkin?
Positiivistakin: Ubuntu 13.10 kanssa oli nettiongelma, jossa (wifi) yhteys katkesi vähän väliä mutta tässä uudessa yhteys näyttää pysyvän päällä.
Tarvitsisin siis kolmosversion pythonin, kolmosversioon sopivan idlen (tässä ei ongelmaa) ja kolmosversioon sopivan sympyn (mm. moduulit math ja  random näyttävät toimivan idle3 version ohjelmakoodissa hyvin, mutta sympy ei)

shelby

  • Käyttäjä
  • Viestejä: 1860
    • Profiili
Vs: python3 ja uusin 14.04
« Vastaus #1 : 02.04.14 - klo:18.56 »
Ei ole viel lopullinen, vuottele. ;D
Kubu 19.04 test
Win 8.1 laptop I
Win 10 laptop II
Ubu Unity 18.04.1 LTS
Ubu Gnome 18.04 LTS

raimo

  • Käyttäjä
  • Viestejä: 3276
    • Profiili
Vs: python3 ja uusin 14.04
« Vastaus #2 : 02.04.14 - klo:19.09 »
http://packages.ubuntu.com/trusty/python3
Asentunee ihan näin:
Koodia: [Valitse]
sudo apt-get install python3
So long and thanks for all the fish!

seniori

  • Käyttäjä
  • Viestejä: 83
    • Profiili
Vs: python3 ja uusin 14.04
« Vastaus #3 : 02.04.14 - klo:20.17 »
Kiitos vastauksista.
Käyttöjärjestelmä on ubuntu 14.04 beta32 bit .
Asensin siis aiemmin idlen version 3 ja ajoin, jolloin se väitti käyttävänsä pythonin versiota 2.7.6. Nyt ajoin  uudestaan , ja se näyttikin käyttävän python 3.4.0 versiota, hienoa (tosin aika outoa)! Ubuntu 14.04 on koneen ainoa käyttöjärjestelmä.
Hain synapticista python-sympyn mutta se ei näytä toimivan. Asensin scipyn ja se näyttää toimivan hyvin. Ehkä sympy tulee kuntoon,kun odottelen sinne 14.04 julkaisuun asti?