Kirjoittaja Aihe: Nelonen Ruutu toimimaan.  (Luettu 25132 kertaa)

Jukki

  • Käyttäjä
  • Viestejä: 407
    • Profiili
Vs: Nelonen Ruutu toimimaan.
« Vastaus #20 : 12.03.14 - klo:16.54 »
Kiitos salai. Laitoin nuo rimpsut. Ruutu ei lähtenyt vielä pyörimään. Näyttäisi olevan vielä vanha  Shockwave Flash 11.2 r202 libflashplayer.so  tuolla lisäosien hallinnassa päällä. Uusi Shockwave Flash 12.0 r.0 libpipelight-flash.so on myös päällä. Mites tuo toinen plugin poistetaan käytöstä?

Ylen areena ja TV7.fi näyttäisi toimivan edelleen näistä toimenpiteistä huolimatta ja käyttää vanhaa Shockwave Flash 11.2 r202-pluginia.
« Viimeksi muokattu: 12.03.14 - klo:16.58 kirjoittanut Jukki »

salai

  • Käyttäjä
  • Viestejä: 2126
    • Profiili
Vs: Nelonen Ruutu toimimaan.
« Vastaus #21 : 12.03.14 - klo:18.35 »
Kiitos salai. Laitoin nuo rimpsut. Ruutu ei lähtenyt vielä pyörimään. Näyttäisi olevan vielä vanha  Shockwave Flash 11.2 r202 libflashplayer.so  tuolla lisäosien hallinnassa päällä. Uusi Shockwave Flash 12.0 r.0 libpipelight-flash.so on myös päällä. Mites tuo toinen plugin poistetaan käytöstä?

Ylen areena ja TV7.fi näyttäisi toimivan edelleen näistä toimenpiteistä huolimatta ja käyttää vanhaa Shockwave Flash 11.2 r202-pluginia.
Ei sitä Ubuntun versiota poisteta käytöstä, vaan se pitää poistaa kokonaan, joko synapticin kautta tai komentoriviltä.

Ainakin seuraavien komentojen pitäisi kai poistaa molemmat vaihtoehdot Ubuntun tarjoamista:
Koodia: [Valitse]
sudo apt-get purge flashplugin-installer
sudo apt-get purge adobe-flashplugin

Jukki

  • Käyttäjä
  • Viestejä: 407
    • Profiili
Vs: Nelonen Ruutu toimimaan.
« Vastaus #22 : 12.03.14 - klo:22.50 »
Sain tuon ubuntun flash-playerin poistettua ohjeillasi. Nyt näkyy vain pipelight flash-plugin 12.0.0.77. Nyt ei vaan yksikään flahs-video käynnisty vaan tulee virheilmoitus "Liitännäinen adobe flash kaatui".

MTV-katsomo ei myöskään näy. Tulee ikkuna joka sanoo "Asenna Silverlight"

Onko joku saanut tuon pipelightin toimimaan?

nm

  • Käyttäjä
  • Viestejä: 14970
    • Profiili
Vs: Nelonen Ruutu toimimaan.
« Vastaus #23 : 12.03.14 - klo:23.33 »
Sain tuon ubuntun flash-playerin poistettua ohjeillasi. Nyt näkyy vain pipelight flash-plugin 12.0.0.77. Nyt ei vaan yksikään flahs-video käynnisty vaan tulee virheilmoitus "Liitännäinen adobe flash kaatui".

Sulje kaikki selainikkunat ja käynnistä firefox päätteessä. Yritä sitten katsella jotain Flash-sisältöä. Tuleeko päätteeseen mitään aiheeseen liittyviä virheilmoituksia?

MTV-katsomo ei myöskään näy. Tulee ikkuna joka sanoo "Asenna Silverlight"

Jos seurasit salain ohjetta, siinä kytkettiin vain Flash Player käyttöön. Silverlightin saat päälle komentamalla lisäksi:

Koodia: [Valitse]
sudo pipelight-plugin --enable silverlight

Onko joku saanut tuon pipelightin toimimaan?

Daneli ja salai kuulemma. :)

Jukki

  • Käyttäjä
  • Viestejä: 407
    • Profiili
Vs: Nelonen Ruutu toimimaan.
« Vastaus #24 : 13.03.14 - klo:00.24 »
MTVn katsomo alkoi toimia tuolla rimpsulla. Tänks män.

Flash-videot ei toimi. Käynnistäessä Firefoxin tulee päätteeseen tämmöistä...

Koodia: [Valitse]
kaarina@kaarina-HP-Pavilion-dv5-Notebook-PC:~$ firefox
[PIPELIGHT:LIN:unknown] attached to process.
[PIPELIGHT:LIN:unknown] checking environment variable PIPELIGHT_FLASH_CONFIG.
[PIPELIGHT:LIN:unknown] searching for config file pipelight-flash.
[PIPELIGHT:LIN:unknown] trying to load config file from '/home/kaarina/.config/pipelight-flash'.
[PIPELIGHT:LIN:unknown] trying to load config file from '/etc/pipelight-flash'.
[PIPELIGHT:LIN:unknown] trying to load config file from '/usr/share/pipelight/configs/pipelight-flash'.
[PIPELIGHT:LIN:unknown] sandbox not found or not installed!
[PIPELIGHT:LIN:flash] using wine prefix directory /home/kaarina/.wine-pipelight/.
[PIPELIGHT:LIN:flash] checking plugin installation - this might take some time.
[install-dependency] wine-flash-installer is already installed in '/home/kaarina/.wine-pipelight/'.
wine: cannot find L"C:\\windows\\system32\\winemenubuilder.exe"
err:wineboot:ProcessRunKeys Error running cmd L"C:\\windows\\system32\\winemenubuilder.exe -a -r" (2)
[PIPELIGHT:WIN:flash] Read dllPath 'C:\windows\system32\Macromed\Flash' and dllName 'NPSWF32_12_0_0_70.dll' from registry
[PIPELIGHT:WIN:flash] embedded mode         is on.
[PIPELIGHT:WIN:flash] windowless mode       is off.
[PIPELIGHT:WIN:flash] linux windowless mode is off.
[PIPELIGHT:WIN:flash] force SetWindow       is off.
[PIPELIGHT:WIN:flash] unity hacks           is off.
[PIPELIGHT:WIN:flash] window class hook     is on.
[PIPELIGHT:WIN:flash] replaced API function CreateWindowExA.
[PIPELIGHT:WIN:flash] replaced API function CreateWindowExW.
[PIPELIGHT:WIN:flash] replaced API function TrackPopupMenuEx.
[PIPELIGHT:WIN:flash] replaced API function TrackPopupMenu.
err:mscms:DllMain Wine was built without support for liblcms2, expect problems
[PIPELIGHT:WIN:flash] init successful!
[PIPELIGHT:LIN:flash] using timer based event handling.
[PIPELIGHT:LIN:flash] nppfunctions.c:436:NPP_New(): malformed argument 'PARAM' -> '(null)'
err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
[PIPELIGHT:WIN:flash] plugin instance switched windowless mode to on.
fixme:winediag:AUDDRV_GetAudioEndpoint Winepulse is not officially supported by the wine project
fixme:winediag:AUDDRV_GetAudioEndpoint For sound related feedback and support, please visit http://ubuntuforums.org/showthread.php?t=1960599

Kun klikkaa http://www.tv7.fi/ Netti-tv:n käyntiin tulee päätteeseen...

Koodia: [Valitse]
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  153 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  1551
  Current serial number in output stream:  1551
[PIPELIGHT:LIN:flash] ../common/common.c:183:receiveCommand(): unable to receive data.

nm

  • Käyttäjä
  • Viestejä: 14970
    • Profiili
Vs: Nelonen Ruutu toimimaan.
« Vastaus #25 : 13.03.14 - klo:01.12 »
Koodia: [Valitse]
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  153 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)

Vaikuttaa näytönohjaimen ajurin ongelmalta, eli X:n OpenGL-rajapinta GLX ei toimi. Mikä näytönohjain ja ajurin on käytössä? Mitä glxinfo kertoo päätteessä?

Jukki

  • Käyttäjä
  • Viestejä: 407
    • Profiili
Vs: Nelonen Ruutu toimimaan.
« Vastaus #26 : 13.03.14 - klo:01.58 »
Jotain tosiaan näkyy mättävän

Koodia: [Valitse]
kaarina@kaarina-HP-Pavilion-dv5-Notebook-PC:~$ glxinfo
name of display: :0.0
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  153 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  12
  Current serial number in output stream:  12

lspci sanoo näytönohjaimesta: 01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV620/M82 [Mobility Radeon HD 3450/3470]

aticonfig sanoo: No supported adapters detected
Catalyst Control Centerkään ei löydä näyttistä.

Voisiko tämä ajurivika liittyä vialliseen näytön kaapeliin. Näyttö välkkyy valkoisena aika ajoin - vika on pahentunut viime aikoina päivittäiseksi riesaksi.

« Viimeksi muokattu: 13.03.14 - klo:11.01 kirjoittanut Jukki »

nm

  • Käyttäjä
  • Viestejä: 14970
    • Profiili
Vs: Nelonen Ruutu toimimaan.
« Vastaus #27 : 13.03.14 - klo:16.28 »
lspci sanoo näytönohjaimesta: 01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV620/M82 [Mobility Radeon HD 3450/3470]

aticonfig sanoo: No supported adapters detected
Catalyst Control Centerkään ei löydä näyttistä.

Poista fglrx kokonaan. Nykyiset versiot eivät tue näytönohjaintasi lainkaan ja fglrx:n legacy-versioiden toimivuus nykyisissä jakeluissa on jokseenkin epävarmaa. Avoimen ajurin pitäisi toimia hyvin, kunhan järjestelmässä ei ole mitään fglrx-jämiä sotkemassa OpenGL:ää. Eli purgea fglrx:lle:

Koodia: [Valitse]
sudo apt-get purge "fglrx*"
Sitten uudelleenkäynnistys.

Jos olet asentanut Catalystin ilman fglrx-paketointia, poisto pitänee tehdä alkuperäisellä Catalyst-asennusskriptillä.


Voisiko tämä ajurivika liittyä vialliseen näytön kaapeliin. Näyttö välkkyy valkoisena aika ajoin - vika on pahentunut viime aikoina päivittäiseksi riesaksi.

Oletko paikallistanut ongelman nimenomaan kaapeliin, eli kuvaa tulee taas kuntoon, jos heilautat läppärin näyttöä (tai kaapelia, jos käytät ulkoista näyttöä)? Muuten vika voi olla myös näytönohjaimessa itsessään. Luultavasti tämä ei kuitenkaan vaikuta tuohon OpenGL-ongelmaan.

Eesaurus

  • Käyttäjä
  • Viestejä: 3291
    • Profiili
Vs: Nelonen Ruutu toimimaan.
« Vastaus #28 : 13.03.14 - klo:16.50 »
poistaa Ubuntun tarjoaman "virallisen" 11.2.* -flashpluginin

Ei kai tämä ole välttämätöntä, tai edes järkevää? Itse en ainakaan ole sitä poistanut, kun olen Pipelightin asentanut, ja homma on toiminut.

Jukki

  • Käyttäjä
  • Viestejä: 407
    • Profiili
Vs: Nelonen Ruutu toimimaan.
« Vastaus #29 : 13.03.14 - klo:18.42 »
Poistin catalystin sovellusvalikoimalla. Sitten tuon fglrxn prkln. Voila - nyt näkyy TV7, ruutu, Areena ja lisäbonuksena MTV Katsomo. Taas respektiä sulle nm. Kiitos muillekin avustanne.

kaapelissa se vika on ja pahenee. Kuvan saa näyttöön juurikin näyttöä kääntelemällä. Alkaa lahota koko kone.

heippa

  • Käyttäjä
  • Viestejä: 9
    • Profiili
Vs: Nelonen Ruutu toimimaan.
« Vastaus #30 : 13.03.14 - klo:19.52 »
Moi,
mulla on myös samantyylinen pulma tuon ruutu.fin kanssa. Kokeilin tätä:

Lainaus
Ruudun videot toimivat, kun poistaa Ubuntun tarjoaman "virallisen" 11.2.* -flashpluginin ja ottaa käyttöön uusimman (Windowsille tarkoitetun) flashplugin 12.0.* -version Pipelightin kautta.

ja nyt eri selaimilla ruutu.fin laitetesti näyttää erilaiselta, mutta mikään ei näytä toimivan kokonaan. :D

Näin:

Selain: Mozilla 27.0  Käytössäsi on tuettu versio selaimesta.
Flash-versio:12.0.0  Laitteellesi on asennettu tuettu Flashin versio
Yhteys mainospalvelimiin: lataa ja pohtii
Yhteys mediapalvelimeen: lataa ja pohtii

Selain: Chrome 26.0.1410.43  Käytössäsi on tuettu versio selaimesta.
Flash-versio:11.6.602  Laitteellasi ei ole asennettuna tuettua Flashin versiota.
Yhteys mainospalvelimiin: Onnistui
Yhteys mediapalvelimeen:Onnistui

Selain: Chrome 32.0.1700.107 Käytössäsi on tuettu versio selaimesta.
Flash-versio:12.0.0  Laitteellesi on asennettu tuettu Flashin versio (ohessa kuvake kaatuneesta flashista)
Yhteys mainospalvelimiin: lataa ja pohtii
Yhteys mediapalvelimeen: lataa ja pohtii


Nuo laitetestit on myös sitä mieltä, että internetini on liian hidas, mutta kyllä sen nopeuden pitäisi tähän riittää.

Kysymys: Miten saan Chromeen 12. version flashista? Sit tuo saattais näkyä. Chromiumissa flashit kaatuu jo alkutekijöissä, joten ehkä vain poistan sen selaimen kokonaan.


EDIT: vai onkohan tuo yhteys hukassa mainos- ja mediapalvelimiin  juuri sen takia, että tuettu Flashin versio on asennettu? Nuo "lataa ja pohtii" -merkinnät siis viittaa siihen, että siinä vain pyörii semmoinen pallura, joka ei pääse mihinkään lopputulokseen.
« Viimeksi muokattu: 13.03.14 - klo:20.00 kirjoittanut heippa »

salai

  • Käyttäjä
  • Viestejä: 2126
    • Profiili
Vs: Nelonen Ruutu toimimaan.
« Vastaus #31 : 13.03.14 - klo:19.57 »
poistaa Ubuntun tarjoaman "virallisen" 11.2.* -flashpluginin

Ei kai tämä ole välttämätöntä, tai edes järkevää? Itse en ainakaan ole sitä poistanut, kun olen Pipelightin asentanut, ja homma on toiminut.
Tämän ketjun aiheena oli kai Nelosen Ruudun ongelmat?

En minä ainakaan saanut sitä (tässä Lubuntu 13.10:ssä) toimimaan, jos en vaihtanut virallista 11.2.* flashplayer - versiota Pipelightin tarjoamaan 12.0.*. -flashiin. Viimeksihän ongelmaan auttoi (12.04 ja 13.04 -pohjaisissa systeemeissä) hal:lin asentaminen: DRM-suojatut flash-videot . . ..

Itse asiassa tuo näyttäisi korjaavan hal:lin poiston aiheuttamat DRM-ongelmat muillakin sivustoilla.  Täytyy testata tuota lisää täysin puhtaalla asennuksella ja useammalla selaimella. Nyt testissä oli Firefox, Chromium ja Maxthon Linux 0.9.3.0 (beta).

mrl586

  • Käyttäjä
  • Viestejä: 4638
    • Profiili
Vs: Nelonen Ruutu toimimaan.
« Vastaus #32 : 13.03.14 - klo:20.01 »
Kysymys: Miten saan Chromeen 12. version flashista? Sit tuo saattais näkyä.
Avainsana on pepper flash.

salai

  • Käyttäjä
  • Viestejä: 2126
    • Profiili
Vs: Nelonen Ruutu toimimaan.
« Vastaus #33 : 13.03.14 - klo:21.02 »
Kysymys: Miten saan Chromeen 12. version flashista? Sit tuo saattais näkyä.
Avainsana on pepper flash.
Kun ei auta  tuokaan avainsana.

Poistin kaikki Lubuntu 13.10:stä kaikki flashplayerit  (ja myös Pipelightin) kokonaan. Sitten asensin Googlen sivulta Chrome 33.0.1750.149 -version. Se asensi itselleen libpepflashplayer.so 12.0.0.77 -version.

Nelosen Ruutu ei toimi tuolla yhdistelmällä. Videoikkunassa vain vilahtaa sana "Lataa . . .", eikä muuta. Ei tuolla pepperillä mennyt Problems playing protected video content | Ubuntu Linux, Flash Player 11tai Makuuni -testitkään läpi.

EDIT: Asensin sitten pipelightin ja otin flash ja silverlight-pluginit käyttöön. Nimesin Chromen plugin-hakemiston (/opt/google/chrome/PepperFlash) uudelleen estääkseni pepperflashin toiminnat. Chrome ei kuitenkaan ymmärrä tuota Windowsille tarkoitettua flashplayeriä, joten piti palata pepperflashiin.

Tilanne tällä hetkellä (Lubuntu 13.10):
Ruutu toimii pipelightin flash-versiolla Firefoxissa ja Chromiumissa, Chromen Linux-versiolla ei mitenkään (EDIT: toimii poistamalla käytöstä pepper flash).

Katsomo toimii pipelightin silverlightilla Firefoxissa suoraan ilman virityksiä, Chromiumissa ja Chromessa jää lataamaan loputtomasti - ilmeisesti vaatisi jotain user-agent-virityksiä?

Flash/DRM testit menevät läpi Firefoxissa ja Chromiumissa pipelightin flashillä. Chromen pepperflash ei toimi.

Tuo Chromen Linux-version pepperflash ei ratkaise yhtään ongelmaa.

EDIT2: Tuo pepper flashin kelvottomuus on helposti tarkistettavista ottamalla se käyttöön Chromiumissa tuon ohjeen mukaan: Install Pepper Flash Player For Chromium In Ubuntu Via PPA ~ Web Upd8: Ubuntu / Linux blog.
Välittömästi loppuvat DRM-flashit toimimasta.
« Viimeksi muokattu: 14.03.14 - klo:00.17 kirjoittanut salai »

zordo

  • Käyttäjä
  • Viestejä: 170
    • Profiili
Vs: Nelonen Ruutu toimimaan.
« Vastaus #34 : 13.03.14 - klo:21.29 »
Täältä vinkkaisin XBMC:n pluginin puoleen, mutta siinä ei pelitä kelaaminen. ...eikä mainokset...
Core I5 2500K  GTX970 ubuntu 14.10

nm

  • Käyttäjä
  • Viestejä: 14970
    • Profiili
Vs: Nelonen Ruutu toimimaan.
« Vastaus #35 : 13.03.14 - klo:21.58 »
Linux.fi:n wikiartikkelissa on päivitetty rtmpdump-skripti, jolla videoita voi ladata Ruudusta ja katsella sitten levyltä millä tahansa mediasoittimella.
« Viimeksi muokattu: 13.03.14 - klo:22.01 kirjoittanut nm »

salai

  • Käyttäjä
  • Viestejä: 2126
    • Profiili
Vs: Nelonen Ruutu toimimaan.
« Vastaus #36 : 13.03.14 - klo:22.45 »
Linux.fi:n wikiartikkelissa on päivitetty rtmpdump-skripti, jolla videoita voi ladata Ruudusta ja katsella sitten levyltä millä tahansa mediasoittimella.
Tuohon videoon (http://www.ruutu.fi/ohjelmat/poliisit/kausi-6-jakso-40-vantaa)  ilmestyy sotkuja säännöllisin väliajoin. Sotkut näyttivät poistuvan, kun muutin skriptistä viimeisen rivin tuollaiseksi:
Koodia: [Valitse]
rtmpdump -v -r  "$STREAMURL" -o $NAME.flv

salai

  • Käyttäjä
  • Viestejä: 2126
    • Profiili
Vs: Nelonen Ruutu toimimaan.
« Vastaus #37 : 13.03.14 - klo:23.25 »
Palataanpa tuohon Chromen "avainsana pepper flashiin" vielä.

Chromessa voi lennossa vaihtaa osoitteessa chrome://plugins/, mitä pluginia se käyttää.
Kunhan vain älyää klikata sivun oikeasta ylälaidasta + Tiedot esiin.
EDIT: Lähde ohjeelle Chromen pluginien vaihdosta: Disable PepperFlash in Chrome - Enounce

Jos käytössä on Chromen oma pepperflash 12.0.0.77
 (/opt/google/chrome/PepperFlash/libpepflashplayer.so), eivät mitkään DRM flash-videot näytä toimivan.

Jos käyttöön vaihtaa pipelightin tarjoaman Windowsille tarkoitetun flashin 12.0 r0
 /usr/lib/pipelight/libpipelight-flash.so, toimivat DRM flash-videot, kuten esim. tuo: Makuuni testi tai käsittelyn alla olevat Ruudun videot.

Tässä kuvakaappaus Chromen flashplugin-valinnasta, jolla Ruutu ym. DRM-flashit toimivat (ainakin tällä hetkellä):



EDIT2:
Sama pluginien vaihto toimii myös Chromiumissa, jos siinä on otettu käyttöön pepper flash aikaisemmin kertomallani tavalla. Kuten myös Maxthon For Linuxissa, joka lataa itselleen tuon virallisen 11.2.* version, joka ei tue DRM-flashejä.


 
« Viimeksi muokattu: 14.03.14 - klo:00.06 kirjoittanut salai »

Cultor

  • Käyttäjä
  • Viestejä: 169
    • Profiili
Vs: Nelonen Ruutu toimimaan.
« Vastaus #38 : 14.03.14 - klo:15.07 »
Linux.fi:n wikiartikkelissa on päivitetty rtmpdump-skripti, jolla videoita voi ladata Ruudusta ja katsella sitten levyltä millä tahansa mediasoittimella.

Taitokoneen ohjeilla sain tallennettua Ffmpeg'illä pakaten samantien mp4-säiliöön.
Koodia: [Valitse]
ffmpeg.exe -i %1 -acodec copy -vcodec copy tallenne.mp4
Katselu streematen onnistuu sekä VLC:llä että K Movie Player'illä (ffplay os2), myös rtmp protokollalla. Selaaminen ei toimi kummallakaan.
Koodia: [Valitse]
rtmp://stream.nelonen.fi/video/mp4:carbon_539389_catchup_360p_none.mp4: error while seeking

salai

  • Käyttäjä
  • Viestejä: 2126
    • Profiili
Vs: Nelonen Ruutu toimimaan.
« Vastaus #39 : 16.03.14 - klo:11.00 »
Näköjään Ruudun videot toimivat taas Firefoxissa, Maxthonissa, Chromiumissa ja Chromessa myös virallisella flashpluginilla 11.2.202.346. Myös pepperflash 12.0.0.77 näyttää Ruudun videot.

DRM-flashit vaativat edelleen pipelightin flashplayerin.
EDIT: Tai sitten HAL:lin asentamisen PPA:sta, kuten kerroin tuolla: Ylen areena ei kaikilta osin toimi mm. Linuxissa?
« Viimeksi muokattu: 16.03.14 - klo:11.32 kirjoittanut salai »