Kirjoittaja Aihe: Käynnistysongelma emo rikki - ääretöntä tumpelointia [RATKAISTU]  (Luettu 3371 kertaa)

valtsu68

  • Käyttäjä
  • Viestejä: 453
  • Aloitteleva peruskäyttäjä
    • Profiili
Tere
Koodia: [Valitse]
sudo grub-install --boot-directory=/mnt/boot /dev/sda Tuollaisen loitsun nakkasin päätteeseen hiukan harkitsemattomasti.

Loitsu oli kopioitu ohjeesta http://wiki.ubuntu-fi.org/Grub2-kaynnistyslataaja

Niitä edeltäviä vaiheita en tehnyt, koska ajattelin, siis en ajatellut varmaan riittävästi...

Riittäneekö nyt, että muutan BIOSista boottijärjestystä, (kunhan olen keksinyt BIOSin salasanan tai nollannut sen jumppereilla...  :-[ :-[ ).

Vai meneekö homma kertaluokkaa vaikeammaksi ja pitää keksiä, mitä nyt avautuvaan päätteen tapaiseen tulisi kirjoittaa?

Toivottavasti tällainen tumpelointi toimii varoittavana esimerkkinä kaikille lukijoille. Eli mitä opimme tästä?
1. Ajattele --> toimi, EI toimi --> kadu
2. Kiire --> älä edes aloita
3. Kirjoita salasanat paperille muistiin, äläkä hukkaa paperia...
4. ..... jne
« Viimeksi muokattu: 23.12.13 - klo:23.02 kirjoittanut valtsu68 »

juyli

  • Vieras
Koodia: [Valitse]
sudo grub-install --boot-directory=/mnt/boot /dev/sda Tuollaisen loitsun nakkasin päätteeseen hiukan harkitsemattomasti.

Hmmm... Sinun pitäisi ensin tarkistaa, mikä on BIOS:ssa määritelty käynnistyväksi levyksi, jonka MBR:ään grub:ia asennat.
Jos järjestelmässäsi on useita kiintolevyjä, voi tuo olla "jokin muu" kuin /dev/sda. Esim. /dev/sdb, /dev,sdc jne.
Nykyisin nimenomaan käytettäneen UUID:tä määrittelemään levyosiot, jottei tarvitsisi määritellä kunkin kiintolevyn laitetiedostoa, joka voi olla toinen kuin BIOS:ssa määritelty.
Nykyisin käytössäoleva EFI/UEFI taas olisi jo sitten toinen juttu...
http://fi.wikipedia.org/wiki/Extensible_Firmware_Interface

Lisäys: Otsikon ntldr taas viittaa puhtaasti Windows-käyttöjärjestelmään. Windows tuskin käynnistyy ilman ntldr -tiedostoa halutulta levyosiolta.
http://support.microsoft.com/kb/320397/fi


« Viimeksi muokattu: 12.12.13 - klo:00.33 kirjoittanut juyli »

nm

  • Käyttäjä
  • Viestejä: 13701
    • Profiili
Tuollaisen loitsun nakkasin päätteeseen hiukan harkitsemattomasti.

Mikä ongelma seurasi tästä toimenpiteestä? Ubuntu ei käynnisty? Windows ei käynnisty (ntldr liittyy nimenomaan Windowsiin, kuten juyli totesi)? Et pääse GRUB-valikkoon edes pitämällä shift-näppäintä painettuna käynnistyksen aikana?

valtsu68

  • Käyttäjä
  • Viestejä: 453
  • Aloitteleva peruskäyttäjä
    • Profiili
Tere

Kiitos vastauksista.

Koodia: [Valitse]
sudo grub-install --boot-directory=/mnt/boot /dev/sda Tuollaisen loitsun nakkasin päätteeseen hiukan harkitsemattomasti.


Hmmm... Sinun pitäisi ensin tarkistaa, mikä on BIOS:ssa määritelty käynnistyväksi levyksi, jonka MBR:ään grub:ia asennat.
Jos järjestelmässäsi on useita kiintolevyjä, voi tuo olla "jokin muu" kuin /dev/sda. Esim. /dev/sdb, /dev,sdc jne.

Tuossa olikin varmaan yksi kohta jossa olisi ollut suotavaa pysähtyä miettimään. Laitteessani on olemassa toinen kiintolevy, joka taisi olla kytkettynäkin, mutta sitä ei käsittääkseni oltu määritetty.


Lisäys: Otsikon ntldr taas viittaa puhtaasti Windows-käyttöjärjestelmään. Windows tuskin käynnistyy ilman ntldr -tiedostoa halutulta levyosiolta.
http://support.microsoft.com/kb/320397/fi


Tuo ntldr:än hukkuminen oli alunperin syynä ronkkimisen aloittamiseen, keinot olivat hiukan hakusessa.

Tuollaisen loitsun nakkasin päätteeseen hiukan harkitsemattomasti.

Mikä ongelma seurasi tästä toimenpiteestä? Ubuntu ei käynnisty? Windows ei käynnisty (ntldr liittyy nimenomaan Windowsiin, kuten juyli totesi)? Et pääse GRUB-valikkoon edes pitämällä shift-näppäintä painettuna käynnistyksen aikana?


Uudelleenkäynnistyksessä näyttöön avautui mustalle taustalle lyhyt selostus ja pääterivi
Koodia: [Valitse]
grub >taidot loppuivatkin siihen.

Tänään illalla pääsin tänne foorumille ja löysin ketjun http://forum.ubuntu-fi.org/index.php?topic=37297.0 , josta noukin Oobetimerin jakamat komennot
Lainaus
grub>ls
grub>root (hd0,1)
grub>configfile /boot/grub/grub.cfg
joita käyttämällä sain järjestelmän käyntiin.

Nyt olisi mahdollista laittaa oikeaa loitsua päätteeseen; pitää antaa koneen olla käynnissä siihen asti, että ongelma on todennäköisesti ratkennut.

Jotakin muutakin häiriötä laitteessani taitaa olla. Jumpperia käyttämällä sain nollattua asettamani salasanan, luonnollisesti muutkin BIOS-asetukset hävisivät. Pari kuukautta sitten vaihdoin CMOS-pariston, kun se todennäköisesti oli tyjhennyt. CMOS-tarkistussummasta valitti ja käynnistäessä vain laite lähti käyntiin, sammuakseen hetken kuluttua yrittämättä ollenkaan käynnistää käyttistä. Nyt tilanne on sama.

Kun nollaa jumpperia käyttämällä BIOSin ja käynnistää laitteen BIOS toimii normaalisti, antaa valituksen CMOS-tarkistussummasta, boottijärjestyksen säädön jälkeen F10, laitteen käynnistys, lähtee käyntiin, sammuakseen hetken kuluttua yrittämättä ollenkaan käynnistää käyttistä.

Toisella tavalla sain aikaan saman tuloksen:

Lisäsin muistia ja käynnistin laitteen, BIOS toimi normaalisti, antoi valituksen CMOS-tarkistussummasta, boottijärjestyksen säädön jälkeen F10, laitteen käynnistys, lähti käyntiin, sammuakseen hetken kuluttua yrittämättä ollenkaan käynnistää käyttistä.

Kiintolevyn lisääminenkin sai aikaan saman efektin kuin muistin lisääminen.

Yhdellä näistä yrityksistä laite oikeasti boottasi, pääsin gruppiin(?) ja tästä voikin palata noihin edellä lainattuihin komentoihin.

Tuota Shiftin painamista en ollut kuullutkaan aikaisemmin Linux-puolella, vuosia sitten eräs taitava kaveri neuvoi vastaavaa XPn uudelleenkäynnistykseen; muistaakseni se siihen jotenkin liittyi.

nm

  • Käyttäjä
  • Viestejä: 13701
    • Profiili
Tänään illalla pääsin tänne foorumille ja löysin ketjun http://forum.ubuntu-fi.org/index.php?topic=37297.0 , josta noukin Oobetimerin jakamat komennot
Lainaus
grub>ls
grub>root (hd0,1)
grub>configfile /boot/grub/grub.cfg
joita käyttämällä sain järjestelmän käyntiin.

Nyt olisi mahdollista laittaa oikeaa loitsua päätteeseen; pitää antaa koneen olla käynnissä siihen asti, että ongelma on todennäköisesti ratkennut.

Tarvittava ohjelma on juuri grub-install ja levy on hyvin todennäköisesti /dev/sda, mutta voit tarkistaa asian komennoilla:

Koodia: [Valitse]
mount
cat /etc/fstab
sudo blkid

sudo blkid listaa kaikkien osioiden UUID:t, joihin fstabissa viitataan. Haluat todennäköisesti asentaa grubin sen levyn MBR:ään, jolla järjestelmän juuriosio sijaitsee. Sitten biosin boottiasetuksilla kyseinen levy asetetaan boottilevyksi.


Jos levy on /dev/sda, aiemmin käyttämäsi grub-install-komento on muuten ok, mutta jätä se --boot-directory=/mnt/boot määrittämättä. Tällöin grub-install käyttää oletuksena olevaa ja oikeaa /boot-hakemistoa. Eli näin:

Koodia: [Valitse]
sudo grub-install /dev/sda


Jotakin muutakin häiriötä laitteessani taitaa olla. Jumpperia käyttämällä sain nollattua asettamani salasanan, luonnollisesti muutkin BIOS-asetukset hävisivät. Pari kuukautta sitten vaihdoin CMOS-pariston, kun se todennäköisesti oli tyjhennyt. CMOS-tarkistussummasta valitti ja käynnistäessä vain laite lähti käyntiin, sammuakseen hetken kuluttua yrittämättä ollenkaan käynnistää käyttistä. Nyt tilanne on sama.

Jos sama jatkuu, tarkista emolevyn manuaalista, että jumpperi on nyt oikeassa paikassa, eikä enää aiheuta nollautumista. Tarkista myös paristo. Ehkä siinä on kosketushäiriö, eli ota ainakin paristo kokonaan irti ja laita takaisin.


Tuota Shiftin painamista en ollut kuullutkaan aikaisemmin Linux-puolella, vuosia sitten eräs taitava kaveri neuvoi vastaavaa XPn uudelleenkäynnistykseen; muistaakseni se siihen jotenkin liittyi.

Windows XP:ssä shiftillä kai ohitetaan työpöydällä automaattisesti käynnistettäviksi määriteltyjen ohjelmien suorittaminen. Boottivalikkoon taas on Windows 95:stä lähtien päässyt F8:lla, mutta W8:ssa se taitaa olla joskus hankalampaa.
« Viimeksi muokattu: 13.12.13 - klo:00.17 kirjoittanut nm »

valtsu68

  • Käyttäjä
  • Viestejä: 453
  • Aloitteleva peruskäyttäjä
    • Profiili
Tarvittava ohjelma on juuri grub-install ja levy on hyvin todennäköisesti /dev/sda, mutta voit tarkistaa asian komennoilla:

Koodia: [Valitse]
mount

Mount-käsky antoi seuraavan tulosteen. Lihavoidut rivit lienevät merkityksellisimpiä.
Koodia: [Valitse]
[b]/dev/sda2 on / type ext4 (rw,errors=remount-ro)[/b]
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home//.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=)
[b]/dev/sr0 on /media/Ubuntu 12.04.1 LTS i386 type iso9660 [/b](ro,nosuid,nodev,uid=1000,gid=1000,iocharset=utf8,mode=0400,dmode=0500,uhelper=udisks)

Koodia: [Valitse]
cat /etc/fstab

sudo blkid listaa kaikkien osioiden UUID:t, joihin fstabissa viitataan.

Tuolla käskyllä tuloste näyttää tältä:
Koodia: [Valitse]
/dev/sda1: UUID="442C7C972C7C85A8" TYPE="ntfs"
/dev/sr0: LABEL="Ubuntu 12.04.1 LTS i386" TYPE="iso9660"
/dev/sda2: UUID="dbc5c9e5-deae-4cdb-8369-65618263dc5c" TYPE="ext4"
/dev/sda3: UUID="ce8cba19-fcc9-4688-ad09-fc77381f3055" TYPE="swap"

Näissä nyt ottaa silmään tuo sr0. Kun loitsuaa seuraavan:
Koodia: [Valitse]
cd media/Ubuntu\ 12.04.1\ LTS\ i386/
ja ls -l

niin näyttäisi olevan live-levyn tiedostot tuossa sijainnissa. Liekö jokin tumpelointi tuonkin takana? :-)

Koodia: [Valitse]
.            boot    dists     md5sum.txt  preseed             wubi.exe
..           casper  install   pics        README.diskdefines
autorun.inf  .disk   isolinux  pool        ubuntu

Jos levy on /dev/sda, aiemmin käyttämäsi grub-install-komento on muuten ok, mutta jätä se --boot-directory=/mnt/boot määrittämättä. Tällöin grub-install käyttää oletuksena olevaa ja oikeaa /boot-hakemistoa. Eli näin:

Koodia: [Valitse]
sudo grub-install /dev/sda

Nyt kun minulla on xp osiolla sda1, temp osiolla sda3, niin laitan näin (?):
Koodia: [Valitse]
sudo grub-install /dev/sda2
Jotakin muutakin häiriötä laitteessani taitaa olla. Jumpperia käyttämällä sain nollattua asettamani salasanan, luonnollisesti muutkin BIOS-asetukset hävisivät. Pari kuukautta sitten vaihdoin CMOS-pariston, kun se todennäköisesti oli tyjhennyt. CMOS-tarkistussummasta valitti ja käynnistäessä vain laite lähti käyntiin, sammuakseen hetken kuluttua yrittämättä ollenkaan käynnistää käyttistä. Nyt tilanne on sama.

Jos sama jatkuu, tarkista emolevyn manuaalista, että jumpperi on nyt oikeassa paikassa, eikä enää aiheuta nollautumista. Tarkista myös paristo. Ehkä siinä on kosketushäiriö, eli ota ainakin paristo kokonaan irti ja laita takaisin.


Jumpperi on oikein, mutta paristo ei ole paikallaan, koska käynnistysyrityksiä oli niin monta ja joka välissä nollasin jumpperin, enkä tohtinut sitä nollata jos paristo olisi ollut paikallaan. Ja kun tämä lopulta lähti oikeasti käyntiin, en ole tohtinut sammuttaakaan. :-)

Pitää kokeilla vielä tuolla paristolla ja hankkia uusi varalle hetimiten.

Voisikohan kiintolevyn vanhuus aiheuttaa mainittuja käynnistymisongelmia? Siellä kyllä surahtaa kun koneen laittaa käyntiin, mutta se ei tosiaan aina yritäkään bootata, vaan käy hetken hiljaa ja sammahtaa. Välittömästi tuollaisen käynnistymisen jälkeen se voi jäädä hiljaisesti käymään pitkäksi aikaa tehden ei mitään.

Sellainen ero "oikean ja väärän" käynnistymisen yhteydessä on, että tuuletin ottaa "oikean" käynnistymisen yhteydessä normaalisti kierroksia ja "väärän" käynnistymisen yhteydessä huomattavasti vähemmän ja laiskemmin.


Koodia: [Valitse]
cat /etc/fstab

Koodia: [Valitse]
# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sdb2 during installation
UUID=dbc5c9e5-deae-4cdb-8369-65618263dc5c /               ext4    errors=remount-ro 0       1
# swap was on /dev/sdb3 during installation
UUID=ce8cba19-fcc9-4688-ad09-fc77381f3055 none            swap    sw              0       0

Tänäänkin taidan jättää koneen käyntiin, enkä vielä koeta tuota "sudo grub-install /dev/sda" loitsua. Pitää laittaa nukkumaan.

nm

  • Käyttäjä
  • Viestejä: 13701
    • Profiili
Koodia: [Valitse]
/dev/sda1: UUID="442C7C972C7C85A8" TYPE="ntfs"
/dev/sr0: LABEL="Ubuntu 12.04.1 LTS i386" TYPE="iso9660"
/dev/sda2: UUID="dbc5c9e5-deae-4cdb-8369-65618263dc5c" TYPE="ext4"
/dev/sda3: UUID="ce8cba19-fcc9-4688-ad09-fc77381f3055" TYPE="swap"

Näissä nyt ottaa silmään tuo sr0. Kun loitsuaa seuraavan:
Koodia: [Valitse]
cd media/Ubuntu\ 12.04.1\ LTS\ i386/
ja ls -l

niin näyttäisi olevan live-levyn tiedostot tuossa sijainnissa. Liekö jokin tumpelointi tuonkin takana? :-)

Näyttää siltä, että DVD-asemassa on Ubuntun asennuslevy ja järjestelmä on liittänyt sen automaattisesti. Tämä on täysin normaalia, jos levy tosiaan on asemassa.


Nyt kun minulla on xp osiolla sda1, temp osiolla sda3, niin laitan näin (?):
Koodia: [Valitse]
sudo grub-install /dev/sda2

Ei vaan GRUB pitää asentaa MBR:ään, aivan levyn alkuun:

sudo grub-install /dev/sda

Tuon jälkeen voisit vielä komentaa sudo update-grub, jotta Windows-asennuksen sijainti tarkistetaan uudelleen. On kyllä mahdollista, että jokin on sekoittanut Windowsin käynnistyslataajan niin, että se pitäisi asentaa uudelleen Windowsin asennuslevyn avulla. Se taas johtaa uusiin ongelmiin Grubin kanssa.

Tarvitsetko Windows XP:tä vielä johonkin, mitä ei voi tehdä Ubuntun alla Winellä tai virtualisoidulla Windows-asennuksella? Itse ainakin olen niin laiska, etten viitsisi vaihtaa jatkuvasti käyttöjärjestelmien välillä.




Jumpperi on oikein, mutta paristo ei ole paikallaan, koska käynnistysyrityksiä oli niin monta ja joka välissä nollasin jumpperin, enkä tohtinut sitä nollata jos paristo olisi ollut paikallaan.

Laita sitten seuraavaa käynnistystä varten paristo paikalleen, jotta koneella olisi edes jotain mahdollisuuksia käynnistyä normaalisti jatkossa. Muuten bios-asetukset häviävät uudelleenkäynnistyksissä ja saat juuri tuon herjan CMOS-tarkistussummasta.


Voisikohan kiintolevyn vanhuus aiheuttaa mainittuja käynnistymisongelmia? Siellä kyllä surahtaa kun koneen laittaa käyntiin, mutta se ei tosiaan aina yritäkään bootata, vaan käy hetken hiljaa ja sammahtaa. Välittömästi tuollaisen käynnistymisen jälkeen se voi jäädä hiljaisesti käymään pitkäksi aikaa tehden ei mitään.

On mahdollista, mutta jos ongelma alkoi esiintyä vasta nyt bios-asetusten nollaamisen jälkeen, vika on ehkä pikemmin jossain asetuksessa. Ensin pitäisi ainakin saada se CMOS-tarkistussumman herja pois.

Voithan myös laittaa CD/DVD-aseman boottijärjestyksessä ensimmäiseksi ja katsoa, käynnistyykö kone yhtään paremmin Ubuntun asennuslevyllä.

valtsu68

  • Käyttäjä
  • Viestejä: 453
  • Aloitteleva peruskäyttäjä
    • Profiili

Näyttää siltä, että DVD-asemassa on Ubuntun asennuslevy ja järjestelmä on liittänyt sen automaattisesti. Tämä on täysin normaalia, jos levy tosiaan on asemassa


Onhan siellä  :-[. Muistinkin laittaneeni sen sisälle, jotta lähtisi vaikka sillä käyntiin.


Nyt kun minulla on xp osiolla sda1, temp osiolla sda3, niin laitan näin (?):

Koodia: [Valitse]
sudo grub-install /dev/sda2

Ei vaan GRUB pitää asentaa MBR:ään, aivan levyn alkuun:

sudo grub-install /dev/sda


Just. Taisi lamppu syttyä. Elikkä meneekös se nyt näin?:

sda = kiintolevy a
  • sda1 = Osio 1,  kiintolevyllä a
  • sda2 = Osio 2,  kiintolevyllä a
  • sdan = Osio n,  kiintolevyllä a

Ja MBR on koko levyn alussa, eikä osiossa.


Tuon jälkeen voisit vielä komentaa sudo update-grub, jotta Windows-asennuksen sijainti tarkistetaan uudelleen.


Näin tehdään.


On kyllä mahdollista, että jokin on sekoittanut Windowsin käynnistyslataajan niin, että se pitäisi asentaa uudelleen Windowsin asennuslevyn avulla. Se taas johtaa uusiin ongelmiin Grubin kanssa.


ntldr:än puuttumista se on kuulemma herjannut.


Tarvitsetko Windows XP:tä vielä johonkin, mitä ei voi tehdä Ubuntun alla Winellä tai virtualisoidulla Windows-asennuksella? Itse ainakin olen niin laiska, etten viitsisi vaihtaa jatkuvasti käyttöjärjestelmien välillä.


Tyttö piirtää, (ja hyvin), sekä pelaavat jotain vanhaa peliä. En tiedä toimivatko nuo riittävän hyvin teinin mielestä muuten kuin oikeasti XP:n päällä. Gimp:kin on kuulemma parempi "väärällä" puolella...


Laita sitten seuraavaa käynnistystä varten paristo paikalleen, jotta koneella olisi edes jotain mahdollisuuksia käynnistyä normaalisti jatkossa. Muuten bios-asetukset häviävät uudelleenkäynnistyksissä ja saat juuri tuon herjan CMOS-tarkistussummasta.



Pitää laittaa kun saa tämän ensimmäisen vaiheen valmiiksi ja tohtii sammuttaa laitteen.

OT:
Jumpperilla nollaaminen ei taida onnistua, jos paristo on paikallaan?

nm

  • Käyttäjä
  • Viestejä: 13701
    • Profiili
Just. Taisi lamppu syttyä. Elikkä meneekös se nyt näin?:

sda = kiintolevy a
  • sda1 = Osio 1,  kiintolevyllä a
  • sda2 = Osio 2,  kiintolevyllä a
  • sdan = Osio n,  kiintolevyllä a

Ja MBR on koko levyn alussa, eikä osiossa.

Jep, juuri näin. MBR:n lisäksi levyn alussa on osiotaulu.

On kyllä mahdollista, että jokin on sekoittanut Windowsin käynnistyslataajan niin, että se pitäisi asentaa uudelleen Windowsin asennuslevyn avulla. Se taas johtaa uusiin ongelmiin Grubin kanssa.

ntldr:än puuttumista se on kuulemma herjannut.

Jos Windows ei lähde toimimaan tämän GRUB-korjauksen jälkeen, joutunet korjailemaan ensin Windows-asennuksen ja sitten todennäköisesti asentamaan grubin uudelleen esimerkiksi Boot-Repair-CD:n avulla.


Tyttö piirtää, (ja hyvin), sekä pelaavat jotain vanhaa peliä. En tiedä toimivatko nuo riittävän hyvin teinin mielestä muuten kuin oikeasti XP:n päällä. Gimp:kin on kuulemma parempi "väärällä" puolella...

Jospa teillä on Windowsissa Gimp 2.8 tai uudempi, jossa on Photoshopin tapainen yhden ikkunan käyttöliittymä (single window mode). Ubuntu 12.04:ssä on vielä vanha Gimp 2.6, jossa tämä ei onnistu vaan sivupaneelit ovat erillisissä ikkunoissa.

Gimp 2.8:n saa Ubuntu 12.04:ään PPA:sta:

Koodia: [Valitse]
sudo add-apt-repository ppa:otto-kesselgulasch/gimp
sudo apt-get update
sudo apt-get install gimp


Vanhemmat pelit voivat hyvinkin toimia Winellä. Tietoa ja neuvoja löytyy AppDB:stä: http://appdb.winehq.org/


OT:
Jumpperilla nollaaminen ei taida onnistua, jos paristo on paikallaan?

Pariston irrottaminen on yleensä suositeltavaa, mutta nollaaminen saattaa onnistua, vaikka paristo olisi paikallaan. Virtajohto kannattaa myös irrottaa kokonaan, ellei emolevyn manuaali erikseen käske pitämään herätevirtaa päällä.

valtsu68

  • Käyttäjä
  • Viestejä: 453
  • Aloitteleva peruskäyttäjä
    • Profiili
Terve
Nyt on jatkettu toimintaa ja seuraavat loitsut on annettu.
Koodia: [Valitse]
sudo grub-install /dev/sda
 sudo update-grub

Sitten meni muutama päivä kun tarvitsin konetta, enkä tohtinut sitä sammuttaa. Toissa iltana vaimo oli sammuttanut sen ja eilen koetin käynnistää sitä noin 5 kertaa, eikä käynnistynyt. Jäi vaan aikaisemmin kuvailemaani tilaan kiintolevyn "narahduksen" jälkeen:

Lainaus
...käynnistäessä vain laite lähti käyntiin, sammuakseen hetken kuluttua yrittämättä ollenkaan käynnistää käyttistä..

Tänään kotiin tullessani huomasin koneen olevan käynnissä. Vaimo oli laittanut sen päälle. (???) Kuulemma noin 15 kertaa oli pitänyt yrittää ennen kuin oli syttynyt tulille.

Liekö viimeiset hetket pelastaa kiintolevyn sisältö ?  :o Alan epäilemään jälleen tuota kiintolevyä, koska se on alkuperäinen ja kone on koottu v. 2005 tai 2006....

OT: Jumpperilla nollaaminen ei taida onnistua, jos paristo on paikallaan?

Pariston irrottaminen on yleensä suositeltavaa, mutta nollaaminen saattaa onnistua, vaikka paristo olisi paikallaan. Virtajohto kannattaa myös irrottaa kokonaan, ellei emolevyn manuaali erikseen käske pitämään herätevirtaa päällä.


Laiskuuttani vain kysyin, kun tuota joutui jatkuvasti poistamaan ja takaisin asettamaan. Manuaali neuvoo irroittamaan sen ja virtajohdon myös; näin on myös tehty, paitsi katkaisijaa olen käyttänyt virtajohdon poiston sijaan.

Noita muita juttuja pitää kokeilla myöhemmin.

valtsu68

  • Käyttäjä
  • Viestejä: 453
  • Aloitteleva peruskäyttäjä
    • Profiili


Voisikohan kiintolevyn vanhuus aiheuttaa mainittuja käynnistymisongelmia? Siellä kyllä surahtaa kun koneen laittaa käyntiin, mutta se ei tosiaan aina yritäkään bootata, vaan käy hetken hiljaa ja sammahtaa. Välittömästi tuollaisen käynnistymisen jälkeen se voi jäädä hiljaisesti käymään pitkäksi aikaa tehden ei mitään.

On mahdollista, mutta jos ongelma alkoi esiintyä vasta nyt bios-asetusten nollaamisen jälkeen, vika on ehkä pikemmin jossain asetuksessa. Ensin pitäisi ainakin saada se CMOS-tarkistussumman herja pois.

Voithan myös laittaa CD/DVD-aseman boottijärjestyksessä ensimmäiseksi ja katsoa, käynnistyykö kone yhtään paremmin Ubuntun asennuslevyllä.


Kyllä olit oikeassa. Ei tämä vika taida olla kiintolevyllä, vaan emolevyllä. Tänään sammutin koko laitteen ja asensin pariston paikalleen. Tämän jälkeen koetin useita kymmeniä kertoja käynnistystä ilman menestystä. Otin pariston pois ja koetin käynnistää; niinhän se lähti tulille. Muutaman kerran koetin uudelleen ilman paristoa: joka kerta ei käynnistynyt, mutta enimmäkseen kyllä.

Tämä havainto sai minut tutkimaan emolevyn komponentteja. Löysin lieriöitä, kondensaattoreita?, joiden yläpäässä oli jonkinlaiset halkaisut, jotka jakoivat sen "katon" kolmeen osaan. (kyl mä oon sitten oikee sähkömies ;-) ). Kolmessa näistä mystisistä osista oli "katto" hiukan pullistunut ulospäin. Vika saattaa olla noissa?

Uutta laitetta pitänee alkaa hankkimaan, vaikka tämäkään mikään ikäloppu ole, (8v.)  ;D 25 centtiä tuli maksamaan päivää kohden tämäkin laite. No, mikään ei ole ilmaista.  ;)

qwertyy

  • Käyttäjä
  • Viestejä: 4787
    • Profiili
Tämä havainto sai minut tutkimaan emolevyn komponentteja. Löysin lieriöitä, kondensaattoreita?, joiden yläpäässä oli jonkinlaiset halkaisut, jotka jakoivat sen "katon" kolmeen osaan. (kyl mä oon sitten oikee sähkömies ;-) ). Kolmessa näistä mystisistä osista oli "katto" hiukan pullistunut ulospäin. Vika saattaa olla noissa?
Kondensaattoreitapa ne hyvinkin on. Jos löytyy selkeästi pullistuneita tai vuotaneita konkkia, niin siellähän se vika on.

Ne ei kyllä ole kalliita, eli koko emolevyn voi kyllä yleensä vielä korjata tyyliin 2€ kustannuksella (komponentit), mutta monesti konkkia on aika ikävän paljon ja ikävästi sijoitettuna. Ei sinänsä ole paha homma tehdä itsekään, mutta mihinkään varsinaiseen liikkeeseen ei juurikaan kannata vanhaa rautaa kiikuttaa.

valtsu68

  • Käyttäjä
  • Viestejä: 453
  • Aloitteleva peruskäyttäjä
    • Profiili
Kondensaattoreitapa ne hyvinkin on. Jos löytyy selkeästi pullistuneita tai vuotaneita konkkia, niin siellähän se vika on.

Ne ei kyllä ole kalliita, eli koko emolevyn voi kyllä yleensä vielä korjata tyyliin 2€ kustannuksella (komponentit), mutta monesti konkkia on aika ikävän paljon ja ikävästi sijoitettuna. Ei sinänsä ole paha homma tehdä itsekään, mutta mihinkään varsinaiseen liikkeeseen ei juurikaan kannata vanhaa rautaa kiikuttaa.

Pitää antaa kaverille korjattavaksi, jos vaikka sattuisi onnistumaan.

Nyt tämä meni astetta hankalammaksi. Yrittää käynnistyä graafiseen tilaan, mutta lopulta antaa tekstitilan. Hassuinta on se, ettei järjestelmä tunnista näyttöä; niin lukee näytöllä  ;D. MUOKS: Tuo ilmoitus: "no screens found" tulikin vasta komennon startx jälkeen.
« Viimeksi muokattu: 02.01.14 - klo:12.33 kirjoittanut valtsu68 »

valtsu68

  • Käyttäjä
  • Viestejä: 453
  • Aloitteleva peruskäyttäjä
    • Profiili

Nyt tämä meni astetta hankalammaksi. Yrittää käynnistyä graafiseen tilaan, mutta lopulta antaa tekstitilan. Hassuinta on se, ettei järjestelmä tunnista näyttöä; niin lukee näytöllä  ;D

Tämä oli päällekkäinen vika, joka ratkesi odottamalla vastausta :-) --> RATKAISU !

« Viimeksi muokattu: 02.01.14 - klo:12.25 kirjoittanut valtsu68 »