Kirjoittaja Aihe: [alkuperäinen ongelma ratkaistu, lopputulos ei]Xbindkeys ei käynnisty  (Luettu 1426 kertaa)

aku506

  • Käyttäjä
  • Viestejä: 356
    • Profiili
Vaikka yritän käynnistää xbindkeyssiä, se ei vain suostu käynnistymään. Tässäkin tuloste kertonee enemmän kuin tuhat sanaa.
Koodia: [Valitse]
aku506@Aspire-3830T:~$ xbindkeys -v
displayName = :0.0
rc file = /home/aku506/.xbindkeysrc
rc guile file = /home/aku506/.xbindkeysrc.scm
getting rc guile file /home/aku506/.xbindkeysrc.scm.
initializing guile fns...

min_keycode=8     max_keycode=255 (ie: know keycodes)
starting loop...
« Viimeksi muokattu: 11.09.13 - klo:20.50 kirjoittanut aku506 »

nm

  • Käyttäjä
  • Viestejä: 14281
    • Profiili
Vs: Xbindkeys ei käynnisty
« Vastaus #1 : 07.09.13 - klo:13.05 »
Näyttää käynnistyvän ihan oikein. Sinulla ei vain ole mitään asetuksia.

Jos haluat avata kuunteluikkunan näppäinyhdistelmien koodaamista varten, se tapahtuu parametrilla -k

Onko sinulla joku erityinen syy xbindkeysin käyttöön? Unityssä ja muissa työpöytäympäristöissä on vastaavat toiminnon sisäänrakennettuna ja näppäinyhdistelmien asettaminen on niissä yleensä helpompaa.
« Viimeksi muokattu: 07.09.13 - klo:13.07 kirjoittanut nm »

aku506

  • Käyttäjä
  • Viestejä: 356
    • Profiili
Vs: Xbindkeys ei käynnisty
« Vastaus #2 : 07.09.13 - klo:13.17 »
Kyllä minulla on asetukset kirjoitettuna. Olen kokeillut niin omilla kuin xbindkeysin esimerkkiasetuksillakin, mutta ilmeisesti ne eivät sitten vain lataudu.

Koodia: [Valitse]
aku506@Aspire-3830T:~$ cat .xbindkeysrc
#specify a mouse button
"xterm"
  control + b:2
#rullavasen
"xte 'mouseclick 6'"
  b:8
#rullaoikea
"xte 'mouseclick 7'"
  b:9

Käsittääkseni ainakaan oletuksena mukana tullut pikanäppäinohjelma ei osaa reagoida hiiren klikkauksiin. Siksi xbindkeys.

nm

  • Käyttäjä
  • Viestejä: 14281
    • Profiili
Vs: Xbindkeys ei käynnisty
« Vastaus #3 : 07.09.13 - klo:14.12 »
Poista tiedosto /home/aku506/.xbindkeysrc.scm
Ohjelma lataa nyt asetukset sieltä .xbindkeysrc:n sijaan.

aku506

  • Käyttäjä
  • Viestejä: 356
    • Profiili
Vs: Xbindkeys ei käynnisty
« Vastaus #4 : 07.09.13 - klo:14.38 »
Kiitos. Nyt käynnistyy ja oletuspikanäppäimet toimivat. Tämä ei kuitenkaan rakaissut ongelmaani, koska omat näppäinyhdistelmäni eivät edelleenkään toimi. Painettaessa nappia 6 tulee seuraavat rivit, kun v-vipu valittuna.
Koodia: [Valitse]
Button press !
e.xbutton.button=8
e.xbutton.state=0
"xte 'mouseclick 6'"
    m:0x0 + b:8   (mouse)
got screen 0 for window c4
Start program with fork+exec call
Button press !
e.xbutton.button=6
e.xbutton.state=0
Button release !
e.xbutton.button=6
e.xbutton.state=0
Button release !
e.xbutton.button=8
e.xbutton.state=0
Mitään ei silti tapahdu. Jos laitan itse päätteessä tuon xte 'mouseclick 6':n, se toimii.