Kirjoittaja Aihe: Ubuntun asentaminen RAID0 [RATKAISTU]  (Luettu 8948 kertaa)

JusMu

  • Käyttäjä
  • Viestejä: 46
    • Profiili
Vs: Ubuntun asentaminen RAID0 [Lisää käynnistys ongelmaa]
« Vastaus #40 : 04.06.13 - klo:23.01 »
Aukaisinpa tuon cat komennolla ja tulos ei ole aivan kenties mitä pitäisi. Olen paljon lukenut eri viestiketjuista tuosta rootista ja hd hommista, että ne pitäisi näkyä ja laittella. Kuitenkin itselleni tulee:

menuentry 'Windows 7 (loader) (on /dev/mapper/isw_bfhjaigicc_Intel\x20RAID1)' --class windows --class os $menuentry_id_option 'osprober-chain-743445593445200A' {
   insmod ntfs
   if [ x$feature_platform_search_hint = xy ]; then
     search --no-floppy --fs-uuid --set=root  743445593445200A
   else
     search --no-floppy --fs-uuid --set=root 743445593445200A
   fi
   chainloader +1
}

Eli tuossahan tuo on. Toisaalta ennen varmennusta, että tuo on normaali en jaksa edes kokeilla, sillä sen verran monta kertaa joutunut hommat aina palauttamaan. Jos tuon kerkeät vielä vilkaisemaan, että onko se ihan normaali, niin sitte voisin kokeilla homman taas kerran testata uusiksi.

mrl586

  • Käyttäjä
  • Viestejä: 4517
    • Profiili
Vs: Ubuntun asentaminen RAID0 [Lisää käynnistys ongelmaa]
« Vastaus #41 : 05.06.13 - klo:00.42 »
Koodia: [Valitse]
   if [ x$feature_platform_search_hint = xy ]; then
     search --no-floppy --fs-uuid --set=root  743445593445200A
   else
     search --no-floppy --fs-uuid --set=root 743445593445200A
   fi
Tässä lienee jotain ylimääräistä?

JusMu

  • Käyttäjä
  • Viestejä: 46
    • Profiili
Vs: Ubuntun asentaminen RAID0 [Lisää käynnistys ongelmaa]
« Vastaus #42 : 05.06.13 - klo:11.36 »
Itsekin kovasti veikkaan, että ei se ole sitä mitä pitäisi. Ainut ohje jonka olen löytänyt on, että windows ja linux asennettaisiin kummatkin fakeraid pakkaan . Kaikissa ohjeissa linux on asennettuna ensimmäisenä ja sitten vasta windows.

Toisaalta aattelin tuossa vielä sen boot repairin katella, sillä siinä tapahtuu tarvittavat mounttaukset vissiinkin. Nuissa ohjeissa on kovasti itse pitänyt kaikenlaista katella ja ihmetellä. Tosin sen verran uusi vielä olen tässä hommassa, että en ihan selvää kaikesta ole ottanut, että mitä tuossa pitäisi tehdä.

Toisaalta boot repairin jälkeen en tiedä onko kuinka viisasta mennä ennen restarttia niitä grub asetuksia muokkailemaan. Kaippa sitä voisi kokeilla, koska on backupit vielkin valmiina.

PS. Raidin saan näkymään aina toistaiseksi kun laittelen vain komennot
sudo apt-get update
sudo apt-get install dmraid
sudo dmraid -ay

Kuitenkin tämä tapahtuu ennen boot repairia. Tämän jälkeen grub poistetaan ja sen jälkeen asennetaan uusiksi. Itse olen käyttänyt tuon 500 GB kovalevyn /boot osioo asennus paikkana, jonka siis asennuksessa väänsin. Kuitenkin tämä menee ihan ok niin pitkään kunnes käynnistän koneen. Silloin se windows 7 loader siellä näkyy, mutta mitään muutoksia en voi enää grub tehdä tai se häviää. Toisaalta olen tässä sitäkin ajatellut, että kun kaikki on tässä kunnossa niin voisin tuohon fakeraid pakkaan molemmat asetella mutta tuosta manuaalisesta mounttaamisesta on niin vähän hajua. Puolestaan äänet eivät toimi linuxilla joten sama sen olisi olla tässäkin erillisellä kovolla. Tuo grub "osittainen" toimiminen vain tekee käytöstä hiukan inhottavaa, kun ei koskaan tiedä, että mitä sitä saa tehdä ja mitä ei, että winukka vielä näkyisi. Tuo raidin tunnistaminen tuntuu silti varmaan tässä olevan se suurin ongelma, sillä kun tämä pönttö hävittää sen aina käynnistyksen jälkeen.
Puolestaan tuo tunnistuskin on mitä on. Tuohon vasempaan sivupalkkiin nuilla komennoilla tulee nuo raidin osiot, joita ei edelleenkään siis voi aukaista, vaikka siellä on myös muutama normaali nfts osio, jossa on esim tällä hetkellä kaikki ns käytettävä materiaali. Kuitenkin tuon raidin tunnistuksen jälkeen kde partition managerilla vilkaisin ja ubuntu tunnistaa nuo 1TB kovot siellä ainakin vielä kahtena erillisenä kovona eikä näytä niiden osioita.

En tiedä tajusiko tuosta kukaan yhtikäs mitään :D Katsotaan jos tästä viel joku päivä jotain yhteisvoimin saisimme aikaan.
« Viimeksi muokattu: 05.06.13 - klo:12.12 kirjoittanut JusMu »

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 10752
    • Profiili
    • Tomin kotisivut
Vs: Ubuntun asentaminen RAID0 [Lisää käynnistys ongelmaa]
« Vastaus #43 : 05.06.13 - klo:15.51 »
menuentry 'Windows 7 (loader) (on /dev/mapper/isw_bfhjaigicc_Intel\x20RAID1)' --class windows --class os $menuentry_id_option 'osprober-chain-743445593445200A' {
   insmod ntfs
   if [ x$feature_platform_search_hint = xy ]; then
     search --no-floppy --fs-uuid --set=root  743445593445200A
   else
     search --no-floppy --fs-uuid --set=root 743445593445200A
   fi
   chainloader +1
}
Kuten mainitsin minulla ei (nyt) ole Windowsia, joten en pysty katsomaan mitä itselläni on, mutta mielestäni tuo kyllä näyttää ihan oikealta paitsi että ehtolause on turha. Lisäksi tuota menuentry-riviä voisi lyhentää. Eli lyhyemmin:
Koodia: [Valitse]
menuentry 'Windows 7 (loader)' --class windows {
insmod ntfs
search --no-floppy --fs-uuid --set=root 743445593445200A
chainloader +1
}
Jos kiinnostaa noiden sanojen merkitykset niin tuolta löytyy: http://www.gnu.org/software/grub/manual/grub.html
Tuo "--class windows" ei ole mitenkään tarpeellinen.
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

JusMu

  • Käyttäjä
  • Viestejä: 46
    • Profiili
Vs: Ubuntun asentaminen RAID0 [Lisää käynnistys ongelmaa]
« Vastaus #44 : 05.06.13 - klo:16.00 »
noh pitääpä kokeilla.

yritän tuossa parilla eri keinolla jotain mälvätä, kun ubuntun puolelle jaksan loggautua.

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 10752
    • Profiili
    • Tomin kotisivut
Vs: Ubuntun asentaminen RAID0 [Lisää käynnistys ongelmaa]
« Vastaus #45 : 05.06.13 - klo:16.20 »
noh pitääpä kokeilla.

yritän tuossa parilla eri keinolla jotain mälvätä, kun ubuntun puolelle jaksan loggautua.

Pitäisi toimia, kun pistät nuo rivit sinne 40_custom-tiedoston loppuun ja ajat update-grubin. Edellyttäen tietysti, että tuo on se millä nytkin lataat Windowsin (ja onhan se, jos valikossa on vain yksi Windows-kohta).

Windowsin ketjulataus Grubista vaatii vain muutaman rivin. Mahdollisesti yhden tiedostojärjestelmien tuen lataamiseksi, yhden oikean osion valisemiseksi ja sitten chainload-rivin. Eli eipä tuossa muuta pitäisikään olla.
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

JusMu

  • Käyttäjä
  • Viestejä: 46
    • Profiili
Vs: Ubuntun asentaminen RAID0 [Lisää käynnistys ongelmaa]
« Vastaus #46 : 05.06.13 - klo:18.10 »
Noh ainakin parempaan päin.

Vetäsin tuon sinne tiedostoon jatkoksi ja nytten kun grub kläynnistyy on 2 x eri kappaletta nuita windows 7 loadereita ( se toinen varmaan se, jonka lisäsin itse). Nytten enää siihen, että saisin sen windowsin latautuu ensimmäisenä. Tosin vieläkin on tuo bootti screen tuona teksti hommana. Tosin sen grub updaten aikana tuli vaikka minkälaista erroria. Lista on pitkä mutta laitetaan se nytten tähän:

sudo update-grub
Tuotetaan tiedosto grub.cfg ...
Linux-levykuva löytyi: /boot/vmlinuz-3.8.0-23-generic
Löytyi initrd-levykuva: /boot/initrd.img-3.8.0-23-generic
Linux-levykuva löytyi: /boot/vmlinuz-3.8.0-22-generic
Löytyi initrd-levykuva: /boot/initrd.img-3.8.0-22-generic
Linux-levykuva löytyi: /boot/vmlinuz-3.8.0-19-generic
Löytyi initrd-levykuva: /boot/initrd.img-3.8.0-19-generic
ERROR: ddf1: seeking device "/dev/dm-4" to 18446744073709421056
ERROR: hpt37x: seeking device "/dev/dm-4" to 4608
ERROR: hpt45x: seeking device "/dev/dm-4" to 18446744073709547008
ERROR: isw: seeking device "/dev/dm-4" to 18446744073708469760
ERROR: sil: seeking device "/dev/dm-4" to 18446744073709289984
ERROR: ddf1: seeking device "/dev/dm-4" to 18446744073709421056
ERROR: hpt37x: seeking device "/dev/dm-4" to 4608
ERROR: hpt45x: seeking device "/dev/dm-4" to 18446744073709547008
ERROR: isw: seeking device "/dev/dm-4" to 18446744073708469760
ERROR: sil: seeking device "/dev/dm-4" to 18446744073709289984
ERROR: ddf1: seeking device "/dev/dm-4" to 18446744073709421056
ERROR: hpt37x: seeking device "/dev/dm-4" to 4608
ERROR: hpt45x: seeking device "/dev/dm-4" to 18446744073709547008
ERROR: isw: seeking device "/dev/dm-4" to 18446744073708469760
ERROR: sil: seeking device "/dev/dm-4" to 18446744073709289984
ERROR: ddf1: seeking device "/dev/dm-4" to 18446744073709421056
ERROR: hpt37x: seeking device "/dev/dm-4" to 4608
ERROR: hpt45x: seeking device "/dev/dm-4" to 18446744073709547008
ERROR: isw: seeking device "/dev/dm-4" to 18446744073708469760
ERROR: sil: seeking device "/dev/dm-4" to 18446744073709289984
ERROR: ddf1: seeking device "/dev/dm-4" to 18446744073709421056
ERROR: hpt37x: seeking device "/dev/dm-4" to 4608
ERROR: hpt45x: seeking device "/dev/dm-4" to 18446744073709547008
ERROR: isw: seeking device "/dev/dm-4" to 18446744073708469760
ERROR: sil: seeking device "/dev/dm-4" to 18446744073709289984
ERROR: ddf1: seeking device "/dev/dm-4" to 18446744073709421056
ERROR: hpt37x: seeking device "/dev/dm-4" to 4608
ERROR: hpt45x: seeking device "/dev/dm-4" to 18446744073709547008
ERROR: isw: seeking device "/dev/dm-4" to 18446744073708469760
ERROR: sil: seeking device "/dev/dm-4" to 18446744073709289984
ERROR: ddf1: seeking device "/dev/dm-4" to 18446744073709421056
ERROR: hpt37x: seeking device "/dev/dm-4" to 4608
ERROR: hpt45x: seeking device "/dev/dm-4" to 18446744073709547008
ERROR: isw: seeking device "/dev/dm-4" to 18446744073708469760
ERROR: sil: seeking device "/dev/dm-4" to 18446744073709289984
ERROR: ddf1: seeking device "/dev/dm-4" to 18446744073709421056
ERROR: hpt37x: seeking device "/dev/dm-4" to 4608
ERROR: hpt45x: seeking device "/dev/dm-4" to 18446744073709547008
ERROR: isw: seeking device "/dev/dm-4" to 18446744073708469760
ERROR: sil: seeking device "/dev/dm-4" to 18446744073709289984
ERROR: ddf1: seeking device "/dev/dm-4" to 18446744073709421056
ERROR: hpt37x: seeking device "/dev/dm-4" to 4608
ERROR: hpt45x: seeking device "/dev/dm-4" to 18446744073709547008
ERROR: isw: seeking device "/dev/dm-4" to 18446744073708469760
ERROR: sil: seeking device "/dev/dm-4" to 18446744073709289984
grub-probe: varoitus: levyä ei ole olemassa, joten palataan takaisin osiolaitteeseen /dev/mapper/isw_bfhjaigicc_Intel\x20RAID1.
grub-probe: varoitus: levyä ei ole olemassa, joten palataan takaisin osiolaitteeseen /dev/mapper/isw_bfhjaigicc_Intel\x20RAID1.
grub-probe: varoitus: levyä ei ole olemassa, joten palataan takaisin osiolaitteeseen /dev/mapper/isw_bfhjaigicc_Intel\x20RAID1.
grub-probe: varoitus: levyä ei ole olemassa, joten palataan takaisin osiolaitteeseen /dev/mapper/isw_bfhjaigicc_Intel\x20RAID2.
grub-probe: varoitus: levyä ei ole olemassa, joten palataan takaisin osiolaitteeseen /dev/mapper/isw_bfhjaigicc_Intel\x20RAID2.
grub-probe: varoitus: levyä ei ole olemassa, joten palataan takaisin osiolaitteeseen /dev/mapper/isw_bfhjaigicc_Intel\x20RAID2.
grub-probe: varoitus: levyä ei ole olemassa, joten palataan takaisin osiolaitteeseen /dev/mapper/isw_bfhjaigicc_Intel\x20RAID3.
grub-probe: varoitus: levyä ei ole olemassa, joten palataan takaisin osiolaitteeseen /dev/mapper/isw_bfhjaigicc_Intel\x20RAID3.
grub-probe: varoitus: levyä ei ole olemassa, joten palataan takaisin osiolaitteeseen /dev/mapper/isw_bfhjaigicc_Intel\x20RAID3.
grub-probe: varoitus: levyä ei ole olemassa, joten palataan takaisin osiolaitteeseen /dev/mapper/isw_bfhjaigicc_Intel\x20RAID5.
grub-probe: varoitus: levyä ei ole olemassa, joten palataan takaisin osiolaitteeseen /dev/mapper/isw_bfhjaigicc_Intel\x20RAID5.
grub-probe: varoitus: levyä ei ole olemassa, joten palataan takaisin osiolaitteeseen /dev/mapper/isw_bfhjaigicc_Intel\x20RAID5.
Löytyi Windows 7 (loader) kohteella /dev/mapper/isw_bfhjaigicc_Intel\x20RAID1
/usr/sbin/grub-probe: varoitus: levyä ei ole olemassa, joten palataan takaisin osiolaitteeseen /dev/mapper/isw_bfhjaigicc_Intel\x20RAID1.
/usr/sbin/grub-probe: varoitus: levyä ei ole olemassa, joten palataan takaisin osiolaitteeseen /dev/mapper/isw_bfhjaigicc_Intel\x20RAID1.
/usr/sbin/grub-probe: varoitus: levyä ei ole olemassa, joten palataan takaisin osiolaitteeseen /dev/mapper/isw_bfhjaigicc_Intel\x20RAID1.
/usr/sbin/grub-probe: varoitus: levyä ei ole olemassa, joten palataan takaisin osiolaitteeseen /dev/mapper/isw_bfhjaigicc_Intel\x20RAID1.
/usr/sbin/grub-probe: varoitus: levyä ei ole olemassa, joten palataan takaisin osiolaitteeseen /dev/mapper/isw_bfhjaigicc_Intel\x20RAID1.
/usr/sbin/grub-probe: varoitus: levyä ei ole olemassa, joten palataan takaisin osiolaitteeseen /dev/mapper/isw_bfhjaigicc_Intel\x20RAID1.
/usr/sbin/grub-probe: varoitus: levyä ei ole olemassa, joten palataan takaisin osiolaitteeseen /dev/mapper/isw_bfhjaigicc_Intel\x20RAID1.
/usr/sbin/grub-probe: varoitus: levyä ei ole olemassa, joten palataan takaisin osiolaitteeseen /dev/mapper/isw_bfhjaigicc_Intel\x20RAID1.
/usr/sbin/grub-probe: varoitus: levyä ei ole olemassa, joten palataan takaisin osiolaitteeseen /dev/mapper/isw_bfhjaigicc_Intel\x20RAID1.
/usr/sbin/grub-probe: varoitus: levyä ei ole olemassa, joten palataan takaisin osiolaitteeseen /dev/mapper/isw_bfhjaigicc_Intel\x20RAID1.
/usr/sbin/grub-probe: varoitus: levyä ei ole olemassa, joten palataan takaisin osiolaitteeseen /dev/mapper/isw_bfhjaigicc_Intel\x20RAID1.
/usr/sbin/grub-probe: varoitus: levyä ei ole olemassa, joten palataan takaisin osiolaitteeseen /dev/mapper/isw_bfhjaigicc_Intel\x20RAID1.
valmis

Toisaalta en tiedä onko tuo normaalia. Itse ekana manuaalisesti terminaalista laitoin tuon linuxin tunnistamaan tuon raidin sillein, joten edellä aikaisemmin mainitsin. Katson nytten, että jos automaattisesti ilman sitä mounttaamista tuon grub päivitän, niin jääkö edes se toinen itse lisäämä windows käynnistys vaihtoehto.

PS. Vetäsin käynnistyksen jälkeen tyhjiltään tuon updat-grub ilman tuota raidin mounttaamista ja toinen nuista windows loadereista hävisi. Pääsen silti windowsiin jäljellä olevan loaderin kautta. Samalla kä'ynnistyksestä ja sammuttamisessa tulee kaikenlaista informaatiota, niin kaikki [fail] (ne pari jotka oli) olivat tällä kertaa ok ja ubuntukin sammui varmaan alta kahden sekunnin. Eli tässä ollaan kovasti voiton puolella. Nytten vielä katsomaan, jos vaikka saisin primary bootiksi asetettua tuon windowsin. Ajattelin grub säädellä manuaalisesti ilman mitään boot managez:a. Katsotaan miten tapahtuu, kun vielä jostakin löydän kyseiset ohjeet :D Ei ensimmäisellä kerralla tullut niitä katsellessa ottaa niitä ylös.
« Viimeksi muokattu: 05.06.13 - klo:18.20 kirjoittanut JusMu »

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 10752
    • Profiili
    • Tomin kotisivut
Vs: Ubuntun asentaminen RAID0 [Lisää käynnistys ongelmaa]
« Vastaus #47 : 05.06.13 - klo:18.40 »
Jos käytit tuota viestissäni ollutta koodia, niin muokkaa /etc/default/grub-tiedostoon seuraava rivi:
Koodia: [Valitse]
GRUB_DEFAULT='Windows 7 (loader)'Siellä on siis valmiiksi jokin GRUB_DEFAULT-alkuinen rivi, muuta sitä.
Ja perään tietenkin update-grub.

Nuo mainitsemasi virheet johtuvat hyvin todennäköisesti siitä, että os-proberin käytössä on jotain tuosta raidista johtuvaa vikaa.
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

JusMu

  • Käyttäjä
  • Viestejä: 46
    • Profiili
Vs: Ubuntun asentaminen RAID0 [Lisää käynnistys ongelmaa]
« Vastaus #48 : 05.06.13 - klo:18.53 »
Kiitoksia.

Tuo olisi ollut parempi ratkaisu, mutta korvasin itse tuon GRUB_DAFAULT=2.

Toimiipahan. Toisaalta jos sitä tulee jotain muuta asennettua nih sittehän sitä voi joutua muuttamaan. Mutta nytten alkaa olemaan homma melko paketissa. Kuitenkin tuossa tuli vielä shutdownin aikana KDE puolella tuo

killing all remainin processes [fail], mutta lueskelin siitä tänään ja se taitaa olla liitoksissa johonkin nettimanager tjms bukiin. Toisaalta se vain hidastaa pikkaisen sulkeutumista, että ei siitä suurta haittaa ole. Vielä tuossa katselen jos plymothin saisin tuon teksti käynnistyksen tilalle survastua ihan vaan tyylin vuoksi. Onhan se olevinaan hitaampi, mutta rautaa on sen verran koneessa, että ei pitäisi pahemmin käynnistys nopeuteen vaikuttaa. Kiitokset ja kumarrukset kaikille vastanneille. Tuntuu siltä, että kerrankin sain jotain aikaiseksi ja hyvältä tuntuu. Tie oli melko rankan tuntuinen, mutta näistähän sitä uutta oppii. Pitää tosin nämä hommat jotenkin kirjoitella ylös ensi kertaa varten.

Lisäilen [ratkaistu] sitten kun olen kaiken tärkeän saanut talteen. En aivan heti vielä jaksa rueta kirjoittelemaan, mutta lähi päivinä kuiteskin.

Toisaalta sen verran kun katteli, että Nvidian ajureiden jälkeen kun tuo bootti menee tekstiksi, niin taidan jättääkin plymouthin vääntämisen välistä. Käynnistys kestää muutenkin vain joitakin sekuntteja, joten ei siitä olisi edes silmille sen kummemmin iloa. Toisaalta voisi olla samalla parempi, että en heti yhden ulkonäkö hommelin takia sekoita tätä suurella työllä vääntämääni prosessia.
« Viimeksi muokattu: 05.06.13 - klo:19.12 kirjoittanut JusMu »