Kirjoittaja Aihe: [ratkaistu]ongelma pakettien riippuvuudet Ub. 12.04 lts  (Luettu 2104 kertaa)

vilmus

  • Käyttäjä
  • Viestejä: 39
    • Profiili
Aluksi asentui esim. libdvdread. ymt hyvin. Sitten koetin asentaa skypeä terminaalissa, ei onnistunut, sen jälkeen mikään muukaan ei onnistu, nimittäin asennuksen suhteen. Ainoa lause, joka jäi lukuisista virheilmoituksista mieleen on "ongelma pakettien riippuvuudessa". Näytön yläreunassa on tiukasti ajokieltomerkki, siinä on ollut useita ilmoituksia, tällä hetkellä lukee "problem occurred while checking for updates."  Ongelman syy vaihtuu, riippuen, mitä on koettanut terminaalissa. Muuten toimii, esim.netti ym.
« Viimeksi muokattu: 22.03.13 - klo:15.49 kirjoittanut vilmus »

Thinkit

  • Käyttäjä
  • Viestejä: 897
  • Kysyvä ei tieltä eksy, eikä eksyvä tietä kysy.
    • Profiili
Vs: ongelma pakettien riippuvuudet Ub. 12.04 lts
« Vastaus #1 : 19.03.13 - klo:14.58 »
Lisäsitkö jonkun pakettilähteen?
Laittaisitko vähän infoa että miten asensit, esim. koodit joita käytit, tai sivu jossa ohjeet?

t: Antti  ;)
Lenovo Thinkpad e520
Kde Neon 5.19
Intel(R) Core(TM) i5-2410M CPU @ 2.30GHz
Amd Radeon HD 6630m
Intel HD 3000 integroitu
Samsung Evo 120G kovo ja 8G muistia
Samsung S8 android 9.0

raimo

  • Käyttäjä
  • Viestejä: 3549
    • Profiili
Vs: ongelma pakettien riippuvuudet Ub. 12.04 lts
« Vastaus #2 : 19.03.13 - klo:15.52 »
oletkos kokeillut päätteeseen:
Koodia: [Valitse]
sudo apt-get -f install
So long and thanks for all the fish!

vilmus

  • Käyttäjä
  • Viestejä: 39
    • Profiili
Vs: ongelma pakettien riippuvuudet Ub. 12.04 lts
« Vastaus #3 : 19.03.13 - klo:18.31 »
oletkos kokeillut päätteeseen:
Koodia: [Valitse]
sudo apt-get -f install

Koetin tuon ja nyt gimpkin käynnistyi, kiitti, jatkan harjoittelua ja kysyn lisää. Joulupukki on ainoa pakettienhallintamanageri, jonka tunnen!

vilmus

  • Käyttäjä
  • Viestejä: 39
    • Profiili
Vs: ongelma pakettien riippuvuudet Ub. 12.04 lts
« Vastaus #4 : 19.03.13 - klo:20.24 »
Koetin tuon ja nyt gimpkin käynnistyi, kiitti, jatkan harjoittelua ja kysyn lisää. Joulupukki on ainoa pakettienhallintamanageri, jonka tunnen!
[/quote]

Nyt ei päivitä ollenkaan, muuten ohjelmat asentuvat hyvin. Update manager ilmoitti:"Could not initialize the package information ym. Netti toimii edelleen.

Storck

  • Vieras
Vs: ongelma pakettien riippuvuudet Ub. 12.04 lts
« Vastaus #5 : 19.03.13 - klo:20.46 »
Lisäsitkö jonkun pakettilähteen?
Laittaisitko vähän infoa että miten asensit, esim. koodit joita käytit, tai sivu jossa ohjeet?

t: Antti  ;)

Vastaatko tuohon.

vilmus

  • Käyttäjä
  • Viestejä: 39
    • Profiili
Vs: ongelma pakettien riippuvuudet Ub. 12.04 lts
« Vastaus #6 : 20.03.13 - klo:12.06 »
Lisäsitkö jonkun pakettilähteen?
Laittaisitko vähän infoa että miten asensit, esim. koodit joita käytit, tai sivu jossa ohjeet?

t: Antti  ;)

Vastaatko tuohon.
Hakusanalla pakettilähde tai pakettienhallinta löysin hyvän suomenkielisen ohjeen, mutta minulla on englanninkielinen Ubuntu, siihen tyssäsi. Nyt koetan samaa englanniksi, menee monta tuntia, on muutakin, mutta olisi mukava, jos joku voisi vaikka illalla tai joku päivä vilkaista tänne, yritän jossain välissä kertoa tilanteen.

Aatos Rapula

  • Käyttäjä
  • Viestejä: 186
    • Profiili
Vs: ongelma pakettien riippuvuudet Ub. 12.04 lts
« Vastaus #7 : 20.03.13 - klo:12.34 »
Hakusanalla pakettilähde tai pakettienhallinta löysin hyvän suomenkielisen ohjeen, mutta minulla on englanninkielinen Ubuntu, siihen tyssäsi. Nyt koetan samaa englanniksi, menee monta tuntia, on muutakin, mutta olisi mukava, jos joku voisi vaikka illalla tai joku päivä vilkaista tänne, yritän jossain välissä kertoa tilanteen.

Voisit komentaa:
Koodia: [Valitse]
sudo apt-get update
ja kopioida mahdolliset virheilmoitukset tänne.
Debian - Jessie - xfce

welmar

  • Käyttäjä
  • Viestejä: 1582
    • Profiili
Vs: ongelma pakettien riippuvuudet Ub. 12.04 lts
« Vastaus #8 : 20.03.13 - klo:13.21 »
Lisäsitkö jonkun pakettilähteen?
Laittaisitko vähän infoa että miten asensit, esim. koodit joita käytit, tai sivu jossa ohjeet?

t: Antti  ;)

Vastaatko tuohon.
Hakusanalla pakettilähde tai pakettienhallinta löysin hyvän suomenkielisen ohjeen, mutta minulla on englanninkielinen Ubuntu, siihen tyssäsi. Nyt koetan samaa englanniksi, menee monta tuntia, on muutakin, mutta olisi mukava, jos joku voisi vaikka illalla tai joku päivä vilkaista tänne, yritän jossain välissä kertoa tilanteen.
Vaihda kieli suomeksi ;)

Storck

  • Vieras
Vs: ongelma pakettien riippuvuudet Ub. 12.04 lts
« Vastaus #9 : 20.03.13 - klo:16.07 »
Laita päätteeseen:
Koodia: [Valitse]
cat /etc/apt/sources.list ja kopio teksti tänne.

vilmus

  • Käyttäjä
  • Viestejä: 39
    • Profiili
Vs: ongelma pakettien riippuvuudet Ub. 12.04 lts
« Vastaus #10 : 20.03.13 - klo:17.14 »
Laita päätteeseen:
Koodia: [Valitse]
cat /etc/apt/sources.list ja kopio teksti tänne.

Tässä on cat sekä aiemmin pyydetty sudo apt-get update:

Koodia: [Valitse]
vilmus@vilmus-HP-530-Notebook-PC-KD085AA-AK8:~$ [b]sudo apt-get update[/b]
[sudo] password for vilmus:
E: Malformed line 57 in source list /etc/apt/sources.list (dist parse)
E: The list of sources could not be read.

Koodia: [Valitse]
vilmus@vilmus-HP-530-Notebook-PC-KD085AA-AK8:~$ [b]cat /etc/apt/sources.list[/b]
# deb cdrom:[Ubuntu 12.04.1 LTS _Precise Pangolin_ - Release i386 (20120817.3)]/ precise main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://fi.archive.ubuntu.com/ubuntu/ precise main restricted
deb-src http://fi.archive.ubuntu.com/ubuntu/ precise main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://fi.archive.ubuntu.com/ubuntu/ precise-updates main restricted
deb-src http://fi.archive.ubuntu.com/ubuntu/ precise-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://fi.archive.ubuntu.com/ubuntu/ precise universe
deb-src http://fi.archive.ubuntu.com/ubuntu/ precise universe
deb http://fi.archive.ubuntu.com/ubuntu/ precise-updates universe
deb-src http://fi.archive.ubuntu.com/ubuntu/ precise-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fi.archive.ubuntu.com/ubuntu/ precise multiverse
deb-src http://fi.archive.ubuntu.com/ubuntu/ precise multiverse
deb http://fi.archive.ubuntu.com/ubuntu/ precise-updates multiverse
deb-src http://fi.archive.ubuntu.com/ubuntu/ precise-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://fi.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
deb-src http://fi.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu precise-security main restricted
deb-src http://security.ubuntu.com/ubuntu precise-security main restricted
deb http://security.ubuntu.com/ubuntu precise-security universe
deb-src http://security.ubuntu.com/ubuntu precise-security universe
deb http://security.ubuntu.com/ubuntu precise-security multiverse
deb-src http://security.ubuntu.com/ubuntu precise-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu precise partner
# deb-src http://archive.canonical.com/ubuntu precise partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu precise main
deb-src http://extras.ubuntu.com/ubuntu precise main
deb http://archive.canonical.com/ partner
deb-src http://archive.canonical.com/ partner



Lisätty koodit, vilmus.... käytä tulevaisuudessa yläreunan Koodia-nappia johon laitat yllä olevia tekstejä.
-Storck


« Viimeksi muokattu: 20.03.13 - klo:17.25 kirjoittanut Storck »

welmar

  • Käyttäjä
  • Viestejä: 1582
    • Profiili
Vs: ongelma pakettien riippuvuudet Ub. 12.04 lts
« Vastaus #11 : 20.03.13 - klo:17.44 »
Kaksi viimeistä riviä on virheellisiä, sillä niistä puuttuu distro maininta. Avaa toi ohjemalähde tiedosto geditillä ja poista kaksi viimeistä riviä.
Koodia: [Valitse]
gksu gedit /etc/apt/sources.list Jos tarvitset partner repoja ota # merkki pois sen edestä muutama rivi ylempää.

vilmus

  • Käyttäjä
  • Viestejä: 39
    • Profiili
Vs: ongelma pakettien riippuvuudet Ub. 12.04 lts
« Vastaus #12 : 20.03.13 - klo:18.48 »
Kaksi viimeistä riviä on virheellisiä, sillä niistä puuttuu distro maininta. Avaa toi ohjemalähde tiedosto geditillä ja poista kaksi viimeistä riviä.
Koodia: [Valitse]
gksu gedit /etc/apt/sources.list Jos tarvitset partner repoja ota # merkki pois sen edestä muutama rivi ylempää.

Tein tuon yllämainitun ja kiitti, nyt päivitti koneen pottuilematta. Ja kiitti myös storckille, nyt osaan merkitä tekstiä koodiksi!
Koodia: [Valitse]
Kiitos kiitos!

Storck

  • Vieras
Vs: ongelma pakettien riippuvuudet Ub. 12.04 lts
« Vastaus #13 : 20.03.13 - klo:19.05 »
 8) hyvä hyvä

Lisää vielä aloitusviestin otsikkoon [RATKAISTU] niin muut osaa etsiä vastausta vastaavaan ongelmaan joka on ratkaistu.  ;)