Kirjoittaja Aihe: Xvid avi videon toisto ongelma MPEG-4 4.2 liitännäinen OK rasti puuttui  (Luettu 1930 kertaa)

Laplinux

  • Käyttäjä
  • Viestejä: 148
    • Profiili
Läppäri noin 10" Aspire 1830TZ jossa päivitetty 10.04.4 Ubuntu ja 2.6.32 alkuinen kerneli

Sovellukset ja sieltä löytyvät seuraavat ohjelmat
-ääni / video ohjelmat

Brasero levynkirjoitin
Rytmilaatikko
Elokuvasoitin
Pitivi videomuokkain
Ääninauhuri

ajettu ja konetta bootattu
sudo apt-get update
sudo apt-get install

Nettiyhteys on käytössä

youtube videot toimii ok
mp3 soi ongelmitta

Ongelman ydin

Xvid avi viedon toistossa murhetta
-etsii liitännäistä
microsoft mpeg-4 4.2 purkajaa yrittää löytää


onko pelastus näissä

libavcodec52   pitäs ilmeisesti riittää mpeg-4 toistoon
libavcodec52-extra-52




Onko tämän linkin ohjeista apua

http://www.doyourself.org/ffmpeg/587-howto-easily-enable-mp3-mpeg4-aac-and-other-restricted-encoders-in-ffmpeg/

Onnistuneesti asennettu

sudo apt-get install ubuntu-restricted-extras

sudo apt-get install w32codecs
-ilmeisesti auttais vain vintous peleihin

asentaja@winlin:~$ sudo apt-get install libdvdcss2
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu      
Luetaan tilatiedot... Valmis        
libdvdcss2 on jo uusin versio.


asentaja@winlin:~$ sudo apt-get install libdvdread4
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu      
Luetaan tilatiedot... Valmis        
Seuraavat ylimääräiset paketit on merkitty asennettaviksi:
  libdvdnav4
Ehdotetut paketit:
  debhelper build-essential
Suositellut paketit:
  head
Seuraavat UUDET paketit asennetaan:
  libdvdnav4 libdvdread4
0 päivitetty, 2 uutta asennusta, 0 poistettavaa ja 74 päivittämätöntä.
Noudettavaa arkistoa 0t/132kt.
Toiminnon jälkeen käytetään 496k t lisää levytilaa.
Haluatko jatkaa [K/e]? k
Valitaan aikaisemmin valitsematon paketti libdvdread4.
(Luetaan tietokantaa... 174259 tiedostoa ja hakemistoa tällä hetkellä asennettuna.)
Puretaan pakettia libdvdread4 (.../libdvdread4_4.1.3-8ubuntu1_i386.deb)...
Valitaan aikaisemmin valitsematon paketti libdvdnav4.
Puretaan pakettia libdvdnav4 (.../libdvdnav4_4.1.3-6_i386.deb)...
Tehdään asetuksia: libdvdread4 (4.1.3-8ubuntu1) ...

Tehdään asetuksia: libdvdnav4 (4.1.3-6) ...

Suoritetaan kohteen libc-bin liipaisimia...
ldconfig deferred processing now taking place




asentaja@winlin:~$ sudo /usr/share/doc/libdvdread4/install-css.sh
--2012-11-20 19:43:47--  http://packages.medibuntu.org/dists/lucid/free/binary-i386/Packages
Selvitetään osoitetta packages.medibuntu.org... 88.191.127.22
Yhdistetään palvelimeen packages.medibuntu.org|88.191.127.22|:80... yhdistetty.
HTTP-pyyntö lähetetty, odotetaan vastausta... 200 OK
Pituus: 8008 (7,8K) [application/octet-stream]
Tallennetaan kohteeseen ”/tmp/dvdcss-ZtZtRv/Packages”

100%[=====================================================>] 8 008       --.-K/s   in 0,07s  

2012-11-20 19:43:47 (113 KB/s) - ”/tmp/dvdcss-ZtZtRv/Packages” tallennettu [8008/8008]

--2012-11-20 19:43:47--  http://packages.medibuntu.org/pool/free/libd/libdvdcss/libdvdcss2_1.2.12-0.0medibuntu1_i386.deb
Selvitetään osoitetta packages.medibuntu.org... 88.191.127.22
Yhdistetään palvelimeen packages.medibuntu.org|88.191.127.22|:80... yhdistetty.
HTTP-pyyntö lähetetty, odotetaan vastausta... 200 OK
Pituus: 39684 (39K) [application/x-debian-package]
Tallennetaan kohteeseen ”/tmp/dvdcss-ZtZtRv/libdvdcss.deb”

100%[=====================================================>] 39 684       192K/s   in 0,2s    

2012-11-20 19:43:47 (192 KB/s) - ”/tmp/dvdcss-ZtZtRv/libdvdcss.deb” tallennettu [39684/39684]

(Luetaan tietokantaa... 174285 tiedostoa ja hakemistoa tällä hetkellä asennettuna.)
Valmistellaan paketin libdvdcss2 1.2.12-0.0medibuntu1 vaihtamista (käyttäen pakettia .../dvdcss-ZtZtRv/libdvdcss.deb)...
Puretaan korvaavaa libdvdcss2-pakettia...
Tehdään asetuksia: libdvdcss2 (1.2.12-0.0medibuntu1) ...

Suoritetaan kohteen libc-bin liipaisimia...
ldconfig deferred processing now taking place


asentaja@winlin:~$ sudo apt-get install ubuntu-restricted-extras
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu      
Luetaan tilatiedot... Valmis        
ubuntu-restricted-extras on jo uusin versio.
Seuraavat paketit asennettiin automaattisesti, eivätkä ne ole enää vaadittuja:
  libswscale0 libtwolame0 libwildmidi0 liborc-0.4-0 libxvidcore4
  libsoundtouch1c2 libdca0 libopenjpeg2 libopenspc0 libpostproc51
  libaccess-bridge-java-jni libaccess-bridge-java libavutil-extra-49 libgme0
  freepats libdvdnav4 libdvdread4 libkate1 libcdaudio1 libmimic0 libsidplay1
  libmodplug0c2 libopencore-amrnb0 libcelt0-0 libdirac-encoder0
  libopencore-amrwb0 libmpeg2-4 libmms0 libiptcdata0 libfaac0 libfaad2
  liba52-0.7.4
Poista ne komennolla "apt-get autoremove".
0 päivitetty, 0 uutta asennusta, 0 poistettavaa ja 80 päivittämätöntä.
asentaja@winlin:~$


asentaja@winlin:~$ sudo aptitude install vlc vlc-plugins-pulse
[sudo] password for asentaja:
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu      
Luetaan tilatiedot... Valmis        
Alustan pakettien tiloja... Valmis
Kirjoitan tilatietoja... Valmis  
En löytänyt pakettia, jonka nimi tai kuvaus sisältäisi merkkijonon "vlc-plugins-pulse".
En löytänyt pakettia, jonka nimi tai kuvaus sisältäisi merkkijonon "vlc-plugins-pulse".
Nämä paketit ovat RIKKI:
  libass4 libavcodec52 vlc vlc-nox

Nämä UUDET paketit asennetaan:
  libavformat52{a} libavutil50{a} libcddb2{a} libdirac-decoder0{a}
  libdvbpsi5{a} libebml3{a} libiso9660-7{a} libmatroska3{a} libmodplug1{a}
  libschroedinger-1.0-0{a} libsdl-image1.2{a} libtar{a} libupnp3{a}
  libva-x11-1{a} libva1{a} libvcdinfo0{a} libvlc5{a} libvlccore4{a}
  libvpx0{a} libx264-98{a} vlc-data{a} vlc-plugin-notify{a}
  vlc-plugin-pulse{a}
Nämä paketit POISTETAAN:
  freepats{u} libaccess-bridge-java{u} libaccess-bridge-java-jni{u}
  libavutil-extra-49{u} libcdaudio1{u} libcelt0-0{u} libfaac0{u} libgme0{u}
  libiptcdata0{u} libmimic0{u} libmms0{u} libmodplug0c2{u}
  libopencore-amrnb0{u} libopencore-amrwb0{u} libopenjpeg2{u}
  libopenspc0{u} libsidplay1{u} libsoundtouch1c2{u} libwildmidi0{u}
  libxvidcore4{u}
Nämä paketit päivitetään:
  libfaad2 liborc-0.4-0 libpostproc51 libswscale0
4 päivitettävää pakettia, 27 uutta asennusta, 20 poistettavaa ja 74 päivittämätöntä.
Tarvitsee noutaa 22,9MB arkistoista. Levytilaa kuluu 19,5MB purkamisen jälkeen.
Näillä paketeilla on tyydyttämättömiä riippuvuuksia:
  libass4: Riippuvuudet: libenca0 (>= 1.9) joka on näennäispaketti.
  vlc-nox: Riippuvuudet: libdc1394-22 joka on näennäispaketti.
           Riippuvuudet: liblua5.1-0 joka on näennäispaketti.
           Riippuvuudet: libmad0 (>= 0.15.1b-3) joka on näennäispaketti.
           Riippuvuudet: libmpcdec3 joka on näennäispaketti.
  vlc: Riippuvuudet: libx11-xcb1 joka on näennäispaketti.
       Riippuvuudet: libxcb-keysyms1 (>= 0.3.6) joka on näennäispaketti.
       Riippuvuudet: libxcb-randr0 (>= 1.1) joka on näennäispaketti.
       Riippuvuudet: libxcb-shm0 joka on näennäispaketti.
       Riippuvuudet: libxcb-xv0 (>= 1.2) joka on näennäispaketti.
  libavcodec52: Riippuvuudet: libgsm1 (>= 1.0.13) joka on näennäispaketti.
Seuraavat toiminnot selvittävät nämä riippuvuudet:

Pidä paketit nykyisessä versiossaan:
libass4 [Ei asennettu]
libavcodec52 [Ei asennettu]
libavformat52 [Ei asennettu]
vlc [Ei asennettu]
vlc-nox [Ei asennettu]
vlc-plugin-notify [Ei asennettu]
vlc-plugin-pulse [Ei asennettu]

-9825 pistettä

Hyväksytkö tämän ratkaisun? [Kyllä=y/ei=n/lopeta=q/?]



Jos yrittää asentaa näitä Synaptic paketinhallinnan kautta tulee herjat

libavcodec52:
 Riippuvuudet: libgsm1 (>=1.0.13) but it is not installable

libass4:
 Riippuvuudet: libenca0 (>=1.9) but it is not installable

vlc:
 Riippuvuudet: vlc-nox mutta sitä ei olla asentamassa
 Riippuvuudet: libavcodec52 mutta sitä ei olla asentamassa tai
    libavcodec-extra-52 mutta sitä ei olla asentamassa
 Riippuvuudet: libx11-xcb1  but it is not installable
 Riippuvuudet: libxcb-keysyms1 (>=0.3.6) but it is not installable
 Riippuvuudet: libxcb-randr0 (>=1.1) but it is not installable
 Riippuvuudet: libxcb-shm0  but it is not installable
 Riippuvuudet: libxcb-xv0 (>=1.2) but it is not installable
 Suosittelut: vlc-plugin-notify mutta sitä ei olla asentamassa
 Suosittelut: vlc-plugin-pulse mutta sitä ei olla asentamassa


asentaja@winlin:~$ sudo apt-get install mplayer
[sudo] password for asentaja:
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu      
Luetaan tilatiedot... Valmis        
Joitakin paketteja ei voitu asentaa. On ehkä vaadittu mahdottomia tai,
jos käytetään epävakaata jakelua, joitain vaadittuja paketteja ei ole
vielä luotu tai siirretty Incoming-kansiosta.
Seuraavista tiedoista voi olla hyötyä selvitettäessä tilannetta:

Näillä paketeilla on tyydyttämättömiä riippuvuuksia:
  mplayer: Riippuvuudet: libavcodec52 (>= 4:0.6-1~) mutta ei ole merkitty asennettavaksi tai
                         libavcodec-extra-52 (>= 4:0.6-1~) mutta ei ole merkitty asennettavaksi
           Riippuvuudet: libavformat52 (>= 4:0.6-1~) mutta ei ole merkitty asennettavaksi tai
                         libavformat-extra-52 (>= 4:0.6-1~) mutta ei ole merkitty asennettavaksi
           Riippuvuudet: libenca0 (>= 1.9) mutta ei ole asennuskelpoinen
           Riippuvuudet: liblzo2-2 mutta ei ole asennuskelpoinen
           Riippuvuudet: libmpcdec3 mutta ei ole asennuskelpoinen
E: Rikkinäiset paketit


Mitä on mennyt ohitse korjaus aloitettava ilmeisesti näistä mutta miten

Nämä paketit ovat RIKKI:
  libass4 libavcodec52 vlc vlc-nox

EDIT
Löysin netistä tälläisen ubuntu sivun alan tuota tavailemaan aiheeseen liittyvää ohjetta lontooksi

Comprehensive Multimedia & Video Howto

http://ubuntuforums.org/showthread.php?t=766683

« Viimeksi muokattu: 29.11.12 - klo:17.28 kirjoittanut Laplinux »

Laplinux

  • Käyttäjä
  • Viestejä: 148
    • Profiili
Onkos tästä jelppiä miksi ei asennuu

asentaja@winlin:~$ gksudo gedit /etc/apt/sources.list


# deb cdrom:[Ubuntu 10.04.3 LTS _Lucid Lynx_ - Release i386 (20110720.1)]/ lucid main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://fi.archive.ubuntu.com/ubuntu/ lucid restricted
deb-src http://fi.archive.ubuntu.com/ubuntu/ lucid restricted

## Major bug fix updates produced after the final release of the
## distribution.

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://fi.archive.ubuntu.com/ubuntu/ lucid universe
deb-src http://fi.archive.ubuntu.com/ubuntu/ lucid universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fi.archive.ubuntu.com/ubuntu/ lucid multiverse
deb-src http://fi.archive.ubuntu.com/ubuntu/ lucid multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://fi.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse
# deb-src http://fi.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu lucid partner
# deb-src http://archive.canonical.com/ubuntu lucid partner

deb http://fi.archive.ubuntu.com/ubuntu/ lucid-security restricted
deb-src http://fi.archive.ubuntu.com/ubuntu/ lucid-security restricted
deb http://fi.archive.ubuntu.com/ubuntu/ lucid-security universe
deb-src http://fi.archive.ubuntu.com/ubuntu/ lucid-security universe
deb http://fi.archive.ubuntu.com/ubuntu/ lucid-security multiverse
deb-src http://fi.archive.ubuntu.com/ubuntu/ lucid-security multiverse
deb http://helineva.net/deb lucid main
# deb http://archive.canonical.com/ lucid partner
# deb http://download.virtualbox.org/virtualbox/debian lucid contrib
deb http://fi.archive.ubuntu.com/ubuntu/ lucid-security main
deb http://security.ubuntu.com/ubuntu/ lucid-security restricted multiverse universe



EDIT

Homma ratkesi osittain ainakin herjoja ei tullut VLC osalta.

VLC asentui ilman ongelmia kun klikkasin rastin kohtaan
ohjelmalähteet ja sieltä ylin kohta
Ubuntu ohjelmistot
Canonicalin tukemat ohjelmalähteet MAIN
« Viimeksi muokattu: 21.11.12 - klo:16.18 kirjoittanut Laplinux »