Kirjoittaja Aihe: Netgen/solve aasennus ongelma.  (Luettu 1469 kertaa)

koivukoski1

  • Käyttäjä
  • Viestejä: 716
    • Profiili
Netgen/solve aasennus ongelma.
« : 01.01.22 - klo:11.40 »
Kyseinen virhe asentaessa.
Mitähän tarkoittaa?
Koodia: [Valitse]
Puretaan ngsolve (6.2.2105-0~ubuntu20.04.1) ...
dpkg: error processing archive /tmp/apt-dpkg-install-X3HGpQ/44-ngsolve_6.2.2105-0~ubuntu20.04.1_amd64.deb (--unpack):
 trying to overwrite '/usr/bin/netgen', which is also in package netgen 1:6.2.2006+really6.2.1905+dfsg-0~202102251943~ubuntu20.04.1
dpkg-deb: virhe: paste subprocess was killed by signal (Katkennut putki)
Käsittelyssä tapahtui liian monta virhettä:
 /tmp/apt-dpkg-install-X3HGpQ/44-ngsolve_6.2.2105-0~ubuntu20.04.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

-Koivukoski1

mpiso

  • Käyttäjä
  • Viestejä: 624
    • Profiili
Vs: Netgen/solve aasennus ongelma.
« Vastaus #1 : 01.01.22 - klo:17.08 »
Minä en ole käyttänyt Netgeniä ratkaisijana, ainoastaan verkon tekemiseen, enkä ole muistaakseni koskaan asentanut pakettia ngsolve. Kun tuota virheilmoitusta katsoo, niin näyttää, että olet aiemmin asentanut verkottajan ja nyt olet asentamassa ratkaisijaa. Niissä näyttäisi olevan sama, mutta eri versio jostain paketista. Pitäisikö sinun poistaa verkottaja ja asentaa verkottaja ja ratkaisija samasta lähteestä.

Lisäys: Kun tarkemmin katsoo, niin verkottaja (netgen) saattaa ollakin mukana paketissa ngsolve, eikä sitä tarvitse erikseen asentaa.
« Viimeksi muokattu: 01.01.22 - klo:17.18 kirjoittanut mpiso »

koivukoski1

  • Käyttäjä
  • Viestejä: 716
    • Profiili
Vs: Netgen/solve aasennus ongelma.
« Vastaus #2 : 01.01.22 - klo:18.01 »
Kiitos vastauksesta!
Yritin poistamalla ubuntun oman version, mutta sama tulos.
Pitää tutkiskella?

-Koivukoski1

mpiso

  • Käyttäjä
  • Viestejä: 624
    • Profiili
Vs: Netgen/solve aasennus ongelma.
« Vastaus #3 : 01.01.22 - klo:19.33 »
Kokeilin asentaa sen Kubuntun (20.04) kokeilutilassa. Asennus onnistui (kuva). Asensin sen alla olevasta ppa:sta.

https://launchpad.net/~ngsolve/+archive/ubuntu/ngsolve

koivukoski1

  • Käyttäjä
  • Viestejä: 716
    • Profiili
Vs: Netgen/solve aasennus ongelma.
« Vastaus #4 : 02.01.22 - klo:11.01 »
Josko minulla Salome Meca:n, Elmerin tai Z88:n asennus vaikuttaa siten,
ettei NetGen/Solven asennus heti onnistunut?
Mutta kokeilen myöhemmin, tuota uusinta vihjettäsi, kiitos!

-Koivukoski1