Kirjoittaja Aihe: Chrome lakkasi toimimasta!  (Luettu 15940 kertaa)

juice82

  • Käyttäjä
  • Viestejä: 219
    • Profiili
Vs: Chrome lakkasi toimimasta!
« Vastaus #20 : 08.07.12 - klo:18.49 »
Meikäläisen tapauksessa suljettuiden tiedostomuotojen asentamatta jättäminen ei ole korjaus flash ongelmiin, taitaa olla ensimmäinen paketti jonka asennan käyttikseen.

Tässä tapauksessa Chromiumissa sekä FF:ssä ei toimi esim. IL-tv kun "missing plug-in".
Youtube toimii tällä hetkellä vain ja ainoastaan HTML5:lla!

En ole aivan varma mitä tarkoitat, mutta tässä selvennyksiä vastauksiini:


a) En ehdottanut Adoben Flashin asentamatta jättämistä vaan nimenomaan sen asentamista. Tuo tapa jonka edellä kerroin asentaa sen ja nimenomaan asentaa sen mitä Ubuntuun pitää asentaa.


b) Youtube toimii tuon jälkeen. Kokeile esim.:

http://www.youtube.com/watch?v=BGHlZwMYO9g

Tämä on hyvin uusi Youtube video. Kaikki mitä olen kokeillut, toimii e.m. tavalla - yleensä olen hakenut vain musiikkivideoita.


c) Mielestäni hyvin voi olla palveluja jotka eivät toimi - syystä tai toisesta. Puhuit kuitenkin edellä Youtubesta ja Areenasta ja vastasin niihin.

EDIT:

Liitin mukaan kuvan josta näet mitä Youtubessa ajetaan. Selain on oletus Firefox.

Vielä kerran:

A) Suljetut tiedosto muodot sisältävät paketit on asennettu, Ubuntun => ubuntu-restricted-extras ja Xubuntun => Xubuntu-restricted-extras.

B) Firefox ja Chromium testattu molemmissa distroissa ilman HTML5 kokeilua. Video EI toimi. Firefox:ssa musta ruutu ja Chromiumissa "missing plug-in"

C) IL-Tv ei toimi mitenkään, Youtube vain HTML5:lla. Koskee molempia selaimia!

D) Google Chrome- selaimessa flashit toimi joka paikassa mutta uusimman päivityksen jälkeen ei toimi koko selain.
Pöytäkone: Ubuntu 16.04 LTS + Win 10 Pro. Läppäri 1: Ubuntu Mate 16.04 LTS. Läppäri 2: Debian Jessie Xfce.

juice82

  • Käyttäjä
  • Viestejä: 219
    • Profiili
Vs: Chrome lakkasi toimimasta!
« Vastaus #21 : 08.07.12 - klo:21.56 »
Lisään vielä kokeilun tuloksia:

Olen kokeillut asentaa ja poistaa synaptic:lla "flash" -paketteja. 

1.Asensin flashplugin-installer paketin joka poistaa/korvaa samalla paketit adobe-flashplugin ja adobe-flash-properties-gtk. Ei ollut vaikutusta mihinkään!

2. Kokeilin poistaa myös flashplugin-installer paketin. Kappas! Chromium ja Firefox alkoivat toistaa youtube videoita, miten se voi olla mahdollista? IL-Tv  ei toimi edelleen, FF:ssä vaatii flashplayer 9 tai uudempaa...

3. FF:ssä kun valitsee youtubessa videon valittaa se ensin puuttuvaa pluginia (flash) mutta alkaa toistamaan välittömästi videota normaalisti. Mutta jos käy asentamassa puuttuvat flash liitännäiset, asentaa kone paketit  adobe-flashplugin ja adobe-flash-properties-gtk takaisin ja jälleen videot ei toimi.

Eli kyllä se on tuo Flash joka tässä temppuilee vai olenko pahasti väärässä?!
Pöytäkone: Ubuntu 16.04 LTS + Win 10 Pro. Läppäri 1: Ubuntu Mate 16.04 LTS. Läppäri 2: Debian Jessie Xfce.

juice82

  • Käyttäjä
  • Viestejä: 219
    • Profiili
Pöytäkone: Ubuntu 16.04 LTS + Win 10 Pro. Läppäri 1: Ubuntu Mate 16.04 LTS. Läppäri 2: Debian Jessie Xfce.

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 11051
    • Profiili
    • Tomin kotisivut
Vs: Chrome lakkasi toimimasta!
« Vastaus #23 : 10.07.12 - klo:22.14 »
2. Kokeilin poistaa myös flashplugin-installer paketin. Kappas! Chromium ja Firefox alkoivat toistaa youtube videoita, miten se voi olla mahdollista? IL-Tv  ei toimi edelleen, FF:ssä vaatii flashplayer 9 tai uudempaa...
Luultavasti siksi, että Youtubessa voi käyttää HTML5-soitinta (osalle videoista).
http://www.youtube.com/html5
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

juice82

  • Käyttäjä
  • Viestejä: 219
    • Profiili
Vs: Chrome lakkasi toimimasta!
« Vastaus #24 : 11.07.12 - klo:07.49 »
Joo eipä ollut HTML5 käytössä vaikka flash-pluginit poistinkin, silti videot näkyi juutuubissa.

Mutta miksi IL-Tv videot ei näy vaikka flashit asennettu, koskee FF että chromiumia?? kokeillut gnassia ja lightspark:ia, ei toimi!
Pöytäkone: Ubuntu 16.04 LTS + Win 10 Pro. Läppäri 1: Ubuntu Mate 16.04 LTS. Läppäri 2: Debian Jessie Xfce.

CoReD

  • Käyttäjä
  • Viestejä: 138
    • Profiili
Vs: Chrome lakkasi toimimasta!
« Vastaus #25 : 11.07.12 - klo:11.23 »
Päivitin juuri eilen tuon läppärin Xubuntun ja Chrome toimii moitteetta siinä missä ennenkin. Virallinen, Googlen sivuilta ladattu 64-bit. Samaten tällä pöytäkoneella uusin Chrome toimii ihan kuten pitääkin, alustana Debian sid (okei, jouduin downgradettamaan libcairo2:en versioon 1.8... kun oli vähän jähmeä käyttää, mutta se ei liity Ubuntuun, eikä vaikuta Chromen käynnistymiseen)

Villi veikkaus tässä vaiheessa on, että kun olet tuon flashin kanssa tapellut, niin siellä koneella on nyt useampia flashplugareita jotka sekoilevat keskenään ja sen takia ei mikään tai vain osa toimii.

Koodia: [Valitse]
dpkg --get-selections | grep flash
Tuolla saat näppärästi etsittyä järjestelmästä kaikki flashiin liittyvät asennetut paketit, jos et kaikkea asentamaasi muista. Sitten ihan kylmästi:

Koodia: [Valitse]
sudo apt-get remove --purge ne kaikki flashiin liittyvät paketit tähän
Ja poista vielä se Google Chromekin samalla

Koodia: [Valitse]
sudo atp-get remove --purge google-chrome
Sitten voisit päivittää koko järjestelmän (kuten sanottua, päivitin eilen 12.04 Xubuntun dist-upgradella ja uusin Chrome toimii moitteetta):

Koodia: [Valitse]
sudo apt-get update
sudo apt-get dist-upgrade

Sitten latailet Chromen sieltä Googlen sivuilta muttet lähde asentelemaan sitä minkään Sovellusvalikoiman kautta vaan komennat päätteeltä niin nähdään suoriltaan heittääkö asennus jotain erroreita:

Koodia: [Valitse]
sudo dpkg -i /hakemisto/johon/tallensit/chromen/google.chrome.....deb
Jos tuo komento antaa minkäänlaista erroria niin aja perään vielä

Koodia: [Valitse]
sudo apt-get -f install
Nyt pitäisi kaiken järjen mukaan Chrome toimia moitteetta, ellei asennuksessasi ole jotain pahemmin hajalla. Jos ei toimi niin voit tietysti pasteta tuon dpkg:n antamat errorit tänne (ja mahdollisesti nekin mitä apt-get -f install antaa) niin on edes jotain pohjaa vähän katsoa mikä sen Chromen kanssa mättää.

tai

Jos sen Chromen kanssa ei kiinnosta tapella, voit palata flashin kanssa tappeluun, mutta pidä huolta, että asennat vain yhden plugarin kerrallaan ja jokaisen kokeilun jälkeen poistat sen edellisellä kerralla kokeilemasi plugarin mikäli se ei toiminut.

Sanottakoon vielä sen verran että ainakin omissa 12.04 asennuksissa flash on toiminut suoraan, asentelematta mitään ylimääräistä. Jos et sitten ole valinnut ei-vapaita ohjelmia asennettavaksi asennuksen yhteydessä niin Ubuntu (samalla tietysti myös Xubuntu) 12.04:ssä flashin pitäisi toimia Firefoxilla ja suurimmalla osalla "vaihtoehtoselaimista" menemällä Sovellusvalikoimaan, kirjoittamalla hakukenttään "flash" ja asentamalla sen tarjomat paketit. Reboot on aina hyvä, astuu varmasti kaikki muutokset voimaan. Vähintään selaimen uudelleenkäynnistys asennuksen jälkeen.

Voi kuitenkin olla hyvä aloittaa poistamalla xubuntu-restricted-extras kaikkien muiden flash-pakettien kanssa ja asentaa se uudelleen, ennenkuin kokeilee asentaa mitään muuta.

Edit:

Lainaus
Based on the details so far, it's looking like an issue with older CPUs, possibly ones that don't support sse2 instructions. The Pepper Flash plugin probably won't support such systems, and we may just have to disable it if the necessary CPU capabilities aren't detected. For now, users who are experiencing this problem should run with the "--disable-bundled-ppapi-flash" flag.

Voithan silti asentaa piruuttaan vielä uudelleen. Eipä siinä mitään häviä. Hyvällä tuurilla kyseinen bugi olisi saatu kojrattua (en jaksanut kahlata kaikkia viestejä läpi).. Luonnollisesti jos rauta ei tue, niin rauta ei tue, sille ei sitten mitään mahda. :( Onko mikä prosessori koneessa?
« Viimeksi muokattu: 11.07.12 - klo:12.34 kirjoittanut CoReD »
Asus Maximux IV Hero | i5-4670K | Thermalright Archon SB-E | 2x4GB RipjawsX | GTX 970 4GB  | Samsung 128GB 840 Pro | Kingston 480GB SSDNow V300 | 2TB WD Green | Fractal Design Define R4 | Seasonic G-550 | Creative Sound Blaster Z |  Asus PB278Q | Win 8.1

juice82

  • Käyttäjä
  • Viestejä: 219
    • Profiili
Vs: Chrome lakkasi toimimasta!
« Vastaus #26 : 11.07.12 - klo:19.34 »
No niin. Vaikka epäilen että suurin syy Chromen toimimattomuuteen minun koneissa on tuo PPAPI eli mulla on liian vanhaa rautaa, koska "--disable-bundled-ppapi-flash" -rimpsulla Crome lähtee käyntiin. No se siitä, odotetaan korjausta!!

kokeiin kuitenkin poistaa chromen, flashit ja ubuntu-resricted-exras. Sitten update, dist-upgrade boottaus ja asensin vain ubuntu-restricted-extras.

- Firefox vaatii asentamaan juutuubissa joko Gnash tai flash-plugin:in mutta toistaa videot ilman asennusta.Kokeilin asentaa flash-pluginin mutta videot ei enään toiminut eli parempi ilman. Gnash on surkea tekele.

- Chromium lähti toistamaan videot lennosta ilman itkua liitännäisistä, tuntuu toimivan hyvin ilman mitään plugineja.

- No edellee! Iltalehden videot ei näy oli sitten flashit tai ei, gnash:sta tai lightspark:sta puhumattakaan.

Koneethan on vanhoja! Läppäri -03-04, pöytäkone samalta ajalta eli AMD Athlon XP prossuilla vielä mennään eli tarvi edes uneksia SSE2 tuesta :D

  
 
« Viimeksi muokattu: 11.07.12 - klo:19.38 kirjoittanut juice82 »
Pöytäkone: Ubuntu 16.04 LTS + Win 10 Pro. Läppäri 1: Ubuntu Mate 16.04 LTS. Läppäri 2: Debian Jessie Xfce.

CoReD

  • Käyttäjä
  • Viestejä: 138
    • Profiili
Vs: Chrome lakkasi toimimasta!
« Vastaus #27 : 11.07.12 - klo:20.10 »
IL:n videot näköjään 11.3.300 ja viimeisin Linuxille julkaistu flash-player on versionumeroa 11.2.202.. Olisiko tuolla sitten väliä, eli vaatiiko tuo IL-TV vaan oikeasti 11.3 sarjalaisen flash-playerin. Ei oikein muuta tule heti mieleen. Jos kerran muut flashvideot toimivat niin silloin se vika ei oikein muussa voi olla kuin flash-playerin versiossa.

Chromehan on ja tulee olemaan ainut tapa saada käyttöönsä ajantasainen Flash Linuxilla, sillä Adobe linuxin tukemisen lopetti tuohon 11.2 versioon.. (jos en ihan väärin ole ymmärtänyt).

Tuo Athlon XP on tosissaan liian vanha tuolle Chromen flashille. Toivottavasti saavat korjattua piakkoin ja nimenomaan korjattua, eivätkä vain tyydy diabloimaan koko Flashiä vanhemmilta koneilta.
Asus Maximux IV Hero | i5-4670K | Thermalright Archon SB-E | 2x4GB RipjawsX | GTX 970 4GB  | Samsung 128GB 840 Pro | Kingston 480GB SSDNow V300 | 2TB WD Green | Fractal Design Define R4 | Seasonic G-550 | Creative Sound Blaster Z |  Asus PB278Q | Win 8.1

juice82

  • Käyttäjä
  • Viestejä: 219
    • Profiili
Vs: Chrome lakkasi toimimasta!
« Vastaus #28 : 11.07.12 - klo:21.19 »
Miten FF ja Chromium voi näyttää esim. youtube videot vaikka flash iä ei ole asennettu eikä kummassakaan ole sitä sisäänrakennettuna.

Tuo Gnash:ia ja lightsparkia saisi kyllä alkaa kunnolla kehittämään!
Pöytäkone: Ubuntu 16.04 LTS + Win 10 Pro. Läppäri 1: Ubuntu Mate 16.04 LTS. Läppäri 2: Debian Jessie Xfce.

CoReD

  • Käyttäjä
  • Viestejä: 138
    • Profiili
Vs: Chrome lakkasi toimimasta!
« Vastaus #29 : 11.07.12 - klo:22.25 »
Jos olet asentanut ubuntu-restricted-extras paketin niin flash on asennettu, sillä tuo kyseinen paketti asentaa myös sen.

Silloin kun flashia ei ole asennettu lainkaan, (eli ei myöskään ubuntu-restricted-extras-pakettia) voit edelleenkin katsoa osaa youtube-videoista html5:lla.

En tiedä missä vaiheessa Youtuben html5-tuki on, mutta se ei välttämättä tarvitse mitään erityistä html5-kokeiluun liittymistä enää tässä vaiheessa. Youtube voi hyvinkin tarjota videoiden html5-versioita kun "haistelee" ettei flashiä ole asennettu ja siksi osa videoista näkyy.
Asus Maximux IV Hero | i5-4670K | Thermalright Archon SB-E | 2x4GB RipjawsX | GTX 970 4GB  | Samsung 128GB 840 Pro | Kingston 480GB SSDNow V300 | 2TB WD Green | Fractal Design Define R4 | Seasonic G-550 | Creative Sound Blaster Z |  Asus PB278Q | Win 8.1

juice82

  • Käyttäjä
  • Viestejä: 219
    • Profiili
Vs: Chrome lakkasi toimimasta!
« Vastaus #30 : 12.07.12 - klo:19.49 »
Eikös komennon dpkg --get-selections | grep flash pitäsisi näyttää asennetut flash:it jos resricted-extras paketista ne on asennettu??

Jos näin niin eipä näkynyt, ei näkynyt edes sovellusvalikoimassa että olisi. Mutta kun asensin puuttuvat flash paketit (ei Flashplugin-installer!) niin jälleen videot lakkasi toimimasta!


 dpkg --get-selections | grep flash näyttää nyt näin:

adobe-flash-properties-gtk         
adobe-flashplugin            

Ja kun poistan nuo niin jälleen videot toimii!
Pöytäkone: Ubuntu 16.04 LTS + Win 10 Pro. Läppäri 1: Ubuntu Mate 16.04 LTS. Läppäri 2: Debian Jessie Xfce.

CoReD

  • Käyttäjä
  • Viestejä: 138
    • Profiili
Vs: Chrome lakkasi toimimasta!
« Vastaus #31 : 12.07.12 - klo:20.25 »
Otin nyt tämän Xubuntu-läppärin tähän nenän eteen. Pöytäkoneella Debian niin huono neuvoa sen kanssa.

Kyseessä on 12.04 joka päivitetty tuossa pari päivää sitten, kuten tuli aikaisemmin jo mainittuakin. Koneelle ei ole mitään ihmeempiä asenneltu tai ihmeempiä viilauksia tehty. Käytännössä kohtalaisen puhdas asennus. Flash toimii Firefoxilla moitteetta.

Koodia: [Valitse]
dpkg --get-selections | grep flash
flashplugin-installer                             install

Ja: (koska en tiennyt mitä paketteja asennus on oletuksena asentanut)

Koodia: [Valitse]
dpkg --get-selections | grep restricted
ubuntu-restricted-addons                          install

Google-haku osoittaa, että paketti 'flashplugin-installer' kuuluu pakettiin 'ubuntu-restricted-addons'.

Ok! Komennot toimii kuten pitääkin ja flash toimii. Otin ja poistin restricted-addons ja flasplugin paketit:

Koodia: [Valitse]
sudo apt-get remove --purge ubuntu-restricted-addons flashblugin-installer
Avasin Firefoxin ja kokeilin katsella flash-videoita. Flash ei toimi!

Asensin (vain ja ainoastaan - enkä mitään muuta)

Koodia: [Valitse]
sudo apt-get install xubuntu-restricted-extras
(joka hakee oletuksena myös paketin xubuntu-restricted-addons koska se kuuluu riippuvuuksiin (joka taasen sisältää paketin flasplugin-installer)).

Asennuksen jälkeen avasin jälleen Firefoxin ja tuloksena:   Flash toimii. Myös IL-TV!

Ja jälleen flashplugin-installer on asennettu ja näkyy aiemmin käytetyllä komennolla:

Koodia: [Valitse]
dpkg --get-selections | grep flash
flashplugin-installer                             install

Menin vielä Ubuntun sovellusvalikoimaan, kirjoitin hakukenttään 'flash' ja ensimmäinen hakutulos:

"Adobe Flash-liitännäinen"

On asennettu. Samoin Xubuntun rajoitetut lisäosat joka näkyy listassa alempana.

Poistin vielä kertaalleen kaikki edellämainitut paketit:

Koodia: [Valitse]
sudo apt-get remove --purge xubuntu-restricted-extras xubuntu-restricted-addons flashplugin-installer
Kokeilin Firefoxilla: Flash ei toimi!

Menin Ubuntun sovellusvalikoimaan, lisäsin hakukenttään "flash" ja asensin ensimmäisen hakutuloksen "Adobe Flash-liitännäinen" suoraan Ubuntun sovellusvalikoiman kautta (enkä mitään muuta)

Kokeilin jälleen Firefoxilla: Flash toimii! Myös IL-TV!

Koodia: [Valitse]
dpkg --get-selections | grep flash
flashplugin-installer                             install

On jälleen asennettu.

Kokeilin tässä nyt yhdeltä istumalta kahta eri tapaa asentaa flash (molemmat tavat neuvottu tässä ketjussa) ja molemmilla Flash toimii Firefoxilla ja myös IL-TV näkyy kuten pitääkin.

Koska minulla ei ollut Chromiumia asennettuna, asensin senkin ja kokeilin toimiiko flash sillä. Toimii! Myös IL-TV!

Ehkä kannattaa vielä kokeilla kertaalleen ihan alusta. Ei tässä oikein muutakaan osaa neuvoa. Poista jälleen kaikki flash-paketit ja restricted-extras ja restricted-addons.

Sitten asennat paketin xubuntu-retricted-extras ja kokeilet Firefoxilla. Kaiken järjen (ja edellä olevan testailun perusteella flashin pitäisi toimia moitteetta ja myös IL-TV toimii kuten pitääkin)

Jos ei toimi, niin itseltä alkaa käymään neuvot vähiin.

Kopioi nyt tällä kerralla vaikka kaikki mitä pääte suoltaa tähän ketjuun code-tagien väliin (löytyy tuosta viestin kirjoituskentän yläpuolelta risuaitamerkin takaa) ihan alusta loppuun saakka. Voit vielä käynnistää Firefoxin/Chromiumin siltä päätteeltä ja kopioida senkin tulosteen tänne. Jos sieltä löytyisi jotain Erroreita jotka selittäisivät asiaa.

Siis siinä tapauksessa, ettei se flash vieläkään toimi.

Voi tietysti olla, että asennuksessasi on nyt jotain pahasti solmussa, tarvittavia pakettilähteitä ei ole asennettu tai jotain muuta mikä ei ole vielä tässä tullut ilmi. Paha sanoa.

Onko kyseessä puhtaat asennukset vai upgradet 10.04:stä? Tuokin voi vaikuttaa.
« Viimeksi muokattu: 12.07.12 - klo:22.18 kirjoittanut CoReD »
Asus Maximux IV Hero | i5-4670K | Thermalright Archon SB-E | 2x4GB RipjawsX | GTX 970 4GB  | Samsung 128GB 840 Pro | Kingston 480GB SSDNow V300 | 2TB WD Green | Fractal Design Define R4 | Seasonic G-550 | Creative Sound Blaster Z |  Asus PB278Q | Win 8.1

juice82

  • Käyttäjä
  • Viestejä: 219
    • Profiili
Vs: Chrome lakkasi toimimasta!
« Vastaus #32 : 12.07.12 - klo:22.47 »
Nyt Kokeiltua!

Postettu kaikki ylimääräinen:

Koodia: [Valitse]
sudo apt-get remove --purge ubuntu-restricted-extras ubuntu-restricted-addons
ja perään vielä jääneet:

Koodia: [Valitse]
sudo apt-get remove --purge (joku adobe-plugin ja adobe-plugion-gtk)
Nyt siis kaikki extrat pois!

Asensin sovellusvalikoimasta tuon "Flashplugin-installerin"

Tulos: Ei toimi flashit, ei youtubessa eikä IL-tv:ssä.

Poistin paketin.

Asennetaan uudelleen :

Koodia: [Valitse]
Sudo apt-get install ubuntu-restricted-extras
eli:
Koodia: [Valitse]
juice@juice-oma:~$ dpkg --get-selections | grep restricted
ubuntu-restricted-addons install
ubuntu-restricted-extras install

ja

Koodia: [Valitse]
juice@juice-oma:~$ dpkg --get-selections | grep flash
adobe-flash-properties-gtk install
adobe-flashplugin install

tulos: ei toimi edelleenkään! youtube & IL-tv

Poistin paketit:

Koodia: [Valitse]
sudo apt-get remove --purge adobe-flash-properties-gtk adobe-flashplugin
Ja asennettu pelkkä flashplugin-installer:

Koodia: [Valitse]
Sudo apt-get install flashplugin-installer
Tulos: ei toimi! joten poistetaan....

Nyt siis asennettuna vain restricted-addons ja -extras

Ei toimi videot.

Mutta Jos kytken flassin pois päältä firefox:in lisäosien hallinnasta videot alkavatkin näkyä!! (youtubessa)


Nyt alkaa olemaan pää sekaisin ja täynnä tuosta flash.... jätetään sanomatta!  >:(


« Viimeksi muokattu: 12.07.12 - klo:22.52 kirjoittanut juice82 »
Pöytäkone: Ubuntu 16.04 LTS + Win 10 Pro. Läppäri 1: Ubuntu Mate 16.04 LTS. Läppäri 2: Debian Jessie Xfce.

Tuxer

  • Käyttäjä
  • Viestejä: 657
  • Debian 7.0, Sailfish
    • Profiili
    • opendimension.org
Vs: Chrome lakkasi toimimasta!
« Vastaus #33 : 13.07.12 - klo:12.19 »
Oma tvkaista-kone lakkasi myös näyttämästä videoita puuttuvan sse2-tuen takia. Korjasin asentamalla Chromen version 19. Ei nyt aivan optimaalinen korjaus mutta toimii.

HUOM! Tuo ei sitten päivity eli jonkin sortin tietoturvariski on.

http://www.sixtoed-design.com/downloads/google-chrome19-stable_current_i386.deb
"Menehän Tonttu Tomera tarkastamaan ollaanko korsuissa kiltisti."
Fingerpori

BBT

  • Käyttäjä
  • Viestejä: 352
    • Profiili
Vs: Chrome lakkasi toimimasta!
« Vastaus #34 : 14.07.12 - klo:12.59 »
Koskeeko nämä flash ongelmat vain 32 bittisiä järjestelmiä? Itsellä on 64 bittinen Ubuntu 12.04 ja kaikki flash sisältö toistuu sekä Firefoxilla että Chromella ongelmitta.

Chromessa käytössä oleva flash-versio on Shockwave Flash 11.3 r31 ja Firefoxissa Shockwave Flash 11.2 r202. Molemmilla esimerkiksi tuo IL-TV ja Youtube toistuvat ongelmitta.

Koodia: [Valitse]
dpkg --get-selections | grep flash
adobe-flash-properties-gtk install
adobe-flashplugin install
flashplugin-installer deinstall

Edit: Chromen versio 20.0.1132.57 ja Firefoxin 13.0.1.

Koodia: [Valitse]
lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise

Koodia: [Valitse]
uname -a
Linux topias-pc 3.2.0-26-generic #41-Ubuntu SMP Thu Jun 14 17:49:24 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

« Viimeksi muokattu: 14.07.12 - klo:13.03 kirjoittanut BBT »

CoReD

  • Käyttäjä
  • Viestejä: 138
    • Profiili
Vs: Chrome lakkasi toimimasta!
« Vastaus #35 : 14.07.12 - klo:13.28 »
Googlettelin vähän ja kuukauden aikarajoituksella saa eteensä melkoisen läjän ketjuja jotka koskevat ongelmia Ubuntun ja Flashin kanssa. Yhdessäkään ketjussa ei ole keksitty ratkaisua vaikka flash-plugineita on poistettu, asenneteltu uudelleen jnejnejne. Ongelma voi olla yksinkertaisesti "liian vanhassa" raudassa koska suurin osa ketjuista koskee nimenomaan ongelmia uusimman Chromen kanssa jonka jälkeen flashiä ei ole saatu toimimaan oikein millään vippaskonsteilla.

Voit kokeilla vielä paria kikkaa:

Asenna Firefoxiin Flash-aid:
https://addons.mozilla.org/en-US/firefox/addon/flash-aid/

Ja Low Quality Flash:
https://addons.mozilla.org/fi/firefox/addon/low-quality-flash/

Kun menet sivustolle jolla on flash-videoita, paina hiiren oikealla video-ikkunaa ja valitse flashin asetuksista hardware acceleration pois päältä.

Ja koska ongelma tuntuu olevan raudassa, kannattanee myös katsoa ajuripuoli kuntoon. Jos suljetut ajurit käytössä, yritä asentaa ne uudelleen/vapailla ajureilla. Jos vapaat ajurit käytössä, yritä suljettuja ajureita.

Voit myös kokeilla tätä scriptiä joka voi helpottaa tilannetta edes vähän (ei mitään tietoa korjaako ongelmat IL-TV:n kanssa):

http://userscripts.org/scripts/show/87011

Tämän käyttöön en osaa antaa neuvoja, mutta Google auttanee sivuston oman ohjeistuksen lisäksi.

Tämän enempää meikäläinen ei osaa auttaa.  :-\

Tuo aiemmin linkitetty Chrome 19 voi olla se helpoin tapa saada Flash taas toimimaan. Sen käyttäminen on luonnollisesti taas tietoturvariski. Mutta ehkä voisi ajatella, että tuota vanhempaa Chromea käyttää videoiden katseluun ja kaikkeen muuhun sitten viimeisintä Chromiumia/Firefoxia.

Koko järjestelmän uudelleen asennus voi toki olla myös ratkaisu, mutta sitä on vaikea mennä lupaamaan, että se ongelman ratkaisisi. Uudelleen asennuksella kuitenkin varmistutaan siitä, että järjestelmä ei ole toisaalla solmussa ja estä täten myös Flashin toimivisen.

Erittäin suositeltavaa jos olet tehnyt versiopäivityksen 10.04:stä 12.04:ään.
« Viimeksi muokattu: 14.07.12 - klo:14.56 kirjoittanut CoReD »
Asus Maximux IV Hero | i5-4670K | Thermalright Archon SB-E | 2x4GB RipjawsX | GTX 970 4GB  | Samsung 128GB 840 Pro | Kingston 480GB SSDNow V300 | 2TB WD Green | Fractal Design Define R4 | Seasonic G-550 | Creative Sound Blaster Z |  Asus PB278Q | Win 8.1

shelby

  • Käyttäjä
  • Viestejä: 1861
    • Profiili
Vs: Chrome lakkasi toimimasta!
« Vastaus #36 : 14.07.12 - klo:14.02 »
Kaikki videot toimii viimeisemmässä Chromessa, mutta ei saa fullscreeniin. Ja uusin 12.04 Ubu kernelillä 3.2.0-27-gen. Tuo ihmetyttää tuo fullscreenin toimimattomuus, toisilla selaimilla toimii kyllä, FF, Opera, Reqong. Niin, ei toimi Kubuntun puolellakaan Chromella??
Ubu Gnome 20.04.1 LTS
Win 8.1 laptop I
Win 10 laptop II
Ubu Mate 20.04.1 LTS
Kubu 20.04.1 LTS

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 11051
    • Profiili
    • Tomin kotisivut
Vs: Chrome lakkasi toimimasta!
« Vastaus #37 : 14.07.12 - klo:14.35 »
Kaikki videot toimii viimeisemmässä Chromessa, mutta ei saa fullscreeniin. Ja uusin 12.04 Ubu kernelillä 3.2.0-27-gen. Tuo ihmetyttää tuo fullscreenin toimimattomuus, toisilla selaimilla toimii kyllä, FF, Opera, Reqong.
Se fullscreenin toimimattomuus johtuu siitä, että Chrome käyttää PPAPI-versiota Flashistä ja muut perinteisempää NPAPI:a (sellaista versiota ei ole enää uusimmasta 11.3 flashistä Linuxille).

http://en.wikipedia.org/wiki/NPAPI
http://en.wikipedia.org/wiki/PPAPI#PPAPI
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

shelby

  • Käyttäjä
  • Viestejä: 1861
    • Profiili
Vs: Chrome lakkasi toimimasta!
« Vastaus #38 : 14.07.12 - klo:15.03 »
Kiits, tämäpäs selkis. Käytössä juuri tuo flashversio 11.3.... Mennään sitten videot toisilla selaimilla.
Ubu Gnome 20.04.1 LTS
Win 8.1 laptop I
Win 10 laptop II
Ubu Mate 20.04.1 LTS
Kubu 20.04.1 LTS

BBT

  • Käyttäjä
  • Viestejä: 352
    • Profiili
Vs: Chrome lakkasi toimimasta!
« Vastaus #39 : 14.07.12 - klo:15.29 »
Kiits, tämäpäs selkis. Käytössä juuri tuo flashversio 11.3.... Mennään sitten videot toisilla selaimilla.

Mikä näytönohjain ja mitkä ajurit? Itsellä on Chrome 20.0.1132.57 ja  flashin versio 11.3.31.115. Kaikki flashvideot toimii fullscreenissä.