Kirjoittaja Aihe: Helppo tapa asentaa Opera ja Flash 64-bittisessä Ubuntussa  (Luettu 53121 kertaa)

MoB

  • Käyttäjä
  • Viestejä: 314
  • Debian Jessie, Ubuntu 12.04 LTS, Android-x86 2.3
    • Profiili
Tämä kikka toimii 64-bittisessä Ubuntu 6.06/6.10/7.04:ssa.

Opera tarvitsee muutaman ia32libraryn, joten asennetaan ne ensin:
Koodia: [Valitse]
sudo apt-get install ia32-libs ia32-libs-gtk linux32 lib32asound2Asetetaan localet kuntoon:
Koodia: [Valitse]
sudo ln -s -T /usr/lib64/locale /usr/lib32/localeImuroi Opera 9.20:n staattinen deb paketti (mene Operan sivulle ja valitse Other/Static DEB)
Asenna Opera komennolla :
Koodia: [Valitse]
sudo dpkg -i --force-architecture opera-static_9.*i386.debKäynnistä opera komennolla :
Koodia: [Valitse]
operaJos kaikki on ok, niin mokoman pitäisi toimia ihan nätisti.
Imuroi Flash Player 9 for x86 Linux.
Pura paketti ja kopioi tiedostot libflashplayer.so sekä flashplayer.xpt hakemistoon /usr/lib/opera/plugins
Avaa Operan yläpalkista Tools -> Preferences. Valitse Advanced välilehti ja Content. Paina Plug-in options namiskaa. Paina Find new.. Operan pitäisi nyt löytää Flashin osaset ja lisätä ne listaan.
Mene jonnekkin sivustolle missä käytetään Flashiä (esim. YouTube) ja taputa itseäsi selkään :P

edit: ohje tarkistettu ja listätty localefixi 09/07
« Viimeksi muokattu: 07.09.07 - klo:08.57 kirjoittanut MoB »
Registered Linux user #186837

Tuplanolla

  • Käyttäjä
  • Viestejä: 1420
  • Reg. Linux user #423604
    • Profiili
Re: Helppo tapa asentaa Opera ja Flash 64-bittisessä Ubuntussa
« Vastaus #1 : 07.07.06 - klo:14.29 »
Mitäs kun pukkaa virhettä?
Eli latasin paketin opera_9.0-20060616.6-shared-qt_en_i386.deb
ja asensin ohjeidesi mukaan, --force :lla.

Koodia: [Valitse]
jani@pehmopallero:~/Desktop$ opera
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.
/usr/lib/opera/9.00-20060616.6/opera: error while loading shared libraries: libqt-mt.so.3: cannot open shared object file: No such file or directory
jani@pehmopallero:~/Desktop$
Lisää [ratkaistu] ketjun ensimmäisen viestin otsikkoon, kun ongelma ratkeaa!

raimo

  • Käyttäjä
  • Viestejä: 4206
  • openSUSE Tumbleweed
    • Profiili
Re: Helppo tapa asentaa Opera ja Flash 64-bittisessä Ubuntussa
« Vastaus #2 : 07.07.06 - klo:15.29 »
Mitäs kun pukkaa virhettä?
Eli latasin paketin opera_9.0-20060616.6-shared-qt_en_i386.deb
ja asensin ohjeidesi mukaan, --force :lla.

Koodia: [Valitse]
jani@pehmopallero:~/Desktop$ opera
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.
/usr/lib/opera/9.00-20060616.6/opera: error while loading shared libraries: libqt-mt.so.3: cannot open shared object file: No such file or directory
jani@pehmopallero:~/Desktop$
2 ekaa on javajuttuja, Java on hukassa, joten se on etsittävä:
Tools -> Preferences -> Advanced  -> Content -> Java options
kun laitat polun Javan luokse oikeaksi, pitäisi noiden virheiden kaikota.

Kolmanteen:
http://ubuntuforums.org/showpost.php?p=1167982&postcount=62
En tiedä yhtään että toimiiko tuo?


Ubuntu Opera Wiki:
https://help.ubuntu.com/community/OperaBrowser
Opera9 Dapper howto:
http://ubuntuforums.org/showthread.php?t=177449


« Viimeksi muokattu: 07.07.06 - klo:15.33 kirjoittanut raimo »
Tietä käyden tien on vanki. Vapaa on vain umpihanki.
Aaro Hellaakoski

MoB

  • Käyttäjä
  • Viestejä: 314
  • Debian Jessie, Ubuntu 12.04 LTS, Android-x86 2.3
    • Profiili
Re: Helppo tapa asentaa Opera ja Flash 64-bittisessä Ubuntussa
« Vastaus #3 : 07.07.06 - klo:15.37 »

ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.

Toimiiko tuo silti? Itselläni meinaan tulee myös nuo kaksi ekaa virhettä, mutta toimii silti vallan mainiosti.
javaa en itse käytä ja tuon kanssa pitäisi käyttää 32-bittistä javaplugaria. Viisammat neuvokoot sen suhteen :D
« Viimeksi muokattu: 07.07.06 - klo:15.43 kirjoittanut MoB »
Registered Linux user #186837

Tuplanolla

  • Käyttäjä
  • Viestejä: 1420
  • Reg. Linux user #423604
    • Profiili
Re: Helppo tapa asentaa Opera ja Flash 64-bittisessä Ubuntussa
« Vastaus #4 : 07.07.06 - klo:16.06 »
Kummallista. Opera toimii roottina (laitoin sudo -s  ja unohdin poistua), muttei omalla käyttäjällä.

Lainaus
root@pehmopallero:~# opera
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.
opera: $HOME set to /root. Use -personaldir if you do not want to use /root/.opera/
Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
*** Tässä vaiheessa Opera käynnistyy ***
root@pehmopallero:~# exit
exit
jani@pehmopallero:~$ opera
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.
opera: Module initialization failure. Generic failure (-1)
jani@pehmopallero:~$
Lisää [ratkaistu] ketjun ensimmäisen viestin otsikkoon, kun ongelma ratkeaa!

raimo

  • Käyttäjä
  • Viestejä: 4206
  • openSUSE Tumbleweed
    • Profiili
Re: Helppo tapa asentaa Opera ja Flash 64-bittisessä Ubuntussa
« Vastaus #5 : 07.07.06 - klo:17.19 »
Kummallista. Opera toimii roottina (laitoin sudo -s  ja unohdin poistua), muttei omalla käyttäjällä.
Joku oikeus on sitten varmaan viturallaan? emt? Taikka se QT-juttu kummittelee edelleen?
Kokeilepas uudelleenasennusta, vanha lähtee mäkeen ainakin näin:
Koodia: [Valitse]
sudo aptitude purge opera-static
Operapeikot muuten korjailee innokkaasti edelleen bukeja luolassaan, joten kannattaa ehkä kokeilla uudemmallakin versiolla, löytyypi tuolta: http://my.opera.com/desktopteam/blog/
Just nyt uusin static on tämä (Opera 9.01 379):
http://snapshot.opera.com/unix/Weekly-379/intel-linux/opera-static_9.01-20060629.1-qt_en_i386.deb


MoB:
Ei se Javan puuttuminen Operan toimintaan vaikuta muuten kuin että java(yök)kökköjutut ei sitten sivuilla toimi, ja nuo kaksi varoitusta tulee konsoliin, mutta ite Opera toimii silti OK.
Tuo QT -errori sensijaan varmaankin estää koko Operan toiminnan, luulisin?

Tietä käyden tien on vanki. Vapaa on vain umpihanki.
Aaro Hellaakoski

eliasj

  • Käyttäjä
  • Viestejä: 4075
    • Profiili
Re: Helppo tapa asentaa Opera ja Flash 64-bittisessä Ubuntussa
« Vastaus #6 : 07.07.06 - klo:17.27 »
Mitä eroa on paketeilla Opera Static ja Opera?
alias vililikku

raimo

  • Käyttäjä
  • Viestejä: 4206
  • openSUSE Tumbleweed
    • Profiili
Re: Helppo tapa asentaa Opera ja Flash 64-bittisessä Ubuntussa
« Vastaus #7 : 07.07.06 - klo:17.57 »
Mitä eroa on paketeilla Opera Static ja Opera?
Opera static ja Opera shared ovat ne vaihtoehdot.
Erona on se että static versiossa tulee mukana oma QT-systeeminsä, kun taas shared-versio käyttää
järjestelmässä olevia QT-juttuja, jos sellainen järjestelmässä on. ts. shared ei toimi ollenkaan jos QT:tä ei ole.

No kuten nyt tässä näemme, tuo ei täysin pidä paikkaansa, koska näemmä static:kaan ei toimi ilman ongelmia kaikissa ympyröissä.

Kannattaa kokeilla myös shared-versiolla, se saattaa jopa toimia paremmin kuin static,
Ja ainakin shared on nätimpi, koska static-version menufontit on rumia ja antialiasointi ei toimi (menuissa).
Static taas toisaalta ainakin periaatteessa on hiukan nopeampi kuin shared...
Elikkä kokeilemalla selviää mikä on mihinkin systeemiin paras.
Näiden asentaminen ja poistaminen on nykyisin niin helppoa, että voe mahoton. ;)


Tietä käyden tien on vanki. Vapaa on vain umpihanki.
Aaro Hellaakoski

Tuplanolla

  • Käyttäjä
  • Viestejä: 1420
  • Reg. Linux user #423604
    • Profiili
Re: Helppo tapa asentaa Opera ja Flash 64-bittisessä Ubuntussa
« Vastaus #8 : 08.07.06 - klo:09.28 »
No joo. Se tarvikin vaan rebootin.

Virheitä silti.
Lainaus
jani@pehmopallero:~$ opera
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.
Conflict in /usr/lib/qt3/plugins/inputmethods/libqimsw-multi.so:
  Plugin uses incompatible Qt library!
  expected build key "i686 Linux g++-4.* full-config", got "x86_64 Linux g++-4.* full-config".
Conflict in /usr/lib/qt3/plugins/inputmethods/libqsimple.so:
  Plugin uses incompatible Qt library!
  expected build key "i686 Linux g++-4.* full-config", got "x86_64 Linux g++-4.* full-config".
Conflict in /usr/lib/qt3/plugins/inputmethods/libqimsw-none.so:
  Plugin uses incompatible Qt library!
  expected build key "i686 Linux g++-4.* full-config", got "x86_64 Linux g++-4.* full-config".
Conflict in /usr/lib/qt3/plugins/inputmethods/libqxim.so:
  Plugin uses incompatible Qt library!
  expected build key "i686 Linux g++-4.* full-config", got "x86_64 Linux g++-4.* full-config".
*** Tässä vaiheessa Opera käynnistyy ***
jani@pehmopallero:~$
Lisää [ratkaistu] ketjun ensimmäisen viestin otsikkoon, kun ongelma ratkeaa!

jemaku

  • Käyttäjä
  • Viestejä: 328
    • Profiili
Vs: Helppo tapa asentaa Opera ja Flash 64-bittisessä Ubuntussa
« Vastaus #9 : 31.03.07 - klo:04.37 »
Otin asiakseni päivitellä tämän forcetetun 32-bit Operan ja Flash 9:n uusimpiin versioihin, eikä äänet sittenkään lähteneet toimimaan. Illan selvitystyön tulos: kannattaa asentaa lib32asound2

Vinkki oli hieman peräisin täältä: https://help.ubuntu.com/community/FirefoxAMD64FlashJava
Toinen tiedonmuru oli että Flash 9:ssä äänet toimii vain alsalla.

MoB

  • Käyttäjä
  • Viestejä: 314
  • Debian Jessie, Ubuntu 12.04 LTS, Android-x86 2.3
    • Profiili
Vs: Helppo tapa asentaa Opera ja Flash 64-bittisessä Ubuntussa
« Vastaus #10 : 18.04.07 - klo:11.55 »
Otin asiakseni päivitellä tämän forcetetun 32-bit Operan ja Flash 9:n uusimpiin versioihin, eikä äänet sittenkään lähteneet toimimaan. Illan selvitystyön tulos: kannattaa asentaa lib32asound2

Ohje ei ole enää sellaisenaan toiminut pitkään aikaan, joten päivitin ensimmäisen viestin ajan tasalle.
Registered Linux user #186837

johtaja

  • Käyttäjä
  • Viestejä: 8
    • Profiili
    • johtajan potero
Vs: Helppo tapa asentaa Opera ja Flash 64-bittisessä Ubuntussa
« Vastaus #11 : 27.04.07 - klo:01.29 »
tein just niin kuin ed. ohjeissa sanottiin (mielestäni?) ny se sit antaa seuraavanlaisen ilmoituksen...
Lainaus
johtaja@johtaja-laptop:~$ opera
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.
/usr/lib/opera/9.20-20070409.6/opera: error while loading shared libraries: libqt-mt.so.3: wrong ELF class: ELFCLASS64
mitäs sitten tekis?... ei lähde ooppera edes käyntiin... :-[
AMD Turion64 x2 512MB 533 MHz DDR2 RAM 80 GB 5400 RPM HD
14.1-inch WXGA ATI Radeon Xpress 1100 integrated graphics, Ubuntu Feisty 7.04, pannu kahvia ja korillinen hermoja (loppumassa)

MoB

  • Käyttäjä
  • Viestejä: 314
  • Debian Jessie, Ubuntu 12.04 LTS, Android-x86 2.3
    • Profiili
Vs: Helppo tapa asentaa Opera ja Flash 64-bittisessä Ubuntussa
« Vastaus #12 : 07.09.07 - klo:08.47 »
Itselläni lakkasi Operassa skandien toimivuus tekstiensyöttökentissä. Tämä bugi alkoi muistaakseni 9.2x versioissa. Ongelma liittyy siihen, ettei Opera jostain syystä osaa kaivella localea oikein. Ongelma korjaantuu kirjoittamalla seuraava rimpsu terminaaliin.
Koodia: [Valitse]
sudo ln -s -T /usr/lib64/locale /usr/lib32/locale
Registered Linux user #186837

juyli

  • Vieras
Vs: Helppo tapa asentaa Opera ja Flash 64-bittisessä Ubuntussa
« Vastaus #13 : 31.10.07 - klo:20.32 »
Tämä kikka toimii 64-bittisessä Ubuntu 6.06/6.10/7.04:ssa.
Noiden ohjeiden mukaan sain Operan 32-bittisenä toimimaan myös Gutsy 7.10 kanssa.
Tuo locale linkitys ei ainakaan vielä edes tarpeelliselta, sillä hätäiseen tuntuivat myös ääkköset toimivan.
Siirsin /usr/bin/opera:n nimelle /usr/bin/opera32, jotta rauhassa voisi kokeilla Operaa  betana tarjottavana 9.50  64-bitin versiona.

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 11449
    • Profiili
    • Tomin kotisivut
Vs: Helppo tapa asentaa Opera ja Flash 64-bittisessä Ubuntussa
« Vastaus #14 : 17.11.07 - klo:19.41 »
Koodia: [Valitse]
tomppeli@tomppeli-laptop:~$ sudo apt-get install ia32-libs ia32-libs-gtk linux32 lib32asound2
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Reading state information... Valmis
Huomautus, valitaan ia32-libs eikä ia32-libs-gtk
Seuraavat ylimääräiset paketit on merkitty asennettaviksi:
  lib32gcc1 lib32ncurses5 lib32stdc++6 lib32z1 libc6-i386
Ehdotetut paketit:
  libasound2-plugins
Seuraavat paketit POISTETAAN:
  ubuntu-minimal util-linux util-linux-locales
Seuraavat UUDET paketit asennetaan:
  ia32-libs lib32asound2 lib32gcc1 lib32ncurses5 lib32stdc++6 lib32z1
  libc6-i386 linux32
VAROITUS: Seuraavat välttämättömät paketit poistetaan.
Näin EI PITÄISI tehdä jos ei aivan tarkkaan tiedä mitä tekee!
  util-linux
0 päivitetty, 8 uutta asennusta, 3 poistettavaa ja 0 päivittämätöntä.
Noudettavaa arkistoa 34,4Mt.
Purkamisen jälkeen käytetään 85,8Mt lisää levytilaa.
Olet aikeissa tehdä mahdollisesti vahingollisen toimenpiteen.
Jatka kirjoittamalla "Kyllä, tee kuten käsketään!"
 ?]
Keskeytä.
tomppeli@tomppeli-laptop:~$ sudo dpkg -i --force-architecture /tmp/opera_9.24-20071015.6-shared-qt_en_i386.deb
dpkg - warning, overriding problem because --force enabled:
 package architecture (i386) does not match system (amd64)
(Luetaan tietokantaa... 88997 tiedostoa ja hakemistoa tällä hetkellä asennettuna.)
Valmistellaan paketin opera 9.24-20071015.6 vaihtamsta (käyttäen pakettia .../opera_9.24-20071015.6-shared-qt_en_i386.deb)...
Puretaan korvaavaa opera-pakettia...
Säädän asetukset: opera (9.24-20071015.6) ...

tomppeli@tomppeli-laptop:~$ opera
exec: 264: /usr/lib/opera/9.24-20071015.6/opera: not found
tomppeli@tomppeli-laptop:~$

!!!
Siis onks toi järkevää!?! ???
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

jemaku

  • Käyttäjä
  • Viestejä: 328
    • Profiili
Vs: Helppo tapa asentaa Opera ja Flash 64-bittisessä Ubuntussa
« Vastaus #15 : 18.11.07 - klo:01.05 »
Siis onks toi järkevää!?! ???

Ei.

Jostain syystä util-linux on ristiriidassa tuon linux32-paketin kanssa.
Lainaus käyttäjältä: util-linux
This package contains a number of important utilities, most of which
are oriented towards maintenance of your system.  Some of the more
important utilities included in this package allow you to partition
your hard disk, view kernel messages, and create new filesystems.

Mulla opera toimii kyllä ilman linux32:ta ja tuota ia32-libs-gtk:ta.

(asentele synapticilla niin saat selkeämmät virheilmot...)

lanard

  • Käyttäjä
  • Viestejä: 11
    • Profiili
Vs: Helppo tapa asentaa Opera ja Flash 64-bittisessä Ubuntussa
« Vastaus #16 : 26.11.07 - klo:19.18 »
Siis Operanhan saa ladattua ubuntulle Operan kotisivuilta. Sieltä tulee paketti, jonka asennat ja se toimii. Tällä tavalla se toimii helpommin, mutta hyvähän tuokin tapa :D

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 11449
    • Profiili
    • Tomin kotisivut
Vs: Helppo tapa asentaa Opera ja Flash 64-bittisessä Ubuntussa
« Vastaus #17 : 28.11.07 - klo:10.43 »
Minulla on nyt tässä 9.50b kun tuo 9.24 ei asentunut sitten paketin hallinnalla eikä tuolla netti sivulla olevalla paketilla.
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

MoB

  • Käyttäjä
  • Viestejä: 314
  • Debian Jessie, Ubuntu 12.04 LTS, Android-x86 2.3
    • Profiili
Vs: Helppo tapa asentaa Opera ja Flash 64-bittisessä Ubuntussa
« Vastaus #18 : 05.12.07 - klo:14.03 »
linux32 sälää ei kait tarvitse 7.10:ssä. Kokeilen joku päivä puhtaalle 7.10:lle ja tarkistan asian.
Registered Linux user #186837

jemaku

  • Käyttäjä
  • Viestejä: 328
    • Profiili
Vs: Helppo tapa asentaa Opera ja Flash 64-bittisessä Ubuntussa
« Vastaus #19 : 05.12.07 - klo:14.46 »
Mulla on feistystä päivitetty gutsy, noita linux32 ja ia32-libs-gtk paketteja mulla ei ole asennettuna, tuskin oli feistyssäkään. ia32-libs ja lib32asound2 löytyy. Ja ne ei ole ristiriidassa util-linuxin kanssa...

Mulla on kyllä shared-versio operasta, oon tainnu ottaa sen ubuntulle merkityn version viime aikoina.

Siis Operanhan saa ladattua ubuntulle Operan kotisivuilta. Sieltä tulee paketti, jonka asennat ja se toimii. Tällä tavalla se toimii helpommin, mutta hyvähän tuokin tapa :D

Häh.
 Noinhan tässä ketjussa on koko ajan tehty, operan kotisivulta haettua pakettia asennettu.