Kirjoittaja Aihe: nForce2_smbus error  (Luettu 2610 kertaa)

sepi

  • Käyttäjä
  • Viestejä: 108
    • Profiili
nForce2_smbus error
« : 19.05.11 - klo:11.07 »
Käynnistyksessä  on tullut aina tämä virhe ilmoitus
eikä ole poistunut vieläkään uudella ytimellä 2.6.32-31-generic

dmesg
[   18.843185] i2c i2c-0: nForce2 SMBus adapter at 0x2d00
[   18.843192] ACPI: resource nForce2_smbus [0x2e00-0x2e3f] conflicts with ACPI region SM00 [0x2e00-0x2e3f]
[   18.843195] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   18.843197] nForce2_smbus 0000:00:01.1: Error probing SMB2.
[   18.860822] Linux video capture interface: v2.00
[   18.862647] EDAC amd64_edac:  Ver: 3.2.0 Apr  8 2011

olen googlaillut tätä ongelmaa ja saanut senverran selville ettei tähän laitekokoelmaan löydy sopivaa ajuria ,mutta jotkut ovat laittanut GRUB:n tällaisen  GRUB_CMDLINE_LINUX ="acpi_enfoce_resourecs =lax".
Tämä riitäisi minullekin kun kone muuten pelittää hyvin,mutta en tiedä miten se tulisi tehdä  .

Kone
emo ASUS M4N78 PRO-ATX
prossu      AMD Athlon || X4 620 2,6GHz
näytönohjain Asus EN9800GT/DI/1GD3/A GeForce 9800GT 1GB PCI Express
CNOME 2,30,2  LUCID 10,04 

tuke81

  • Käyttäjä
  • Viestejä: 1667
    • Profiili
Vs: nForce2_smbus error
« Vastaus #1 : 21.05.11 - klo:15.25 »
Niin olisihan tähänkin voinut vastauksen aikaisemmin antaa:

Eli avaat grubin konffi tiedoston esim nanolla:
sudo nano /etc/default/grub
Etsit kohdan missä lukee tuo GRUB_CMDLINE_LINUX ="" ja lisäät liishen option acpi_enfoce_resourecs =lax lainausmerkkien siään. Eli tiedoston alku näyttää suunnilleen tältä:
Koodia: [Valitse]
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=10
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX="acpi_enforce_resources=lax"

Tämän jälkeen päivität vielä grubin:
sudo update-grub2
Seuraavassa buutissa tuo kernelin  pitäisi ottaa tuo käyttöön. Itselläki asuksen nforce lätty(M4N68) ja pitäis tehä jotain tuolle acpi taululle kuhan jossain välissä joutais.
Miksi tehdä jotain helposti, kun sen voi tehdä vaikeastikin...

Storck

  • Vieras
Vs: nForce2_smbus error
« Vastaus #2 : 21.05.11 - klo:15.34 »
Tämän jälkeen päivität vielä grubin:
sudo update-grub2

Tuo numero ei taida hyödyttää mitään.

tuke81

  • Käyttäjä
  • Viestejä: 1667
    • Profiili
Vs: nForce2_smbus error
« Vastaus #3 : 21.05.11 - klo:15.38 »
Tämän jälkeen päivität vielä grubin:
sudo update-grub2

Tuo numero ei taida hyödyttää mitään.

Jaa onkos lucidissa jo poistettu grub1:nen? Pitäis varmaan päivittää oma konekki joskus.
Miksi tehdä jotain helposti, kun sen voi tehdä vaikeastikin...

sepi

  • Käyttäjä
  • Viestejä: 108
    • Profiili
Vs: nForce2_smbus error
« Vastaus #4 : 22.05.11 - klo:11.04 »
KIITOKSET   ohjeista

Sain muokattua  sen /etc/default/grub tiedoston ohjeen mukaan ja mulla toimi myös toi update-grub2  vaikka on asennettuna grub-pc jota komento se ei ymmärtänyt.

näillä toimenpiteillä errori ei kuitenkaan poistunut   , toisaalta sillä ei ollis niin väliä jos sais sen errori-ajan jotenkin pienemmäksi.

Tämä mun tuskailu johtuu lähinnä siitä kun jouduin samsug kies:n takia asentaan myös win7:n joka käynnistyy tän ubuntun errorin takia  lähes yhtä nopeasti .

Storck

  • Vieras
Vs: nForce2_smbus error
« Vastaus #5 : 22.05.11 - klo:11.10 »
Jaa onkos lucidissa jo poistettu grub1:nen? Pitäis varmaan päivittää oma konekki joskus.

Eipä kai poistettu, silti senkään grubia ei tarvitse päivittää muuten kuin sudo update-grub.

vrt. avaat päätteen kautta Firefoxin, pelkkä komento firefox riittää, koneelle ei tarvitse kertoa mikä versio on kyseessä. Poikkeus sitten jos useita...

tuke81

  • Käyttäjä
  • Viestejä: 1667
    • Profiili
Vs: nForce2_smbus error
« Vastaus #6 : 22.05.11 - klo:13.50 »
Jaa onkos lucidissa jo poistettu grub1:nen? Pitäis varmaan päivittää oma konekki joskus.

Eipä kai poistettu, silti senkään grubia ei tarvitse päivittää muuten kuin sudo update-grub.

vrt. avaat päätteen kautta Firefoxin, pelkkä komento firefox riittää, koneelle ei tarvitse kertoa mikä versio on kyseessä. Poikkeus sitten jos useita...

Tjooh kaks update-grubbia näyttäis olevan lucidissa:
Koodia: [Valitse]
~$ locate update-grub
/usr/lib/grub/update-grub_lib                                                                                                                                                       
/usr/lib/grub-legacy/update-grub                                                                                                                                                   
/usr/sbin/update-grub                                                                                                                                                               
/usr/sbin/update-grub2                                                                                                                                                             
/usr/share/man/man8/update-grub.8.gz                                                                                                                                               
/usr/share/man/man8/update-grub2.8.gz

Sinällään tuo sinun firefox esimerkki ei ole hyvä sillä se komento /usr/bin/firefox on vain linkki eri softaan:
Koodia: [Valitse]
~$ ls -n /usr/bin/firefox                                                                                                                                         
lrwxrwxrwx 1 0 0 32 2010-11-06 14:17 /usr/bin/firefox -> ../lib/firefox-3.6.12/firefox.sh
..kun taas update-grubbeja on kaksi ja molemmat ovat binäärejä:
Koodia: [Valitse]
~$ ls -n /usr/sbin/update-gru*
-rwxr-xr-x 1 0 0 60 2010-07-01 23:30 /usr/sbin/update-grub
-rwxr-xr-x 1 0 0 35 2010-07-01 23:30 /usr/sbin/update-grub2

Tosin molempien man sivujen mukaan ne ovat kumpikin grub2:lle tarkoitettuja. Eli lyhennys komennosta grub-mkconfig -o /boot/grub/grub.cfg
Miksi tehdä jotain helposti, kun sen voi tehdä vaikeastikin...

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 11425
    • Profiili
    • Tomin kotisivut
Vs: nForce2_smbus error
« Vastaus #7 : 22.05.11 - klo:13.54 »
Tosin molempien man sivujen mukaan ne ovat kumpikin grub2:lle tarkoitettuja.
Hmm-h.
Koodia: [Valitse]
~$ md5sum /usr/sbin/update-grub*
c3ed4e339f7416d43dce67dc095379f2  /usr/sbin/update-grub
c3ed4e339f7416d43dce67dc095379f2  /usr/sbin/update-grub2
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

Storck

  • Vieras
Vs: nForce2_smbus error
« Vastaus #8 : 23.05.11 - klo:01.44 »
Sinällään tuo sinun firefox esimerkki ei ole hyvä

En ota kantaa onko hyvä vai huono, käytännössä se on kuitenkin noin.

..kun taas update-grubbeja on kaksi ja molemmat ovat binäärejä:

Sama komento molempiin toimii, turha alkaa mitään ylimääräisiä rimpsuja keksimään/laittamaan perään jos lyhyemmällä komennolla sama lopputulos.
« Viimeksi muokattu: 23.05.11 - klo:01.47 kirjoittanut Storck »

ajaaskel

  • Palvelimen ylläpitäjä
  • Käyttäjä
  • Viestejä: 3401
    • Profiili
Vs: nForce2_smbus error
« Vastaus #9 : 23.05.11 - klo:09.14 »
Tutkin uteliaisuudesta mitä nämä komennot ovat "syöneet", nuo ovat toiminnallisesti samoja.  update-grub2 on scripti joka ei tee muuta kuin kutsuu update-grub: a.

cat /usr/sbin/update-grub2
#!/bin/sh
set -e
exec update-grub "$@"
Autamme ilolla ja ilmaiseksi omalla ajallamme.  Ethän vaadi, uhoa tai isottele näin saamasi palvelun johdosta.

tuke81

  • Käyttäjä
  • Viestejä: 1667
    • Profiili
Vs: nForce2_smbus error
« Vastaus #10 : 23.05.11 - klo:13.23 »
Tutkin uteliaisuudesta mitä nämä komennot ovat "syöneet", nuo ovat toiminnallisesti samoja.  update-grub2 on scripti joka ei tee muuta kuin kutsuu update-grub: a.

cat /usr/sbin/update-grub2
#!/bin/sh
set -e
exec update-grub "$@"


Kappas se olikin vain bash-skripti toiseen bash skriptiin :D
Koodia: [Valitse]
~$ cat /usr/sbin/update-grub
#!/bin/sh -e
exec grub-mkconfig -o /boot/grub/grub.cfg "$@"
Miksi tehdä jotain helposti, kun sen voi tehdä vaikeastikin...