Kirjoittaja Aihe: Mistä 2.6.38  (Luettu 3315 kertaa)

noname

  • Käyttäjä
  • Viestejä: 828
  • Linuxilla maaliskuusta 2009
    • Profiili
Mistä 2.6.38
« : 03.05.11 - klo:17.09 »
Otsikossa kysymys, eli haluaisin tuon uuden ytimen saada asennetuksi.

Mikä repo pitää lisätä kun ei synapticissa näy kun oletuksena mukanaolevissa on vekit lisätty.

Kiitos kaikille jotka auttavat jo etukäteen.

Storck

  • Vieras
Vs: Mistä 2.6.38
« Vastaus #1 : 03.05.11 - klo:17.19 »

noname

  • Käyttäjä
  • Viestejä: 828
  • Linuxilla maaliskuusta 2009
    • Profiili
Vs: Mistä 2.6.38
« Vastaus #2 : 03.05.11 - klo:18.47 »
Nattylle sopivaat toimii myös 10.04?
Kumpi asennetaan ensin headers vai image?

tommis

  • Käyttäjä
  • Viestejä: 418
    • Profiili
Vs: Mistä 2.6.38
« Vastaus #3 : 03.05.11 - klo:20.08 »
https://launchpad.net/~kernel-ppa/+archive/ppa?field.series_filter=lucid
Koodia: [Valitse]
sudo apt-get update
sudo add-apt-reporisotory ppa:kernel-ppa/ppa
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install linux-meta-lts-backport-natty
sudo reboot
11.04 tarjoaa tuon suoraan, eikä ytimien kanssa kannata mennä leikkimään jos ei tiedä mitä tekee. Tuossa paketissa lukee natty, mutta pitäisi toimia lucidissakin koska se on sille merkattu yhteensopivaksi.

JaniAlander

  • Käyttäjä / moderaattori+
  • Viestejä: 3169
    • Profiili
Vs: Mistä 2.6.38
« Vastaus #4 : 03.05.11 - klo:21.28 »
Ko. ydin muuten pelasi 10.4ssä mutta ainakin itse jouduin asentamaan näytönohjaimen suljetut ajurit komentoriviltä ja nimenomaan ne nvidian sivuilta saatavat versiot, kun päivitin ko. ytimeen. Pakettienhallinnan kautta tulevat ei toimineet. Joten kannattaa miettiä ennenkuin päivittää, ellei syystä tai toisesta ole ehdotonta tarvetta.
Core i5-9400F 2.9ghz 32GB Ram, Nvidia RTX2060 Kubuntu 22.04-64bit, Windows 10 Pro 64-bit Samsung Series 5, AMD A-6 2.1 GHz 4 Gt Ram, Ubuntu 18.04 64-bit.
Lenovo T60 Core2Duo 2GB Ram Ati Mobility Radeon 128 MB Ubuntu Mate 16.04-64bit
Commodore Amiga 500 1MB Ram.

mrl586

  • Käyttäjä
  • Viestejä: 4638
    • Profiili
Vs: Mistä 2.6.38
« Vastaus #5 : 03.05.11 - klo:23.09 »
https://launchpad.net/~kernel-ppa/+archive/ppa?field.series_filter=lucid
Koodia: [Valitse]
sudo apt-get update
sudo add-apt-reporisotory ppa:kernel-ppa/ppa
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install linux-meta-lts-backport-natty
sudo reboot
11.04 tarjoaa tuon suoraan, eikä ytimien kanssa kannata mennä leikkimään jos ei tiedä mitä tekee. Tuossa paketissa lukee natty, mutta pitäisi toimia lucidissakin koska se on sille merkattu yhteensopivaksi.
Tommisin mainitsema pakettivarasto on virallisesti tuettu ja se sisältää LTS-versiolle (tällä hetkellä Lucid) backportatun kernelin. Tuossa komentolistauksessa on virhe. Tässä virheellinen komento korjattuna:
Koodia: [Valitse]
sudo add-apt-repository ppa:kernel-ppa/ppa
« Viimeksi muokattu: 03.05.11 - klo:23.11 kirjoittanut mrl586 »

noname

  • Käyttäjä
  • Viestejä: 828
  • Linuxilla maaliskuusta 2009
    • Profiili
Vs: Mistä 2.6.38
« Vastaus #6 : 04.05.11 - klo:15.00 »
Onko atin(amd) näytönohjaimissa ollut ongelmia, suljettujen kanssa siis.

noname

  • Käyttäjä
  • Viestejä: 828
  • Linuxilla maaliskuusta 2009
    • Profiili
Vs: Mistä 2.6.38
« Vastaus #7 : 05.05.11 - klo:18.30 »
Koodirimpsun ajamalla (korjattuna) ei löytynyt kyseistä pakettia, sen jälkeen synapticista kuitenkin löytyi image-paketteja versiosta 38, riittääkö siis kyseinen pelkkä image-paaketti

Edit: Image paketin asentamalla ja reboottaamalla boottasi toimivasti 2.6.38, mutta on graafinen tila kökkö, webbisivuja selatessa ne eivät enää "siirry" vaan ne piirretään joka rullauksella uudestaan, ei taida ihan oikein toimia.
Vanhempi taitaa vielä toimia.
Edit2: nyt crashasi se atin suljettu ajuri, saako sitä mistään tälle versiolle.
« Viimeksi muokattu: 05.05.11 - klo:18.41 kirjoittanut milan »

tommis

  • Käyttäjä
  • Viestejä: 418
    • Profiili
Vs: Mistä 2.6.38
« Vastaus #8 : 05.05.11 - klo:20.15 »
Koodirimpsun ajamalla (korjattuna) ei löytynyt kyseistä pakettia, sen jälkeen synapticista kuitenkin löytyi image-paketteja versiosta 38, riittääkö siis kyseinen pelkkä image-paaketti
Riittää.
Edit: Image paketin asentamalla ja reboottaamalla boottasi toimivasti 2.6.38, mutta on graafinen tila kökkö, webbisivuja selatessa ne eivät enää "siirry" vaan ne piirretään joka rullauksella uudestaan, ei taida ihan oikein toimia.
Vanhempi taitaa vielä toimia.
Tämä koska suljettuja ajureita ei usein testata taaksepäin portatuilla linux- ja xorg versiolla. Tämän takia vanha jakelu ja uusi ydin on huono yhdistelmä.
Edit2: nyt crashasi se atin suljettu ajuri, saako sitä mistään tälle versiolle.
Paha sanoa, jos niitä ei pakettivarastosta löydy niin niitä ei suurella toden näköisyydellä ehkä ole. Kannattaa kokeilla kuitenkin kokeilla amd:en sivuilta ladata se ajuri ja kokeile jos se toimisi.


Uuden ytimen asentaminen kumoaa lts julkaisun tarkoituksen, vakauden. Jos haluat haluat kumota tekemäsi muutokset voit asentaa ppa-purge paketin ja käyttää sitä poistamaan ppa:an ja sen tekemät muutokset.
Koodia: [Valitse]
sudo ppa-purge ppa:kernel-ppa/ppaSaattaa olla, että vanha ydin ei ole vaihtoehtoinen paketti joten koneesi saattaa jäädä ilman ydintä. Ole varovainen.

mrl586

  • Käyttäjä
  • Viestejä: 4638
    • Profiili
Vs: Mistä 2.6.38
« Vastaus #9 : 06.05.11 - klo:01.02 »
Koodirimpsun ajamalla (korjattuna) ei löytynyt kyseistä pakettia, sen jälkeen synapticista kuitenkin löytyi image-paketteja versiosta 38, riittääkö siis kyseinen pelkkä image-paaketti
Ei riitä. Tarvitset dkms:än käyttöön myös headerit.

noname

  • Käyttäjä
  • Viestejä: 828
  • Linuxilla maaliskuusta 2009
    • Profiili
Vs: Mistä 2.6.38
« Vastaus #10 : 06.05.11 - klo:15.12 »
Vanha ydin boottaa täysin toimivasti järjestelmään, käytän sitä nyt.
Vaikuttavatko uudempaan ytimeen tehdyt ajuriasennukset vanhan ytimen toimintaan.