Kirjoittaja Aihe: (Ratkaistu)Puuttuva paketti luodin lentoratalaskurissa  (Luettu 2457 kertaa)

Timo Virtanen

  • Käyttäjä
  • Viestejä: 2083
    • Profiili
Tarkoitus oli testata Linuxissa toimivaa ammuntalaskuria http://linux.softpedia.com/get/Science-and-Engineering/Mathematics/Small-Arms-Ballistics-2908.shtml Latasin ja olin asentamassa ohjelmaa kun configurointi tyssäsi liitteessä olevaan tylyyn ilmoitukseen puuttuvasta lnurces paketista. Yritin Synapticista löytää sopivaa ehdokasta mutta en löydä soveliasta. Missä olen mennyt hakoteille? terveisin Timo
ps. näitä ohjelmia on erittäin vähän Linuxille  :P

Lainaus
timo@timo-Latitude-110L:~/Työpöytä/saballistics-1.3.2$ sh ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking for linuxdoc... false
checking for main in -lm... yes
checking for main in -lncurses... no
configure: error: ncurses library is required
timo@timo-Latitude-110L:~/Työpöytä/saballistics-1.3.2$
« Viimeksi muokattu: 25.03.11 - klo:08.55 kirjoittanut Timo Virtanen »
"Linux, made in Finland"

Lasse.

  • Käyttäjä
  • Viestejä: 1668
  • Techjunkie.
    • Profiili
    • Liquid Flower Games
Vs: Puuttuva paketti luodin lentoratalaskurissa
« Vastaus #1 : 20.03.11 - klo:22.07 »
Koita asentaa paketti libncurses5-dev
Kone 1: Intel Core i5 2500K, 8GB DDR3, nVidia GTX 560 Ti 1GB, 2x1TB & 1x 250GB HDD, Windows 7 & Arch
Kone 2: Lenovo Ideapad Z370 (i5-2410M, 4GB RAM & GeForce 410M) Chakra
Google LG Nexus 4 (ParanoidAndroid)
Linuxia noin vuodesta 2004.

Timo Virtanen

  • Käyttäjä
  • Viestejä: 2083
    • Profiili
Vs: Puuttuva paketti luodin lentoratalaskurissa
« Vastaus #2 : 20.03.11 - klo:22.57 »
Kiitos Lasse, ehdotit oikeaa pakettia. Nyt asentui loppuun asti. Tein "make" ja "make install" ohjeiden mukaan. Nyt on ongelmana, ohjelman käynnistäminen testiä varten. Ohjelmankäynnistin saballistics löytyy usr/local/saballistics/bin kansiosta. Ohjelman käyttöoikeudet ovat rootilla.  ??? Yritin
Koodia: [Valitse]
sh saballisticsja
Koodia: [Valitse]
sudo saballisticsEi starttaa. Ihmetyttää tuo root-homma, en ole ennen törmännyt. terveisin Timo
"Linux, made in Finland"

Timo Virtanen

  • Käyttäjä
  • Viestejä: 2083
    • Profiili
Vs: Puuttuva paketti luodin lentoratalaskurissa
« Vastaus #3 : 21.03.11 - klo:10.09 »
Katsoin "Ominaisuudet" ikkunaa ja ruksi oli kohdassa "Salli tiedoston suorittaminen sovelluksena". Yritin chmod komentoa mutta heikoin tuloksin. Onko antaa vinkkiä miten pääsen eteenpäin? terveisin Timo

ps. kunnianhimoinen tavoite olisi OPETELLA paketoimaan tuo .deb muotoon. Lähipiirissä olisi tarvetta ks. ohjelmalle. Lauma tiedonnälkäisiä, uusia Ubuntun käyttäjiä odottaa malttamattomana työn tuloksia  :D
"Linux, made in Finland"

retu

  • Käyttäjä
  • Viestejä: 949
    • Profiili
Vs: Puuttuva paketti luodin lentoratalaskurissa
« Vastaus #4 : 21.03.11 - klo:11.00 »
Ohjelmankäynnistin saballistics löytyy usr/local/saballistics/bin kansiosta. Ohjelman käyttöoikeudet ovat rootilla.
Ohjelmien asennus tapahtuu yleensä roottina, joten on ihan normaalia että omistajaksi tulee root. Tiedoston oikeudet pitäisi olla esim. -rwxr-xr-x. Kts. vaikka /usr/bin -hakemiston tiedostoja.

Jos kerran "Salli tiedoston suorittaminen sovelluksena" täppä on ruksattuna, ohjelman pitäisi käynnistyä ihan tiedostoa tuplaklikkaamalla. Jollei, mahdollinen virheilmoitus saattaa jäädä näkemättä ellet aja sitä päätteestä. Tuohan on vissiin merkkipohjainen ohjelma muutenkin.

Valikkoon ilmestyäkseen ohjelma tarvitsee .desktop tiedoston.

Päätteestä ajettaessa on annettava koko polku, jos ohjelman hakemisto ei ole hakupolussa. Komenna:
Koodia: [Valitse]
/usr/local/saballistics/bin/saballistics
Tosin jotenkin tuntuu että tuossa on polku väärin. Onko ohjelma tosiaan /usr/local/saballistics/bin -hakemistossa eikä /usr/local/bin -hakemistossa?

Timo Virtanen

  • Käyttäjä
  • Viestejä: 2083
    • Profiili
Vs: Puuttuva paketti luodin lentoratalaskurissa
« Vastaus #5 : 21.03.11 - klo:16.19 »
Kiitos retu kommenteista. Kyllä se on sen polun päässä, jonka ilmoitin. /usr/local/bin on tyhjä tiedosto. Käytin varsin raakaa temppua ohjelman käynnistämiseksi. Testiläppärillä on Xubuntu, joten komennolla "sudo thunar" ohjelma käynnistyi. Ohjelma jumi alkuvalikkoonsa. Tehtävien hallinta näytti prosessorille 100% käyttöastetta. Tuo mäkistartti päättyi siis kehnosti. "Salli sovelluksen suorittaminen ohjelmana"-ikkuna on harmaana. terveisin Timo
"Linux, made in Finland"

Lasse.

  • Käyttäjä
  • Viestejä: 1668
  • Techjunkie.
    • Profiili
    • Liquid Flower Games
Vs: Puuttuva paketti luodin lentoratalaskurissa
« Vastaus #6 : 24.03.11 - klo:22.56 »
Kokeilinpa kääntää ja asentaa itsekin. Kyllä tuo minulla toimii kun päätteelle heittää
Koodia: [Valitse]
/usr/local/saballistics-1.3.2/bin/saballisticsItse ohjelman käytöstä en osaa sanoa mitään.

EDIT: Ja lähti kivasti poiskin kun komensi lähdekoodikansiossa
Koodia: [Valitse]
sudo make uninstall
Kone 1: Intel Core i5 2500K, 8GB DDR3, nVidia GTX 560 Ti 1GB, 2x1TB & 1x 250GB HDD, Windows 7 & Arch
Kone 2: Lenovo Ideapad Z370 (i5-2410M, 4GB RAM & GeForce 410M) Chakra
Google LG Nexus 4 (ParanoidAndroid)
Linuxia noin vuodesta 2004.

Timo Virtanen

  • Käyttäjä
  • Viestejä: 2083
    • Profiili
Vs: Puuttuva paketti luodin lentoratalaskurissa
« Vastaus #7 : 25.03.11 - klo:08.37 »
Kiitos Lasse! Tuo oli hyvä uutinen. Taas jaksaa punertaa eteenpäin. Voi olla, etä kämmäsin jotain asennuksen alkutaipaleella. Ei näköjään tarvinnut sudoakaan eteen. Pitää vielä kerrata ja opetella. Ohjelman käytöstä voisin kertoa lyhyesti mutta jääköön. terveisin Timo
"Linux, made in Finland"

Timo Virtanen

  • Käyttäjä
  • Viestejä: 2083
    • Profiili
Vs: Puuttuva paketti luodin lentoratalaskurissa
« Vastaus #8 : 25.03.11 - klo:08.55 »
Koodia: [Valitse]
/usr/local/saballistics-1.3.2/bin/saballisticsToimii!  :D Pieni episodi työpöydälle luodusta käynnistyskuvakkeesta. Ominaisuudet ikkunasta pitää valita "Suorita päätteessä" kohta ja homma pelittää. Kiitokset Lasse ja retu avusta.
"Linux, made in Finland"