Kirjoittaja Aihe: Erittäin hidas järjestelmä.  (Luettu 2217 kertaa)

mattiteppo

  • Käyttäjä
  • Viestejä: 42
    • Profiili
Erittäin hidas järjestelmä.
« : 19.03.11 - klo:18.21 »
Mistäköhän kannattais lähteä hakemaan ongelmaan ratkaisua? ubuntu 10.10 asennettuna ja aivan järkyttävän hidas ja rakaskaan tuntuinen. ollut ennenkin tässä koneessa muutaman kovalevyn alustuksen jalkeen ajattelin asentaa taas kun jäi kaipaamaan sitä nopeutta mikä oli ubuntussa. muttä nyt kone aivan takkuinen. dock ei jaksa aueta kunnolla koko ajan kun avaat jotain niin hyrrä vaan pyöriin ja kaikki kestää todella kauan.

Ganymedes

  • Käyttäjä
  • Viestejä: 3915
    • Profiili
Vs: Erittäin hidas järjestelmä.
« Vastaus #1 : 19.03.11 - klo:18.41 »
Pari ensimmäistä katsottavaa:

- System Monitor tai komento "top" Päätteessä (Terminal). Pyöriikö ylimääräisiä prosesseja?

- Paljonko on muistia? Jos on oleellisesti vähemmän kuin 512 MB niin voi ollakin hyvin hidas.

Minkälainen kone on kyseessä? ... pitäisi tietää jotta pääsemme oikealle planeetalle arvioinnissa.

mattiteppo

  • Käyttäjä
  • Viestejä: 42
    • Profiili
Vs: Erittäin hidas järjestelmä.
« Vastaus #2 : 19.03.11 - klo:19.29 »
top - 19:26:11 up  2:11,  2 users,  load average: 0.17, 0.22, 0.18
Tasks: 147 total,   3 running, 144 sleeping,   0 stopped,   0 zombie
Cpu(s):  7.1%us,  2.4%sy,  1.1%ni, 88.6%id,  0.5%wa,  0.0%hi,  0.3%si,  0.0%st
Mem:   2836160k total,  1108252k used,  1727908k free,   108472k buffers
Swap:  2656252k total,        0k used,  2656252k free,   627704k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND           
 1149 root      20   0  114m  72m  13m S   11  2.6   7:28.79 Xorg               
 2656 home      20   0  167m  15m  11m S    4  0.5   0:01.46 gnome-terminal     
 2449 home      25   5  147m  32m  15m S    3  1.2   1:13.34 chrome             
 2200 home      20   0  414m  64m  30m S    3  2.3   0:56.70 chrome             
 2359 home      20   0  218m  23m  14m S    1  0.8   2:51.63 transmission       
  247 root      20   0     0    0    0 S    0  0.0   0:01.37 usb-storage       
 1378 home      20   0  205m  46m  20m S    0  1.7   0:19.23 docky             
 2703 home      20   0  2620 1124  832 R    0  0.0   0:00.28 top               
    1 root      20   0  2888 1652 1188 S    0  0.1   0:00.52 init               
    2 root      20   0     0    0    0 S    0  0.0   0:00.45 kthreadd           
    3 root      20   0     0    0    0 S    0  0.0   0:00.13 ksoftirqd/0       
    4 root      RT   0     0    0    0 S    0  0.0   0:02.08 migration/0       
    5 root      RT   0     0    0    0 S    0  0.0   0:00.00 watchdog/0         
    6 root      RT   0     0    0    0 S    0  0.0   0:01.52 migration/1       
    7 root      20   0     0    0    0 S    0  0.0   0:00.63 ksoftirqd/1       
    8 root      RT   0     0    0    0 S    0  0.0   0:00.00 watchdog/1         
    9 root      20   0     0    0    0 S    0  0.0   0:00.08 events/0     

koneessa on 3gb muistia, dual core, 500gb 7200rmp kovo ja geoforce8200. Ja siis samalla koneella ennenkin käyttänyt mut  nyt täyttä tervaa uudelleen asenneksun jälkeen.

Ganymedes

  • Käyttäjä
  • Viestejä: 3915
    • Profiili
Vs: Erittäin hidas järjestelmä.
« Vastaus #3 : 19.03.11 - klo:20.48 »
Yllättävää.

Tuollaisesta episodista ainoa kokemus on sellainen, että asennuksessa pujahti mukaan väärän version paketteja. Tämä oli siis itse tehty moka eli oli lisätty väärän version pakettivarasto ja asennettu siitä (itse asiassa VDPAU kamoja).

Onko sinulla järjestelmä hidas jo heti perusversion asennuksen jälkeen? Onko tuo nimenomainen näytönohjain ennen toiminut ok juuri tuolla Ubuntu versiolla?

Kovalevyn viallisuus voi jumittaa järjestelmää törkeästi. Mitä sanoo System - Administration - Disk Utility kovalevyn kunnosta? Siellä on testejä ja muutakin.

JakeStyles

  • Käyttäjä
  • Viestejä: 70
  • Cold, So Cold...
    • Profiili
Vs: Erittäin hidas järjestelmä.
« Vastaus #4 : 19.03.11 - klo:20.58 »
Mistäköhän kannattais lähteä hakemaan ongelmaan ratkaisua? ubuntu 10.10 asennettuna ja aivan järkyttävän hidas ja rakaskaan tuntuinen. ollut ennenkin tässä koneessa muutaman kovalevyn alustuksen jalkeen ajattelin asentaa taas kun jäi kaipaamaan sitä nopeutta mikä oli ubuntussa. muttä nyt kone aivan takkuinen. dock ei jaksa aueta kunnolla koko ajan kun avaat jotain niin hyrrä vaan pyöriin ja kaikki kestää todella kauan.

Itselläni juuri tänään asennellessani pakettejani, päätin käynnistää koneen. Eiköhän kaikki jumittanut kympillä mutta heti ymmärsin ongelman kun compizin efektit olivat kadonneet käytöstä.

Jokin päivitys vetäisi näytönohjaimen (6850) ajurit sikinsokin ja pienellä säädöllä kaikki toimi taas kuin unelma. Sitä ennen oli kuin hyytelöä työntänyt piikkilankamatossa.

Eli mites on sen näytönohjaimen ajurin kanssa? Mikäli osuin oikeaan niin ainakin tuolla on tutustuttu asiaan: http://www.howtoforge.com/enabling-compiz-fusion-on-an-ubuntu-10.10-desktop-nvidia-geforce-8200
« Viimeksi muokattu: 19.03.11 - klo:21.00 kirjoittanut JakeStyles »
"Who is General Failure and who is he reading my hard disk?"

mattiteppo

  • Käyttäjä
  • Viestejä: 42
    • Profiili
Vs: Erittäin hidas järjestelmä.
« Vastaus #5 : 19.03.11 - klo:21.28 »
Eli kone oli tukossa heti. Näytönohjaimen ajurin kuvittelin jo vaihtaneeni mut en ollutkaan se auttoi jo paljon nyt esim. dock vastaa heti. mut vieläkin kun avaa jonkun ohjelman niin laahausta tapahtuu. ja compiz jutut ei pelaa myöskään. kovalevy on niinkuin arvelinkin täysin kunnossa.

mattiteppo

  • Käyttäjä
  • Viestejä: 42
    • Profiili
Vs: Erittäin hidas järjestelmä.
« Vastaus #6 : 19.03.11 - klo:22.31 »
Ja sellaisen ihmeellisyyden huomasin kun koitin speestest kautta miten data kulkee niin antaa vain 5-10mbps ja jos vaihdan winukan puolelle niin ei ole milloinkaan jäänyt alle 16mbps ja pin luku 120 nurkilla kun vinukassa noin kymmenesosa.

Ganymedes

  • Käyttäjä
  • Viestejä: 3915
    • Profiili
Vs: Erittäin hidas järjestelmä.
« Vastaus #7 : 20.03.11 - klo:10.28 »
Edelleen kummallista, mielestäni.

Tuon TOP listauksesi mukaanhan koneellasi ei pyörinyt mitään prosessia, joka olisi jumittanut - kannattaa tietysti seurata sitä jatkossakin.

Minulla on kaksi, puhtaan asennuksen, 10.10 64-bit konetta joissa:

1. GS 8400, ei näytöntehosteita ollenkaan, aivan oletusajurit

2. 9500 GT, perusnäytöntehosteet mukana (ei täydet), (oletus) suljetut ajurit

3. On kolmaskin jossa on joku 8500 tms, halvimmissa hintaluokissa oleva nVidia.


En ole näissä missään vaiheessa huomannut mitään hidastumisia tai takkuiluja. Näitä koneita kuormitetaan kyllä "ihan hyvin" ja niissä on useampia levyjä kestämään tätä kuormaa, ei tosin kuormiteta grafiikkaominaisuuksiltaan. Täysiä näytöntehosteita en ole edes kokeillut enkä hakenut ajureita mistään muualta kuin Ubuntun perusjakelusta.

Mistä sinun ajurisi ovat peräisin ja oletko kokeillut ilman näytöntehosteita? Onko sinulla ollut joitakin erikoisempia paketteja mukana pakettilähteissä, esim. "proposed" tai "backports? Tai oletko jopa lisännyt sinne omia? Minulla ei ole mitään tällaisia. Tuollaisten "esiversioiden" ja muiden vastaavien toiminnasta ei minulla ole mitään tietoa.

mattiteppo

  • Käyttäjä
  • Viestejä: 42
    • Profiili
Vs: Erittäin hidas järjestelmä.
« Vastaus #8 : 20.03.11 - klo:12.08 »
kaikki mitä asennettu niin kaikki on suoria päivityksiä ja sit jokunen ohjelma toulta sovelluksen asennuksen kautta. tarvii varmaan ottaa vielä pois ja koittaa laittaa uudestaan jos vaikka asennuksessa olis tullut joku bugi.

Ganymedes

  • Käyttäjä
  • Viestejä: 3915
    • Profiili
Vs: Erittäin hidas järjestelmä.
« Vastaus #9 : 20.03.11 - klo:12.18 »
Tuollaista vielä:

- minun esimerkkinihän eivät olleet juuri samalta näytönohjaimelta. Ehkäpä joku osaa kertoa jos juuri sinun tapauksessasi oletusajurit eivät toimisikaan

- kokeile vielä ottaa kaikki näytöntehosteet pois, josko auttaisi

- varmista vielä että nuo ohjelmalähteet ovat kunnossa (kuten aiemmin jo kerroin)