Kirjoittaja Aihe: pakettia ei voida asentaa  (Luettu 3560 kertaa)

JarTak

  • Käyttäjä
  • Viestejä: 333
    • Profiili
pakettia ei voida asentaa
« : 13.03.11 - klo:02.06 »
Tuli tarve asentaa pidgin - pikaviestin uudelleen uudelleen osoitteesta: http://www.pidgin.im/download/ubuntu/

Tuolta sivustolta sitten klikkasin Pidgin ppa package kohtaa ja tämän jälkeen gdebi alkoi avaamaan ohjelmaa. Asennus ei kuitenkaan mene loppuun saakka, sillä Gdebi ilmoittaa: Virhe: pakettia "pidgin" ei voida asentaa Gdebin kuvaus osiossa lukee seuraavanlainen teksti:
 Pidgin PPA
This package configures the Pidgin PPA to provide you with updated versions of Pidgin and Finch as well as their underlying libraries libpurple and libgnt. These packages are provided by the Pidgin project and are not supported by Ubuntu or Canonical.

Onko kellään tietoa taitoa tai kokemusta siitä, kuinka tästä voitaisiin edetä?

mrl586

  • Käyttäjä
  • Viestejä: 4638
    • Profiili
Vs: pakettia ei voida asentaa
« Vastaus #1 : 13.03.11 - klo:02.36 »
Asentuuko paketti komentoriviltä?

JarTak

  • Käyttäjä
  • Viestejä: 333
    • Profiili
Vs: pakettia ei voida asentaa
« Vastaus #2 : 13.03.11 - klo:12.37 »
Vois kokeilla asentaa komentoriviltä, mutta en tiedä miten teen sen, joten lisä info ois tarpeen.

tommis

  • Käyttäjä
  • Viestejä: 418
    • Profiili
Vs: pakettia ei voida asentaa
« Vastaus #3 : 13.03.11 - klo:12.47 »
Mikä ubuntun versio? Ja minkä takia et asenna sitä ohjelmalähteistä jossa se varmasti olisi yhteensopiva?

JarTak

  • Käyttäjä
  • Viestejä: 333
    • Profiili
Vs: pakettia ei voida asentaa
« Vastaus #4 : 13.03.11 - klo:15.53 »
Ubuntu on 10.04 ja syy miksi en asenna ohjelmalähteestä on se, että facebook-chatin kanssa pidgin ei oikein tahdo toimia ja samalla se saattaa viedä huomattavan paljon prosessori tehoja.

Synaptic tarjoaa 2.6.6 versiota ja aikaisemmin minulla oli käytössä 2.7.3 versio, joka toimi oikein hyvin, mutta erinäisten asioiden vuoksi tuli tarve poistaa se. Harmi etten enään muista miten asensin 2.7.3 version.

tommis

  • Käyttäjä
  • Viestejä: 418
    • Profiili
Vs: pakettia ei voida asentaa
« Vastaus #5 : 13.03.11 - klo:16.29 »
Ubuntu on 10.04 ja syy miksi en asenna ohjelmalähteestä on se, että facebook-chatin kanssa pidgin ei oikein tahdo toimia ja samalla se saattaa viedä huomattavan paljon prosessori tehoja.
Facebook chattiin tarvitaan erillinen paketti. En nyt muista mikä se oli, enkä voi tarkistaakkaan.

Synaptic tarjoaa 2.6.6 versiota ja aikaisemmin minulla oli käytössä 2.7.3 versio, joka toimi oikein hyvin, mutta erinäisten asioiden vuoksi tuli tarve poistaa se. Harmi etten enään muista miten asensin 2.7.3 version.
Alt + f2, ja kirjoita `ohjelmalähteet´, ja sitten enter.
Mene kolmansien osapuolten välilehteen ja lisää tämä.
Koodia: [Valitse]
deb http://archive.getdeb.net/ubuntu maverick-getdeb apps
Sitten sulje ikkuna, avaa pääte, ja kirjoita nämä.
Koodia: [Valitse]
wget -q -O- http://archive.getdeb.net/getdeb-archive.key | sudo apt-key add -
Koodia: [Valitse]
sudo apt-get updateNyt ohjelmalähteistä löytyy uusin pidgin ja voit asentaa sen vaikka synapticilla.
Lisää infoa täältä: http://www.getdeb.net/updates/Ubuntu/10.04/

JarTak

  • Käyttäjä
  • Viestejä: 333
    • Profiili
Vs: pakettia ei voida asentaa
« Vastaus #6 : 14.03.11 - klo:00.31 »
Tommis: alt + f2 ja teksti ohjelmalähteet tuotti tesktin joka ilmoitti, että sijaintia Sijaintia ”file:///home/jarmo/ohjelmal%C3%A4hteet” ei voi avata. Tuota ongelmaa ei varmaan tarvi ratkaista enempää, sillä käsittääkseni saman operaation voi hoitaa graafisesti siten että lisää tekstin: deb http://archive.getdeb.net/ubuntu maverick-getdeb apps ohjelmalähteet/muut ohjelmistot/lisää osioon, jolloin kone osaa hakea dataa tuolta paikasta. Ehkä maverickin kohdalle kannattaa laitta lucid???

Muistaakseni aikaisemmin värkkäilin pidginin kanssa ja laitoin koneelleni getdeb osoitteen ja tämän jälkeen kone alkoi hakemaan päivityksiä, joita tuli iso läjä. Noh....päivitysten jälkeen kone oli aika jumissa. Tämä oli osoitus itselleni siitä, että kolmansien osapuolten kanssa toimiesa saattaa tulla ongelmia. Löysin yritys ja erehdys menetelmällä ratkaisun tähän ongelmaan. Poistin getdeb osoitteen ohjelmalähteistä ja sen jälkeen menin synapticiin. Sieltä löysin asennettujen pakettien historian, joten ei muuta kuin poistamaan asennettuja paketteja, joita oli paljon. Tämän jälkeen kone toimi samalla tavalla kuin aikaisemmin, eli loistavasti.

Nyt alkaa vaan muisti palailemaan pätkittäin ja luulen tehneeni niin, että olen poistanut kaikki muut getdebin mukanaan tuomat päivitykset paitsi pidginin ja tällä tavalla olen saanut uusimman pidginin toimimaan koneellani. Todella työläs operaatio. Onko siis mitenkään mahdollista asentaa getdebin kautta pelkästään yhtä ohjelmaa. Kokemukseni mukaan getdeb syytää koneelleni kaikista ohjelmista uusimmat versiot, joiden toimivuus 10.04:ssa saattaa olla niin ja näin? Pitää tutkia asiaa vielä. Laittakaa kommentia kehiin jos on kommentoitavaa.

Niin, tuo facebookchat vaatii todellakin lisäosan ja sen saa osoitteesta: http://code.google.com/p/pidgin-facebookchat/   Ubuntu antaa kyseisestä palikasta 1.64 versiota, joka ei todellakaan toimi. Edellä mainitusta sivustosta saa 1.69 version joka toimii moitteetta, eli ei ne kolmansien osapuolten lähteet aina niin huonoja ole.


pttk

  • Käyttäjä
  • Viestejä: 1045
    • Profiili
Vs: pakettia ei voida asentaa
« Vastaus #7 : 14.03.11 - klo:02.10 »

Onnistuit tekemään monimutkaisesti mutta pääasia että toimii.

http://digg.com/news/technology/Install_Pidgin_2_7_3_on_Ubuntu

Seuraavistakin saattaisi saada toimivan:

http://packages.debian.org/search?keywords=pidgin
Debian 6 "Squeeze", Ubuntu  10.04, Ubuntu 12.04

JarTak

  • Käyttäjä
  • Viestejä: 333
    • Profiili
Vs: pakettia ei voida asentaa
« Vastaus #8 : 14.03.11 - klo:11.24 »
Pidgin 2.7.11 on nyt asennettu sillä tavalla, että ohjelmalähteisiin lisäsin getdebin osoiterivin. Tämän jälkeen menin Synapticiin ja klikkasin päivitä kohtaa. Tämän jälkeen asensin pidgin. Jälkitoimenpiteinä poistin getdebin osoiterivin ohjelmalähteistä. Omituisen kummallista toimintaa jos haluaa saada uusimman ohjelman omalle koneelleen???

Storck

  • Vieras
Vs: pakettia ei voida asentaa
« Vastaus #9 : 14.03.11 - klo:11.33 »
Omituisen kummallista toimintaa jos haluaa saada uusimman ohjelman omalle koneelleen???

Eipäs vaan Ubuntun oletuksena on ohjelmat jotka ohjelmalähteistä löytyy vakiona. Näin sen pitääkin toimia, Synapticista löytyvät ovat TOIMIVIA ja tarkoitettu käyttöön, muualta haetut ei välttis niin toimivia eikä haluta näin ollen aiheuttaa käyttäjille harmia.

Ubuntuun ei tule uusimpia ja kromikiiltoisia juuri julkaistuja ohjelmia vaan sellaisia jotka toimii. Periaatteessa siis.

gedit. minulla on Ubuntusta 10.10 ja Pidginistä 2.7.3 versiot. Näin se homma etenee.  :)
« Viimeksi muokattu: 14.03.11 - klo:11.55 kirjoittanut Storck »

tommis

  • Käyttäjä
  • Viestejä: 418
    • Profiili
Vs: pakettia ei voida asentaa
« Vastaus #10 : 14.03.11 - klo:21.19 »
Tommis: alt + f2 ja teksti ohjelmalähteet tuotti tesktin joka ilmoitti, että sijaintia Sijaintia ”file:///home/jarmo/ohjelmal%C3%A4hteet” ei voi avata. Tuota ongelmaa ei varmaan tarvi ratkaista enempää, sillä käsittääkseni saman operaation voi hoitaa graafisesti siten että lisää tekstin: deb http://archive.getdeb.net/ubuntu maverick-getdeb apps ohjelmalähteet/muut ohjelmistot/lisää osioon, jolloin kone osaa hakea dataa tuolta paikasta. Ehkä maverickin kohdalle kannattaa laitta lucid???
Neuvoin käyttämään tuota alt + f2 metodia koska jotkut fiksut olivat poistaneet ohjelmalähteet kohdan valikosta jossain uudemmassa ubuntu julkaisussa, tuo saattaa jollekin olla todella hämmentävää.

Nyt alkaa vaan muisti palailemaan pätkittäin ja luulen tehneeni niin, että olen poistanut kaikki muut getdebin mukanaan tuomat päivitykset paitsi pidginin ja tällä tavalla olen saanut uusimman pidginin toimimaan koneellani. Todella työläs operaatio. Onko siis mitenkään mahdollista asentaa getdebin kautta pelkästään yhtä ohjelmaa. Kokemukseni mukaan getdeb syytää koneelleni kaikista ohjelmista uusimmat versiot, joiden toimivuus 10.04:ssa saattaa olla niin ja näin? Pitää tutkia asiaa vielä. Laittakaa kommentia kehiin jos on kommentoitavaa.
Apt:iin on sisään rakennettu tuollainen toiminto, itse en siinä tosin osaa neuvoa.

Hyvä, että tosin jotenkin tehtyä.