Kirjoittaja Aihe: [RATKAISTU] Boottaus epäonnistuu: init not found  (Luettu 1890 kertaa)

hro1

  • Käyttäjä
  • Viestejä: 61
  • 12.04
    • Profiili
Ubuntu 10.04 boottaus pysähtyy 'init not found' tms. ilmoitukseen ja saadaan prompti '(initramfs)' ruudulle. Eli grub toimii, vmlinux? toimii, initramfs toimii. dev hakemistossa löytyy sda1, sda2 (win xp), sda3 (=extended part), sda5 (=ubuntu boot), sda6 (=linux swap) ja sda7. Jos yrittää 'mkdir tst; mount -t ext4 /dev/sda5 tst' niin en pääse takaisin promptiin. Jos taas yrittän  mahdotonta 'mkdir tst; mount -t ext4 /dev/sda3 tst', niin saan herjan devicen lopun yli lukemisesta ja superblokin puuttumisesta ja palaudun promptiin. Kokeilut run-init komennolla päätyvät aina panic-tilaan.

Olen tien päällä ja live-USB boot tikkua ei ole mukana.

Onko mitään keinoa päästä eteenpäin jollain maagisella loitsulla joka syötetään promptille?

Entä kun päästään telakalle. Kannattaako yrittää korjata vai vedetäänkö suoraan uusi päälle?
« Viimeksi muokattu: 14.03.11 - klo:15.04 kirjoittanut hro1 »

juyli

  • Vieras
Vs: Boottaus epäonnistuu: init not found
« Vastaus #1 : 11.03.11 - klo:23.12 »
Entä kun päästään telakalle. Kannattaako yrittää korjata vai vedetäänkö suoraan uusi päälle?

Ehkä tuolloin on Live-USB-tikku käsillä ja aluksi koitat asentaa grub2:n uudelleen.
Grub:ia voi editoida komentoriviltä, joten jos keksit hyviä variaatioita, voisi olla mahdollista, että saat järjestelmän käyntiin.

hro1

  • Käyttäjä
  • Viestejä: 61
  • 12.04
    • Profiili
Vs: [RATKAISTU] Boottaus epäonnistuu: init not found
« Vastaus #2 : 14.03.11 - klo:15.16 »
Ratkaisu: Irrotin kovalevyn ja asensin sen SATA-USB sovittimeen. Tökkäsin USB piuhan Ubuntu 10.04 pöytäkoneeseen ja menu > system > administration > disk utility > peripheral devices > 160 gb hard disk > 20 gb ext4 > check filesystem. Kovalevy takaisin kiinni läppäriin ja taas toimii.

Live-USB (10.04) ei bootannut. 10.10 live-USB ei toiminut muuten kuin F6 noapic, nolapic optioilla. 'sudo -f fsck /dev/sda5' sanoi että device on jonkin muun prosessin käytössä. mountin mukaan sitä ei oltu mountattu. Vika tiedostojärjestelmässä oli ehkä sen verran outo, että joku ohjelma oli jäänyt luuppiin.

hro1

  • Käyttäjä
  • Viestejä: 61
  • 12.04
    • Profiili
Vs: [RATKAISTU] Boottaus epäonnistuu: init not found
« Vastaus #3 : 05.07.11 - klo:13.38 »
Vika uusiutui tänä aamuna. Koska ongelma oli tuttu ja olin kotona, korjaus vei noin 15 minuuttia. Edellisen kerran googlettamisista päätellen vika ei ole kovinkaan yleinen, joten vinkkejä sen välttämisestä ei löytynyt. Oletan ongelman johtuvan siitä, että sammutettaessa kaikkea dataa ei ole vielä kirjoitettu varsinaiselle levylle, kun kovalevyn virta katkeaa.

Mitenkä saisi kovanlevyn sammutusta viivästettyä niin että kaikka data on varmasti kirjoitettu? 

Jantunen

  • Käyttäjä
  • Viestejä: 254
  • Hö.
    • Profiili
    • Strobotti.com: Valokuvausta ja kameraharrastusta
Vs: [RATKAISTU] Boottaus epäonnistuu: init not found
« Vastaus #4 : 05.07.11 - klo:14.11 »
Vika uusiutui tänä aamuna. Koska ongelma oli tuttu ja olin kotona, korjaus vei noin 15 minuuttia. Edellisen kerran googlettamisista päätellen vika ei ole kovinkaan yleinen, joten vinkkejä sen välttämisestä ei löytynyt. Oletan ongelman johtuvan siitä, että sammutettaessa kaikkea dataa ei ole vielä kirjoitettu varsinaiselle levylle, kun kovalevyn virta katkeaa.

Mitenkä saisi kovanlevyn sammutusta viivästettyä niin että kaikka data on varmasti kirjoitettu? 

Lienee jotenkin mahdollista kytkeä pois käytöstä kirjoitus-cache levyltä, jolloin kaikki kirjoitettaisiin välittömästi, mutta se varmaankin hidastaisi järjestelmää huomattavasti...
Lenovo Thinkpad T420 Intel i5 16Gt/SSD512GB+HDD2TB, Ubuntu 16.04 Xenial Xerus 64bit; Kuvia ja lätinää valokuvauksesta: https://www.strobotti.com/