Kirjoittaja Aihe: Pikku scripti probleema  (Luettu 2893 kertaa)

tomppa

  • Käyttäjä
  • Viestejä: 165
  • Debian4.0
    • Profiili
Pikku scripti probleema
« : 17.06.06 - klo:18.14 »
Eli eli...

Tarvitsen aina ajaa seuraavan scriptin, jotta enemy territory ja teamspeak toimisi yhtäikaa:
Koodia: [Valitse]
#!/bin/sh
echo "et.x86 0 0 disable" > /proc/asound/card0/pcm0c/oss
echo "et.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss

Saisiko tuon scriptin ajettua jotenkin automaattisesti koneen käynnistyksen yhteydessä? Eihän se toki kauhea vaiva ole sitä käsinkään ajaa, mutta.... ;)

janne

  • Käyttäjä
  • Viestejä: 5150
    • Profiili
Re: Pikku scripti probleema
« Vastaus #1 : 17.06.06 - klo:18.25 »
Tarvitsen aina ajaa seuraavan scriptin, jotta enemy territory ja teamspeak toimisi yhtäikaa:
Koodia: [Valitse]
#!/bin/sh
echo "et.x86 0 0 disable" > /proc/asound/card0/pcm0c/oss
echo "et.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss

Saisiko tuon scriptin ajettua jotenkin automaattisesti koneen käynnistyksen yhteydessä? Eihän se toki kauhea vaiva ole sitä käsinkään ajaa, mutta.... ;)

saa, siitä on kirjoitettu HOWTOkin:
http://forum.ubuntu-fi.org/index.php?topic=1553.0

tosin siinä init-scriptissä ei tarvita tuota #!/bin/sh-riviä.

[edit]
lisätään nyt vielä, että periaatteessa dapperilla sen punaiseksi maalatun tekstin lukeminen riittää, mutta jos ei ole mitään oppimista vastaan, niin koko artikkelin lukemisesta voi saada jotain uuttakin tietoa.
« Viimeksi muokattu: 17.06.06 - klo:18.27 kirjoittanut janne »
Janne

tomppa

  • Käyttäjä
  • Viestejä: 165
  • Debian4.0
    • Profiili
Re: Pikku scripti probleema
« Vastaus #2 : 18.06.06 - klo:02.04 »
Katoppas vaan. Enpä tuota howto:a ole edes huomannut. Mutta kiitoksia taas kerran jannelle. :)

ChampCap

  • Käyttäjä
  • Viestejä: 17
    • Profiili
Re: Pikku scripti probleema
« Vastaus #3 : 19.07.06 - klo:11.18 »
Mulla on sama ongelma ja koetin tehdä kaiken tuon ohjeen (howto....) mukaan mut en silti vaan saanu toimimaan... Mut sitten kun mä ajan noi scriptit käsin niin taas pelaa, mutta missäköhän meni väärin...? ???



Edit: oli väärä kuva mut sain toimimaan jo
« Viimeksi muokattu: 19.07.06 - klo:19.08 kirjoittanut ChampCap »
ubuntu nyyppä

Speque

  • Käyttäjä
  • Viestejä: 258
  • Ubuntu Hardy Heron
    • Profiili
Re: Pikku scripti probleema
« Vastaus #4 : 19.07.06 - klo:13.28 »
Minä mistään tiedä, mutta eikös noissa scripteissä #-merkki tarkoita kommentoitua riviä?

janne

  • Käyttäjä
  • Viestejä: 5150
    • Profiili
Re: Pikku scripti probleema
« Vastaus #5 : 19.07.06 - klo:19.47 »
Minä mistään tiedä, mutta eikös noissa scripteissä #-merkki tarkoita kommentoitua riviä?

tarkoittaa, mutta tiedoston alussa oleva #! -alkuinen rivi ei ole sitä
Janne